• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

How's your Windows 10 Fall Creator Update experience so far?

How's your Windows 10 Fall Creators Update experience so far?

  • Haven't updated yet

    Votes: 1,468 22.0%
  • Perfectly smooth

    Votes: 2,396 35.9%
  • Some bumps but fine now

    Votes: 754 11.3%
  • Upgrade is failing

    Votes: 326 4.9%
  • Sticking with Windows 8

    Votes: 202 3.0%
  • Sticking with Windows 7

    Votes: 1,231 18.5%
  • Sticking with Windows XP

    Votes: 289 4.3%

  • Total voters
  • Poll closed .
Apr 16, 2015
283 (0.26/day)
System Name 2016
Processor intel i7-6700K
Motherboard ASUS Maximus VIII Impact (just for DTS Connect)
Cooling Noctua NH-D14
Memory G.Skill Ripjaws V DDR4 2x16GB 3200MHz
Video Card(s) Gigabyte GTX 1070 mini
Storage Samsung EVO 850
Display(s) Benq + Dell
Case Raijintek Metis Classic Black
Audio Device(s) ROG SupremeFX Impact III (motherboard integrated)
Power Supply Silverstone SX500-LG (with Scythe fan!!)
Mouse Aula Killing The Soul
Keyboard Logitech K290
Software Windows 10 Pro
Benchmark Scores upgrade: www.3dmark.com/compare/fs/9798108/fs/5598299 www.3dmark.com/compare/spy/285676/spy/64550
When the Spring Creators Update was a clusterfuck for me, then this Fall Creators update seemed to be like SP1 for Spring Creators update, fixing most of my remaining problems from the spring one. So yeah, thumbs up.
Aug 22, 2014
35 (0.03/day)
System Name Bird's Monolith
Processor Intel i7-4770k 4.6 GHz
Motherboard Asrock Z87 Extreme3
Cooling Noctua NH-D14, Noctua 140mm fans throughout case.
Memory 16 GB G-Skill Trident-X DDR3 2400 CAS 9
Video Card(s) 2 x ASUS STRIX GTX 970 (1400/7800)
Storage 2 TB Mushkin Triactor 3D (RAID 0)
Display(s) 2 x QNIX QX2710 2560x1440 (AHVA Panel)
Case Fractal Design Define R4
Audio Device(s) HT Omega Claro+, Line 6 UX2 driving Audio Engine A5+ Speakers
Power Supply Seasonic Platinum 660 W
Mouse SteelSeries Rival
Keyboard SteelSeries Apex
Software Windows 8.1 x64 Professional
Benchmark Scores Firestrike: 17998
Tried last night. SLI stopped working. One card in device manager reported "device could not find enough free resources" and the other reported "the driver trying to start isn't the driver that POSTed" whatever the heck those two mean. Tried doing a complete uninstall of all Nvidia drivers and starting fresh to no avail, ended up rolling back. That being said my XPS 13 upgraded today and it's running just fine.
Nov 27, 2010
197 (0.07/day)
System Name future xeon II
Processor DUAL SOCKET xeon e5 2686 v3 , 36c/72t, hacked all cores @3.5ghz, TDP limit hacked
Motherboard asrock rack ep2c612 ws
Cooling case fans,liquid corsair h100iv2 x2
Memory 48gb ddr4 2133mhz gskill
Video Card(s) 2x 1080 sc acx3 SLI, @115% tdp,+95 core, +410 mem
Storage 2x ssd evo750 512gb, one for OS, one for caching spinners(10TB)
Display(s) philips 40" bdm4065uc 4k @60
Case silverstone temjin tj07-b
Audio Device(s) sb Z
Power Supply corsair hx1200i
Mouse corsair m95 16 buttons
Keyboard microsoft internet keyboard pro
Software windows 10 x64 rs3 fall creators update ,enterprise
Benchmark Scores fire strike ultra- 10k time spy- 15k cpu z- 400/7500
I had similar issues with sli, did you make sure the cards are at the motherboard recommended slots for two way sli? as in other slots it might work but problematic. also fiddle with bios settings such as above 4g decoding, verify the pcie speed of both(NVidia cpl -system information)