• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

HP printer not working in Linux mint 7

Joined
Jun 28, 2008
Messages
1,662 (0.48/day)
Likes
118
Location
Newcastle
System Name The neighbour of the beast|NC10
Processor Q6600 GO|Atom N270
Motherboard Asus P5QSE/R
Cooling Stock|Stock
Memory 4GB Crucial Ballistix Tracer Red @800|1GB@533
Video Card(s) Palit HD4850|Intel GMA 945
Storage Maxtor 500GB 32 MB Cache|160GB IDE 2.5"
Display(s) 15.4" touchscreen, 15.4" Digimate LCD| 10.2"
Case Coolermaster Elite 330|Black NC10 case
Audio Device(s) Realtek HD audio|Integrated
Power Supply Corsair 650W TX|6 Cell battery
Software Vista Home Premium, Win 7| Win XP
Benchmark Scores Benches will be taken on the main rig soon. (AKA never)
#1
I've been trying to get my ancient HP Deskjet 5500 to work so I can print out some stuff for school as I gave up on the lexmark printers working in linux.
I plugged the printer in and linux instantly recognised it when I tried to print something, however when I tried to print anything it would make all the usual noises but wouldn't pick up any paper, fixed this by putting an inch of paper in the tray, now the rollers pick up sheets and feed them through without any issues.
I've managed to get it to print test pages with the little HP logo at the bottom which come out perfectly, however when I go to print a document it fails.
When printing a block of text it picks up the paper and then spits it out without printing on it.
When printing a table it prints one vertical line at the end of the page and then the horizontal lines (it's a 4*4 table), no text is printed, what do I need to do to fix it?
Thanks in advance
Spen
 
Joined
Oct 20, 2009
Messages
2,842 (0.94/day)
Likes
340
System Name FumoffuFumoffu
Processor Intel i7 4770K
Motherboard Gigabyte Z87X -UD3H
Cooling Corsair H100i
Memory 16GB DDR3 1600 Crucial Ballistix
Video Card(s) Sapphire AMD Radeon HD 7970 OC
Storage 1- WD 500GB 1- Samsung F2 1.5TB 1- Crucial M4 128GB SSD 1-256GB ADATA XPG SX900 ASX900S3 SSD
Display(s) Hanns-G HZ281HPB 27.5'' 3ms Full HD 1920x1200 WideScreen LCD Monitor
Case Corsair Graphite Series 600T
Audio Device(s) Creative Soundblaster X-Fi Titanium
Power Supply Corsair HX 750W Gold
Software Windows 7 Pro x64
#2
did you install the hplip drivers found in the synaptic package manager
 
Joined
Jun 28, 2008
Messages
1,662 (0.48/day)
Likes
118
Location
Newcastle
System Name The neighbour of the beast|NC10
Processor Q6600 GO|Atom N270
Motherboard Asus P5QSE/R
Cooling Stock|Stock
Memory 4GB Crucial Ballistix Tracer Red @800|1GB@533
Video Card(s) Palit HD4850|Intel GMA 945
Storage Maxtor 500GB 32 MB Cache|160GB IDE 2.5"
Display(s) 15.4" touchscreen, 15.4" Digimate LCD| 10.2"
Case Coolermaster Elite 330|Black NC10 case
Audio Device(s) Realtek HD audio|Integrated
Power Supply Corsair 650W TX|6 Cell battery
Software Vista Home Premium, Win 7| Win XP
Benchmark Scores Benches will be taken on the main rig soon. (AKA never)
#3
Yep, I did.
 
Joined
Oct 20, 2009
Messages
2,842 (0.94/day)
Likes
340
System Name FumoffuFumoffu
Processor Intel i7 4770K
Motherboard Gigabyte Z87X -UD3H
Cooling Corsair H100i
Memory 16GB DDR3 1600 Crucial Ballistix
Video Card(s) Sapphire AMD Radeon HD 7970 OC
Storage 1- WD 500GB 1- Samsung F2 1.5TB 1- Crucial M4 128GB SSD 1-256GB ADATA XPG SX900 ASX900S3 SSD
Display(s) Hanns-G HZ281HPB 27.5'' 3ms Full HD 1920x1200 WideScreen LCD Monitor
Case Corsair Graphite Series 600T
Audio Device(s) Creative Soundblaster X-Fi Titanium
Power Supply Corsair HX 750W Gold
Software Windows 7 Pro x64
#4
which program are you using to print from? What interface is the printer on? SCSI, LPT, USB, etc...

Lexmark works ok on linux.

Try the open printing site.

I almost never have issues with HP Printers and Linux
 
Joined
Jun 28, 2008
Messages
1,662 (0.48/day)
Likes
118
Location
Newcastle
System Name The neighbour of the beast|NC10
Processor Q6600 GO|Atom N270
Motherboard Asus P5QSE/R
Cooling Stock|Stock
Memory 4GB Crucial Ballistix Tracer Red @800|1GB@533
Video Card(s) Palit HD4850|Intel GMA 945
Storage Maxtor 500GB 32 MB Cache|160GB IDE 2.5"
Display(s) 15.4" touchscreen, 15.4" Digimate LCD| 10.2"
Case Coolermaster Elite 330|Black NC10 case
Audio Device(s) Realtek HD audio|Integrated
Power Supply Corsair 650W TX|6 Cell battery
Software Vista Home Premium, Win 7| Win XP
Benchmark Scores Benches will be taken on the main rig soon. (AKA never)
#5
The interface is USB, I think I tried open printing, might have another shot tomorrow night when I'm at my gran's.
I was trying to use open office to print.
I do have a habit of killing printers quite spectacularly, like managing to corrupt drivers in the middle of printing a 100 page coursework...
 
Joined
Oct 20, 2009
Messages
2,842 (0.94/day)
Likes
340
System Name FumoffuFumoffu
Processor Intel i7 4770K
Motherboard Gigabyte Z87X -UD3H
Cooling Corsair H100i
Memory 16GB DDR3 1600 Crucial Ballistix
Video Card(s) Sapphire AMD Radeon HD 7970 OC
Storage 1- WD 500GB 1- Samsung F2 1.5TB 1- Crucial M4 128GB SSD 1-256GB ADATA XPG SX900 ASX900S3 SSD
Display(s) Hanns-G HZ281HPB 27.5'' 3ms Full HD 1920x1200 WideScreen LCD Monitor
Case Corsair Graphite Series 600T
Audio Device(s) Creative Soundblaster X-Fi Titanium
Power Supply Corsair HX 750W Gold
Software Windows 7 Pro x64
#6
try using a print server device. It hooks up between a router and a computer and can act as a computer