• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

HyperX Pulsefire FPS Pro

Joined
Feb 8, 2012
Messages
123 (0.05/day)
Location
Hungary
HyperX's first gaming mouse was the Pulsefire FPS, and now, it's back with a face lift, perfectly up-to-date by today's standards. PixArt PMW3389 top-of-the-line optical sensor, Omron D2FC-F-7N switches rated for 20 million clicks, highly customizable RGB lighting, and a robust, palm-gripping-oriented shape—the specifications are stunning, but is it truly that great?

Show full review
 
Last edited by a moderator:

Pop_Mihai_Ioan

New Member
Joined
May 3, 2019
Messages
1 (0.02/day)
For some strange unknown reason, the mouse is unusable to navigate in my motherboard BIOS/UEFI, Aorus X470 Utra Gaming, with up to date bios version. The soon i select any option, the cursor get stuck, not moving at all. With other 2 mouses everything is fine.
 
Joined
Mar 20, 2019
Messages
126 (1.37/day)
Location
Australia
Processor AMD Ryzen 5 2600
Motherboard MSI B450 Gaming Plus
Cooling Cryorig H7
Memory Kingston HyperX Predator DDR4 3200MHz 2x8GB
Video Card(s) ASUS Radeon RX 580 8GB Dual-fan OC Edition
Storage Samsung 970 EVO Plus NVMe 250GB
Case NZXT H500
Power Supply Corsair RM650x Gold 650W
Mouse HyperX Pulsefire FPS Pro
Keyboard MaxKeyboard Nighthawk X8 (Cherry Brown)
Software Kubuntu
I picked up this mouse to replace my 2013 Deathadder. Couldn't be happier with the upgrade - it feels snappier and "clickier", and for my palm grip it seems to push up into my palm a lot more that the Razer mouse in a way that makes me feel like I have more control. The in-built memory is great for saving DPI profiles straight onto the mouse - no more messing around with software a la Razer Synapse.

Very solid all round.

For some strange unknown reason, the mouse is unusable to navigate in my motherboard BIOS/UEFI, Aorus X470 Utra Gaming, with up to date bios version. The soon i select any option, the cursor get stuck, not moving at all. With other 2 mouses everything is fine.
I'm using a MSI B450 Gaming Plus - no issues navigating the UEFI menu for me. I noticed that there is a firmware update for the mouse - perhaps this will clear the issue up?
 
Top