• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

I believe i have a crappy version of gt 520.. and i can't install any driver from nvidia official

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,034 (6.32/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Are you certain? Its my understanding that that card requires the ION driver series not the Geforce Driver series.
Seems to be a funky card, uses a custom bios due to being a 210 just to make it forward compatible.

I wonder if a 210 bios can be put on it

Here is the GT 520 Driver for Windows 10

http://www.nvidia.com/download/driverResults.aspx/131443/en-us

Here is the 210 driver for 10

http://www.nvidia.com/download/driverResults.aspx/112596/en-us

Get Display Driver Uninstaller, Get latest motherboard chipset specific from your motherboard maker.

Disconnect ethernet or disable wifi connections, Run DDU and follow directions. Restart when told, then run it again.

Reinstall motherboard chipset driver, restart, install GPU driver for 520.

If it fails try the 210 driver.

If it still fails reinstall Windows or bin the card for a test machine.
 
Last edited:
Joined
Nov 5, 2015
Messages
495 (0.32/day)
Location
Skopje, Macedonia
System Name The Tesseract Cube
Processor AMD Ryzen 5 3600
Motherboard MSI X570A-PRO
Cooling DeepCool Maelstrom 240, 2 X DeepCool GS120 (radiator fans), 4 X DeepCool RF120 (case fans)
Memory 1 x 16gb Kingston HyperX 3200mhz
Video Card(s) Sapphire Radeon RX 580 8GB Nitro +
Storage Kingston V300 120GB (Boot Device), Kingston A400 480GB (Games), Western Digital Caviar Blue 1TB
Display(s) MSI MAG241C Full HD, 144hz FreeSync
Case DeepCool Matrexx 55
Audio Device(s) MB Integrated, Sound Blaster Play 3 (Headset)
Power Supply Corsair CX650M Modular 80+ Bronze
Mouse MSI GM10
Keyboard Genesys RHOD 400 RGB
Software Windows 10 Pro
Benchmark Scores CPUZ: Single Thread - 510 Multi Thread - 4.050 Cinebench R20: CPU - 3 500 score
Wait a minute? GF119? That isnt a Fermi Card?
Maybe try and use GT620 drivers and see if they work.

The GeForce GT 620 (OEM) card is a rebranded GeForce GT 520.
Source: Wikipedia
 
Last edited:

satrianiboys

New Member
Joined
Feb 27, 2018
Messages
20 (0.03/day)
Are you certain? Its my understanding that that card requires the ION driver series not the Geforce Driver series.
I believe you gave me a link to a regular gtx 400-titan latest driver, which i already tried it didn't work.
I check the ION driver, though it has an up to 400 series compability which i believe will give me a result of "incompatible card" later
CMIIW

Wait a minute? GF119? That isnt a Fermi Card?
Maybe try and use GT620 drivers and see if they work.

The GeForce GT 620 (OEM) card is a rebranded GeForce GT 520.
Source: Wikipedia
Searching for GT 620 driver give me the regular gtx 400-titan latest driver in nvidia website

===================================

Despite a "warm" welcome feeling i get here, this is the only forum i get the real guide to solve my problem.
Just finished testing on windows xp, 7, and 10 32/64b for doing an editing driver method guide by @StefanM and everything working great!

Thank very much to @StefanM for providing a very good guide for me. You're sure bothering yourself for downloading, taking a screenshot, and thinking how to write a clear guide for me. Words can't express more my gratitude towards you. If only you in the same city/country as mine, i'll definetly give you a treat. You just saved 5 "dead" cards of mine!

Thank you very much to @Apocalypsee for the tips on flashing bios. Sure anybody stuble across this thread when trying to flashing a bios will find it usefull.

Thank you to @eidairaman1 too for.. mmm... the cynic reply and first thing to do guide when you have a non working driver vga...

Also thank you to everybody who replied on this thread for bothering yourself thinking about my problem. I'll leave this place to moderatos.

Thanks Techpowerup forums.
 
Top