• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

I believe my PC is the Antichrist and I am willing to pay anyone that helps fix it

Yuiiski

New Member
Joined
Jun 19, 2021
Messages
19 (0.50/day)
Hello, I am going to keep this somewhat short because, after almost 5 years of trying to fix it, I have long reached the point of being fed up with explaining it so will make it as simple as possible.

So, I got into PC gaming back in 2017 with a brand new pre-built PC, all games were unplayable from the getgo, every single game suffered from constant stutters and no amount of fixes helped, I contacted the seller and they sent me a replacement GPU and PSU, they didn't need to do that but they did anyway, I swapped over these components and the issue was still there. I was helpless, I had no idea what was causing it because everything was working fine, the temps were fine and so were the other components yet the issues remained. Over time I slowly started to replace each component of the PC until all parts from the original prebuilt PC were gone, the issues still remained, after basically building a new PC I had the exact same issues. After doing this I then started the process of swapping out parts again thinking that I just got unlucky, the PC still stuttered big time in all games despite replacing all parts two times.

Years went past and I tried every trick in the book, I would list them but I have honestly lost track of all the things I have tried, it's been years and I honestly spend most days trying to figure out the cause. Fast forward to late 2020 and I decided literally build a new PC from scratch, instead of just swapping out parts from the first pre-built PC. I packed up my old PC and put it away. I then ordered a bunch of new components and decided to build a completely new PC including a new monitor and mouse and keyboard.

These are the following specs that I bought and what I still currently use today as I write this.

NVIDIA GeForce RTX 2080 SUPER
Intel Core i9-9900K
NZXT Kraken Z73 Liquid Cooler
Corsair Vengeance RGB PRO DDR4 3200MHZ (4X8)
Gigabyte Z390 AORUS MASTER
EVGA SuperNOVA 1000 G3
Samsung 970 EVO 500GB
Samsung 970 EVO 1TB
NZXT H700 Tower
ASUS ROG SWIFT PG279Q

After putting together this brand new PC, with all new parts, the issue remained, games were still unplayable including simple games like Minecraft which suffers from an unplayable constant stutter, it doesn't matter what the game is, it will stutter constantly and after spending so much money, and so much time trying to fix it, I have lost all hope that I will ever find the cause. I still do question if it's the electrics in my home causing it but I took it to another house and the issues persisted there too, unless the damage was already done at that point. Apart from playing games, the computer works fine, it boots up with no issues, it isn't loud, the temps are always normal. I just don't get it.

I know I have not given much info, I suppose this is more of a vent on my part but hopefully, you can understand my frustration in all this.

I'll just leave an image of the frametime in a game (Bright Memory) I just played, as you can see the frametime is an absolute joke but at the same time, there are zero reasons for it to be doing that. If you have any question please just ask and I will answer them. But like I said in the title, I will pay anyone that helps me fix this, I have so desperate at this point.
 

Attachments

  • sdadadad.png
    sdadadad.png
    13.8 KB · Views: 147
Joined
Jun 27, 2015
Messages
679 (0.31/day)
System Name Laptop with deskstop heart
Processor Ryzen R9 3900X stock 3.8GHz (eco mode 65w)
Motherboard Aftershock Forge 15R B450 LAPTOP MOTHERBOARD
Cooling Laptop dual fan copper heatsink
Memory Corsair Vengeance 64GB TOTAL ( 2x32GB sodimm 2666mhz C18 )
Video Card(s) RTX 2070 Max-P Laptop
Storage Sabrent Rocket 2TB PCIE 3x4 SSD
Display(s) 15.6 inch 1080p 144hz panel
Case laptop Aftershock Forge 15R
Audio Device(s) Onboard & soundblaster g3 usb
Power Supply Chicony 230W power brick
Mouse Elecom wireless mouse
Keyboard Logitech Mk240 Nano Wireless Keyboard
Software Windows 10 HOME
Benchmark Scores Don't know any benchmark. It runs good enough for me.
I can't really think of anything except bringing your PC to someone with a fully working PC at a different place for them to test every single part in a known working PC to eliminate problems. It could hardware or it could problems with windows I don't know. Maybe a forum member here close by you can help you.
 

Yuiiski

New Member
Joined
Jun 19, 2021
Messages
19 (0.50/day)
I can't really think of anything except bringing your PC to someone with a fully working PC at a different place for them to test every single part in a known working PC to eliminate problems. It could hardware or it could problems with windows I don't know. Maybe a forum member here close by you can help you.
Hello.

I should add that I have tried multiple different versions of Windows including Windows 7, Windows 8, Windows 8.1 and Windows 10. I have also tried Linux, all of which suffered from the same issues with constant stutters and frametime issues, so I doubt it's the OS. And I don't know a single person that has a PC, everyone else I know plays on a console, and even if I did, all the components are fine as I have tested each component multiple times, have tested countless PSU's, Motherboards, GPUs, SSDs and HDDs, RAM, Coolers, everything has been tested so many times so I can't see it being an issue with one of the parts.
 
Joined
Sep 16, 2018
Messages
2,258 (2.16/day)
*Points finger @ Corsair*

Jk I don't really know.. but I would pull a pair of ram out and clear the cmos and start again.
 
Joined
Oct 2, 2005
Messages
3,014 (0.52/day)
Location
Baltimore MD
Processor Ryzen 5900X
Motherboard ASUS Prime X470 Pro
Cooling Dark Rock TF
Memory 2 x 8 Gb Gskill Trident Z 3200 Mhz
Video Card(s) MSI Ventus 3060 Ti OC
Storage Samsung 960 EVO 500 Gb / 860 EVO 1 Tb
Display(s) Dell S2719DGF
Case Lian Li Lancool II Mesh
Audio Device(s) Soundblaster Z
Power Supply Seasonic Focus Plus 550 W
Mouse Zowie EC1
Keyboard Logitech G513
Software Win 10 Pro 64 bit
what parts did you carry over from the old build
 

Yuiiski

New Member
Joined
Jun 19, 2021
Messages
19 (0.50/day)
what parts did you carry over from the old build
None, my current PC is all brand new and doesn't have a single component from the old build in it.

*Points finger @ Corsair*

Jk I don't really know.. but I would pull a pair of ram out and clear the cmos and start again.
I have done that many times, I have a bunch of RAM that I have tested and it never helped. I have also cleared CMOS many times and that did not help either.
 
Joined
Oct 2, 2005
Messages
3,014 (0.52/day)
Location
Baltimore MD
Processor Ryzen 5900X
Motherboard ASUS Prime X470 Pro
Cooling Dark Rock TF
Memory 2 x 8 Gb Gskill Trident Z 3200 Mhz
Video Card(s) MSI Ventus 3060 Ti OC
Storage Samsung 960 EVO 500 Gb / 860 EVO 1 Tb
Display(s) Dell S2719DGF
Case Lian Li Lancool II Mesh
Audio Device(s) Soundblaster Z
Power Supply Seasonic Focus Plus 550 W
Mouse Zowie EC1
Keyboard Logitech G513
Software Win 10 Pro 64 bit
is there any software you have used besides windows and drivers also when configuring bios have you tried just setting XMP an no other changes
 

Yuiiski

New Member
Joined
Jun 19, 2021
Messages
19 (0.50/day)
Also, no idea if this helps but this is what the power percent, power w etc says on Afterburner.
 

Attachments

  • pls.png
    pls.png
    18.6 KB · Views: 86

Solaris17

Dainty Moderator
Staff member
Joined
Aug 16, 2005
Messages
22,341 (3.84/day)
Location
Florida
System Name Venslar
Processor I9 7980XE
Motherboard MSI x299 Tomahawk Arctic
Cooling EK Custom
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Nvidia Titan RTX
Storage 1x 250GB 960 EVO | 1x 500gb Intel 720p | 32TB SAN
Display(s) 3x AOC Q2577PWQ (2k IPS)
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Schiit Fulla 3 on Beyerdynamic DT 990 Pros
Power Supply Seasonic 1050W Snow
Mouse M55 RGB PRO (White)
Keyboard Ducky Shine 6 Snow White
VR HMD HTC VIVE
Software Windows 10 x64 Pro
Hm, this isn't orthodox. This sounds like a user issue. Some setting or configuration style is persisting across these changes.

Do you play windowed?

Do you configure refresh rate?

Do you play with or change mouse/kb polling rates?

Do you set custom heat/fan profiles?

Do you make specific setting changes to the games you play? Texture? Shadows? AA?
 

Yuiiski

New Member
Joined
Jun 19, 2021
Messages
19 (0.50/day)
is there any software you have used besides windows and drivers also when configuring bios have you tried just setting XMP an no other changes
All I have installed currently is Steam and two games. And I reinstalled Windows 10 and installed nothing but Minecraft and it still did it. The only thing that I have touched in BIOS is XMP, which is currently turned on but it still does it with it turned off.

Hm, this isn't orthodox. This sounds like a user issue. Some setting or configuration style is persisting across these changes.

Do you play windowed?

Do you configure refresh rate?

Do you play with or change mouse/kb polling rates?

Do you set custom heat/fan profiles?

Do you make specific setting changes to the games you play? Texture? Shadows? AA?

I don't play in windowed but have tested windowed mode in the past.

Yes, my refresh rate is currently set to 165hz and have tested it at 144hz, 120hz and 60hz and it did not help.

I have currently have the polling rate for my mouse set at 1000 but have tested it with lower rates.

I have not messed about with fan profiles because all my temps are fine so I have had no reason to mess about with it.

Yes, but it doesn't matter, I could set everything too low and would still get unplayable stutter.
 

newtekie1

Semi-Retired Folder
Joined
Nov 22, 2005
Messages
28,082 (4.90/day)
Location
Indiana, USA
Processor Intel Core i7 10850K@5.2GHz
Motherboard AsRock Z470 Taichi
Cooling Corsair H115i Pro w/ Noctua NF-A14 Fans
Memory 32GB DDR4-3600
Video Card(s) RTX 2070 Super
Storage 500GB SX8200 Pro + 8TB with 1TB SSD Cache
Display(s) Acer Nitro VG280K 4K 28"
Case Fractal Design Define S
Audio Device(s) Onboard is good enough for me
Power Supply eVGA SuperNOVA 1000w G3
Software Windows 10 Pro x64
Have you installed all the drivers for your motherboard and GPU? Not just let Windows install them automatically, but actually go to the manufacturers website, download them from there and install them.
 

Yuiiski

New Member
Joined
Jun 19, 2021
Messages
19 (0.50/day)
Have you installed all the drivers for your motherboard and GPU?
Yes, I update my GPU drivers whenever a new one is available. And I went on the site to update the drivers for my motherboard hoping it would help, but it didn't sadly.
 
Joined
Oct 26, 2016
Messages
1,256 (0.72/day)
Location
BGD
System Name KING-XEON
Processor Xeon 2697 V2(12c/24t) (OC-3,45Ghz-ALL*CORES----TURBO BOOSTING 4,03Ghz)
Motherboard Sabertooth X79
Cooling Xigmatek LOKI SD963 double-Fan
Memory 40Gb DDR3 Kingston Hyper Blue 1540Mhz Active clocks(9-9-9-30-160-2T)
Video Card(s) 1)R9 Fury Sapphire Nitro 4gbHBM/1080Mhz***2)MATROX P690
Storage 2 x ssd-Kingston 240Gb A400 in RAID 0+ HDD 500Gb +Samsung 128gbSSD
Display(s) BenQ 28"EL2870U(4K-HDR)/ Acer 24"(1080P)/ 2x Eizo 19"
Case Lian Li
Audio Device(s) Realtek/Creative T20 Speakers
Power Supply F S P Hyper S 700W
Mouse Asus TUF-GAMING M3
Keyboard Func FUNC-KB-460/Mechanical Keyboard
Software Win 11
Benchmark Scores Fire Strike=14610,Cinebench R15=1789,Cinebench R20=3756.Passmark=20450,Geekbench4=32885
Did you tried any other monitor or after all those changes you been trying always on the same monitor?
 
Joined
Oct 26, 2016
Messages
1,256 (0.72/day)
Location
BGD
System Name KING-XEON
Processor Xeon 2697 V2(12c/24t) (OC-3,45Ghz-ALL*CORES----TURBO BOOSTING 4,03Ghz)
Motherboard Sabertooth X79
Cooling Xigmatek LOKI SD963 double-Fan
Memory 40Gb DDR3 Kingston Hyper Blue 1540Mhz Active clocks(9-9-9-30-160-2T)
Video Card(s) 1)R9 Fury Sapphire Nitro 4gbHBM/1080Mhz***2)MATROX P690
Storage 2 x ssd-Kingston 240Gb A400 in RAID 0+ HDD 500Gb +Samsung 128gbSSD
Display(s) BenQ 28"EL2870U(4K-HDR)/ Acer 24"(1080P)/ 2x Eizo 19"
Case Lian Li
Audio Device(s) Realtek/Creative T20 Speakers
Power Supply F S P Hyper S 700W
Mouse Asus TUF-GAMING M3
Keyboard Func FUNC-KB-460/Mechanical Keyboard
Software Win 11
Benchmark Scores Fire Strike=14610,Cinebench R15=1789,Cinebench R20=3756.Passmark=20450,Geekbench4=32885
I am out of ideas could be electrical issue in your house or maybe electromagnetic interference or EMI problems...try to enable spread spectrum in your bios....did you try to bring your PC somewhere else maybe some other house?
 

Yuiiski

New Member
Joined
Jun 19, 2021
Messages
19 (0.50/day)
I am out of ideas could be electrical issue in your house or maybe electromagnetic interference or EMI problems...try to enable spread spectrum in your bios....did you try to bring your PC somewhere else maybe some other house?
I mentioned in my first post that I thought it might be electrical and that I took it to another house but the problems remained. Unless the damage had already been done by having it plugged in at my house.
 
Joined
Nov 15, 2020
Messages
33 (0.13/day)
System Name Glasshouse
Processor Ryzen 9 5900X
Motherboard MSI x570 Tomahawk wifi
Cooling Noctua NH D15 Chromax Black
Memory G Skill Neo 16GBx4
Video Card(s) XFX 6900XT Merc Black
Storage Force MP600 (1TB) & Sabrent Rocket 4 (2TB) & 2TB Crucial Sata
Display(s) LG CX 48 inch
Case Corsair Crystal 570X White
Audio Device(s) Creative Speakers
Power Supply Corsair RM850x
Software Windows
May be an obvious thing but have you done clean install of Windows and removed and replaced the drivers? Or is it the same system you were using for your old system?
 
Joined
Nov 21, 2010
Messages
1,767 (0.45/day)
Location
Right where I want to be
System Name Miami
Processor Ryzen 3800X
Motherboard Asus Crosshair VII Formula
Cooling Ek Velocity/ 2x 280mm Radiators/ Alphacool fullcover
Memory F4-3600C16Q-32GTZNC
Video Card(s) SAPPHIRE NITRO+ Radeon RX 5700 XT
Storage 1TB WD M.2 SSD/ 2TB WD SN750/ 4TB WD Black HDD
Display(s) DELL AW3420DW / HP ZR24w
Case Lian Li O11 Dynamic XL
Audio Device(s) EVGA Nu Audio
Power Supply Seasonic Prime Gold 1000W
Mouse Corsair Scimitar/Glorious Model O-
Keyboard Corsair K95 Platinum
Software Windows 10 Pro
Joined
Jan 8, 2017
Messages
6,836 (4.12/day)
System Name Good enough
Processor AMD Ryzen R7 1700X - 4.0 Ghz / 1.350V
Motherboard ASRock B450M Pro4
Cooling Deepcool Gammaxx L240 V2
Memory 16GB - Corsair Vengeance LPX - 3333 Mhz CL16
Video Card(s) OEM Dell GTX 1080 with Kraken G12 + Water 3.0 Performer C
Storage 1x Samsung 850 EVO 250GB , 1x Samsung 860 EVO 500GB
Display(s) 4K Samsung TV
Case Deepcool Matrexx 70
Power Supply GPS-750C
Do you use V-sync or G-sync ?
 
Joined
Oct 2, 2005
Messages
3,014 (0.52/day)
Location
Baltimore MD
Processor Ryzen 5900X
Motherboard ASUS Prime X470 Pro
Cooling Dark Rock TF
Memory 2 x 8 Gb Gskill Trident Z 3200 Mhz
Video Card(s) MSI Ventus 3060 Ti OC
Storage Samsung 960 EVO 500 Gb / 860 EVO 1 Tb
Display(s) Dell S2719DGF
Case Lian Li Lancool II Mesh
Audio Device(s) Soundblaster Z
Power Supply Seasonic Focus Plus 550 W
Mouse Zowie EC1
Keyboard Logitech G513
Software Win 10 Pro 64 bit
I mentioned in my first post that I thought it might be electrical and that I took it to another house but the problems remained. Unless the damage had already been done by having it plugged in at my house.
extremely unlikely
is there anything your changing as far as driver settings vsync/gsync etc also is the across all games or just a specific game
 
Joined
Nov 15, 2020
Messages
33 (0.13/day)
System Name Glasshouse
Processor Ryzen 9 5900X
Motherboard MSI x570 Tomahawk wifi
Cooling Noctua NH D15 Chromax Black
Memory G Skill Neo 16GBx4
Video Card(s) XFX 6900XT Merc Black
Storage Force MP600 (1TB) & Sabrent Rocket 4 (2TB) & 2TB Crucial Sata
Display(s) LG CX 48 inch
Case Corsair Crystal 570X White
Audio Device(s) Creative Speakers
Power Supply Corsair RM850x
Software Windows
Many times, yes.


I mentioned my current specs in my original post.
I think you need to start eliminating things. Start with the power supply. Try to source one that works and replace that item and try it first at someone else's place to eliminate any power source issue at your home.
 
Joined
Oct 2, 2005
Messages
3,014 (0.52/day)
Location
Baltimore MD
Processor Ryzen 5900X
Motherboard ASUS Prime X470 Pro
Cooling Dark Rock TF
Memory 2 x 8 Gb Gskill Trident Z 3200 Mhz
Video Card(s) MSI Ventus 3060 Ti OC
Storage Samsung 960 EVO 500 Gb / 860 EVO 1 Tb
Display(s) Dell S2719DGF
Case Lian Li Lancool II Mesh
Audio Device(s) Soundblaster Z
Power Supply Seasonic Focus Plus 550 W
Mouse Zowie EC1
Keyboard Logitech G513
Software Win 10 Pro 64 bit
also something just occurred to me have you tried different keyboards mice or unplugging all other usb devices
 

Yuiiski

New Member
Joined
Jun 19, 2021
Messages
19 (0.50/day)
I think you need to start eliminating things. Start with the power supply. Try to source one that works and replace that item and try it first at someone else's place to eliminate any power source issue at your home.
Like I said in my original post, I have done that.

also something just occurred to me have you tried different keyboards mice or unplugging all other usb devices
Yep, have tried different devices and have tried unplugging stuff, still does it.

Do you use V-sync or G-sync ?
G-sync.
 
Top