• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

I broke it... RX 580 flashed, now black screen whenever plugged in

Tsherwoo

New Member
Joined
May 5, 2021
Messages
3 (0.21/day)
Hi I flashed my new 580 8gb using the windows ATIflash and oneclickbiosmod utility without error. Now whenever this card is plugged in it windows doesn’t load or at least I can’t see it until I unplug the card. I have tried dos ATIflash with a variety of 580 MSI and Dell roms but I either get a ssid mismatch or other errors..

Has anyone experienced this before?

0CEFD024-34C5-4ED8-AEAF-559FBE7D8439.jpeg
 

Attachments

  • image.jpg
    image.jpg
    2.6 MB · Views: 21
  • image.jpg
    image.jpg
    1.8 MB · Views: 22
Joined
Aug 11, 2014
Messages
759 (0.31/day)
Processor ryzen 5 5600x
Motherboard AB350m Pro4 with B450M Pro4-F bios
Cooling custom loop
Memory TEAMGROUP T-Force TXKD416G3600HC18ADC01 16gbs XMP
Video Card(s) HP GTX1650 super 4gb
Storage MZVLB256HBHQ-000H1 PM981a (256GB)/3TB HDD
Display(s) Nitro XF243Y Pbmiiprx
Case Rosewill CULLINAN
Audio Device(s) onboard
Power Supply Corsair 750w
Mouse Best Buy Insignia
Keyboard Best Buy Insignia
Software Win 10 pro
get a ch341a programmer and clip. also could give trying the onboard video a go and see if you can flah it that way. first, take the video card out of the pc. second, connect your video cable to your motherboard. third, go to bios and set onboard video to primary. forth, shutdown, reconnect graphics card, leave monitor hooked up to motherboard and power on pc and proceed to flash the proper bios. if this does not work than you can add a second gpu and see if it will display off that one and if that still does not work, go with the programmer.
 

Tsherwoo

New Member
Joined
May 5, 2021
Messages
3 (0.21/day)
get a ch341a programmer and clip. also could give trying the onboard video a go and see if you can flah it that way. first, take the video card out of the pc. second, connect your video cable to your motherboard. third, go to bios and set onboard video to primary. forth, shutdown, reconnect graphics card, leave monitor hooked up to motherboard and power on pc and proceed to flash the proper bios. if this does not work than you can add a second gpu and see if it will display off that one and if that still does not work, go with the programmer.
I tried the MB graphics, still gets the black screen. When I put another GPU in device in, GPU isn’t even found in device manager.
 
Joined
Aug 11, 2014
Messages
759 (0.31/day)
Processor ryzen 5 5600x
Motherboard AB350m Pro4 with B450M Pro4-F bios
Cooling custom loop
Memory TEAMGROUP T-Force TXKD416G3600HC18ADC01 16gbs XMP
Video Card(s) HP GTX1650 super 4gb
Storage MZVLB256HBHQ-000H1 PM981a (256GB)/3TB HDD
Display(s) Nitro XF243Y Pbmiiprx
Case Rosewill CULLINAN
Audio Device(s) onboard
Power Supply Corsair 750w
Mouse Best Buy Insignia
Keyboard Best Buy Insignia
Software Win 10 pro
ch341a programmer it is then.
 
Joined
Aug 11, 2014
Messages
759 (0.31/day)
Processor ryzen 5 5600x
Motherboard AB350m Pro4 with B450M Pro4-F bios
Cooling custom loop
Memory TEAMGROUP T-Force TXKD416G3600HC18ADC01 16gbs XMP
Video Card(s) HP GTX1650 super 4gb
Storage MZVLB256HBHQ-000H1 PM981a (256GB)/3TB HDD
Display(s) Nitro XF243Y Pbmiiprx
Case Rosewill CULLINAN
Audio Device(s) onboard
Power Supply Corsair 750w
Mouse Best Buy Insignia
Keyboard Best Buy Insignia
Software Win 10 pro

glusber

New Member
Joined
May 5, 2021
Messages
2 (0.14/day)
Hi, look, I'll tell you about my experience with an aorus 580 8gb, I wanted to flash it once and it went wrong .. I went to the techpower up page and downloaded the correct bios (you have to see what memories it has and thus download the correct one if you don't throw errors or directly do not start the pc), I connected the graphic and monitor to the integrated video of the mother but in the task manager it did not appear ... I had to do the following, look in the graphic on the back for the chip of the bios, then I had to bridge (putting the graphic with the pci port down) pin 1 and 8, so when you connect the graphic to the pc and monitor the integrated video, the pc starts up .. once it turns on, you flash the bios ... that's what I did and it works out of 10
 

impero

New Member
Joined
Apr 22, 2021
Messages
17 (0.63/day)
Glusber, i would like to ask you more details if you don't mind.
When your video card was dead - and you put it in the pciex slot - you started the computer with integrated video i presume.
1 -The fans from the video card was spinning ?
2 - you made the bridge 1 > 8 while the computer was running or you did it before and with bridge on you started the comp ?
Thanks
 

glusber

New Member
Joined
May 5, 2021
Messages
2 (0.14/day)
Glusber, me gustaría pedirte más detalles si no te importa.
Cuando su tarjeta de video estaba muerta, y la colocó en la ranura pciex, comenzó la computadora con video integrado, supongo.
1 -¿Los ventiladores de la tarjeta de video estaban girando?
2 - ¿Hiciste el puente 1> 8 mientras la computadora estaba funcionando o lo hiciste antes y con el puente encendido iniciaste la compilación?
Gracias
Hola no hay problema
Tuve que sacar el gráfico, ingresar el bios de la madre y empezar el video integrado primero ... de lo contrario la máquina se bloqueó en negro, no hizo nada ...
1- No recuerdo bien pero me parece que giraron lentamente ...
2- Tuve que descargar el gráfico porque tiene blackpake, una vez desarmado, hice un puente, conecté el gráfico a la pc y lo encendí, para ver si el puente funcionaba, vas al administrador de tareas y allí, en el adaptador de pantalla, saldría la serie rx 580 y un signo de exclamación de que windos se detuvo con tanta fuerza. etc etc ... en youtube hay un video de DAVID LIGHTMAN reviviendo un rx 570 mal flasheado, y allí nombra los comandos correctamente y luego parpadea ...
 
Top