• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Is it possible to bios flash 2070 Super FE?

yourig

New Member
Joined
Mar 15, 2020
Messages
7 (0.04/day)
I have a NVIDIA 2070 Super FE. The fans at idle are really annoying in my silent ITX build. The card runs at 27-30c, so I think it's a bit overkill having both fans locked at 41% during idle operation.
With that said, I want to flash the EVGA 2070 super bios that has 0db fanstop during idle operation. Is this possible?

I checked my FE card with GPU-Z and it says my device id is 10DE 1E84. The EVGA 2070 super is also 10DE 1E84. They also both have matching ports on the IO bracket.
With that said, is there any other precautions I need to take before attempting flashing besides matching the device id?

My GPU - https://www.techpowerup.com/vgabios/212046/nvidia-rtx2070super-8192-190531
What I want to flash - https://www.techpowerup.com/vgabios/213495/evga-rtx2070super-8192-190621
 
Joined
Apr 29, 2014
Messages
3,884 (1.66/day)
Location
Texas
System Name SnowFire / The Reinforcer / Portable? / New Portable?
Processor i7 8086K 5.0ghz (24/7) / 2x Xeon E52650v2 / i7 7700HQ / AMD Ryzen 5 3600X
Motherboard Asus Z370 Prime-A / Dell Dual Socket (R720) / HP Omen Stock / Asrock X570 ITX
Cooling RX 360mm + 140mm Custom Loop / Dell Stock / HP Stock / Noctua L9i (Yes L9i)
Memory Corsair RGB 16gb DDR4 3000 CL 16 / DDR3 128gb 16 x 8gb / 12gb DDR4 3 x 4gb / Corsair RGB 3200 16gb
Video Card(s) GTX Titan XP (2025mhz) / Asus GTX 950 (No Power Connector) / RX 580 / GTX 970 (Temp)
Storage Samsung 970 1tb NVME and 2tb HDD x4 RAID 5 / 300gb x8 RAID 5 / NVME 240gb SSD and 1tb HDD
Display(s) Acer XG270HU 1440p 144hz Freesync, Acer B286HK 4K UHD Monitor / 1080p 60hz Freesync display
Case Corsair Obsidian 800D / Dell Poweredge R720 Rack Mount Case / HP Omen 17 / Fractal Design Node 202
Audio Device(s) Realtec ALC1150 (On board)
Power Supply Rosewill Lightning 1300Watt / Dell Stock 750 / Brick / Fractal Design 450 Watt Bronze
Mouse Logitech G5
Keyboard Logitech G19S
Software Windows 10 Pro / Windows Server 2008 R2 / Windows 10 Home / Windows 10 Pro
I have a NVIDIA 2070 Super FE. The fans at idle are really annoying in my silent ITX build. The card runs at 27-30c, so I think it's a bit overkill having both fans locked at 41% during idle operation.
With that said, I want to flash the EVGA 2070 super bios that has 0db fanstop during idle operation. Is this possible?

I checked my FE card with GPU-Z and it says my device id is 10DE 1E84. The EVGA 2070 super is also 10DE 1E84. They also both have matching ports on the IO bracket.
With that said, is there any other precautions I need to take before attempting flashing besides matching the device id?

My GPU - https://www.techpowerup.com/vgabios/212046/nvidia-rtx2070super-8192-190531
What I want to flash - https://www.techpowerup.com/vgabios/213495/evga-rtx2070super-8192-190621
Why not just use MSI afterburner and set your own manual fan curve. Is a lot safer and less likely to cause an issue.
 

yourig

New Member
Joined
Mar 15, 2020
Messages
7 (0.04/day)
Why not just use MSI afterburner and set your own manual fan curve. Is a lot safer and less likely to cause an issue.
I've tried, but it won't go below 41% fan speed. For some reason it's locked.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.29/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I've tried, but it won't go below 41% fan speed. For some reason it's locked.
You are at absolute minimum for that card, you do this flash at your own risk.

Go ahead and flash using this tool, i would suggest reinstalling the gpu driver after flashing.

 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.29/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Yeah, that's why I want to flash it? Did you read the thread, or am I missing something?
Fan stop may not even work, by the way I updated my previous post.
 

yourig

New Member
Joined
Mar 15, 2020
Messages
7 (0.04/day)
Fan stop may not even work, by the way I updated my previous post.
Thanks. Is there anything else I need to check before flashing? Or is the matching IO ports and device ID enough to verify I won't brick it?
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.29/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Thanks. Is there anything else I need to check before flashing? Or is the matching IO ports and device ID enough to verify I won't brick it?
Yes you should be ok, ive helped users with AMD and nvidia cards either restore or crossflash them.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.29/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64

yourig

New Member
Joined
Mar 15, 2020
Messages
7 (0.04/day)
Are you using this specific tool from this link?


Proceed, there is a reason i gave you the link to the specific tool earlier.
Yup, downloaded what ya gave me, and it worked using the bios I found! The fans are completely off now when I'm on the desktop :clap:. Just have to test some games after and see if they spin up properly when hitting 60c.

I did have an issue with certains apps being drawn completely black, but reinstalling the drivers fixed it.

I think I might be the first to do this on the 2070 super, as there isn't any info anywhere on this one besides people asking.

Edit: Fans start to spin at 58c while gaming :clap:. Going to test RGB now.
Edit2: RGB does not work, but you can now turn off the green LED, where before you couldn't.
Edit3: Runs about 10c warmer, I'm at 38-40c, which should be expected. My 1060 sc that has fanstop by default also idled at around 40c.
Edit4: My card now maxes out around 37-40% fan speed during load. Apex Legends, maxed settings, 1440p - didn't even break 65c, this cooler is really good.
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.29/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Yup, downloaded what ya gave me, and it worked using the bios I found! The fans are completely off now when I'm on the desktop :clap:. Just have to test some games after and see if they spin up properly when hitting 60c.

I did have an issue with certains apps being drawn completely black, but reinstalling the drivers fixed it.

I think I might be the first to do this on the 2070 super, as there isn't any info anywhere on this one besides people asking.

Edit: Fans start to spin at 58c while gaming :clap:. Going to test RGB now.
Edit2: RGB does not work, but you can turn off the green LED.
Actually youre not the only 1 to have cross flashed a 2070, seen plenty, ive helped users restore fake 1050s/960s back to 450GTS lol

Yup, downloaded what ya gave me, and it worked using the bios I found! The fans are completely off now when I'm on the desktop :clap:. Just have to test some games after and see if they spin up properly when hitting 60c.

I did have an issue with certains apps being drawn completely black, but reinstalling the drivers fixed it.

I think I might be the first to do this on the 2070 super, as there isn't any info anywhere on this one besides people asking.

Edit: Fans start to spin at 58c while gaming :clap:. Going to test RGB now.
Edit2: RGB does not work, but you can turn off the green LED.
Use evga software for rgb effects
 

yourig

New Member
Joined
Mar 15, 2020
Messages
7 (0.04/day)
Actually youre not the only 1 to have cross flashed a 2070, seen plenty, ive helped users restore fake 1050s/960s back to 450GTS lol



Use evga software for rgb effects
For the 2070 super? I couldn't find anything on Google on flashing it. There was one post on Reddit, but it was a different device ID and the guy flashed an ASUS bios that killed a few of his ports.

And I am using EVGA software, seems the LED they used isn't RGB, but just G.

Also, I think I now know why they locked this card at 40%. I tried setting 15% fan speed to see the noise level, and the fans rev instead of continuously running. They rev up, then rev down, repeat over and over. But it stops reving at 20%, so still not completely sure why they locked it to 40%, when that's what they run at normally under load now.

And thanks for your guidance.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.29/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
For the 2070 super? I couldn't find anything on Google on flashing it. There was one post on Reddit, but it was a different device ID and the guy flashed an ASUS bios that killed a few of his ports.

And I am using EVGA software, seems the LED they used isn't RGB, but just G.

Also, I think I now know why they locked this card at 40%. I tried setting 15% fan speed to see the noise level, and the fans rev instead of continuously running. They rev up, then rev down, repeat over and over. But it stops reving at 20%, so still not completely sure why they locked it to 40%, when that's what they run at normally under load now.

And thanks for your guidance.
Thermal safety is why. Also port config does matter, if you have a card that doesnt have usb c and you flash a bios that does, your card may not work...
 

BusterDuster

New Member
Joined
Apr 13, 2020
Messages
3 (0.02/day)
Hi! I'm Dustin and new here!
I own a Zotac rtx 2070 super amp extreme (Tripple Fan) and have the same problem with the fans not going under 21% ! Also i would like to flash a bios with a little higher power limit.
Could someone offer me a bios for my Zotac Card ?

Best regards and stay safe!
 

Attachments

GeZorTenPlotZ

New Member
Joined
Apr 16, 2020
Messages
3 (0.02/day)
Sorry for "hijacking" but i can't get the modified NVFlash64 to flash my 2070 Super. Can someone please tell me how to do?
 

Attachments

Joined
Oct 22, 2014
Messages
9,631 (4.44/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
Hi! I'm Dustin and new here!
I own a Zotac rtx 2070 super amp extreme (Tripple Fan) and have the same problem with the fans not going under 21% ! Also i would like to flash a bios with a little higher power limit.
Could someone offer me a bios for my Zotac Card ?

Best regards and stay safe!
Zotac does not offer the fan stop feature on all it's cards.
Try this at your own risk: https://www.techpowerup.com/vgabios/212546/212546

Sorry for "hijacking" but i can't get the modified NVFlash64 to flash my 2070 Super. Can someone please tell me how to do?
It is preventing you from flashing the WRONG Bios.
 
Last edited:

Regeneration

NGOHQ.COM
Joined
Oct 26, 2005
Messages
2,436 (0.45/day)
I sense a wave of "flashed the wrong BIOS without taking a backup" threads coming this way.

If your fans are noisy at idle, you don't have to cross-flash, just download MSI Afterburner and setup a custom fan curve like this:

Clipboard02.jpg

"Idle off" is a bad idea for the long term. Higher temperature = shorter lifespan.

Another option is to upgrade to a 3rd party VGA cooler - like Accelero Xtreme.
 

Regeneration

NGOHQ.COM
Joined
Oct 26, 2005
Messages
2,436 (0.45/day)
But this Bios should be right. I just want to push-up the Power-Limit.
First of, backup your current BIOS.

Then find BIOS with higher power limit, but similar clocks, and SAME memory brand (Samsung/Hynix/Micron), and SAME monitor output configuration (for example: 2x DisplayPort, 3x HDMI).

Download this: https://www.techpowerup.com/download/nvidia-nvflash-with-board-id-mismatch-disabled/

nvflash64 --protectoff
nvflash64 -b backup.rom
nvflash64 -6 filename.rom
 

GeZorTenPlotZ

New Member
Joined
Apr 16, 2020
Messages
3 (0.02/day)

BusterDuster

New Member
Joined
Apr 13, 2020
Messages
3 (0.02/day)
I sense a wave of "flashed the wrong BIOS without taking a backup" threads coming this way.

If your fans are noisy at idle, you don't have to cross-flash, just download MSI Afterburner and setup a custom fan curve like this:

View attachment 151750

"Idle off" is a bad idea for the long term. Higher temperature = shorter lifespan.

Another option is to upgrade to a 3rd party VGA cooler - like Accelero Xtreme.
The fans won't go under 21% event when i make a custom fan curve. I also did a accelero extreme swap and thought i can go with these under 21% .. but the bios is preventing it.
And because of the Accelero Xtreme Swap i want a bios with zero fan mode and with slight higher TDP

The bios you posted is for a normal Zotac Rtx2070.

First of, backup your current BIOS.

Then find BIOS with higher power limit, but similar clocks, and SAME memory brand (Samsung/Hynix/Micron), and SAME monitor output configuration (for example: 2x DisplayPort, 3x HDMI).

Download this: https://www.techpowerup.com/download/nvidia-nvflash-with-board-id-mismatch-disabled/

nvflash64 --protectoff
nvflash64 -b backup.rom
nvflash64 -6 filename.rom
Hey, does Power Connection Ports matter?
I found a bios from the palit rtx2070 super Jetstream with a tdp of 300W with 2x 8pin Power Connection.
My Zotac Rtx 2070 super (240W tdp) only offers 1x6 and 1x8 pin.

Through pcie its 75W + 1x6pin (75W) + 1x8 pin (150W)... It should Work with 1x6 and 1x8 only the questions is if it matters for thr bios or is it equal what the Power Transistor get's his Power from?
 

Attachments

Last edited:
Joined
Jul 29, 2015
Messages
9 (0.00/day)
For the 2070 super? I couldn't find anything on Google on flashing it. There was one post on Reddit, but it was a different device ID and the guy flashed an ASUS bios that killed a few of his ports.

And I am using EVGA software, seems the LED they used isn't RGB, but just G.

Also, I think I now know why they locked this card at 40%. I tried setting 15% fan speed to see the noise level, and the fans rev instead of continuously running. They rev up, then rev down, repeat over and over. But it stops reving at 20%, so still not completely sure why they locked it to 40%, when that's what they run at normally under load now.

And thanks for your guidance.
Hi Yourig,

Well done!

It's good to see someone who managed to do it. I have been searching for this a while. Unfortunately, I don't seem to be very savvy with flashing and I would love some help to do it too.

I have the same GPU (2070 Super FE), downloaded the EVGA bios you mentioned and the patched tool from eidairaman1. But I am stuck there... :(
Bios: https://www.techpowerup.com/vgabios/213495/evga-rtx2070super-8192-190621
NVFLASH patched: https://www.techpowerup.com/download/nvidia-nvflash-with-board-id-mismatch-disabled/

I must be missing something, I do not get how to run the bios after running the patched nvflash...

Many thanks in advance for sharing/helping!
McFly
 
Top