1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Issues With C&C The First Decade: Zero Hour

Discussion in 'Games' started by Lone123, Sep 1, 2008.

  1. Lone123 New Member

    Sep 1, 2008
    2 (0.00/day)
    Thanks Received:
    Ive had The First Decade for a while now but i have just really started playing Zero Hour... im having a slight problem with it tho...

    When there is a big force or a large base with a few units my screen messes up, i would say it goes black but that isnt what happens... then Menu Bar at the bottom stays but the picture messes up it turns black but had certain images on it (one time it was King Raptors) it seems more like the image is being overlapped with another image from the map

    Can anyone help me with this problem? ive tried everything i was using 1280x960 res on high... but it also does it on 800x600 on low.

    to help here is my computer spec:

    OS: Vista Home Premium

    CPU: Intel Core 2 Duo, 2.2GHz
    Memory: 2GB 667MHz
    Graphics: Nvidia 8600GTS 512MB
  2. PVTCaboose1337

    PVTCaboose1337 Graphical Hacker

    Feb 1, 2006
    9,501 (2.25/day)
    Thanks Received:
    Dallas, Texas
    C&C does not work on Vista well. If you set the .exe to compatibility with XP, it will work. C&C Red Alert 2 had that same problem with me.
    10 Year Member at TPU
  3. Polarman

    Polarman New Member

    Jun 24, 2008
    1,626 (0.49/day)
    Thanks Received:
    To get the C&C first Decade working on Windows Vista, follow these:

    Install both patches. To install patch #2, copy the "TFD-102en.exe" file to the 'Support' folder in the TFD install
    directory and run the patch from this location.

    After that, take ownership of the TFD main folder.

    To do this right click on "Command & Conquer The First Decade" folder:

    Choose Properties > Security > Advanced > Owner > Edit > Select your username > Tick Replace Owner box > Apply.

    For TS/FS, RA2/Yuri's, Renegade & Generals/Zero Hour:

    Do the following for all .exe's (applications) in the folder:

    Go to Compatibility Tab, uncheck "run this program in compatibility mode for" and also check the box that says run as administrator.

    At the same time, You can do this fix for widescreen in some games.

    Just go to the game directory, open up the appropriate .ini file.

    Tiberian Sun: "sun.ini"
    Red Alert 2: "ra2.ini"
    Yuri's Revenge: "ra2md.ini"

    Look for these lines:

    ScreenWidth= (put your resolution here like 1680)
    ScreenHeight= (put your resolution here like 1050)
    Last edited: Sep 1, 2008
    Lone123 says thanks.
  4. Lone123 New Member

    Sep 1, 2008
    2 (0.00/day)
    Thanks Received:
    Thanks Polarman, went into the options file and changed the resolution and everything seems to be working fine now... actually had a match were i could see my fleet of 50 tanks lol

    Everything has worked fine appart from that little issue that now seems to be sorted

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)