• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Kingston A2000 1TB drive only showing up as "sm2263" and total size 1019 MB

Feb 7, 2020
16 (0.01/day)
I just got it. I'm on Windows 10 and had installed a 512GB XPG NVME drive for months without problem.

On a Ryzen 5 3600x and MSI B450M motherboard.

Anyone know what's going on?

I have it installed as a non-system drive. I saw another post with the same issue: https://www.reddit.com/r/MSI_Gaming/comments/edt3do
But I was seeing the correct Kingston 1000GB drive installed in device manager a couple of hours ago.


Oct 26, 2005
3,032 (0.46/day)
The dude from Reddit experienced exactly the same problem.


And he also tried it in another motherboard before RMAing it.

You should do the same thing... just return it to the shop or RMA.

SM2263 is the NVMe SSD controller.
Last edited:


Semi-Retired Folder
Nov 22, 2005
28,472 (4.32/day)
Indiana, USA
Processor Intel Core i7 10850K@5.2GHz
Motherboard AsRock Z470 Taichi
Cooling Corsair H115i Pro w/ Noctua NF-A14 Fans
Memory 32GB DDR4-3600
Video Card(s) RTX 2070 Super
Storage 500GB SX8200 Pro + 8TB with 1TB SSD Cache
Display(s) Acer Nitro VG280K 4K 28"
Case Fractal Design Define S
Audio Device(s) Onboard is good enough for me
Power Supply eVGA SuperNOVA 1000w G3
Software Windows 10 Pro x64
If the drive just reports as the controller model and a small size(usually the dram cache size) it is a fairly good chance the drive is dead.
Feb 7, 2020
16 (0.01/day)
If the drive just reports as the controller model and a small size(usually the dram cache size) it is a fairly good chance the drive is dead.

Yeah, that's what I fear. I emailed them.

I uninstalled the device from device manager, removed it, rebooted. I reseated it a couple of times.

It was showing Kingston 1000GB in the beginning, but when I tried to format it, it didn't format and the system just rebooted. For some time it was showing up as a "read-only" drive, and I tried to remove it from "read only" mode with diskpart but it didn't work.
Jun 2, 2017
6,934 (2.92/day)
System Name Best AMD Computer
Processor AMD 7900X3D
Motherboard Asus X670E E Strix
Cooling In Win SR36
Memory GSKILL DDR5 32GB 5200 30
Video Card(s) Sapphire Pulse 7900XT (Watercooled)
Storage Corsair MP 700, Seagate 530 2Tb, Adata SX8200 2TBx2, Kingston 2 TBx2, Micron 8 TB, WD AN 1500
Display(s) GIGABYTE FV43U
Case Corsair 7000D Airflow
Audio Device(s) Corsair Void Pro, Logitch Z523 5.1
Power Supply Deepcool 1000M
Mouse Logitech g7 gaming mouse
Keyboard Logitech G510
Software Windows 11 Pro 64 Steam. GOG, Uplay, Origin
Benchmark Scores Firestrike: 46183 Time Spy: 25121
No promises but I have had limited success using a external NVME adapter to reset the drive. I usually find that the volume is not set and populating it solves the problem.