• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Laptop died suggestions needed

Joined
May 7, 2008
Messages
921 (0.26/day)
Likes
128
System Name Demented
Processor AMD FX-8320 Vishera @ 4.5
Motherboard ASRock 970 EXTREME3
Cooling Thermaltake Frio
Memory G.SKILL Ripjaws Sniper Gaming Series 8GB (2 x 4GB)
Video Card(s) PowerColor AXR9 280X 3GBD5-2DHE/OC Radeon R9 280X
Storage (1)Crucial M500 240GB ssd (1)WD 500GB Black Edition
Display(s) Samsung 27" w/ Acer X163W 16" secondary
Case Antec P183
Audio Device(s) Realtek High Definition Audio (On Board 7.1)
Power Supply Corsair CMPSU-650TX 650W
Mouse SteelSeries Rival
Keyboard Tt eSPORTS MEKA G-Unit
Software Windows 7 64 bit Home Premium
#1
I have a Gateway M-6866 Notebook That has died. I have never worked on a laptop so I dont know anything hands on. I have read on the net but nothing I found seemed like my case. Can someone help me with diagnosing this.

Here is the story. It acted like the hard drive might be going out for a week or so. Weird glitches I even thought it might be Windows. I was going to order a new drive for it I was so sure that was the problem. Being the school loaned/leased them we just put the laptop away and used theirs. Its been about a year id guess and I decided to see what was wrong. I plugged it it knowing the battery was fore sure dead and nothing. I tried removing the battery and checked all my power cord connections but still nothing. I mean not one light or even a hint of power. Where should I start with this? :confused:

This thing is like brand new it was my daughters for school and has barely any use and never abused. It still looks like its a few weeks old. So I am ruling out it was dropped on its head syndrome. :laugh:
 
Joined
May 9, 2011
Messages
1,892 (0.77/day)
Likes
890
Location
Mainland Britain
System Name H2o Box
Processor Intel(R) Xeon e5-2690 v2 Stock 3.3GHz
Motherboard MSI X79A-G43 Plus (MS-7760) v3
Cooling CPU EK Block & Phobya G-Changer 360 V2.0 RAD H2o
Memory Gskill RipjawsZ 16Gb & Gskill TridentX 16Gb 9-10-9-28 2T @ 1866Mhz [locked]
Video Card(s) Zotac GTX 1080ti AMP EXTREME
Storage HyperX Fury 120GB & Savage 480GB SSD, Seagate 250GB,250GB 7200rpm Kingston 64GB SSD
Display(s) Panasonic GT30 46'' 1080p 3D HDTV [Custom Resolution 4096*2304]
Case Corsair O-800D
Audio Device(s) Creative Sound Blaster X-Fi Titanium Fatal1ty Pro
Power Supply Be Quiet! [Dark Power Pro 11] 1200W CM replaced [7-4-2017]
Mouse Asus ROG
Keyboard Microsoft Digital Media 1.0A
Software Win 10 Pro 64Bit v 1703 / OS[build 16299.192]
#2
Hi

remove battery or try one that is already charged if possible borrow one from a friend or colleague

remove the mouse and any other items that may be attached

check that you are using the correct AC adapter 65w [Part Number: 2528429R65-Watt 3-Prong AC Adapter (CRU/EURP)] - If yes; ensure this is working or use another compatible AC adapter that you know works

If you still have no power then it is more than likely that the main board is damaged or it has loose or broken connections

atb (all the best)

Law-II
 
Last edited: