1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Lexar JumpDrive P10 32 GB USB 3.0

Discussion in 'Reviews' started by Darksaber, Oct 25, 2013.

  1. Darksaber

    Darksaber W1zzard's Sidekick Staff Member

    Joined:
    Jul 8, 2005
    Messages:
    2,620 (0.60/day)
    Thanks Received:
    1,038
    Location:
    Gmunden, Austria
    Last edited: Dec 2, 2013
    H82LUZ73 says thanks.
    10 Year Member at TPU
  2. FreedomEclipse

    FreedomEclipse ~Technological Technocrat~

    Joined:
    Apr 20, 2007
    Messages:
    16,489 (4.47/day)
    Thanks Received:
    4,754
    Location:
    London,UK
    Whenever i see the word 'Jump' I think of Van Halen and have to load the song into my playlist

    But this is a pretty nippy drive.
     
    H82LUZ73 says thanks.
    10 Year Member at TPU
  3. Athlon2K15

    Athlon2K15 HyperVtX™

    Joined:
    Sep 27, 2006
    Messages:
    7,771 (1.99/day)
    Thanks Received:
    2,313
    Location:
    O-H-I-O
    What is the test system specs?
     
    10 Year Member at TPU
  4. ShurikN

    ShurikN

    Joined:
    Nov 3, 2013
    Messages:
    496 (0.38/day)
    Thanks Received:
    413
    Location:
    Tokyo, South Side
  5. FreedomEclipse

    FreedomEclipse ~Technological Technocrat~

    Joined:
    Apr 20, 2007
    Messages:
    16,489 (4.47/day)
    Thanks Received:
    4,754
    Location:
    London,UK
    10 Year Member at TPU
  6. SimpleTECH

    Joined:
    Jul 12, 2013
    Messages:
    163 (0.12/day)
    Thanks Received:
    114
    The only issue I have with those flash drives is that it has a minor compatibility issue with native USB 3.0 controllers (ex: AMD / Intel). Causes longer POSTs and slower shutdowns when the drive is inserted in those particular USB ports.
     
    Crunching for Team TPU
  7. HossHuge

    HossHuge

    Joined:
    Jun 26, 2008
    Messages:
    2,292 (0.70/day)
    Thanks Received:
    846
    Location:
    EDM, AB, CAN
    I bought the 32GB JumpDrive S73 about 5 months ago and it stopped working about a month ago.

    RMA sent.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)