• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Lookup Tool in GPU-Z - Reporting wrong model

Joined
Jan 18, 2024
Messages
329 (1.84/day)
Location
Mile High City
System Name Keds
Processor 5600X3D
Motherboard Gigabyte X470 AORUS ULTRA GAMING
Cooling Corsair H100i
Memory 32 GB Team Force DDR4 3200 CL16
Video Card(s) Power Color RX 7900 XT Red Devil
Storage 2x 1TB SSD / NVME
Display(s) AOpen 27in 1440p 170hz (27HC5UR)
Case Modified Corsair 540 Air
Audio Device(s) Logitech G35 / Corsair HS80
Power Supply EVGA 850GQ
Mouse Corsair M65
Keyboard Corsair Strafe Silent
Software Win 11 Home (Modded)
Benchmark Scores It will beat a snail in a down hill race.
So when I select look up, it takes my to a TPU page, but it is the wrong page. The page is for a Power Color Hell Hound and I have a Red Devil. Could they just be using the same product code that GPU-Z is picking up on?


Screenshot_3.png


Screenshot_4.png
 
Joined
Jan 5, 2006
Messages
18,347 (2.71/day)
System Name AlderLake / Laptop
Processor Intel i7 12700K P-Cores @ 5Ghz / Intel i3 7100U
Motherboard Gigabyte Z690 Aorus Master / HP 83A3 (U3E1)
Cooling Noctua NH-U12A 2 fans + Thermal Grizzly Kryonaut Extreme + 5 case fans / Fan
Memory 32GB DDR5 Corsair Dominator Platinum RGB 6000MT/s CL36 / 8GB DDR4 HyperX CL13
Video Card(s) MSI RTX 2070 Super Gaming X Trio / Intel HD620
Storage Samsung 980 Pro 1TB + 970 Evo 500GB + 850 Pro 512GB + 860 Evo 1TB x2 / Samsung 256GB M.2 SSD
Display(s) 23.8" Dell S2417DG 165Hz G-Sync 1440p / 14" 1080p IPS Glossy
Case Be quiet! Silent Base 600 - Window / HP Pavilion
Audio Device(s) Panasonic SA-PMX94 / Realtek onboard + B&O speaker system / Harman Kardon Go + Play / Logitech G533
Power Supply Seasonic Focus Plus Gold 750W / Powerbrick
Mouse Logitech MX Anywhere 2 Laser wireless / Logitech M330 wireless
Keyboard RAPOO E9270P Black 5GHz wireless / HP backlit
Software Windows 11 / Windows 10
Benchmark Scores Cinebench R23 (Single Core) 1936 @ stock Cinebench R23 (Multi Core) 23006 @ stock
Try the "Report an Error" button.
 
Joined
Jan 18, 2024
Messages
329 (1.84/day)
Location
Mile High City
System Name Keds
Processor 5600X3D
Motherboard Gigabyte X470 AORUS ULTRA GAMING
Cooling Corsair H100i
Memory 32 GB Team Force DDR4 3200 CL16
Video Card(s) Power Color RX 7900 XT Red Devil
Storage 2x 1TB SSD / NVME
Display(s) AOpen 27in 1440p 170hz (27HC5UR)
Case Modified Corsair 540 Air
Audio Device(s) Logitech G35 / Corsair HS80
Power Supply EVGA 850GQ
Mouse Corsair M65
Keyboard Corsair Strafe Silent
Software Win 11 Home (Modded)
Benchmark Scores It will beat a snail in a down hill race.
1712417099409.png

I should have known that.. .... .....
 

W1zzard

Administrator
Staff member
Joined
May 14, 2004
Messages
27,229 (3.70/day)
Processor Ryzen 7 5700X
Memory 48 GB
Video Card(s) RTX 4080
Storage 2x HDD RAID 1, 3x M.2 NVMe
Display(s) 30" 2560x1600 + 19" 1280x1024
Software Windows 10 64-bit
Making a thread is fine, too.

Try now, you should see a "multiple devices found" page. Underlying reason is that PowerColor keeps using teh same IDs for multiple products .. no idea why
 
Top