• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Making Audio Enhancers Work on Windows

Joined
May 28, 2018
Messages
43 (0.25/day)
Likes
0
wow it open but no sound effect, (music,voice,movies etc) I need xml files ?
edit: It want a "trick" for open, try to use TAB 4 times and press SPACE


dts.png
 
Last edited:
Joined
Aug 24, 2018
Messages
51 (0.62/day)
Likes
13
I realized here on the PC that after installing Dolby atmos uwp the equalizer apo is no longer working. Any solution?
Both solutions rely on APOs, thus you need to combine them.
Fastest possible solution: Configure Equaliser APO configuration to 1. use SFX/MFX/EFX 2. enable Equaliser APO as MFX APO.
Other solution: Open the Equaliser APO ini file from the load external config in notepad and paste LFX contents in composite SFX and GFX contents in composite EFX. Both composite SFX and EFX have contents if Dolby Atmos UWP is being used. Add Equaliser APO LFX and GFX on a new line.
 
Joined
Aug 19, 2018
Messages
7 (0.08/day)
Likes
0
Both solutions rely on APOs, thus you need to combine them.
Fastest possible solution: Configure Equaliser APO configuration to 1. use SFX/MFX/EFX 2. enable Equaliser APO as MFX APO.
Other solution: Open the Equaliser APO ini file from the load external config in notepad and paste LFX contents in composite SFX and GFX contents in composite EFX. Both composite SFX and EFX have contents if Dolby Atmos UWP is being used. Add Equaliser APO LFX and GFX on a new line.
Thank you so much, I understand how it works now.
 
Joined
May 28, 2018
Messages
43 (0.25/day)
Likes
0
Last edited:
Joined
Dec 13, 2014
Messages
121 (0.08/day)
Likes
30
Sound Blaster Connect UWP app to 2.2.2.0 not work for me only

Edit: 2.2.1.0 works
do NOT use SBConnect UWP app v2.2.2 - that is for Creative MBAPO2 DLL versions 2.0.0.20 & higher which only works with new Realtek chipsets

v2.2.1 is the last known working version although it actually shows v2.1.4 instead of 2.2.1 as I found out myself when using v2.0.0.14 of the Creative MBAPO2 DLL files from APO driver

note to alanfox2000 - see if you can update Creative.UWPRPCService.exe file in APO driver program to v2.0.2.3 (recent Realtek UAD drivers w/ Creative software component v2.0.0.25). also note that patching to enable Dolby Digital Live & DTS Interactive features (with pihto patcher) disables/removes SRS Premium Sound options as these options cannot be used at the same time; DDL/DTSi options kill SRS as DJ Urko mentioned in another thread

There too many GenKGA here.
This is the newest one fixed incorrect MAC hashing, it hashes now only Ethernet adapters (MIB_IF_TYPE_ETHERNET)
http://www.mediafire.com/file/1bab988oug7sglb/25.10.2018_GenKGA3.1.exe/file

Old KGA file:
http://www.mediafire.com/folder/u6u7lx014gq5s/Old_KGA
what is PW to extract genkga.3.1.exe? I cannot use it because I don't know the PW :(
 
Last edited:
Joined
Jan 30, 2018
Messages
317 (1.10/day)
Likes
163
do NOT use SBConnect UWP app v2.2.2 - that is for Creative MBAPO2 DLL versions 2.0.0.20 & higher which only works with new Realtek chipsets

v2.2.1 is the last known working version although it actually shows v2.1.4 instead of 2.2.1 as I found out myself when using v2.0.0.14 of the Creative MBAPO2 DLL files from APO driver

note to alanfox2000 - see if you can update Creative.UWPRPCService.exe file in APO driver program to v2.0.2.3 (recent Realtek UAD drivers w/ Creative software component v2.0.0.25). also note that patching to enable Dolby Digital Live & DTS Interactive features (with pihto patcher) disables/removes SRS Premium Sound options as these options cannot be used at the same time; DDL/DTSi options kill SRS as DJ Urko mentioned in another thread
No, the older laptop that have Cinema 5 UWP laptop which have older MBAPO2 DLL (e.g. v2.0.0.14) which update to newer MBAPO2 DLL through Windows Update (the older and newer MBAPO2 DLL have same software component ID).

I think they saw this post and did a "fix" already.

APO Driver updated to 2.2.8 - UWPRPCService v2.0.2.3

Also, you need to disable automatic updates for Windows 10 Store Apps in order to not get 2.2.2 installing



what is PW to extract genkga.3.1.exe? I cannot use it because I don't know the PW :(
You just need to double click and run it. Read the text carefully and you will see. If you still cannot see from the file, highlight -> password: 123
 
Last edited:
Joined
Aug 24, 2018
Messages
51 (0.62/day)
Likes
13
@alanfox2000
1541521137859.png

Scaling is obviously not a solved problem.
Try to enable System(enhanced). The current scaling rely only on making the application scale from the on log in DPI (application scaling). I logged on a 4k TV with 300% scaling. Now on my 1080p tablet broken scaling is occuring.
Normal task manager with FxConfigurator.
 
Joined
Apr 26, 2017
Messages
9 (0.02/day)
Likes
2
Processor Intel i7-7700HQ
Motherboard Clevo PA70Hx - AKA PA71HP6-G
Memory SK Hynix 16GB PC43-19200
Video Card(s) 6GB Nvidia GTX 1060 (Pascal)
Storage 120GB Western Digital SSD - 1TB Seagate ST1000LM048 - 1TB Samsung HD103SJ
Display(s) 1080p 120hz Chi Mei N173HHE-G32 - Samsung C27HG70
Case Clevo
Mouse MSI GM70 Clutch
Keyboard Logitech G Pro
Still can't get SBC 2 to work. Tried following several different instructions here, all to no avail.

I don't even get the thing where you can see it and it just says that it can't connect. This was after Windows decided to update drivers for both. I uninstalled those, attempted to install the previous. The old version seems to have an issue with Windows however, SBC instantly crashes.

I've tried using the APO on here an everything. Nothing seems to want to work.

Both Realtek and Creative suck, but Realtek does it in exceptional fashion.
 

Attachments

Joined
Oct 23, 2018
Messages
2 (0.09/day)
Likes
0
Still can't get SBC 2 to work. Tried following several different instructions here, all to no avail.

I don't even get the thing where you can see it and it just says that it can't connect. This was after Windows decided to update drivers for both. I uninstalled those, attempted to install the previous. The old version seems to have an issue with Windows however, SBC instantly crashes.

I've tried using the APO on here an everything. Nothing seems to want to work.

Both Realtek and Creative suck, but Realtek does it in exceptional fashion.

try dolby or nahimic... works fine

i use uad driver win10 latest stable with insider october patches

creative need the righ patch sometimes the tool produce not a vaild patch so try again :) also see the list which file you need for the creative version you have installed. i recommend uwp apps @win10 rs3 or higher

realtek alc 1150 with dac
 
Joined
Dec 13, 2014
Messages
121 (0.08/day)
Likes
30
You just need to double click and run it. Read the text carefully and you will see. If you still cannot see from the file, highlight -> password: 123
thanks. i am sorry for the trouble. I have had a "d'oh!" (homer simpson) moment because I was used to opening self-extracting exe files in 7zip without actually double-clicking on them to read the text. :banghead:

I was able to extract & run newer genkga file to activate SBconnect UWP app as SBCinema5. SBC5 really has less features than SBX360 & SBX720 as the environment and "voice morph" options were removed in SBC5 (need to connect a microphone to use voice morph options in SBX360 & SBX720).
 
Joined
Jan 30, 2018
Messages
317 (1.10/day)
Likes
163
Lenovo AIO 940 integrated with dolby atmos speaker system and using XML 3.3.0
https://github.com/alanfox2000/real...lenovo_ideapad/ext_lenovo_aio940_rs4_rs5_v228

Extra options in XML 3.3.0 (Highlight in orange)

<endpoint type="internal_speaker" brand="Generic" model="Default" operating_mode="normal" fs="48000" total_count="2" front_count="2" side_count="0" height_count="0" has_subwoofer="0">
<profile type="dynamic">
<tuning-cp>
<init-info>
<mi_process_disable value="0"/>
<virtual_bass_process_enable value="0"/>
<mode value="1"/>
<max_num_objects value="1"/>

</init-info>
<audio-optimizer-enable value="0"/>
<audio-optimizer-bands>
<ch_00 preset="array_20_zero"/>
<ch_01 preset="array_20_zero"/>
<ch_02 preset="array_20_zero"/>
<ch_03 preset="array_20_zero"/>
<ch_04 preset="array_20_zero"/>
<ch_05 preset="array_20_zero"/>
<ch_06 preset="array_20_zero"/>
<ch_07 preset="array_20_zero"/>
<ch_08 preset="array_20_zero"/>
<ch_09 preset="array_20_zero"/>
</audio-optimizer-bands>
<bass-enhancer-enable value="0"/>
<bass-enhancer-boost value="0"/>
<bass-enhancer-cutoff-frequency value="200"/>
<bass-enhancer-width value="16"/>
<bass-extraction-enable value="0"/>
<bass-extraction-cutoff-frequency value="200"/>
<calibration-boost value="0"/>
<dialog-enhancer-enable value="1"/>
<dialog-enhancer-amount value="7"/>
<dialog-enhancer-ducking value="0"/>
<graphic-equalizer-enable value="0"/>
<graphic-equalizer-bands value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<height-filter-mode value="0"/>
<ieq-enable value="1"/>
<ieq-amount value="10"/>
<ieq-bands-set value="157,166,218,218,203,189,192,192,205,213,218,210,194,158,134,98,70,22,-90,-283"/>
<mi-dialog-enhancer-steering-enable value="1"/>
<mi-dv-leveler-steering-enable value="1"/>
<mi-ieq-steering-enable value="1"/>
<mi-surround-compressor-steering-enable value="1"/>
<mi-virt-steering-enable value="1"/>
<postgain value="0"/>
<pregain value="0"/>
<process-optimizer-enable value="0"/>
<process-optimizer-bands>
<ch_00 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_01 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_02 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_03 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_04 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_05 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_06 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_07 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_08 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_09 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
</process-optimizer-bands>
<regulator-enable value="0"/>
<regulator-overdrive value="0"/>
<regulator-relaxation-amount value="96"/>
<regulator-speaker-dist-enable value="0"/>
<regulator-timbre-preservation value="12"/>
<regulator-tuning>
<threshold_high preset="array_20_zero"/>
<threshold_low preset="array_20_n192"/>
<isolated_band preset="array_20_zero"/>
</regulator-tuning>
<surround-boost value="96"/>
<surround-decoder-enable value="1"/>
<system-gain value="0"/>
<virtualizer-front-speaker-angle value="10"/>
<virtualizer-height-speaker-angle value="10"/>
<virtualizer-surround-speaker-angle value="10"/>
<virtual-bass-mix-freqs value="94,469"/>
<virtual-bass-mode value="0"/>
<virtual-bass-overall-gain value="0"/>
<virtual-bass-subgains value="-32,-144,-192"/>
<virtual-bass-slope-gain value="0"/>
<virtual-bass-src-freqs value="35,160"/>
<volmax-boost value="128"/>
<volume-leveler-enable value="1"/>
<volume-leveler-amount value="6"/>
<volume-leveler-in-target value="-320"/>
<volume-leveler-out-target value="-320"/>
<volume-modeler-enable value="0"/>
<volume-modeler-calibration value="0"/>
<output-mode-partial-surround-virtualizer-enable value="1"/>
<output-mode-partial-height-virtualizer-enable value="1"/>
<output-mode>
<processing_mode value="11"/>
<nb_output_channels value="2"/>
<mix_matrix value="16384,0,0,16384,11583,11583,8192,8192,16384,0,0,16384,16384,0,0,16384"/>
<output_ports value="1,2,3,4,5,6,7,8"/>

</output-mode>
</tuning-cp>
<tuning-vlldp>
<audio-optimizer-bands>
<ch_00 value="112,126,-96,-85,-82,-27,3,-34,-75,-13,-13,13,50,50,13,-67,-50,-34,43,77"/>
<ch_01 value="110,77,-90,-75,-75,-35,-10,-35,-50,-24,-6,29,70,56,26,-40,-10,0,58,93"/>
<ch_02 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_03 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_04 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_05 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_06 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_07 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
</audio-optimizer-bands>
<audio-optimizer-enable value="1"/>
<filter_coefficients>
<filter_setting>
<crossover_enable value="0"/>
<input_ch_0_1_crossover>
<frequency value="100"/>
<order value="4"/>
</input_ch_0_1_crossover>
<woofer_high_pass_filter>
<enable value="0"/>
<frequency value="100"/>
<order value="4"/>
</woofer_high_pass_filter>
<peaking_filter>
<enable value="0"/>
<frequency value="100"/>
<gain value="0"/>
<q value="1.000000"/>
</peaking_filter>
<polarity_invert value="0"/>
</filter_setting>
<coefficients>
<coefficient>
<sample_rate value="44100"/>
<array value=""/>
</coefficient>
<coefficient>
<sample_rate value="48000"/>
<array value=""/>
</coefficient>
<coefficient>
<sample_rate value="96000"/>
<array value=""/>
</coefficient>
<coefficient>
<sample_rate value="192000"/>
<array value=""/>
</coefficient>
</coefficients>
<max_num_channels value="6"/>

</filter_coefficients>
<postgain value="0"/>
<regulator-relaxation-amount value="96"/>
<regulator-overdrive value="0"/>
<regulator-timbre-preservation value="12"/>
<regulator-speaker-dist-enable value="1"/>
<regulator-tuning>
<threshold_high value="-139,-322,-368,-288,-136,-46,-53,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<threshold_low value="-331,-514,-560,-480,-328,-238,-245,-192,-192,-192,-192,-192,-192,-192,-192,-192,-192,-192,-192,-192"/>
<isolated_band value="1,1,1,1,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
</regulator-tuning>
<system-gain value="0"/>
</tuning-vlldp>
</profile>
 
Last edited:
Joined
Jun 20, 2017
Messages
407 (0.79/day)
Likes
35
Lenovo AIO 940 integrated with dolby atmos speaker system and using XML 3.3.0
https://github.com/alanfox2000/real...lenovo_ideapad/ext_lenovo_aio940_rs4_rs5_v228

Extra options in XML 3.3.0 (Highlight in orange)

<endpoint type="internal_speaker" brand="Generic" model="Default" operating_mode="normal" fs="48000" total_count="2" front_count="2" side_count="0" height_count="0" has_subwoofer="0">
<profile type="dynamic">
<tuning-cp>
<init-info>
<mi_process_disable value="0"/>
<virtual_bass_process_enable value="0"/>
<mode value="1"/>
<max_num_objects value="1"/>

</init-info>
<audio-optimizer-enable value="0"/>
<audio-optimizer-bands>
<ch_00 preset="array_20_zero"/>
<ch_01 preset="array_20_zero"/>
<ch_02 preset="array_20_zero"/>
<ch_03 preset="array_20_zero"/>
<ch_04 preset="array_20_zero"/>
<ch_05 preset="array_20_zero"/>
<ch_06 preset="array_20_zero"/>
<ch_07 preset="array_20_zero"/>
<ch_08 preset="array_20_zero"/>
<ch_09 preset="array_20_zero"/>
</audio-optimizer-bands>
<bass-enhancer-enable value="0"/>
<bass-enhancer-boost value="0"/>
<bass-enhancer-cutoff-frequency value="200"/>
<bass-enhancer-width value="16"/>
<bass-extraction-enable value="0"/>
<bass-extraction-cutoff-frequency value="200"/>
<calibration-boost value="0"/>
<dialog-enhancer-enable value="1"/>
<dialog-enhancer-amount value="7"/>
<dialog-enhancer-ducking value="0"/>
<graphic-equalizer-enable value="0"/>
<graphic-equalizer-bands value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<height-filter-mode value="0"/>
<ieq-enable value="1"/>
<ieq-amount value="10"/>
<ieq-bands-set value="157,166,218,218,203,189,192,192,205,213,218,210,194,158,134,98,70,22,-90,-283"/>
<mi-dialog-enhancer-steering-enable value="1"/>
<mi-dv-leveler-steering-enable value="1"/>
<mi-ieq-steering-enable value="1"/>
<mi-surround-compressor-steering-enable value="1"/>
<mi-virt-steering-enable value="1"/>
<postgain value="0"/>
<pregain value="0"/>
<process-optimizer-enable value="0"/>
<process-optimizer-bands>
<ch_00 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_01 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_02 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_03 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_04 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_05 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_06 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_07 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_08 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_09 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
</process-optimizer-bands>
<regulator-enable value="0"/>
<regulator-overdrive value="0"/>
<regulator-relaxation-amount value="96"/>
<regulator-speaker-dist-enable value="0"/>
<regulator-timbre-preservation value="12"/>
<regulator-tuning>
<threshold_high preset="array_20_zero"/>
<threshold_low preset="array_20_n192"/>
<isolated_band preset="array_20_zero"/>
</regulator-tuning>
<surround-boost value="96"/>
<surround-decoder-enable value="1"/>
<system-gain value="0"/>
<virtualizer-front-speaker-angle value="10"/>
<virtualizer-height-speaker-angle value="10"/>
<virtualizer-surround-speaker-angle value="10"/>
<virtual-bass-mix-freqs value="94,469"/>
<virtual-bass-mode value="0"/>
<virtual-bass-overall-gain value="0"/>
<virtual-bass-subgains value="-32,-144,-192"/>
<virtual-bass-slope-gain value="0"/>
<virtual-bass-src-freqs value="35,160"/>
<volmax-boost value="128"/>
<volume-leveler-enable value="1"/>
<volume-leveler-amount value="6"/>
<volume-leveler-in-target value="-320"/>
<volume-leveler-out-target value="-320"/>
<volume-modeler-enable value="0"/>
<volume-modeler-calibration value="0"/>
<output-mode-partial-surround-virtualizer-enable value="1"/>
<output-mode-partial-height-virtualizer-enable value="1"/>
<output-mode>
<processing_mode value="11"/>
<nb_output_channels value="2"/>
<mix_matrix value="16384,0,0,16384,11583,11583,8192,8192,16384,0,0,16384,16384,0,0,16384"/>
<output_ports value="1,2,3,4,5,6,7,8"/>

</output-mode>
</tuning-cp>
<tuning-vlldp>
<audio-optimizer-bands>
<ch_00 value="112,126,-96,-85,-82,-27,3,-34,-75,-13,-13,13,50,50,13,-67,-50,-34,43,77"/>
<ch_01 value="110,77,-90,-75,-75,-35,-10,-35,-50,-24,-6,29,70,56,26,-40,-10,0,58,93"/>
<ch_02 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_03 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_04 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_05 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_06 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<ch_07 value="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
</audio-optimizer-bands>
<audio-optimizer-enable value="1"/>
<filter_coefficients>
<filter_setting>
<crossover_enable value="0"/>
<input_ch_0_1_crossover>
<frequency value="100"/>
<order value="4"/>
</input_ch_0_1_crossover>
<woofer_high_pass_filter>
<enable value="0"/>
<frequency value="100"/>
<order value="4"/>
</woofer_high_pass_filter>
<peaking_filter>
<enable value="0"/>
<frequency value="100"/>
<gain value="0"/>
<q value="1.000000"/>
</peaking_filter>
<polarity_invert value="0"/>
</filter_setting>
<coefficients>
<coefficient>
<sample_rate value="44100"/>
<array value=""/>
</coefficient>
<coefficient>
<sample_rate value="48000"/>
<array value=""/>
</coefficient>
<coefficient>
<sample_rate value="96000"/>
<array value=""/>
</coefficient>
<coefficient>
<sample_rate value="192000"/>
<array value=""/>
</coefficient>
</coefficients>
<max_num_channels value="6"/>

</filter_coefficients>
<postgain value="0"/>
<regulator-relaxation-amount value="96"/>
<regulator-overdrive value="0"/>
<regulator-timbre-preservation value="12"/>
<regulator-speaker-dist-enable value="1"/>
<regulator-tuning>
<threshold_high value="-139,-322,-368,-288,-136,-46,-53,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
<threshold_low value="-331,-514,-560,-480,-328,-238,-245,-192,-192,-192,-192,-192,-192,-192,-192,-192,-192,-192,-192,-192"/>
<isolated_band value="1,1,1,1,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"/>
</regulator-tuning>
<system-gain value="0"/>
</tuning-vlldp>
</profile>
@alanfox2000 is Dolby Atmos v3.3.0 issues fixed? Or v3.2.0 is still better option?(Dialogue enhancer,etc)
 
Top