• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Making Audio Enhancers Work on Windows

StuDentBR

New Member
Joined
Mar 29, 2020
Messages
9 (0.15/day)
Where can I get the modded Nvidia drivers with dolby digital / DTS output on hdmi?
The one I got is crashing after sometime of use...
Can someone share it?
Is still possible to get dolby or dts encoding from Nvidia hdmi using the latest drivers?
Can someone confirm it?

Sorry for having so many questions
 
Joined
Apr 24, 2019
Messages
118 (0.29/day)
Where can I get the modded Nvidia drivers with dolby digital / DTS output on hdmi?
The one I got is crashing after sometime of use...
Can someone share it?
Is still possible to get dolby or dts encoding from Nvidia hdmi using the latest drivers?
Can someone confirm it?

Sorry for having so many questions
I'll try modding the latest HDAudio from nvidia driver, the version in my github probably not compatible with latest driver.
 

slayer23

New Member
Joined
Feb 18, 2020
Messages
13 (0.13/day)
Where can I get the modded Nvidia drivers with dolby digital / DTS output on hdmi?
The one I got is crashing after sometime of use...
Can someone share it?
Is still possible to get dolby or dts encoding from Nvidia hdmi using the latest drivers?
Can someone confirm it?

Sorry for having so many questions
Install the nvidia drivers without the HDMI audio drivers (maybe the nvidia ones work as well). install DS1 from Apo, then open Fx configurator, select the nvidia hdmi output, press product config and select Dolby Digital Plus Home theatre (HDMI/SPDIF) then apply. You will have dolby digital from the nvidia hdmi audio output.
 
Joined
Apr 24, 2019
Messages
118 (0.29/day)
I updated the nvidia hdaudio to latest v1.3.38.26 > Download (restart pc with disable driver signature enforcement mode then install, vdo instruction)

See the changes that needed to support dolby pcee4 in .inf file > original vs mod (if u can figure things out u can make updated mod for urself in future)

The bug u r talking abt that stops receiving sound for a while it's related to windows driver/component power saving mode. I can't fix that in kernel level thats on microsoft. But I have a fix in my mind. I'll tell u it later, first let me know if the driver works or not. @StuDentBR
 

StuDentBR

New Member
Joined
Mar 29, 2020
Messages
9 (0.15/day)
Captura de Tela (65).png

I still didn't install following that video guide that you made, by device manager.
I managed to install on these menus by right click on volume bar , but i am getting this error.
Any suggestion?
Edit: I managed it to get it working... But with some older version of the driver, now how can I stop windows from disconnect from receiver?
What is your idea?
 

Attachments

Last edited:
Joined
Aug 24, 2018
Messages
634 (0.98/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
Install the nvidia drivers without the HDMI audio drivers (maybe the nvidia ones work as well). install DS1 from Apo, then open Fx configurator, select the nvidia hdmi output, press product config and select Dolby Digital Plus Home theatre (HDMI/SPDIF) then apply. You will have dolby digital from the nvidia hdmi audio output.
Preferable to update the HDMI audio driver when using APO Driver.
APO driver can be reapplied if necessary.
Also, no need for disable driver signature enforcement.
 
Joined
Apr 24, 2019
Messages
118 (0.29/day)
View attachment 149822
I still didn't install following that video guide that you made, by device manager.
I managed to install on these menus by right click on volume bar , but i am getting this error.
Any suggestion?
Edit: I managed it to get it working... But with some older version of the driver, now how can I stop windows from disconnect from receiver?
What is your idea?

I'm sorry that u have to go through some trial and errors which should be done by me. But my pc and tv in a different room that's why I can't troubleshoot properly to give u a final solution. I updated the driver .inf in github and did some things differently than last time. If u r still interested in it u can try and tell me if this works this time or not.
 

StuDentBR

New Member
Joined
Mar 29, 2020
Messages
9 (0.15/day)
I'm sorry that u have to go through some trial and errors which should be done by me. But my pc and tv in a different room that's why I can't troubleshoot properly to give u a final solution. I updated the driver .inf in github and did some things differently than last time. If u r still interested in it u can try and tell me if this works this time or not.
Did you to use dolby home theater V4 with this driver?
because when i installed this driver before i was getting an error that the driver version was different i had 7.2.8000.13 and the expected was 7.2.7000.4...
Edit: Sorry still didn't work with your modded driver yet, i didn't got the registry error anymore but it won't let me use dolby because it says that the driver version is different it expects the version , i made some prints showing the errors, and also showing the driver that i am using and that is working now...
 

Attachments

Last edited:
Joined
Apr 24, 2019
Messages
118 (0.29/day)
Did you to use dolby home theater V4 with this driver?
because when i installed this driver before i was getting an error that the driver version was different i had 7.2.8000.13 and the expected was 7.2.7000.4...
Edit: Sorry still didn't work with your modded driver yet, i didn't got the registry error anymore but it won't let me use dolby because it says that the driver version is different it expects the version , i made some prints showing the errors, and also showing the driver that i am using and that is working now...

u already had an older version (7.2.7000.4) that is registered in ur system which is conflicting with the new version 7.2.8000.13 (mine)..u have to uninstall all previously installed driver by cmd pnputil.

Open CMD as administrator, type this -
Code:
pnputil /enum-drivers
This will show all installed driver in ur system. Find those modded audio driver related oem**.inf file (There could be multiple of them as what I saw from 4th image). Uninstall those oem**.inf drivers one by one by following this command-
Code:
pnputil /delete-driver oem**.inf /force
** = respected oem driver numbers that r related to those modded inf, uninstall all of them then restart ur PC.

Also I updated the inf in github with a little fix.
 
Joined
Feb 22, 2020
Messages
53 (0.54/day)
Hello.
This time i configured new audio drivers for CREATIVE SOUND BLASTER X-FI 5.1 SURROUND PRO USB & Realtek HD Audio mod with
-MB3 or BLASTERx720 for analog devices
-THX ThruStudio Pro with Dolby Digital Live,
-Dolby Atmos Sound System,
-Atmos for Headphones
-Dts: X, Headphones,
-Dts Interactive (SPiDF),
-Dts Audio Panel active.
I collect package of enhancers apps and upload files so download links coming soon!
....
xfi001.jpg
xfi0010.jpg
xfi0011.jpg
xfi002.jpg
xfi004.jpg
xfi003.jpg
xfi005.jpg
xfi006.jpg
xfi007.jpg
xfi009.jpg
 

dododo

New Member
Joined
Feb 18, 2018
Messages
27 (0.03/day)
Hello.
This time i configured new audio drivers for CREATIVE SOUND BLASTER X-FI 5.1 SURROUND PRO USB & Realtek HD Audio mod with
-MB3 or BLASTERx720 for analog devices
-THX ThruStudio Pro with Dolby Digital Live,
-Dolby Atmos Sound System,
-Atmos for Headphones
-Dts: X, Headphones,
-Dts Interactive (SPiDF),
-Dts Audio Panel active.
I collect package of enhancers apps and upload files so download links coming soon!
....
View attachment 150136View attachment 150137View attachment 150138View attachment 150139View attachment 150140View attachment 150141View attachment 150142View attachment 150143View attachment 150144View attachment 150145
THX:clap::clap:
 

StuDentBR

New Member
Joined
Mar 29, 2020
Messages
9 (0.15/day)
Hello.
This time i configured new audio drivers for CREATIVE SOUND BLASTER X-FI 5.1 SURROUND PRO USB & Realtek HD Audio mod with
-MB3 or BLASTERx720 for analog devices
-THX ThruStudio Pro with Dolby Digital Live,
-Dolby Atmos Sound System,
-Atmos for Headphones
-Dts: X, Headphones,
-Dts Interactive (SPiDF),
-Dts Audio Panel active.
I collect package of enhancers apps and upload files so download links coming soon!
....
View attachment 150136View attachment 150137View attachment 150138View attachment 150139View attachment 150140View attachment 150141View attachment 150142View attachment 150143View attachment 150144View attachment 150145
If i have installed your last package should i uinstall it first? or just install this one also and i am good to go?
Looking forward to test this new package out, thank you.
 
Last edited:
Joined
Feb 22, 2020
Messages
53 (0.54/day)
If i have installed your last package should i uinstall it first? or just install this one also and i am good to go?
Looking forward to test this new package out, thank you.
Download links for blaster suite:



Have fun!
 
Joined
Aug 24, 2018
Messages
634 (0.98/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
Joined
Apr 8, 2018
Messages
40 (0.05/day)
I install Uni Xonar Drivers.Install Apo Driver on Windows 7. I uninstall it and install oficial Asus DX Drivers.
Apo Driver not work for it.
 
Joined
Aug 24, 2018
Messages
634 (0.98/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
I install Uni Xonar Drivers.Install Apo Driver on Windows 7. I uninstall it and install oficial Asus DX Drivers.
Apo Driver not work for it.
What enhancer did you apply?
 
Joined
Apr 8, 2018
Messages
40 (0.05/day)
DTS and Dolby. No one not work. I think need modded driver for this sound card.
On Realtek all work fine and well.
 
Joined
Aug 24, 2018
Messages
634 (0.98/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
DTS and Dolby. No one not work. I think need modded driver for this sound card.
On Realtek all work fine and well.
Sure you are applying on the good endpoint?
Can I get a screenshot of:
1. sound control panel
2. playback device supported formats tab
3. playback device advanced tab, with shared formats option clicked?
4. FX Configurator with endpoint selected.
Xonar DX | Sound Cards | ASUS Global
www.asus.com › Sound Cards › Gaming

Is this the sound card? It says that DDL is already supported on stock driver.
 
Last edited:
Joined
Apr 8, 2018
Messages
40 (0.05/day)
Yes. DTS and other enhacers not work. Via Sys FX too. Modded driver need.
Driver this not support DTS and APO Driver??
 
Joined
Aug 24, 2018
Messages
634 (0.98/day)
System Name Dell Inspiron 7375
Processor AMD Ryzen™ 7 2700U Mobile Processor with Radeon™ RX Vega 10 Graphics
Memory 16GB (total) 2400MHz DDR4 SODIMM
Video Card(s) Radeon™ RX Vega 10 Graphics
Storage SanDisk X600 SATA SSD 512GB
Display(s) BOE NV13FHM
Audio Device(s) Realtek ALC3253 (Dell Labelling) ALC255 (Real name)
Yes. DTS and other enhacers not work. Via Sys FX too. Modded driver need.
Driver this not support DTS and APO Driver??
Give the screenshot.
Usually people makes modded drivers for popular sound interfaces. Hard to get someone to make a modded driver, when modders may not have the card.
APO driver is meant for cases like yours. So let me help you by providing the screenshot, so that I (or someone else) may help you use APO driver.
 
Joined
Feb 22, 2020
Messages
53 (0.54/day)
Any idea for non realtek users.
H4cziLLa
What You mean "non realtek" users?
I have realtek hd audio device but using sound blaster x-fi 5.1 surround pro and most settings audio on my computer using for most quality sound for sound blaster.
xfi17.jpg
xfi16.jpg
xfi15.jpg
xfi18.jpg


Virtual cable device is not needed. In my priv opinion is a shit software and cannot make a better quality of sound.

Greatful for Alan Finotty best drivers modder EVER!! :)

My version of realtek ha audio driver is based on Alan Finotty drivers but..... :)
xfi19.jpg
 
Last edited:
Joined
Feb 15, 2019
Messages
36 (0.08/day)
@ador250 love your git hub bro, nice work. I would love to make a suggestion based on what I am doing with your drivers that I am very pleased with.

Check out a post I made here about how I have been patching UAD drivers for a while now. I think it would go great with almost all your setups, easier to implement in a way too, except if you do include the patched .dll in the install process I dont know of a way around having to have driver enforcement disabled unless one could successfully sign the .dll beforehand which I do not. Personally I drop in safe mode, just easier.

I have pics and etc on other post showing it working in UAD and all, personally I have never had it not work and everything sounds nice on both headphones or my AVR.
 
Joined
Apr 24, 2019
Messages
118 (0.29/day)
@ador250 love your git hub bro, nice work. I would love to make a suggestion based on what I am doing with your drivers that I am very pleased with.

Check out a post I made here about how I have been patching UAD drivers for a while now. I think it would go great with almost all your setups, easier to implement in a way too, except if you do include the patched .dll in the install process I dont know of a way around having to have driver enforcement disabled unless one could successfully sign the .dll beforehand which I do not. Personally I drop in safe mode, just easier.

I have pics and etc on other post showing it working in UAD and all, personally I have never had it not work and everything sounds nice on both headphones or my AVR.
Yeah, I know about that. You can literally use the HDA version of "RltkAPO64.dll" (patched by pihto A1 patcher) to UAD version of "RltkAPOU64.dll". U can unlock those legacy DTS/Dolby component in UAD driver. Right now there is 3 way to do this-

1. A1 patcher by pihto
2. Emulate a dolby/dts supported mobo by rtkhdaud.dat (AudioDevice_sky tool)
3. Use the apo file by implementing LFX/GFX strings in .inf file. (what alanfox2000 do, I also follow this method)

I don't want to use the patched HDA version of dll in UAD bcoz of consistency plus I think 8899 is the last version of HDA release. Realtek will go full UAD from now. AudioDevice_sky is great, u can use it on any modded driver, mine or Alan Finote driver. @bottlefedc83
 
Top