• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Mining BIOS repository

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,644 (5.72/day)
Location
Houston
System Name All the cores || Into the Blue
Processor 2990WX || 5960X
Motherboard Asrock X399M || Asus X99M WS
Cooling CPU-XSPC RayStorm Neo, 2x240mm+360mm, D5PWM+140mL, GPU-2x360mm, 2xbyski, D4+D5+100mL || TBD
Memory 4x8GB G.Skill Trident Z 3200 CL16 || EVGA 3200 2x8GB
Video Card(s) (2) EVGA SC BLACK 1080Ti's || EVGA 1080Ti FE
Storage 2x Samsung SM951 512GB, Samsung PM961 512GB || OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || TBD
Case Caselabs Mercury S5+pedestal || Supermicro S5 (GS5A-753K)
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Seasonic Snow Silent 750w
Mouse Thermaltake Theron, Steam controller || TBD
Keyboard Thermaltake Poseidon ZX, Steam controller || Corsair K70
Software W10P || W10P


Oh man playing with some of those new MSI Mk2 armor cards. Not bad for the first revision on a 570
 
Joined
Aug 3, 2011
Messages
911 (0.30/day)
Location
At the Pub
System Name Sli Lake
Processor i5 7600K w.c
Motherboard Z170 Pro Gaming
Cooling Hardline Acrylic w.c
Memory 2x8GB Corsair 3000
Video Card(s) GTX 1070 Sli w.c
Storage M.2 850 Evo 512
Display(s) 4K 40" BDM4065UC
Case Corsair 750D
Audio Device(s) Asus Zonar
Power Supply Corsair AX1200
Mouse Logitech G502
Keyboard Logitech G910
Software Win 10 x64 atm
Benchmark Scores It Chops
Hey buddy,

Got a 570 8gb Nitro here for you to check out : )

I did try a strap at 1500 but windows didn't like it and wouldn't boot. Maybe start the strap at 1750? Hynix mem.

Thanks pal.

BTW was very close to picking up some of those Mk2 armor cards but went the Nitro..
 

Attachments

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,644 (5.72/day)
Location
Houston
System Name All the cores || Into the Blue
Processor 2990WX || 5960X
Motherboard Asrock X399M || Asus X99M WS
Cooling CPU-XSPC RayStorm Neo, 2x240mm+360mm, D5PWM+140mL, GPU-2x360mm, 2xbyski, D4+D5+100mL || TBD
Memory 4x8GB G.Skill Trident Z 3200 CL16 || EVGA 3200 2x8GB
Video Card(s) (2) EVGA SC BLACK 1080Ti's || EVGA 1080Ti FE
Storage 2x Samsung SM951 512GB, Samsung PM961 512GB || OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || TBD
Case Caselabs Mercury S5+pedestal || Supermicro S5 (GS5A-753K)
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Seasonic Snow Silent 750w
Mouse Thermaltake Theron, Steam controller || TBD
Keyboard Thermaltake Poseidon ZX, Steam controller || Corsair K70
Software W10P || W10P


30mh/s from the 8GB 570 isn't bad. @Outback Bronze will get on it after I get this one in it's new home and out of my test rig
 
Joined
Aug 3, 2011
Messages
911 (0.30/day)
Location
At the Pub
System Name Sli Lake
Processor i5 7600K w.c
Motherboard Z170 Pro Gaming
Cooling Hardline Acrylic w.c
Memory 2x8GB Corsair 3000
Video Card(s) GTX 1070 Sli w.c
Storage M.2 850 Evo 512
Display(s) 4K 40" BDM4065UC
Case Corsair 750D
Audio Device(s) Asus Zonar
Power Supply Corsair AX1200
Mouse Logitech G502
Keyboard Logitech G910
Software Win 10 x64 atm
Benchmark Scores It Chops
Joined
Mar 10, 2015
Messages
2,126 (1.27/day)
System Name Wut?
Processor 4770K @ 4.4
Motherboard MSI Z97 Gaming 7
Cooling Water
Memory 16GB DDR3 2400
Video Card(s) Vega 56
Storage 1TB SSD, forgot which one. Evo maybe?
Display(s) 3440 x 1440
Case Thermaltake T81
Power Supply Seasonic 750 Watt Gold
Oh man playing with some of those new MSI Mk2 armor cards. Not bad for the first revision on a 570
Curious, what is the ambient temp to keep your dual mining temps that low?
 

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,644 (5.72/day)
Location
Houston
System Name All the cores || Into the Blue
Processor 2990WX || 5960X
Motherboard Asrock X399M || Asus X99M WS
Cooling CPU-XSPC RayStorm Neo, 2x240mm+360mm, D5PWM+140mL, GPU-2x360mm, 2xbyski, D4+D5+100mL || TBD
Memory 4x8GB G.Skill Trident Z 3200 CL16 || EVGA 3200 2x8GB
Video Card(s) (2) EVGA SC BLACK 1080Ti's || EVGA 1080Ti FE
Storage 2x Samsung SM951 512GB, Samsung PM961 512GB || OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || TBD
Case Caselabs Mercury S5+pedestal || Supermicro S5 (GS5A-753K)
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Seasonic Snow Silent 750w
Mouse Thermaltake Theron, Steam controller || TBD
Keyboard Thermaltake Poseidon ZX, Steam controller || Corsair K70
Software W10P || W10P
Joined
Mar 10, 2015
Messages
2,126 (1.27/day)
System Name Wut?
Processor 4770K @ 4.4
Motherboard MSI Z97 Gaming 7
Cooling Water
Memory 16GB DDR3 2400
Video Card(s) Vega 56
Storage 1TB SSD, forgot which one. Evo maybe?
Display(s) 3440 x 1440
Case Thermaltake T81
Power Supply Seasonic 750 Watt Gold
All of my cards were well into the 70s when trying to dual mine. There were mostly msi gaming and armors.

EDIT: On a side note, we keep the temp of our house near 80F though.
 

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,644 (5.72/day)
Location
Houston
System Name All the cores || Into the Blue
Processor 2990WX || 5960X
Motherboard Asrock X399M || Asus X99M WS
Cooling CPU-XSPC RayStorm Neo, 2x240mm+360mm, D5PWM+140mL, GPU-2x360mm, 2xbyski, D4+D5+100mL || TBD
Memory 4x8GB G.Skill Trident Z 3200 CL16 || EVGA 3200 2x8GB
Video Card(s) (2) EVGA SC BLACK 1080Ti's || EVGA 1080Ti FE
Storage 2x Samsung SM951 512GB, Samsung PM961 512GB || OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || TBD
Case Caselabs Mercury S5+pedestal || Supermicro S5 (GS5A-753K)
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Seasonic Snow Silent 750w
Mouse Thermaltake Theron, Steam controller || TBD
Keyboard Thermaltake Poseidon ZX, Steam controller || Corsair K70
Software W10P || W10P


This is the powercolor red dragon 580 8GB I have finally got around to BIOS modding. Took more memory clockspeed, but it is doing quite well.

My house is at like 72-74, when they move out into the no-AC garage temps are higher, but not crazy. Everything I have is set to try and maintain 75C (no noise constraints) with a max temp of 83C

Hey buddy,

Got a 570 8gb Nitro here for you to check out : )

I did try a strap at 1500 but windows didn't like it and wouldn't boot. Maybe start the strap at 1750? Hynix mem.

Thanks pal.

BTW was very close to picking up some of those Mk2 armor cards but went the Nitro..
Give this a go. The strap should be good for 2200-2250mhz depending on card.

EDIT: Also attached the other two cards I worked on today.
 

Attachments

Last edited:

cyrhex

New Member
Joined
Mar 6, 2018
Messages
3 (0.01/day)
hi cdawall can you mod my xfx rx 460 vbios for macOS ,the default xfx rx 460 bios is not compatible under macOS form sierra to the current macOS,willing to donate,thanx in advance
 

Attachments

Last edited:

hmgp

New Member
Joined
Mar 14, 2018
Messages
3 (0.01/day)
Hi members.

I've been going thru hell with my rx570nitro+ (3 4gb and 3 8gb).

I can't get the best stable power/hashrate ratio and I've almost bricked two of them. Luckily I could recover and flash stock bios.

I wonder if anyone can help me in getting these good and pointers on the best overdrive settings. I'm not mining since saturday and I believe I've lost some hair :p

Thanks in advance

ps: More than help on getting the right bios, I'd like to really understand what I should change and why so I know what I'm doing and can improve gpu's in the future.

ps 2: I've attached all the 4gb roms but I think they're all the same
 

Attachments

vaddy

New Member
Joined
Mar 14, 2018
Messages
1 (0.00/day)
I no longer have a Micron based card though so if you have one and would like to see it tweaked please send me the BIOS!
hello cdawall help me with modifying my powercolor red dragon 570 8GB micron BIOS based off of mining card DVI only
I've tried different settings but the bios miner blocks the GPU frequency above 800 MHz. I no longer know what to do, can I flash a similar BIOS from the game version RX 570 Red Devil 8GB Mircon of the card, and not for the mining. I also put the game version here
ORIGINAL 18-19 m/H
MOD 21 m/H
I need lower power consuptio too
I also attach her mod version
 

Attachments

Joined
Aug 3, 2011
Messages
911 (0.30/day)
Location
At the Pub
System Name Sli Lake
Processor i5 7600K w.c
Motherboard Z170 Pro Gaming
Cooling Hardline Acrylic w.c
Memory 2x8GB Corsair 3000
Video Card(s) GTX 1070 Sli w.c
Storage M.2 850 Evo 512
Display(s) 4K 40" BDM4065UC
Case Corsair 750D
Audio Device(s) Asus Zonar
Power Supply Corsair AX1200
Mouse Logitech G502
Keyboard Logitech G910
Software Win 10 x64 atm
Benchmark Scores It Chops
The gaming X bios with micron has a very conservative memory clock right now please play with this and let me know what it maxes out at I can redo the BIOS for that.
Hey buddy,

I've been having crashing issues with the bios that you have supplied for this card. I think its the memory clock set in the bios.

It's written for 1900Mhz and when I leave it default it seems to not like it. I've been having constant rebooting/screen freezing issues. If I down clock the memory to 1800Mhz it doesn't crash.

I'm testing 1850Mhz atm and will let you know if this speed is good to go.

Thanks.
 

Devilioso

New Member
Joined
Mar 26, 2018
Messages
3 (0.01/day)
Are there any Gigabyte Gaming RX 580 8GB modded BIOSs out here? Or could I use different brand BIOS on Gigabyte?
Thx!
 

VietOZ

New Member
Joined
Apr 4, 2018
Messages
3 (0.01/day)
Location
Houston
Hi cdawall,

I have a couple of the RX 580 MSI Mk2 armor OC 8gb version. Can you help mod the bios for me?

Thanks in advance!!
 

Attachments

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,644 (5.72/day)
Location
Houston
System Name All the cores || Into the Blue
Processor 2990WX || 5960X
Motherboard Asrock X399M || Asus X99M WS
Cooling CPU-XSPC RayStorm Neo, 2x240mm+360mm, D5PWM+140mL, GPU-2x360mm, 2xbyski, D4+D5+100mL || TBD
Memory 4x8GB G.Skill Trident Z 3200 CL16 || EVGA 3200 2x8GB
Video Card(s) (2) EVGA SC BLACK 1080Ti's || EVGA 1080Ti FE
Storage 2x Samsung SM951 512GB, Samsung PM961 512GB || OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || TBD
Case Caselabs Mercury S5+pedestal || Supermicro S5 (GS5A-753K)
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Seasonic Snow Silent 750w
Mouse Thermaltake Theron, Steam controller || TBD
Keyboard Thermaltake Poseidon ZX, Steam controller || Corsair K70
Software W10P || W10P
Hi cdawall,

I have a couple of the RX 580 MSI Mk2 armor OC 8gb version. Can you help mod the bios for me?

Thanks in advance!!
Which memory does your specific card have? This one is preloaded for hynix/samsung/micron

EDIT give this a try this has all of the straps modded corresponding to their brand. So it should work with them all. Let me know if you have stability problems.
 

Attachments

Last edited:

VietOZ

New Member
Joined
Apr 4, 2018
Messages
3 (0.01/day)
Location
Houston
Which memory does your specific card have? This one is preloaded for hynix/samsung/micron

EDIT give this a try this has all of the straps modded corresponding to their brand. So it should work with them all. Let me know if you have stability problems.
Thanks a bunch bro!! Mine has Micron memory. Sorry shoulda stated in the 1st post, was hurried for work this morning :)
I'll give it a try tonight when I get home from work. Thanks again!!
 

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,644 (5.72/day)
Location
Houston
System Name All the cores || Into the Blue
Processor 2990WX || 5960X
Motherboard Asrock X399M || Asus X99M WS
Cooling CPU-XSPC RayStorm Neo, 2x240mm+360mm, D5PWM+140mL, GPU-2x360mm, 2xbyski, D4+D5+100mL || TBD
Memory 4x8GB G.Skill Trident Z 3200 CL16 || EVGA 3200 2x8GB
Video Card(s) (2) EVGA SC BLACK 1080Ti's || EVGA 1080Ti FE
Storage 2x Samsung SM951 512GB, Samsung PM961 512GB || OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || TBD
Case Caselabs Mercury S5+pedestal || Supermicro S5 (GS5A-753K)
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Seasonic Snow Silent 750w
Mouse Thermaltake Theron, Steam controller || TBD
Keyboard Thermaltake Poseidon ZX, Steam controller || Corsair K70
Software W10P || W10P
Let me know how it works may have to push the memory to 2200mhz but my micron 570 8gb mk2 does 31.5 or so with that timing set. In theory that should get you to the same.
 

VietOZ

New Member
Joined
Apr 4, 2018
Messages
3 (0.01/day)
Location
Houston
I'll test it out tonight and report back here. Thanks man!

Update:

It won't boot after flash, I had to use another card to recover the stock bios.
Here's what I did:
Ran ATIwinflash as admin
load your bios
program ====> here I notice ATIwinflash kinda hang ...
ran atikmdag
reboot

Error code 62 during boot

Edit 2:

So after reading around and gaining confident that I can restore the stock bios, I download the PolarisEditor 1.4 RX5xx and tried to copied some of your setting.
I came up with this. Not a huge improvement but it did hit 29.5 using 110W. I know it can be more optimize, but I'm not sure which strap to use.
Can you take a look to see what can be improve? Thanks again! I learned alot.
Settings:
I copied 1:1750 to 1:2000 and 2:1750 to 2:2000
TDP 120

Current setting when mining:
GPU clock : 1150
Memory clock: 2175
Power usage (gpuz) 110W
Temp: 50C

I ran it over 6hrs and got 9 shares rejected. 0 memory errors show on hwinfo64
 

Attachments

Last edited:

KPACABA

New Member
Joined
Apr 10, 2018
Messages
1 (0.00/day)
@cdawall Hey! Can you please take a look at my ASUS MINING-RX470-4G-LED with 4GB and Samsung memory?
Have tried to use your Samsung straps, but still can't get more than 27-28 MH/s...
Thanks in advance!
 

Attachments

amaddel

New Member
Joined
Apr 19, 2018
Messages
5 (0.01/day)
Hello!
i have a very tricky powercolor rx 470 red devil, i just cant get past ~500 hs on monero and ~21on ethash.
Even if i overclock nothing changes in better on contrary i get worse hashrate.
If i mod the bios with one click straps i get 0 core, 0voltage, etc in msi, and the miner doesnt recognize.
I tried 1 rx red devil 470 bios that i found on internet but it didnt work, i tried a rx 570 red devil but again it didnt work.

So please i would like to get atleast 700 hs on monero and 26 on ethash.
I will mine for 2 day if you can mod it.
i posted the original bios.
 

Attachments

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,644 (5.72/day)
Location
Houston
System Name All the cores || Into the Blue
Processor 2990WX || 5960X
Motherboard Asrock X399M || Asus X99M WS
Cooling CPU-XSPC RayStorm Neo, 2x240mm+360mm, D5PWM+140mL, GPU-2x360mm, 2xbyski, D4+D5+100mL || TBD
Memory 4x8GB G.Skill Trident Z 3200 CL16 || EVGA 3200 2x8GB
Video Card(s) (2) EVGA SC BLACK 1080Ti's || EVGA 1080Ti FE
Storage 2x Samsung SM951 512GB, Samsung PM961 512GB || OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || TBD
Case Caselabs Mercury S5+pedestal || Supermicro S5 (GS5A-753K)
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Seasonic Snow Silent 750w
Mouse Thermaltake Theron, Steam controller || TBD
Keyboard Thermaltake Poseidon ZX, Steam controller || Corsair K70
Software W10P || W10P
@amaddel the first part of that issue is driver related. After you install your patched driver you need to run the atikpatcher also it sounds like you are not using the beta blockchain drivers. If that is true you need to enable compute mode. On the latest claymore dual miner you can do that with a -y command in your config.txr
 

amaddel

New Member
Joined
Apr 19, 2018
Messages
5 (0.01/day)
@amaddel the first part of that issue is driver related. After you install your patched driver you need to run the atikpatcher also it sounds like you are not using the beta blockchain drivers. If that is true you need to enable compute mode. On the latest claymore dual miner you can do that with a -y command in your config.txr
Hi, you were right, i used atikpatcher and my modded bios was recognized, but the second part of the problem is that i cant overclock, i mean it does not increase the performance.
So what i did next i copied the 1350 memory string and pasted to the 1750 which is default and that's what gave me 690 hs then i overclocked the core to 1450 and now i have 720 hs.
 
Top