• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

MSI R6950 flashing bios problem

Cinders

New Member
Joined
Mar 21, 2013
Messages
4 (0.00/day)
Likes
1
#1
Hi all, hope someone can give me advice here

Problem:
MSI R6950 2PM2D2GD5
I cannot successfully flash a working bios into position 1 (afaik position 2 is the protected one, or at least that's the way I've been doing it).
On my prior mobo, I had it flashed to a 6970 reference bios, and while it gave me troubles with checksums, I got it to boot and work.

I've rebuilt with an M5A99FX PRO mobo, and it won't POST (gives a red light POST error on card). Going to position 2 (original bios), it posts fine.

So after trying ATIFlash, WinFlash, RBE, etc. it gives me SSID and adapter checksum errors. I used forced flash (both in dos and in winflash), which will not post.

Ok, so I tried to flash the original BIOS into position 1 (modded position), but it gives me checksum errors (SSID and adapter). I cannot even flash the original BIOS into position 1, nor any other BIOS that I've tried, including modded ones and other copies of original BIOS.

Just to clarify: I'm fine in position 2. Not touching that one as far as modding, since it's the only one that boots.

So the new issue comes from the new MOBO that won't POST past this. I'm not sure if it's not liking the checksum or what and just stopping dead.

Also, when I force flash it and check it in WinFlash and RBE, it does report the forced BIOS is indeed there, but just won't boot up under that BIOS. It's verified flashed.

I'd appreciate any advice. My google-fu is strong and I've looked up the most common fixes. I'm not sure what's going on here.
 
Last edited:
Joined
May 9, 2011
Messages
1,893 (0.77/day)
Likes
891
Location
Mainland Britain
System Name H2o Box
Processor Intel(R) Xeon e5-2690 v2 Stock 3.3GHz
Motherboard MSI X79A-G43 Plus (MS-7760) v3
Cooling CPU EK Block & Phobya G-Changer 360 V2.0 RAD H2o
Memory Gskill RipjawsZ 16Gb & Gskill TridentX 16Gb 9-10-9-28 2T @ 1866Mhz [locked]
Video Card(s) Zotac GTX 1080ti AMP EXTREME
Storage HyperX Fury 120GB & Savage 480GB SSD, Seagate 250GB,250GB 7200rpm Kingston 64GB SSD
Display(s) Panasonic GT30 46'' 1080p 3D HDTV [Custom Resolution 4096*2304]
Case Corsair O-800D
Audio Device(s) Creative Sound Blaster X-Fi Titanium Fatal1ty Pro
Power Supply Be Quiet! [Dark Power Pro 11] 1200W CM replaced [7-4-2017]
Mouse Asus ROG
Keyboard Microsoft Digital Media 1.0A
Software Win 10 Pro 64Bit v 1703 / OS[build 16299.192]
#2
Hi

Welcome to TPU

look up this issue: Asus bios and unlocked cards

other members of the tpu community may be able to assit further

EDIT from search bar on TPU front page - first hit here - http://www.techpowerup.com/forums/showthread.php?t=166708 this is not much but is a start

Q. What is the exact model number of the vga card? [need to know as the original bios is required]

- it may be possible for an image to be lifted from the position 2
- Use GPU-Z example: & save to File make two copies of this and keep safe
Extract vga bios.jpg


atb (all the best)

Law-II
 
Last edited:

Cinders

New Member
Joined
Mar 21, 2013
Messages
4 (0.00/day)
Likes
1
#3
Will do, thanks for the current info. I did pull the original BIOS from position 2, but it gives checksum errors when trying to flash, and when I force flash it, I get no POST.

I'll get the images up
 

Cinders

New Member
Joined
Mar 21, 2013
Messages
4 (0.00/day)
Likes
1
#4
It's a MSI R6950-2PM2D2GD D5 (912-V803-669)






The working ROM, that came with the card and seems to be original is:
2D - 250,150,0.9 3D - 725, 1250, ---.rom

And I saved it via GPU-Z (thanks)
 

Cinders

New Member
Joined
Mar 21, 2013
Messages
4 (0.00/day)
Likes
1
#5
*FIXED!!!*

Thanks so much! The problem *was* that ASUS has blocked the 6970 BIOS on the 6950 card. I followed that link you provided and found the solution. Simply load up the 6970 BIOS in WinFlash/RBE, change 6970 to 6950, save, flash, reboot. Reload drivers. Bam! Fixed.

Again, I really appreciate your time and attention here.
 
Joined
May 9, 2011
Messages
1,893 (0.77/day)
Likes
891
Location
Mainland Britain
System Name H2o Box
Processor Intel(R) Xeon e5-2690 v2 Stock 3.3GHz
Motherboard MSI X79A-G43 Plus (MS-7760) v3
Cooling CPU EK Block & Phobya G-Changer 360 V2.0 RAD H2o
Memory Gskill RipjawsZ 16Gb & Gskill TridentX 16Gb 9-10-9-28 2T @ 1866Mhz [locked]
Video Card(s) Zotac GTX 1080ti AMP EXTREME
Storage HyperX Fury 120GB & Savage 480GB SSD, Seagate 250GB,250GB 7200rpm Kingston 64GB SSD
Display(s) Panasonic GT30 46'' 1080p 3D HDTV [Custom Resolution 4096*2304]
Case Corsair O-800D
Audio Device(s) Creative Sound Blaster X-Fi Titanium Fatal1ty Pro
Power Supply Be Quiet! [Dark Power Pro 11] 1200W CM replaced [7-4-2017]
Mouse Asus ROG
Keyboard Microsoft Digital Media 1.0A
Software Win 10 Pro 64Bit v 1703 / OS[build 16299.192]
#6
Hi

Great news:toast: thank you for the feedback

atb

Law-II
 
Joined
Mar 14, 2009
Messages
3,358 (1.04/day)
Likes
1,167
Location
Ohio
System Name Spanky
Processor Ryzen 1400
Motherboard MSI 350 gaming pro
Cooling NZXT Kracken X42
Memory 8gb Crucial 2133 at 2667
Video Card(s) Nvidia 1060
Storage 250gb WD blue
Display(s) Acer 32" 2560x1440
Case Raidmax Sigma
Audio Device(s) Sound Blaster Audigy FX
Power Supply Seasonic
Mouse Epicgear
Keyboard Razer Deatstalker
Software Windows 10Pro x64
#7