• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

My browser is blank when I try to see the forums

Joined
Jan 1, 2021
Messages
82 (0.25/day)
My PC web browser won't display the forums anymore it shows up blank
 
Last edited by a moderator:
Joined
Nov 4, 2005
Messages
10,850 (1.85/day)
System Name MoFo 2
Processor AMD PhenomII 1100T @ 4.2Ghz
Motherboard Asus Crosshair IV
Cooling Swiftec 655 pump, Apogee GT,, MCR360mm Rad, 1/2 loop.
Memory 8GB DDR3-2133 @ 1900 8.9.9.24 1T
Video Card(s) HD7970 1250/1750
Storage Agility 3 SSD 6TB RAID 0 on RAID Card
Display(s) 46" 1080P Toshiba LCD
Case Rosewill R6A34-BK modded (thanks to MKmods)
Audio Device(s) ATI HDMI
Power Supply 750W PC Power & Cooling modded (thanks to MKmods)
Software A lot.
Benchmark Scores Its fast. Enough.
Disable ad blockers and see if you added something that’s causing this
 
Joined
Oct 15, 2011
Messages
700 (0.19/day)
Location
Springfield, Vermont
System Name KHR-1
Processor Ryzen 7 3700X with Fclk and Uclk at 1:1
Motherboard MSI B450 Tomahawk
Memory 16 GB Corsair Vengeance LPX 3000 in XMP mode
Video Card(s) MSI Gaming X Radeon RX5600XT
Storage Samsung 970 Pro 512 GB NVMe SSD
Display(s) Asus VG278QR
Case Corsair 275R
Audio Device(s) Technics SA-EX140 receiver with Polk VT60 speakers
Power Supply eVGA Supernova G3 750W
Mouse Logitech Pro (Hero)
Software Windows 10 Pro x64 21H1
My PC web browser won't display the forums anymore it shows up blank
That usually means required domains are being blocked by NoScript. (or eMatrix, if using Pale Moon)
 
Top