• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

My games feel laggy on high fps help!

Joined
Feb 29, 2020
Messages
54 (1.42/day)
Ok so I'm new to posting threads on the internet so please tell me if there are any better websites I could ask this question on.

So this is a problem I've had for a long time and it's driving me crazy. I've had this same issue with all the electronics I've bought. When I play games it feels like it's laggy even though the fps counter reports more than 100fps and I'm not sure if it's just me having ocd or if my computer actually has a problem because the game feels responsive as expected with high fps but when I move my head around it doesn't feel smooth.
So let me explain my history with this issue and I'm gonna mainly focus on Minecraft as that's the game I play the most. I first got my gaming laptop which I don't remember the exact specs of but it's GPU was a gtx 1050ti and it had an i7 (not sure which one), 8gb RAM and a 120hz monitor and that thing gave me 150-180fps while playing in Minecraft servers like hypixel and it felt laggy after a week. Then I returned that and got another gaming laptop with a gtx 1060, 16gb RAM , a 60hz display and an i7 8th gen and that one gave me 180-200fps in servers and it felt fine during the first week but then I started feeling that it wasn't smooth. So I returned that and decided to build a desktop, and so I did and that's the computer I currently have. It has a gtx 1660, an i7 9700, 16gb ddr4 2666mhz RAM and a 75hz display and it runs all my games at a great fps. Minecraft now runs at 300-600fps while I'm inside a game in servers like hypixel, all my other games run at above 100fps and for the first month I didn't have any issues at all, but after using it for a month, I started noticing that Minecraft was not running as smoothly even thought it was still at an average of 500fps. Then I checked Fortnite and it felt even worse, csgo didn't feel as bad and I could barely notice it in gta v.
Now here's my analysis, it could be related to refresh rate even though I have no idea how I ussually won't notice it the first month. I'm not sure about my 120hz laptop I didn't change it's refresh rate to 120 in settings like I did for my 75hz monitor as I didn't know I had to do that back then but I'm pretty sure laptops are automatically set to highest refresh rate by manufacturer. Second thing could be microstutters, the discription of microstutters kind of fits my situation but I'm not sure as I wouldn't call it a stutter since it just feels different. Third thing could be me having ocd as I ussually don't notice these issues within the first week of using my new computer but then my expectations somehow go higher and I notice them. Another thing that you might need to know in order to help me is that my new desktop feels alot better than the laptops however I still cannot call it smooth when I'm inside a hypixel skywars game and I'm jumping and looking around. Also, when I set my frame cap to less than 200fps in Minecraft it feels really laggy, it's still responsive but frames look laggy, but when I put it back on unlimited it looks alot better but as I said it still doesn't feel flawlessly smooth as expected with 500fps.

So please, tell me wether there could be something wrong(and how to fix it) or I'm really becoming crazy :/
 
Joined
Jun 7, 2019
Messages
116 (0.38/day)
System Name Times Killer
Processor Ryzen 9 3900X
Motherboard MSI B450-A Pro rev. 2.0
Cooling arctic freezer 33 TR4
Memory 2x 8gb Corsair 3200 mhz LPX for Ryzen @ 3733mhz 16-16-16-38
Video Card(s) EVGA GTX 1070Ti ACX 3.0 +223/455 / Asus Strix Vega 56 Gaming OC 1630/900 1120 mw
Storage 2 X 1TB WD's 1X 4gb WB red 1x LG GH22NS70 DVD-RAM Drive
Display(s) HP Omen X 27
Case Corsair Obsidian 750D W/ airflow kit
Audio Device(s) SoundblasterX AE-5 / Asus Xonar DX
Power Supply Carsair 850-M
Mouse Logitech Proteus spectrum G502
Keyboard Logitech G213 Prodigy
Software Windows 10 home
try turning on v-sync and see if that helps it feel smoother.
doesn't matter how many fps you're getting, your monitor will only display up too 75 full frames per second.
 
Joined
Sep 17, 2014
Messages
11,485 (5.66/day)
Location
Mars
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
This is really vague. Impossible to tell what you are experiencing.

Make a video for us, perhaps while gaming casually. Don't do weird stuff, just record a typical session that feels laggy to you. Make sure the FPS is displayed on screen, and if possible also monitor your CPU/GPU temps and CPU/GPU clocks on it.
 
Joined
Feb 29, 2020
Messages
54 (1.42/day)
try turning on v-sync and see if that helps it feel smoother.
doesn't matter how many fps you're getting, your monitor will only display up too 75 full frames per second.
I've tried v-sync. It makes Fortnite look a bit smoother but every other game feels alot laggier, as I said below 200fpa feels really laggy on my computer somehow. Or it might be just me

This is really vague. Impossible to tell what you are experiencing.

Make a video for us, perhaps while gaming casually. Don't do weird stuff, just record a typical session that feels laggy to you. Make sure the FPS is displayed on screen, and if possible also monitor your CPU/GPU temps and CPU/GPU clocks on it.
I don't know how to show my cpu/gpu temps and clocks on screen, but I'll make sure to send you a footage of a minecraft skywars gameplay with the fps on top recorded at 60fps.
 
Joined
Nov 13, 2007
Messages
7,821 (1.73/day)
Location
Austin Texas
System Name _
Processor 8700K @ 5.2 Ghz / -1 avx 24/7
Motherboard MSI Z370-A PRO
Cooling 120mm Custom Liquid
Memory 32 GB 3900 Mhz DDR4 17-17-17-34-400 trfc - 2T
Video Card(s) Gigabyte GTX 2080 Ti Windforce (Undervolted OC 1905MHz)
Storage 3x1TB SSDs
Display(s) Alienware 34" 3440x1440 120hz, G-Sync
Case Jonsbo U4
Audio Device(s) Bose Solo
Power Supply Corsair SF750
Mouse logitech hero
Keyboard tenkeyless
Software Windows 10 64 Bit
Benchmark Scores pretty fast!
I've tried v-sync. It makes Fortnite look a bit smoother but every other game feels alot laggier, as I said below 200fpa feels really laggy on my computer somehow. Or it might be just me


I don't know how to show my cpu/gpu temps and clocks on screen, but I'll make sure to send you a footage of a minecraft skywars gameplay with the fps on top recorded at 60fps.
It might be frame pacing issues - usually if the frames are inconsistent games can stuttery even at high fps. Some games are just crap so there is nothing to really do about that; but others adaptive sync, like freesync or gsync can really help if you're sensitive to that.

Also high FPS will always feel better than low fps, but your games should feel really good at about 80-100FPS if you have adaptive sync.
 
Joined
Feb 29, 2020
Messages
54 (1.42/day)
try turning on v-sync and see if that helps it feel smoother.
doesn't matter how many fps you're getting, your monitor will only display up too 75 full frames per second.
Also I had the same problem with the 120hz display laptop so I don't think refresh rate is the issue, however as I said I didn't change the refresh rate in the settings of my laptop so it might have been on 60hz by default. Do you know wether laptop manufacturers set refresh rate to highest by default or I still have to change them myself?

It might be frame pacing issues - usually if the frames are inconsistent games can stuttery even at high fps. Some games are just crap so there is nothing to really do about that; but others adaptive sync, like freesync or gsync can really help if you're sensitive to that.

Also high FPS will always feel better than low fps, but your games should feel really good at about 80-100FPS if you have adaptive sync.
Does that mean it's the game's problem or could it still be a problem from my computer? Are other people experiencing this as well?
 
Joined
Jun 7, 2019
Messages
116 (0.38/day)
System Name Times Killer
Processor Ryzen 9 3900X
Motherboard MSI B450-A Pro rev. 2.0
Cooling arctic freezer 33 TR4
Memory 2x 8gb Corsair 3200 mhz LPX for Ryzen @ 3733mhz 16-16-16-38
Video Card(s) EVGA GTX 1070Ti ACX 3.0 +223/455 / Asus Strix Vega 56 Gaming OC 1630/900 1120 mw
Storage 2 X 1TB WD's 1X 4gb WB red 1x LG GH22NS70 DVD-RAM Drive
Display(s) HP Omen X 27
Case Corsair Obsidian 750D W/ airflow kit
Audio Device(s) SoundblasterX AE-5 / Asus Xonar DX
Power Supply Carsair 850-M
Mouse Logitech Proteus spectrum G502
Keyboard Logitech G213 Prodigy
Software Windows 10 home
hmm... go to "manage 3d settings" in the control panel and set " low latency mode" to ultra.

as for the laptop, no, windows set's 60 hz as default unless set other wise by the drivers or you / the game.

i was going to mention you might just be sensitive to lower refresh rates and/or input lag, i know my old 60hz started giving me a headache so i got a 144hz and now a 240hz, with freesync.

and you can use the rivatuner part of msi afterburner to display gpu/cpu usage/temps on screen.
 
Joined
Feb 29, 2020
Messages
54 (1.42/day)
hmm... go to "manage 3d settings" in the control panel and set " low latency mode" to ultra.

as for the laptop, no, windows set's 60 hz as default unless set other wise by the drivers or you / the game.

i was going to mention you might just be sensitive to lower refresh rates and/or input lag, i know my old 60hz started giving me a headache so i got a 144hz and now a 240hz, with freesync.

and you can use the rivatuner part of msi afterburner to display gpu/cpu usage/temps on screen.
Thank you I will try that and let you know about the results.
 
Joined
Sep 17, 2014
Messages
11,485 (5.66/day)
Location
Mars
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
I've tried v-sync. It makes Fortnite look a bit smoother but every other game feels alot laggier, as I said below 200fpa feels really laggy on my computer somehow. Or it might be just me


I don't know how to show my cpu/gpu temps and clocks on screen, but I'll make sure to send you a footage of a minecraft skywars gameplay with the fps on top recorded at 60fps.
Install MSI Afterburner and activate the OSD with whatever you want to monitor. I can guide you if needed, let us know.
 
Joined
Feb 29, 2020
Messages
54 (1.42/day)
hmm... go to "manage 3d settings" in the control panel and set " low latency mode" to ultra.

as for the laptop, no, windows set's 60 hz as default unless set other wise by the drivers or you / the game.

i was going to mention you might just be sensitive to lower refresh rates and/or input lag, i know my old 60hz started giving me a headache so i got a 144hz and now a 240hz, with freesync.

and you can use the rivatuner part of msi afterburner to display gpu/cpu usage/temps on screen.
So I set low latency mode to ultra and it didn't change anything. As I said I don't have any problem with input lag my game's responsivness is just how it should be at 500fps (really low to no input lag) my problem is that it doesn't look smooth. I know I'm getting really confusing with this but basically the game is like 50fps but without input lag. So the responsivness is what you'd expect from 500fps but the fps looks like 50 when I'm looking around. So more like a refresh rate issue or microstutter (please tell me if I'm wrong about the defenition of microstutters and if they're different from what I'm experiencing)
 

Solaris17

Dainty Moderator
Staff member
Joined
Aug 16, 2005
Messages
21,391 (4.00/day)
Location
Florida
System Name Venslar
Processor I9 7980XE
Motherboard MSI x299 Tomahawk Arctic
Cooling EK Custom
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Nvidia Titan RTX
Storage 2x Micron 500GB SSD | 1x 1TB 850 EVO | 1x 250GB 960 EVO | 32TB SAN
Display(s) 3x AOC Q2577PWQ (2k IPS)
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Focusrite Scarlett Solo on beyerdynamic DT 990 Pros
Power Supply Seasonic 1050W Snow
Mouse Roccat Kone Aimo White
Keyboard Ducky Shine 6 Snow White
Software Windows 10 x64 Pro
This just sounds like screen tearing.
 
Joined
Sep 17, 2014
Messages
11,485 (5.66/day)
Location
Mars
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
So I set low latency mode to ultra and it didn't change anything. As I said I don't have any problem with input lag my game's responsivness is just how it should be at 500fps (really low to no input lag) my problem is that it doesn't look smooth. I know I'm getting really confusing with this but basically the game is like 50fps but without input lag. So the responsivness is what you'd expect from 500fps but the fps looks like 50 when I'm looking around. So more like a refresh rate issue or microstutter (please tell me if I'm wrong about the defenition of microstutters and if they're different from what I'm experiencing)
Going on what you say yes, it sounds like stutter or refresh rate not being in sync with FPS.

But it could also be something else entirely... A video will tell us a lot more and narrow things down.
 
Joined
Feb 29, 2020
Messages
54 (1.42/day)
Going on what you say yes, it sounds like stutter or refresh rate not being in sync with FPS.

But it could also be something else entirely... A video will tell us a lot more and narrow things down.
I will make sure to install msi afterburner and send a video with all the statistics as soon as possible but I can't at the moment. Perhaps tommorow.
 
Joined
Oct 26, 2016
Messages
699 (0.56/day)
Location
BGD
System Name KING-XEON
Processor Xeon 2650 V2 (OC-Base Clock 3,4Ghz-Turbo 3,8Ghz)
Motherboard Sabertooth X79
Cooling Xigmatek LOKI SD963 double-Fan
Memory 34Gb DDR3 Kingston Hyper Blue 1507Mhz Active clocks(9-9-9-24)
Video Card(s) RX 480 8gb/Red-Devil/
Storage 2 x ssd-Kingston 240Gb A400 in RAID 0+ HDD 500Gb
Display(s) 1x Acer 1080P Ips 2x Eizo(Triple Monitor Setup)
Case Lian Lee
Audio Device(s) Realtek/Creative T20 Speakers
Power Supply F S P Hyper S 700W
Mouse Asus TUF-GAMING M3
Keyboard Func FUNC-KB-460/Mechanical Keyboard
Benchmark Scores Fire Strike=12501,Cinebench R15=1284,Cinebench R20=2538.Passmark=15670,Geekbench=23623 multi
Are all those games you been playing Online?
 
Joined
Nov 4, 2005
Messages
10,514 (2.00/day)
System Name MoFo 2
Processor AMD PhenomII 1100T @ 4.2Ghz
Motherboard Asus Crosshair IV
Cooling Swiftec 655 pump, Apogee GT,, MCR360mm Rad, 1/2 loop.
Memory 8GB DDR3-2133 @ 1900 8.9.9.24 1T
Video Card(s) HD7970 1250/1750
Storage Agility 3 SSD 6TB RAID 0 on RAID Card
Display(s) 46" 1080P Toshiba LCD
Case Rosewill R6A34-BK modded (thanks to MKmods)
Audio Device(s) ATI HDMI
Power Supply 750W PC Power & Cooling modded (thanks to MKmods)
Software A lot.
Benchmark Scores Its fast. Enough.
Try frame limiting games to the refresh rate, it may reduce the out of sync feeling you are getting.
 
Joined
Feb 29, 2020
Messages
54 (1.42/day)
Are all those games you been playing Online?
Yes I play online most of the time. But I do notice it in offline Minecraft as well, just less.

Try frame limiting games to the refresh rate, it may reduce the out of sync feeling you are getting.
You see as I said less than 200fps feels really laggy to me. So when I set my frame cap to 75 it looks really bad. At least this is mostly the case with Minecraft but Fortnite kind of benifits from this.
 
Joined
Oct 26, 2016
Messages
699 (0.56/day)
Location
BGD
System Name KING-XEON
Processor Xeon 2650 V2 (OC-Base Clock 3,4Ghz-Turbo 3,8Ghz)
Motherboard Sabertooth X79
Cooling Xigmatek LOKI SD963 double-Fan
Memory 34Gb DDR3 Kingston Hyper Blue 1507Mhz Active clocks(9-9-9-24)
Video Card(s) RX 480 8gb/Red-Devil/
Storage 2 x ssd-Kingston 240Gb A400 in RAID 0+ HDD 500Gb
Display(s) 1x Acer 1080P Ips 2x Eizo(Triple Monitor Setup)
Case Lian Lee
Audio Device(s) Realtek/Creative T20 Speakers
Power Supply F S P Hyper S 700W
Mouse Asus TUF-GAMING M3
Keyboard Func FUNC-KB-460/Mechanical Keyboard
Benchmark Scores Fire Strike=12501,Cinebench R15=1284,Cinebench R20=2538.Passmark=15670,Geekbench=23623 multi
Yes I play online most of the time. But I do notice it in offline Minecraft as well, just less.
Then you possibly having network issues probably some packet loss which makes your games feels laggy........
 
Joined
Oct 26, 2016
Messages
699 (0.56/day)
Location
BGD
System Name KING-XEON
Processor Xeon 2650 V2 (OC-Base Clock 3,4Ghz-Turbo 3,8Ghz)
Motherboard Sabertooth X79
Cooling Xigmatek LOKI SD963 double-Fan
Memory 34Gb DDR3 Kingston Hyper Blue 1507Mhz Active clocks(9-9-9-24)
Video Card(s) RX 480 8gb/Red-Devil/
Storage 2 x ssd-Kingston 240Gb A400 in RAID 0+ HDD 500Gb
Display(s) 1x Acer 1080P Ips 2x Eizo(Triple Monitor Setup)
Case Lian Lee
Audio Device(s) Realtek/Creative T20 Speakers
Power Supply F S P Hyper S 700W
Mouse Asus TUF-GAMING M3
Keyboard Func FUNC-KB-460/Mechanical Keyboard
Benchmark Scores Fire Strike=12501,Cinebench R15=1284,Cinebench R20=2538.Passmark=15670,Geekbench=23623 multi
Joined
Feb 29, 2020
Messages
54 (1.42/day)

Attachments

Joined
Oct 26, 2016
Messages
699 (0.56/day)
Location
BGD
System Name KING-XEON
Processor Xeon 2650 V2 (OC-Base Clock 3,4Ghz-Turbo 3,8Ghz)
Motherboard Sabertooth X79
Cooling Xigmatek LOKI SD963 double-Fan
Memory 34Gb DDR3 Kingston Hyper Blue 1507Mhz Active clocks(9-9-9-24)
Video Card(s) RX 480 8gb/Red-Devil/
Storage 2 x ssd-Kingston 240Gb A400 in RAID 0+ HDD 500Gb
Display(s) 1x Acer 1080P Ips 2x Eizo(Triple Monitor Setup)
Case Lian Lee
Audio Device(s) Realtek/Creative T20 Speakers
Power Supply F S P Hyper S 700W
Mouse Asus TUF-GAMING M3
Keyboard Func FUNC-KB-460/Mechanical Keyboard
Benchmark Scores Fire Strike=12501,Cinebench R15=1284,Cinebench R20=2538.Passmark=15670,Geekbench=23623 multi
I would guess these are bad results, but still don't know how they would affect my fps :|


This is the second and third result, a lot better.
Yep that is Very Bad result and certainly your problem why you having laggy gaming experience...here bellow is my result just for comparison....
 

Attachments

Last edited:
Joined
Feb 29, 2020
Messages
54 (1.42/day)
Yep that is Very Bad result and certainly your problem why you heaving laggy gaming experience...here bellow is my result just for comparison....
Yes but please look at the second and third result. I think I just got unlucky withe the first one
 
Joined
Oct 26, 2016
Messages
699 (0.56/day)
Location
BGD
System Name KING-XEON
Processor Xeon 2650 V2 (OC-Base Clock 3,4Ghz-Turbo 3,8Ghz)
Motherboard Sabertooth X79
Cooling Xigmatek LOKI SD963 double-Fan
Memory 34Gb DDR3 Kingston Hyper Blue 1507Mhz Active clocks(9-9-9-24)
Video Card(s) RX 480 8gb/Red-Devil/
Storage 2 x ssd-Kingston 240Gb A400 in RAID 0+ HDD 500Gb
Display(s) 1x Acer 1080P Ips 2x Eizo(Triple Monitor Setup)
Case Lian Lee
Audio Device(s) Realtek/Creative T20 Speakers
Power Supply F S P Hyper S 700W
Mouse Asus TUF-GAMING M3
Keyboard Func FUNC-KB-460/Mechanical Keyboard
Benchmark Scores Fire Strike=12501,Cinebench R15=1284,Cinebench R20=2538.Passmark=15670,Geekbench=23623 multi
Yes but please look at the second and third result. I think I just got unlucky withe the first one
Even IF you have good result but it's not constant and in certain time you having packet loss you will most likely experience jiterry&laggy game-play.... Also when you playing games try to not upload&download during that time and IF you really MUST then make sure that your torrents/downloads/uploads using less then 30%-50% of your capacity especially your upload.....
 
Joined
Sep 17, 2014
Messages
11,485 (5.66/day)
Location
Mars
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
Yep that is Very Bad result and certainly your problem why you heaving laggy gaming experience...here bellow is my result just for comparison....
Even IF you have good result but it's not constant and in certain time you having packet loss you will most likely experience jiterry&laggy game-play....
Sorry but this test is complete and utter BS, and very misleading in this case. It will not determine a problem with the connection at all.

Look at this

1582999926034.png


And here is the Fortnite preset.

Now, these are tiny packets so its not a bandwidth issue, and I have literally seconds prior to this test recorded a 16ms round trip above. With 3ms jitter.

How?!

1582999945679.png


And here is the default preset, same load of horseshit and also no consistency between runs. The 100ms I can understand. The rest, no, just no.

1583000098235.png


Oh, and its not the location either. Here is a US server on a reliable test: 9ms jitter.

1583000285046.png
 
Last edited:
Top