• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

My monitor isn't coming on sometimes when my computer wakes from sleep?

Joined
May 6, 2019
Messages
63 (0.09/day)
Processor i5-10600
Motherboard MSI Z490-A Pro
Cooling Arctic Freezer 34 eSports DUO
Memory Crucial Ballistix 16GB DDR4-3200 CL16
Video Card(s) Palit Geforce GTX 1660
Storage Samsung 840 Pro 256GB, 860 EVO 2TB
Display(s) iiyama G2730HSU-B1 G-Master 27"
Case Corsair 200R
Audio Device(s) Asus Xonar Essence STX
Power Supply Seasonic Focus GX 650W
Software Windows 10 Pro
Anyone have any idea about this? I have a strange issue which is intermittent, which makes me wonder if it could be hardware related. But it is possible it's a setting in Windows somewhere.

When I wake my computer from sleep, the display usually remains off until I press a key or move the mouse. It never used to do this, I have been putting my Windows 10 computer into sleep mode for years, before I upgraded last year and since then. But only in the last week or two has it been behaving like it does now. It's not a major problem, but it is annoying.

My specs are i5-10600, MSI Z490-A Pro, 16GB, GTX 1660. Windows 10 Pro version 20H2 which I upgraded today from 1909 hoping it might solve the problem, but it hasn't.

I have double checked the BIOS settings and also tried setting them to defaults, that didn't fix it. I can't rule out it being some sort of motherboard fault, but it isn't a BIOS setting at least. Nor do I think it is a monitor fault, the monitor is two years old (iiyama 27") and hasn't exhibited any problems.

Windows power saving is and always has been set to never turn off the monitor under any circumstances, and nor is there any screen saver enabled. (Obviously, the monitor does sleep when I manually put Windows to sleep. It just isn't waking up when I wake the computer.) Hibernation is disabled and always has been.

Since before when it was working, and now, I haven't changed any settings that should affect this, like GPU power (which is set to optimal, the default) or anything else I can think of.

Windows issue? Faulty motherboard / GPU / monitor?
 
Joined
Jul 25, 2006
Messages
8,555 (1.58/day)
Location
Nebraska, USA
System Name Brightworks Systems BWS-6 E-IV
Processor Intel Core i5-6600 @ 3.9GHz
Motherboard Gigabyte GA-Z170-HD3 Rev 1.0
Cooling Quality case, 2 x Fractal Design 140mm fans, stock CPU HSF
Memory 16GB (2 x 8GB) DDR4 3000 Corsair Vengeance
Video Card(s) EVGA GEForce GTX 1050Ti 4Gb GDDR5
Storage Samsung 850 Pro 256GB SSD, Samsung 860 Evo 500GB SSD
Display(s) Samsung S24E650BW LED x 2
Case Fractal Design Define R4
Power Supply EVGA Supernova 550W G2 Gold
Mouse Microsoft Wireless 5000
Keyboard Microsoft Wireless Comfort 5050
Software W10 Pro 64-bit
I would try/check a couple things. Make sure your video cable is securely fastened at both ends. If you have another cable, try that.

If you have another monitor, swap that in. This will determine if the problem is on the computer side, or monitor side.

Have you done a cold reboot? By “cold”, I mean shut down the computer and flip the master power switch on the back of the power supply (if your supply has one) to off (or “O”) or unplug the power supply from the wall for about 15 seconds. Then turn the master power switch to on (or “|”) or reconnect power and boot up and see what happens. By totally removing power, you remove the +5Vsb standby voltage all ATX Form Factor power supplies are required to supply whenever the power supply is plugged into the wall and (if applicable) the master power switch is set to on. This standby voltage is distributed throughout several points on the motherboard, including RAM for faster boots and the USB ports too. This also keeps alive several features, including “wake on keyboard” and “wake on mouse”, and the network interface for “Wake on LAN” commands. A cold reboot ensures any device settings that may be held by the standby voltage are released, then reset when power is restored.
 
Joined
May 6, 2019
Messages
63 (0.09/day)
Processor i5-10600
Motherboard MSI Z490-A Pro
Cooling Arctic Freezer 34 eSports DUO
Memory Crucial Ballistix 16GB DDR4-3200 CL16
Video Card(s) Palit Geforce GTX 1660
Storage Samsung 840 Pro 256GB, 860 EVO 2TB
Display(s) iiyama G2730HSU-B1 G-Master 27"
Case Corsair 200R
Audio Device(s) Asus Xonar Essence STX
Power Supply Seasonic Focus GX 650W
Software Windows 10 Pro
Okay I have now tried a few things and the problem still exhibits itself with all of them.

Different HDMI cables.
Different monitors.
Different GPUs. ie. I also tried it with my onboard iGPU.

I also tried as suggested, to power off and switch off the PSU at the switch on the back, which I left off for a few minutes. Another thing I did was reset all Windows power settings to default, even though I had already carefully gone through and checked them all. I thought maybe one of them was behaving differently to what it said and had got stuck somehow. Well you never know. So I reset them all, and then manually disabled all the stuff it re-enables, like turning things off after 10 mins or whatever. And it still makes no difference.

Note that whenever I power the computer on from being turned off, rather than from sleep, it NEVER fails to wake the monitor up. It only fails to wake it up when Windows has been sleeping, and only sometimes. Other times, it does come on. So it seems to be either a motherboard fault or a Windows issue.

So, I am baffled.

The only thing I can think of, is I upgraded the BIOS recently from an early revision to the latest one. Is it possible it could have introduced this issue, I wonder?

Also, my BIOS has the option to choose to allow the BIOS or the OS to handle waking from sleep. I was using 'BIOS'. I just tried it on 'OS' and the issue remains. Whether that rules out it being a BIOS issue per se though, I don't know. Maybe I should try and roll back the BIOS but I don't know if that's possible, or advisable.
 
Last edited:
Joined
Jul 25, 2006
Messages
8,555 (1.58/day)
Location
Nebraska, USA
System Name Brightworks Systems BWS-6 E-IV
Processor Intel Core i5-6600 @ 3.9GHz
Motherboard Gigabyte GA-Z170-HD3 Rev 1.0
Cooling Quality case, 2 x Fractal Design 140mm fans, stock CPU HSF
Memory 16GB (2 x 8GB) DDR4 3000 Corsair Vengeance
Video Card(s) EVGA GEForce GTX 1050Ti 4Gb GDDR5
Storage Samsung 850 Pro 256GB SSD, Samsung 860 Evo 500GB SSD
Display(s) Samsung S24E650BW LED x 2
Case Fractal Design Define R4
Power Supply EVGA Supernova 550W G2 Gold
Mouse Microsoft Wireless 5000
Keyboard Microsoft Wireless Comfort 5050
Software W10 Pro 64-bit
I don't see how a BIOS update could do this - especially with a graphics card.

You said,
When I wake my computer from sleep, the display usually remains off until I press a key or move the mouse.
How are you waking it then? With the power button?

And I'm curious as to why you let your computer go to sleep, but have your monitors set to "Never sleep". Why? I have my monitors to sleep after 10 minutes and the computer goes to sleep after 20. That said, I always wake my computer by pressing the space bar. Will have to try to remember to ignore my habit and to try the power button.

I agree with that this appears to be a Windows setting - where apparently, a signal is not being sent to the monitor until after you press a key or mouse button. But
 
Joined
May 6, 2019
Messages
63 (0.09/day)
Processor i5-10600
Motherboard MSI Z490-A Pro
Cooling Arctic Freezer 34 eSports DUO
Memory Crucial Ballistix 16GB DDR4-3200 CL16
Video Card(s) Palit Geforce GTX 1660
Storage Samsung 840 Pro 256GB, 860 EVO 2TB
Display(s) iiyama G2730HSU-B1 G-Master 27"
Case Corsair 200R
Audio Device(s) Asus Xonar Essence STX
Power Supply Seasonic Focus GX 650W
Software Windows 10 Pro
I am waking the computer by pressing a key on the keyboard. I have the BIOS set to allow that, because it's the most convenient method for me. However, when I just tried setting the BIOS to only allow the OS to wake it, I had to use the power button on the PC itself to wake it. Note that I have the ability to wake the computer from sleep via mouse, DISABLED, because otherwise I would find I sometimes accidentally woke it. Now, when the computer wakes, and the screen fails to wake with it, I can wake the screen by moving the mouse. It's exactly like if there was a screen saver enabled, and moving the mouse turned off the screen saver.

I never 'let' the computer go to sleep, as in a time limit. It is on permanently until and unless I manually put it to sleep, either with the sleep button on the keyboard (usually) or if I were to choose sleep from the start menu.

I set the monitor to 'never sleep' because I don't want it going off while I'm using the PC but have been idle for a while, like if I'm reading something or whatever. But it does sleep whenever I put the computer to sleep.
 
Joined
Jul 25, 2006
Messages
8,555 (1.58/day)
Location
Nebraska, USA
System Name Brightworks Systems BWS-6 E-IV
Processor Intel Core i5-6600 @ 3.9GHz
Motherboard Gigabyte GA-Z170-HD3 Rev 1.0
Cooling Quality case, 2 x Fractal Design 140mm fans, stock CPU HSF
Memory 16GB (2 x 8GB) DDR4 3000 Corsair Vengeance
Video Card(s) EVGA GEForce GTX 1050Ti 4Gb GDDR5
Storage Samsung 850 Pro 256GB SSD, Samsung 860 Evo 500GB SSD
Display(s) Samsung S24E650BW LED x 2
Case Fractal Design Define R4
Power Supply EVGA Supernova 550W G2 Gold
Mouse Microsoft Wireless 5000
Keyboard Microsoft Wireless Comfort 5050
Software W10 Pro 64-bit
I'm afraid I don't know what to suggest. A quick search with Google shows you are not alone. But sadly, there does not seem to be a common cause and therefore, no common fix.

You might look through here and see if you feel anything is worth trying.
 
Joined
May 6, 2019
Messages
63 (0.09/day)
Processor i5-10600
Motherboard MSI Z490-A Pro
Cooling Arctic Freezer 34 eSports DUO
Memory Crucial Ballistix 16GB DDR4-3200 CL16
Video Card(s) Palit Geforce GTX 1660
Storage Samsung 840 Pro 256GB, 860 EVO 2TB
Display(s) iiyama G2730HSU-B1 G-Master 27"
Case Corsair 200R
Audio Device(s) Asus Xonar Essence STX
Power Supply Seasonic Focus GX 650W
Software Windows 10 Pro
Thanks, if I even just knew it was a Windows issue, I would relax a bit, at least knowing it wasn't a hardware fault.

I saw one of the search results had someone with a solution which I tried, but like you say, there is apparently no common cause or fix! A user said installing the Intel Management Engine Driver fixed it for him but I just reinstalled the latest version, plus the latest chipset drivers for good measure and it's the same. Well, I rebooted, first time I tried sleep, it worked properly. Second time, monitor stayed asleep again. The fact it is random like this is a head scratcher.

I will keep looking!
 
Joined
Jul 25, 2006
Messages
8,555 (1.58/day)
Location
Nebraska, USA
System Name Brightworks Systems BWS-6 E-IV
Processor Intel Core i5-6600 @ 3.9GHz
Motherboard Gigabyte GA-Z170-HD3 Rev 1.0
Cooling Quality case, 2 x Fractal Design 140mm fans, stock CPU HSF
Memory 16GB (2 x 8GB) DDR4 3000 Corsair Vengeance
Video Card(s) EVGA GEForce GTX 1050Ti 4Gb GDDR5
Storage Samsung 850 Pro 256GB SSD, Samsung 860 Evo 500GB SSD
Display(s) Samsung S24E650BW LED x 2
Case Fractal Design Define R4
Power Supply EVGA Supernova 550W G2 Gold
Mouse Microsoft Wireless 5000
Keyboard Microsoft Wireless Comfort 5050
Software W10 Pro 64-bit
Yeah, intermittent problems are always the hardest to troubleshoot. I will keep looking and if you find a solution, please post it.
 
Joined
May 6, 2019
Messages
63 (0.09/day)
Processor i5-10600
Motherboard MSI Z490-A Pro
Cooling Arctic Freezer 34 eSports DUO
Memory Crucial Ballistix 16GB DDR4-3200 CL16
Video Card(s) Palit Geforce GTX 1660
Storage Samsung 840 Pro 256GB, 860 EVO 2TB
Display(s) iiyama G2730HSU-B1 G-Master 27"
Case Corsair 200R
Audio Device(s) Asus Xonar Essence STX
Power Supply Seasonic Focus GX 650W
Software Windows 10 Pro
It looks like I have found the culprit... the new BIOS. Today I reverted from v2.80 to v2.30 and after ten or so wakes from sleep, every one so far has worked properly, the screen has woken up instantly without any further key press or mouse movement necessary.

I did this after more googling where a BIOS update has been the reason for others having similar problems, on different boards or even with AMD, it's nothing specific to MSI or Intel per se. But it seems MSI messed something up somewhere with v2.80.

If the problem returns I'll update this thread.
 

JeffF

New Member
Joined
Mar 23, 2021
Messages
25 (0.46/day)
Glad to hear you figured it out. I was just going to suggest disabling "Hibernation and Fast Startup" in your power management settings as a test. Hibernation and Fast Startup in windows have been a problem for years when trying to wake systems up.
 
Joined
May 6, 2019
Messages
63 (0.09/day)
Processor i5-10600
Motherboard MSI Z490-A Pro
Cooling Arctic Freezer 34 eSports DUO
Memory Crucial Ballistix 16GB DDR4-3200 CL16
Video Card(s) Palit Geforce GTX 1660
Storage Samsung 840 Pro 256GB, 860 EVO 2TB
Display(s) iiyama G2730HSU-B1 G-Master 27"
Case Corsair 200R
Audio Device(s) Asus Xonar Essence STX
Power Supply Seasonic Focus GX 650W
Software Windows 10 Pro
Glad to hear you figured it out. I was just going to suggest disabling "Hibernation and Fast Startup" in your power management settings as a test. Hibernation and Fast Startup in windows have been a problem for years when trying to wake systems up.

Already is and was, it's one of the first things I do when installing Windows.
 
Joined
Jul 25, 2006
Messages
8,555 (1.58/day)
Location
Nebraska, USA
System Name Brightworks Systems BWS-6 E-IV
Processor Intel Core i5-6600 @ 3.9GHz
Motherboard Gigabyte GA-Z170-HD3 Rev 1.0
Cooling Quality case, 2 x Fractal Design 140mm fans, stock CPU HSF
Memory 16GB (2 x 8GB) DDR4 3000 Corsair Vengeance
Video Card(s) EVGA GEForce GTX 1050Ti 4Gb GDDR5
Storage Samsung 850 Pro 256GB SSD, Samsung 860 Evo 500GB SSD
Display(s) Samsung S24E650BW LED x 2
Case Fractal Design Define R4
Power Supply EVGA Supernova 550W G2 Gold
Mouse Microsoft Wireless 5000
Keyboard Microsoft Wireless Comfort 5050
Software W10 Pro 64-bit
Great! I am glad you got it sorted out and thanks, Dirtdog, for coming back and posting your findings. :)
 
Top