• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

My newly built gaming PC (AMD RADEON RX 5600 XT) has been lagging in frames, and shutting down.

barvee7

New Member
Joined
Nov 15, 2020
Messages
6 (0.02/day)
Hi, so im not an expert when it comes to drivers and softwares, so any help will be appreciated !

So i just build my first ever gaming pc (specs below), and everything was running smoothly. All my downloaded games like Valorant, Overwatch, CS:GO all ran smoothly with high frames until i cntrl+esc to open up windows or discord and get back into the game where it lowers my frames, even when the applications are closed.

Another problem, if i were to open up two windows side by side on one monitor, clicking and scrolling will be delayed, and if i were to watch twitch vods, my computer would shut down.
My drivers on the AMD Radeon Software tool are up to date, but still lags whenever multiple tabs or software are open.

Specs:
AMDRyzen 5 3600x
Msi AMD Radeon RX 5600 XT Gaming M X
ASROCK B550 Phantom Gaming 4
GIGABYTE P650B Power Supply (80 Plus Bronze)
16gb RAM Corsair Venegance
Seagate 2TB HDD
Kingston 250gb NVMe SSD
+
LiquidCooler (Cooler Master)
 
Joined
Sep 2, 2020
Messages
1,155 (3.02/day)
System Name Whonock
Processor Amd 3200g
Motherboard A320m-h
Cooling Wraith Stealth
Memory 2x 8g ddr4 2666mz
Video Card(s) Msi Gaming x 1060 6g
Storage 5.5 tb hd 220 g ssd
Display(s) Normal moniter
Case Deepcool smater
Check task manager see whats under load
 
Joined
Nov 15, 2020
Messages
23 (0.07/day)
System Name Jaegermeister
Processor R5 5600X, max PBO
Motherboard Gigabyte B550 Aorus Pro V2
Cooling be quiet! Dark Rock Pro 4 w/ MX-4 thermal paste
Memory 2x16GB Crucial Ballistix 3600MHz CL16 (16Gbit Micron Rev.B) - @ 3800MHz, CL16
Video Card(s) Powercolor Red Devil 6600XT w/ MX-4 thermal paste
Storage 1x 2TB WD SN550 (storage), 1x 1TB SK hynix Gold P31 (boot)
Display(s) 1x Gigabyte G27Q, 1x MSI Optix G241
Case Phanteks P500A (non-digital), w/ 4x 140mm Arctic P14 PST CO fans
Audio Device(s) (Onboard) Realtek ALC 1220-VB
Power Supply Super Flower Leadex III 750W 80+ Gold
Mouse Logitech G203
Keyboard HyperX Core RGB
Software Windows 10 unfortunately
Benchmark Scores TBD
I don't know everything of course, and I sincerely am not trying to be patronizing with any of my below suggestions. Apologies if I give off the impression of either :)

- Have you tried using DDU to remove all AMD GPU drivers, and reinstalling?
- Does this issue occur inside of Linux? (you can just try running a live CD off of a decently fast thumb drive)
- Do you have the latest BIOS from ASRock? Is there a newly released BIOS for your 5600XT? (shot in the dark)
- Do you have up-to-date drivers for your chipset, newest firmware for SSD, etc.? (also a shot in the dark solution)

Also, has anyone else that you've come across had this issue with your specific MSI 5600XT?

Good luck to you and I hope that things are working smoothly soon!
 
Joined
Dec 29, 2010
Messages
2,372 (0.61/day)
Processor AMD 5900x
Motherboard Asus x570 Strix-E
Cooling Hardware Labs
Memory G.Skill 4000c17 2x16gb
Video Card(s) RTX 3090
Storage Sabrent
Display(s) Samsung G9
Case Phanteks 719
Audio Device(s) Fiio K5 Pro
Power Supply EVGA 1300 G2
Mouse Logitech G600
Keyboard Corsair K95
Wanna bet there's whea errors?
 

barvee7

New Member
Joined
Nov 15, 2020
Messages
6 (0.02/day)
I don't know everything of course, and I sincerely am not trying to be patronizing with any of my below suggestions. Apologies if I give off the impression of either :)

- Have you tried using DDU to remove all AMD GPU drivers, and reinstalling?
- Does this issue occur inside of Linux? (you can just try running a live CD off of a decently fast thumb drive)
- Do you have the latest BIOS from ASRock? Is there a newly released BIOS for your 5600XT? (shot in the dark)
- Do you have up-to-date drivers for your chipset, newest firmware for SSD, etc.? (also a shot in the dark solution)

Also, has anyone else that you've come across had this issue with your specific MSI 5600XT?

Good luck to you and I hope that things are working smoothly soon!
Thank you so much for this quick response, i'm not aware how to access the latest bios for my ASRock, although my drivers for my gpu and chipset are all up to date, automatic settings.
So far today, my computer has been running smoothly without any frame lag whatsoever nor shutting down.
 
Joined
Nov 15, 2020
Messages
23 (0.07/day)
System Name Jaegermeister
Processor R5 5600X, max PBO
Motherboard Gigabyte B550 Aorus Pro V2
Cooling be quiet! Dark Rock Pro 4 w/ MX-4 thermal paste
Memory 2x16GB Crucial Ballistix 3600MHz CL16 (16Gbit Micron Rev.B) - @ 3800MHz, CL16
Video Card(s) Powercolor Red Devil 6600XT w/ MX-4 thermal paste
Storage 1x 2TB WD SN550 (storage), 1x 1TB SK hynix Gold P31 (boot)
Display(s) 1x Gigabyte G27Q, 1x MSI Optix G241
Case Phanteks P500A (non-digital), w/ 4x 140mm Arctic P14 PST CO fans
Audio Device(s) (Onboard) Realtek ALC 1220-VB
Power Supply Super Flower Leadex III 750W 80+ Gold
Mouse Logitech G203
Keyboard HyperX Core RGB
Software Windows 10 unfortunately
Benchmark Scores TBD
Thank you so much for this quick response, i'm not aware how to access the latest bios for my ASRock, although my drivers for my gpu and chipset are all up to date, automatic settings.
So far today, my computer has been running smoothly without any frame lag whatsoever nor shutting down.

Not a problem! As for your specific motherboard's BIOS, it should be found at this page. If that link doesn't work, then just go to ASRock's website -> B550 Phantom Gaming 4 -> Support -> BIOS. Just be sure to follow all instructions diligently, as losing power during the flash for example can lead to a bricked board.

Glad to hear that it's not giving you any issues today. If it does do so again, then I'd definitely try that BIOS update as a last resort (although, it may not be the solution to your specific issue necessarily).

edit: One last thing I forgot to mention: even though your drivers are totally up to date for the GPU, it sometimes still can't hurt to use AMD DDU to try and fix the problem. I'm sure that you made no mistake with the install, but sometimes AMD / driver vendors make an oopsie nonetheless. Worth a shot!
 
Last edited:

barvee7

New Member
Joined
Nov 15, 2020
Messages
6 (0.02/day)
Wanna bet there's whea errors?
although i dont know much about it, from looking it up it can't be that
Not a problem! As for your specific motherboard's BIOS, it should be found at this page. If that link doesn't work, then just go to ASRock's website -> B550 Phantom Gaming 4 -> Support -> BIOS. Just be sure to follow all instructions diligently, as losing power during the flash for example can lead to a bricked board.

Glad to hear that it's not giving you any issues today. If it does do so again, then I'd definitely try that BIOS update as a last resort (although, it may not be the solution to your specific issue necessarily).

edit: One last thing I forgot to mention: even though your drivers are totally up to date for the GPU, it sometimes still can't hurt to use AMD DDU to try and fix the problem. I'm sure that you made no mistake with the install, but sometimes AMD / driver vendors make an oopsie nonetheless. Worth a shot!
Downloading the wrong bios update can damage it entirely, because i honestly don't know what im looking at and which BIOS to update.

Not a problem! As for your specific motherboard's BIOS, it should be found at this page. If that link doesn't work, then just go to ASRock's website -> B550 Phantom Gaming 4 -> Support -> BIOS. Just be sure to follow all instructions diligently, as losing power during the flash for example can lead to a bricked board.

Glad to hear that it's not giving you any issues today. If it does do so again, then I'd definitely try that BIOS update as a last resort (although, it may not be the solution to your specific issue necessarily).

edit: One last thing I forgot to mention: even though your drivers are totally up to date for the GPU, it sometimes still can't hurt to use AMD DDU to try and fix the problem. I'm sure that you made no mistake with the install, but sometimes AMD / driver vendors make an oopsie nonetheless. Worth a shot!
And i just currently downloaded and processed the amd ddu cleanup utility, waiting and hoping to see if this did the trick.
 
Joined
Nov 15, 2020
Messages
23 (0.07/day)
System Name Jaegermeister
Processor R5 5600X, max PBO
Motherboard Gigabyte B550 Aorus Pro V2
Cooling be quiet! Dark Rock Pro 4 w/ MX-4 thermal paste
Memory 2x16GB Crucial Ballistix 3600MHz CL16 (16Gbit Micron Rev.B) - @ 3800MHz, CL16
Video Card(s) Powercolor Red Devil 6600XT w/ MX-4 thermal paste
Storage 1x 2TB WD SN550 (storage), 1x 1TB SK hynix Gold P31 (boot)
Display(s) 1x Gigabyte G27Q, 1x MSI Optix G241
Case Phanteks P500A (non-digital), w/ 4x 140mm Arctic P14 PST CO fans
Audio Device(s) (Onboard) Realtek ALC 1220-VB
Power Supply Super Flower Leadex III 750W 80+ Gold
Mouse Logitech G203
Keyboard HyperX Core RGB
Software Windows 10 unfortunately
Benchmark Scores TBD
although i dont know much about it, from looking it up it can't be that

Downloading the wrong bios update can damage it entirely, because i honestly don't know what im looking at and which BIOS to update.


And i just currently downloaded and processed the amd ddu cleanup utility, waiting and hoping to see if this did the trick.

Yup, you're completely right on that first part. I don't mean to push you to do something you're not comfortable doing / aren't fully knowledgeable about.

Pertaining to DDU: Sounds good, please let me know if the issue returns.
 

barvee7

New Member
Joined
Nov 15, 2020
Messages
6 (0.02/day)
Yup, you're completely right on that first part. I don't mean to push you to do something you're not comfortable doing / aren't fully knowledgeable about.

Pertaining to DDU: Sounds good, please let me know if the issue returns.
Hey, so after i went through with the amdcleanuputility, it removed my amd graphics settings (right clicking on home screen) where i cant access my graphics anymore. It's also making my computer lag more than usual.

Hey, so after i went through with the amdcleanuputility, it removed my amd graphics settings (right clicking on home screen) where i cant access my graphics anymore. It's also making my computer lag more than usual.
How do i redownload or get back to access my radeon system settings.
 
Joined
Jan 25, 2006
Messages
1,470 (0.26/day)
Processor Ryzen 1600AF @4.2Ghz 1.35v
Motherboard MSI B450M PRO-A-MAX
Cooling Deepcool Gammaxx L120t
Memory 16GB Team Group Dark Pro Sammy-B-die 3400mhz 14.15.14.30-1.4v
Video Card(s) XFX RX 5600 XT THICC II PRO
Storage 240GB Brave eagle SSD/ 2TB Seagate Barracuda
Display(s) Dell SE2719HR
Case MSI Mag Vampiric 011C AMD Ryzen Edition
Power Supply EVGA 600W 80+
Software Windows 10 Pro
Download MSI Live update 6 and run it, see if there is a bios update for your GPU, some early versions of 5600/5700's had some slight issues with early bios revisions and vram speed was increased from 12gbps to 14gbps on some cards, whilst your's is a new card from what I can gather it may well have an update available from MSI

Hey, so after i went through with the amdcleanuputility, it removed my amd graphics settings (right clicking on home screen) where i cant access my graphics anymore. It's also making my computer lag more than usual.


How do i redownload or get back to access my radeon system settings.
Thats not DDU, you can get it from GURU 3D or other websites, now you need to download it install and run it, download the latest AMD drivers for GPU and perform a clean install, you should have all radeon settings available to you then
 

barvee7

New Member
Joined
Nov 15, 2020
Messages
6 (0.02/day)
Download MSI Live update 6 and run it, see if there is a bios update for your GPU, some early versions of 5600/5700's had some slight issues with early bios revisions and vram speed was increased from 12gbps to 14gbps on some cards, whilst your's is a new card from what I can gather it may well have an update available from MSI


Thats not DDU, you can get it from GURU 3D or other websites, now you need to download it install and run it, download the latest AMD drivers for GPU and perform a clean install, you should have all radeon settings available to you then
I cant seem to find the correct download link on the guru 3d website, could you kindly help provide the certain link i need to download?
 
Joined
Jan 25, 2006
Messages
1,470 (0.26/day)
Processor Ryzen 1600AF @4.2Ghz 1.35v
Motherboard MSI B450M PRO-A-MAX
Cooling Deepcool Gammaxx L120t
Memory 16GB Team Group Dark Pro Sammy-B-die 3400mhz 14.15.14.30-1.4v
Video Card(s) XFX RX 5600 XT THICC II PRO
Storage 240GB Brave eagle SSD/ 2TB Seagate Barracuda
Display(s) Dell SE2719HR
Case MSI Mag Vampiric 011C AMD Ryzen Edition
Power Supply EVGA 600W 80+
Software Windows 10 Pro
Joined
Jan 25, 2006
Messages
1,470 (0.26/day)
Processor Ryzen 1600AF @4.2Ghz 1.35v
Motherboard MSI B450M PRO-A-MAX
Cooling Deepcool Gammaxx L120t
Memory 16GB Team Group Dark Pro Sammy-B-die 3400mhz 14.15.14.30-1.4v
Video Card(s) XFX RX 5600 XT THICC II PRO
Storage 240GB Brave eagle SSD/ 2TB Seagate Barracuda
Display(s) Dell SE2719HR
Case MSI Mag Vampiric 011C AMD Ryzen Edition
Power Supply EVGA 600W 80+
Software Windows 10 Pro
Top