• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Need help: HD 5870 Never stepping beyond the 600/900Mhz frquencies

voidburn

New Member
Joined
May 25, 2010
Messages
4 (0.00/day)
Likes
0
#1
[SOLVED] HD 5870 Never stepping beyond the 600/900Mhz frquencies

Hello all,

It's been a month now that I'm looking for a solution. I have a Sapphire HD 5870 Vapor-X card, which is supposed to run @ 875/1250Mhz under full load. The problem is that even the heaviest game engines never trigger that powerplay mode, best I get is the GPU to run @ 600/900Mhz. I even tried to RMA the card but it returned with a clean bill of health. I'm turning to you guys for help.

Here's my system spec:

CPU: Intel i7 980X @ stock freq
Motherboard: Asus Rampage II Extreme
Memory: Corsair 6x2Gbyte (Choice based on the QVL provided by asus for such configuration)
PSU: Chieftec 560W - Sli/Crossfire ready (Getting a brand new modular Enermax 850 this week)
OS: Genuine Win7 Ultimate x64 fully updated
Driver: Catalyst 10.4 (I've tried 10.3/2/1 with same results)

I already submited my bios to Sapphire and they reported no apparent issues with it, though I'm attaching it here (fresh dump with GPU-Z 0.4.2, for some reason v. 0.4.3 refused to save the bios).

There must be something wrong with my windows installation, and this thursday I'm getting a new Raptor-X hard drive together with the Enermax 850W, and will attempt a clean install, but I've reinstalled before, with no results.

There must be something in my system that prevents powerplay to switch to the correct frequencies, but I'm at a loss of ideas.

I have an APC UPS connected to this machine via USB which reports battery charge, this isn't tricking the system into thinking it's running in a laptop environment, is it? Under power options the system is set to run at High Performance, with no power saving applied in any scenario to the PCI-E rails.

I hope some of you can provide some fresh ideas on how to tackle this issue. If any of you as ever seen or heard of something like this I'd love to hear from you.

Full resolution screenshot of furmark running @ full settings with CPU-Z sensors in view:

 

Attachments

Last edited:
Joined
Dec 5, 2007
Messages
5,133 (1.35/day)
Likes
1,970
System Name Addison Clark / HTPC
Processor Ryzen 1800X / I7 6700k
Motherboard Asrock X370 ITX/ Asrock Z270 Taichi
Cooling Custom loop for CPU and GPU / Be Quiet Dark Knight
Memory G.Skill 32GB DDR4 - 3200 / G.Skill 16GB DDR4 - 2400
Video Card(s) Zotac 1080 TI F.E. under EK block / Asus Turbo GTX 1080 w/ Corsair H55
Storage Plextor M8Pe 1TB M.2 / 256GB and 512GB WD Black NVME's
Display(s) Asus 28" 4K / Samsung 55" 1080p
Case Corsair 380T / Silverstone GD10
Audio Device(s) Onboard Realtek/ Onboard Realtek
Power Supply EVGA G3 Supernova 1KW / Rosewill 750W
Mouse G.Skill 780
Keyboard MS Sidewinder x4 / Logitech K400 combo
Software Win 10 Pro / Windows 8.1 w MCE and Win 10 Pro
#2
Have you hit the unlock tab in the Catalyst Control Center?
 

voidburn

New Member
Joined
May 25, 2010
Messages
4 (0.00/day)
Likes
0
#3
Yes indeed, I went as far as to create a personal profile for Overdrive, forcing all frequencies to 875/1250 in every operating mode, but as much as it happens with MSI Afterburner, most of the settings I apply via software modifications are completely disregarded.

For example, I cannot tweak the frequencies via CCC panel or MSI Afterburner, any change I made is completely ignored.

By editing the currently loaded bios I can see that there is no voltage specified for the mode3 setting, could that be an issues? would it be worth it to try, edit and flash the bios? If so, what voltage would be adequate for the high performance mode?

Screenshot of the current settings:

 
Last edited:
Joined
Dec 5, 2007
Messages
5,133 (1.35/day)
Likes
1,970
System Name Addison Clark / HTPC
Processor Ryzen 1800X / I7 6700k
Motherboard Asrock X370 ITX/ Asrock Z270 Taichi
Cooling Custom loop for CPU and GPU / Be Quiet Dark Knight
Memory G.Skill 32GB DDR4 - 3200 / G.Skill 16GB DDR4 - 2400
Video Card(s) Zotac 1080 TI F.E. under EK block / Asus Turbo GTX 1080 w/ Corsair H55
Storage Plextor M8Pe 1TB M.2 / 256GB and 512GB WD Black NVME's
Display(s) Asus 28" 4K / Samsung 55" 1080p
Case Corsair 380T / Silverstone GD10
Audio Device(s) Onboard Realtek/ Onboard Realtek
Power Supply EVGA G3 Supernova 1KW / Rosewill 750W
Mouse G.Skill 780
Keyboard MS Sidewinder x4 / Logitech K400 combo
Software Win 10 Pro / Windows 8.1 w MCE and Win 10 Pro
#4
I would go and grab Driver Sweeper, uninstall all ATI/AMD drivers and OC tools like Afterburner, reboot into safe mode, install Driver Sweeper, run and clean ATI drivers/reg entries with Driver Sweeper, reboot back into Normal Mode, and install 10.4 drivers.
 

voidburn

New Member
Joined
May 25, 2010
Messages
4 (0.00/day)
Likes
0
#5
Been there, done that :( The only more thorough method I can think of I'm postponing for when I get the Enermax + New hard drive, which is a complete reinstall of windows.

I have tweaked the CCC profile again, this time I managed to get the frequencies to work in mode 2 by copying the mode 3 settings over to mode 2:

Code:
<Profile>
  <Caste name="Graphics">
    <Groups>
      <Group name="Overdrive5">
        <Feature name="TimeUnlocked" />
        <Feature name="OverclockEnabled">
          <Property name="OverclockEnabledProperty" value="True" />
        </Feature>
        <Feature name="AutoTuneSupport" />
        <Feature name="CoreClockTarget_0">
          <Property name="Want_0" value="15700" />
          <Property name="Want_1" value="87500" />
          <Property name="Want_2" value="87500" />
        </Feature>
        <Feature name="MemoryClockTarget_0">
          <Property name="Want_0" value="30000" />
          <Property name="Want_1" value="125000" />
          <Property name="Want_2" value="125000" />
        </Feature>
        <Feature name="CoreVoltageTarget_0">
          <Property name="Want_0" value="950" />
          <Property name="Want_1" value="1163" />
          <Property name="Want_2" value="1163" />
        </Feature>
        <Feature name="MemoryVoltageTarget_0">
          <Property name="Want_0" value="0" />
          <Property name="Want_1" value="0" />
          <Property name="Want_2" value="0" />
        </Feature>
        <Feature name="FanSpeedProtocol_0">
          <Property name="FanSpeedProtocolProperty" value="Percent" />
        </Feature>
        <Feature name="FanSpeedAlgorithm_0">
          <Property name="FanSpeedAlgorithm" value="Automatic" />
        </Feature>
        <Feature name="FanSpeedRPMTarget_0">
          <Property name="Want" value="962" />
        </Feature>
        <Feature name="FanSpeedPercentTarget_0">
          <Property name="Want" value="50" />
        </Feature>
      </Group>
    </Groups>
    <Adapter name="PCI_VEN_1002&amp;DEV_6898&amp;SUBSYS_E140174B&amp;REV_00_4&amp;2F1C4782&amp;0&amp;0018A">
      <Aspect name="Overdrive5" />
    </Adapter>
  </Caste>
</Profile>
If anyone has a clue as to why my system is unable to step into mode 3 I'm all ears :)
 
Last edited:

voidburn

New Member
Joined
May 25, 2010
Messages
4 (0.00/day)
Likes
0
#6
After further testing with the software mod, I decided to embed the settings within the bios. Since I also sporadically experienced the infamous striped crash I also normalized the voltages across the various powerplay states, that is because I was able to confirm that every crash took place during a sudden switch between high and low states. As I presumed, it wasn't an issue of frequencies dropping, as much as voltages.

Here is a table containing the new settings for a stable Sapphire HD 5870 Vapor-X OC Edition, together with some improvements to the fan management, which keeps the GPU cores within 75 degrees celsius even under long hours at full load (the stock settings never push the fan beyond 55%, allowing the board to reach 87 degrees, which I don't like).

The following settings were applied to a fresh dump of the bios, using TechPowerUP's Radeon Bios Editor 1.25 + WinFlash 2.0.1.11.

Clock info 00:
850/1250 Voltage 1.063 (original voltage 0.950)

Clock info 01:
157/300 Voltage 1.063 (original voltage 0.950) [Aero/2D state, overvolted to avoid the vdrop when switching between 3D and 2D, frequently happening during loading screens]

Clock info 02:
875/1250 Voltage 1.163 (original voltage 1.063) [Pushed the medium state up to 3D, since my system would ignore that one, with this I can get the card to correctly go @ full speed in games]

Clock info 03:
875/1250 Voltage 1.163 [untouched]

Clock info 04:
600/900 Voltage 1.063 [UVD state, slightly pumped up]

Clock info 05:
875/1250 Voltage 1.163 [No idea when this is used, since the state structure that contains it has the same name as the main one, normalized and pumped up]

Clock info 06:
875/1250 Voltage 1.163 [Same as clock info 05]

Fan throttle:

Tmin: 40 Degrees
Tmax: 75 Degrees
Tslope: 39%

Duty cycle min: 15%

With these settings I completely god rid of artifacting and so far couldn't experience any stripe crashes. If your card is acting up, I strongly suggest you normalize your power-play settings across the board, especially avoiding the gap btween 0.950v and 1.163v in the low/high modes.

Good luck.
 
Last edited:
Joined
Oct 6, 2005
Messages
10,241 (2.24/day)
Likes
2,107
Location
Granite Bay, CA
System Name Big Devil
Processor Intel Core i5-2500K
Motherboard ECS P67H2-A2
Cooling XSPC Rasa | Black Ice GT Stealth 240 | XSPC X2O 750 | 2x ACF12PWM | PrimoChill White 7/16"
Memory 2x4GB Corsair Vengeance LP Arctic White 1600MHz CL9
Video Card(s) EVGA GTX 780 ACX SC
Storage Intel 520 Series 180GB + WD 1TB Blue
Display(s) HP ZR30W 30" 2650x1600 IPS
Case Corsair 600T SE
Audio Device(s) Xonar Essence STX | Sennheisser PC350 "Hero" Modded | Corsair SP2500
Power Supply ABS SL 1050W (Enermax Revolution Rebadge)
Software Windows 8.1 x64 Pro w/ Media Center
Benchmark Scores Ducky Year of the Snake w/ Cherry MX Browns & Year of the Tiger PBT Keycaps | Razer Deathadder Black
#7
Glad to hear you got it figured out, and thanks for actually posting the solution for others!

Oh, and welcome to TPU :toast: