• We've upgraded our forums. Please post any issues/requests in this thread.

Need help with wrong BIOS! XFX Radeon 5770 HD-557A-ZNFC!

matbarni

New Member
Joined
Apr 5, 2011
Messages
5 (0.00/day)
Likes
0
#1
Hi...

I have a XFX HD 5770 850M 1GB DDR5 DP HDMI DUAL DVI PCI-E.

I flashed a bad BIOS on it... without the backup of the old one.

Now it wont boot...


What I tried:

I flashed all the BIOS I could find in the XFX 5770 Techpowerup database.

-----------------------------

I tried BIOSes from different manufacturers, 2 of them "half worked" (by half I mean some BSOD and no CrossFireX).

-----------------------------

I googled for the model HD-577A-ZNFC VE.5 without success. It seems that the "VE.5" does not exist... but is writen on my gfx card here in front of me!

-----------------------------

What do I do? I'm in need of the correct bios version...
 
Joined
Jan 21, 2009
Messages
734 (0.23/day)
Likes
121
Location
Golden, Colorado
System Name KAREN / EVA / GHOST
Processor Intel Core i7-950 / AMD Phenom II X4 940 BE / Core i5 3570k
Motherboard ASUS TUF Sabertooth X58 / DFI LP DK 790FXB-M2RSH / Asrock z77e-itx
Cooling Thermaltake Frio / Corsair Cooling™ Hydro Series H50 / Corsair Hydro Series H60
Memory Corsair Dominator 6GB DDR3 1600 / Corsair Dominator Quad2X4096-8500C5DF / G.SKILL Ripjaws Serie 1600
Video Card(s) XFX HD6950 CF unlocked /XFX HD5770 CF/ MSI R4890 Cyclone
Storage OCZ Vertex 2 60 WD Raptor X WD1500AHFD / Seagate Barracuda /Western Digital 80gb, Toshiba 1TB
Display(s) 2 Acer P215H 21.5 Widescreen / Acer S211HL 21.5 / HP 2009F 20inch
Case SILVERSTONE RAVEN RV02-BW / NZXT Phantom /Bitfenix Prodigy
Audio Device(s) On board / Philips MMS 321 - PC multimedia speakers
Power Supply Ultra X3 ULT40311 1000W / Cosair CMPSU-750TX 750W/ CORSAIR Gaming Series GS700 700W
Software Windows 7 64 bit / Windows 7 64 bit / Windows 7 64 bit
#2
Did you run any benchmarks and made screen shots with GPUZ before the flash?
 
Joined
Aug 29, 2005
Messages
4,801 (1.07/day)
Likes
1,575
Location
Whatever my internet protocol shows I guess O.o
System Name Lynni and The Great White Dragon in Tempered Glass | Lynni-Stick
Processor Intel Core i7-6700K "Skylake" | Intel Atom X5-Z8300 "Cherry Trail"
Motherboard Gigabyte Aorus GA-Z270X-Gaming 7 "Union Point" | Intel Compute Stick board
Cooling Thermalright True (Old legend still going strong) 1xNoctua NF-F12 PWM | Fan xD
Memory Geil Dragon 2x8GB@3000mhz 15-17-17-35 (GWW416GB3000C15DC) | 2GB DDR3-L @ 1600mhz
Video Card(s) MSI GTX 1080 Ti FE "Pascal" | Intel HD Graphics
Storage OS/Games:Samsung 960 EVO 250GB NVME|2xSamsung EVO 850 1TB SSD|Data:3xWD Red/Purple 4TB & WD SE 1TB
Display(s) Dell S2417DG 1440p@165hz G-Sync | Philips 50PFT4009/12
Case Phantek Eclipse P400 Black/White | Intel Compute Case
Audio Device(s) Creative Core3D (Onboard) | Intel HD Audio
Power Supply Corsair SF600 | Generic Intel Power Adapter (3amp)
Mouse Logitech G502 | Logtech MK270 kit @ Lynni-Stick
Keyboard Razer Blackwidow Chroma X UK
Software Win10 Pro CU UK x64 | Win10 Home CU x86
Benchmark Scores 3DMark Skydrive @ 1440p: GS: 25188 / PS: 12238 / CS: 25308: http://www.3dmark.com/3dm/11665249
#3
this one should be the bios ino it don't have VE.5 in it but it's from a HD-577A-ZNFC card if that don't work, i think u need to email XFX and ask if they can email you the bios for your card, i think that will be the easiest solution if they do that ^^
 

matbarni

New Member
Joined
Apr 5, 2011
Messages
5 (0.00/day)
Likes
0
#4
this one should be the bios ino it don't have VE.5 in it but it's from a HD-577A-ZNFC card if that don't work, i think u need to email XFX and ask if they can email you the bios for your card, i think that will be the easiest solution if they do that ^^
Already tried that one... does not work.


Already asked XFX for the BIOS... the answer? = "We don't keep our BIOSes in hand".
 

matbarni

New Member
Joined
Apr 5, 2011
Messages
5 (0.00/day)
Likes
0
#5
Did you run any benchmarks and made screen shots with GPUZ before the flash?
No :/


Would that be important? Make a parameter to find the BIOS with the Benchmarks?

Well... anyway... I did not...

I am stupid... I should have done a backup before flashing.
 
Joined
Jan 21, 2009
Messages
734 (0.23/day)
Likes
121
Location
Golden, Colorado
System Name KAREN / EVA / GHOST
Processor Intel Core i7-950 / AMD Phenom II X4 940 BE / Core i5 3570k
Motherboard ASUS TUF Sabertooth X58 / DFI LP DK 790FXB-M2RSH / Asrock z77e-itx
Cooling Thermaltake Frio / Corsair Cooling™ Hydro Series H50 / Corsair Hydro Series H60
Memory Corsair Dominator 6GB DDR3 1600 / Corsair Dominator Quad2X4096-8500C5DF / G.SKILL Ripjaws Serie 1600
Video Card(s) XFX HD6950 CF unlocked /XFX HD5770 CF/ MSI R4890 Cyclone
Storage OCZ Vertex 2 60 WD Raptor X WD1500AHFD / Seagate Barracuda /Western Digital 80gb, Toshiba 1TB
Display(s) 2 Acer P215H 21.5 Widescreen / Acer S211HL 21.5 / HP 2009F 20inch
Case SILVERSTONE RAVEN RV02-BW / NZXT Phantom /Bitfenix Prodigy
Audio Device(s) On board / Philips MMS 321 - PC multimedia speakers
Power Supply Ultra X3 ULT40311 1000W / Cosair CMPSU-750TX 750W/ CORSAIR Gaming Series GS700 700W
Software Windows 7 64 bit / Windows 7 64 bit / Windows 7 64 bit
#7
No :/


Would that be important? Make a parameter to find the BIOS with the Benchmarks?

Well... anyway... I did not...

I am stupid... I should have done a backup before flashing.
The only time I ever flashed my cards is when I am trying to get better benchmark scores. I would always have screen shots of before flash and after. I had flashed my bios before and those screen shots saved me. Thats why I asked if maybe you did some bench marks.
 
Joined
Jun 13, 2009
Messages
1,528 (0.49/day)
Likes
324
Location
Canada/Québec/Montreal
System Name Main PC
Processor PII 925 @3.724GHz (266x14) 1.525v NB 2660 1.425v
Motherboard Gigabyte AM3 GA-890XA-UD3 (790x+SB850)
Cooling Scythe Mugen 2 rev.B
Memory Hyperx 8GB (2x4) 1600@1418 8-7-7-20-27-1t
Video Card(s) Sapphire 6850 Stock (Max Overclock 1030/1200)
Storage 1x1TB WD Green / 1x1TB Seagate
Display(s) LCD Samsung 24" 16:9
Case Cooler Master HAF 912
Audio Device(s) On-Board HD
Power Supply CM 750w GX |3.3v@25a|5v@25a|12v@60a
Software Windows 7 Ultimate 64bit
Benchmark Scores later...
#8
Already tried that one... does not work.


Already asked XFX for the BIOS... the answer? = "We don't keep our BIOSes in hand".
What didn't work?
The Flash didn't go or after the flash you got some problems &/or BSOD?

If it's the flash part that didn't work... did you tried to force the flash?
 
Joined
Oct 19, 2007
Messages
6,201 (1.67/day)
Likes
982
System Name Phantom Skylake
Processor Intel i5 6600k @ 4.5GHZ w/ Corsair H80i CPU AiO w/Corsair 120mm SP120 RBG fan
Motherboard Asus z170-A
Cooling 4x120mm Corsair SP120 RBG fans
Memory G.skill DDR4 3200MHz 2x4GB (Soon to be Corsair Vengeance RBG)
Video Card(s) Asus DirectCUII GTX 980 STRIX
Storage Samsung 960 EVO m.2, Samsung 850 EVO 1TB SSD, 2TB backup, 16TB Synology DS1515+ RAID-5
Display(s) Acer Predator 34" 3440x1440
Case Corsair 570x RBG Tempered Glass
Audio Device(s) Onboard / Corsair Void Wireless RGB
Power Supply Corsair HX750w Professional Series
Mouse Logitech G602s
Keyboard Corsair K70 Rapidfire
Software Windows 10 x64 Professional
Benchmark Scores Coming Soon
#9
This sort of thing is why ill never flash a video cards BIOS. Its just so much better to do it through software and leave flashing to the motherboard BIOS. If you cant find the original BIOS from another user or you cant get a stock bios to work from XFX for the 5770 or another manufacturer, then the card is probably borked. Since I have never personally flashed a video card BIOS, there could still be another option I dont know about.
 

matbarni

New Member
Joined
Apr 5, 2011
Messages
5 (0.00/day)
Likes
0
#10
What didn't work?
The Flash didn't go or after the flash you got some problems &/or BSOD?

If it's the flash part that didn't work... did you tried to force the flash?
Flashing the ZNFC BIOS link from the upper post is what didn't work.

About the flashing part... I force flashed all the XFX BIOSes... The flashing part works.

After flashing... the card wont boot... Im using my other 5770 to boot and flash the problematic one.

So...

Im in pursuit to the original BIOS... if the original one does not work... then the hardware part is messed up.
 
Last edited: