• We've upgraded our forums. Please post any issues/requests in this thread.

Network share to require login

Tau

New Member
Joined
Mar 9, 2007
Messages
821 (0.21/day)
Likes
92
#1
Alright what i am trying to do is have a password, or login required to access some shared folders on a computer. All computers are using XP Pro SP2, now i have had situations in the past were i try to access a shared folder over the network on a laptop and it asks for a username and password before it will let me access it. This is what i am trying to setup. Even if i was able to assign the folder permissions for a specific user account.

Any help?
 

Tau

New Member
Joined
Mar 9, 2007
Messages
821 (0.21/day)
Likes
92
#2
Right click on the folder you want to share. Set sharing. Click on permissions. Identify the users (or groups) you want to allow, and thier permissions.

The folder access (permissions) is based on User ID, not on individial password per folder irrespective of user.

To do that, you need to set up a new account for each folder where you want a unique password, e.g. User "Pr0n", set the password so "Y3ahBaby", and then let everyone know the login details for that folder.

Yeah iv been through all that and i cant add a user from another machine.

Right now i have a local account (on the computer with the shares) that has full control alowed, than when i try to access the folder from another machine i get a "\\servername\foldername is not accessable. You might not have permission to use this network resource. Please contact the administrator of this server to find out if you have access permissions. Logon failure: Unknown username or bad password"


I just want it to prompt for username/password credentials when i try to access it from another machine.
 

Tau

New Member
Joined
Mar 9, 2007
Messages
821 (0.21/day)
Likes
92
#5
Got it so i can access the folder, now i need to make it ask me for a password.
 

Tau

New Member
Joined
Mar 9, 2007
Messages
821 (0.21/day)
Likes
92
#7
Sigh, comon people, i either get it so it blatantly denys me access, or it just lets me in.

Google has been of little use as well.
 

kureng

New Member
Joined
Apr 6, 2007
Messages
100 (0.03/day)
Likes
0
Processor AMD64 X2 5000 BE OCed 3.0Ghz
Motherboard MSI K9A2 CF A790X
Cooling CoolerMaster Gemin II
Memory 2GB Corsair XMS2 6400C4 DDR2 OCed 1000Mhz CL 4-4-4-13
Video Card(s) HIS ATI Radeon HD3870 ICEQ3 512MB GDDR4
Storage WD 500GB SATA2, Seagate 250GB SATA2, Seagate 160GB SATA2
Display(s) Viewsonic LCD 17inch
Case CoolerMaster RC-690
Audio Device(s) Realtek High Definition ALC888
Power Supply CoolerMaster Extreme Power
Software Windows Vista Ultimate x86 SP1
#8
try add user "everyone" and mark read and list permission
 

Shyska

New Member
Joined
Sep 7, 2005
Messages
158 (0.04/day)
Likes
16
Processor AMD Athlon64 3000+ Venice @2.5GHz
Motherboard Asus A8N-E :(this board limits my cpu overclock ):
Cooling CPU box, GPU Zalman VF700-Cu
Memory 2x512MB PC3200 @227MHz
Video Card(s) Sapphire X850XT 256MB PCI-E @ 605/618
Storage 40GB & 120GB Maxtors
Power Supply Generic 400W
Software Windows XP Pro SP2 | Debian GNU/Linux <sarge>
#9
Sigh, comon people, i either get it so it blatantly denys me access, or it just lets me in.

Google has been of little use as well.
Hi, Tau
To properly share a folder there are five things you should do:

1. Disable simple file sharing.
2. Share the folder.
3. Set share permissions.
4. Set folder permissions.
5. Make sure you don't have same username/password on both machines.


Maybe it already gives you a clue?
If not, there is some wider explanation (if you are testing all over, do it on a new folder in root space, e.g. on "C:\testshare"):


1. Go to Explorer (e.g. open My Computer). Go to menu "Tools->Folder Options...", "View" tab, Make sure "Use simple file sharing (Recomended)" is UNchecked.


2. Rightclick the folder, choose "Sharing and Security...", click on "Share this folder". Do NOT exit this window, you need it for next step, just press "Apply" button.
After this you have a shared folder for which only your local users can get access and only to read information (can not change old or add new files).


3. On the previous window press "Permissions" button, mark "Everyone" group and check "Full Control", it is not checked by default. Close window by pressing "OK" ONE times. You should see "Sharing" tab now, leave it at that and go to next step.
Do not use any other rights on sharing permission tab, let everyone with full access and manage anyting else on folder permission tab, it is a better practise, trust me.


4. Click on "Security" tab. There you see all the users, there you manage who can access resources and who can not. This is the part where you probably have problems.

First of all, remove all permissions. To do that, click "Advanced" button, unckeck "Inherit from parent the permission...<>", click "Remove" as an answer. Close Advanced Security Settings window by pressing "OK".

Now you have clean Security tab. You can go and see that you can not even enter the folder ;)

At this point you should be looking at folder properties "Security" tab, which has no entries in "Group or user names" textbox.
Click "Add..." button, write name of the user you want to give access, click OK. Now you have your choosen user able to view folder contents and read (open) files. You can add another access options like Modify (change files) and Write (create files) by checking permission boxes on "Allow" column.
Add all the users you need there.
Add user "SYSTEM" with Full Control.
Be carefull if you add "Deny" permissions, they overide "Allow" permissions.

At this point you are all set up.


5. If someone still can access folder from another PC without giving username/password, they are working with same username and same password as a user that has access permissions on your host PC. Change that.


P.S. oh, and I assume you have passwords for your users.