• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

New router- Help really weird problem! Belkin N1 Vision

Greek

New Member
Joined
Oct 23, 2006
Messages
572 (0.14/day)
Likes
3
Location
Leicester, UK
Processor AMD 64bit - Dual-Core 4200+X2 at 2.64GHz 24/7
Motherboard ASUS A8n-SLi Deluxe
Cooling Zalman AB3CL CPU Cooler with 12Cm Fan, Plus 10 Fans at 12CM lol
Memory 2GB DDR 400MHz 3-3-3-8
Video Card(s) BFG 7900GTX OC - " My Big F'N Gun "
Storage 1 x 250GB WD Caviar RE SATA-300, 1 x 250GB Maxtor IDE, 1 x 160GB Samsung Spinpoint
Display(s) 17 " Hansol TFT LCD
Case Thermaltake Kandalf VA9000SWA - Aluminium Full Tower Case
Audio Device(s) On-board 7.1
Power Supply 650WAtt Atrix
Software Vista Business
#1
Hey guys,

God its been time since i last posted here, been so busy and have been moving around a lot.

Ok i got a Belkin N1 vsision router which i have been using for 1 year no, bought it back in england and used it with Virgin medias cable service.

I came to albania for a few months so i took that and the NAS bufallo with me, the NAS crashed on me as the power to the whole house went and butched up the firmware, but thank god there as a lot of help on how to fix it.

So 3 days ago the power went again, this time my router kept restarting every 10 seconds it wont even boot up, ive tried various methods but no luck, it loads to about 20 percent then reboots it self, so i put it in the freezer for a couple of hours and it worked, but when i unpluged it and pluged it back in it did the same, so i updated firmare, still the same no luck, now i have to leave it on and prey that the poer dont go off or the router dont turn off by it self else it ill have to go back in the freezer, reset methods dont work plus i get a message on the routersw screen saying Download Mode..... I tried belkin support but the guy just told me ho to reset it, not much help and they will contact me with a fix, yher right like thats ever going to happen.

So my question is this, what do u reckon is the problem, can it be fixed? do i need a ne router? if so i have been looking at this one currently selling at a store in Greece here i can just pop down and get this as my budget is limited to 100 euros.

HTML:
http://www.netgear.com/Products/RoutersandGateways/WirelessNRoutersandGateways/WNB2100.aspx?detail=Specifications
Or if you have any better suggestion or know any better routers then please let me know.

Thanks a lot

Greek
 

Wile E

Power User
Joined
Oct 1, 2006
Messages
24,318 (5.88/day)
Likes
3,682
System Name The ClusterF**k
Processor 980X @ 4Ghz
Motherboard Gigabyte GA-EX58-UD5 BIOS F12
Cooling MCR-320, DDC-1 pump w/Bitspower res top (1/2" fittings), Koolance CPU-360
Memory 3x2GB Mushkin Redlines 1600Mhz 6-8-6-24 1T
Video Card(s) Evga GTX 580
Storage Corsair Neutron GTX 240GB, 2xSeagate 320GB RAID0; 2xSeagate 3TB; 2xSamsung 2TB; Samsung 1.5TB
Display(s) HP LP2475w 24" 1920x1200 IPS
Case Technofront Bench Station
Audio Device(s) Auzentech X-Fi Forte into Onkyo SR606 and Polk TSi200's + RM6750
Power Supply ENERMAX Galaxy EVO EGX1250EWT 1250W
Software Win7 Ultimate N x64, OSX 10.8.4
#2
If you end up needing a new router, you can;t go wrong with a D-Link DIR-655. Absolutely great performance.
 

Greek

New Member
Joined
Oct 23, 2006
Messages
572 (0.14/day)
Likes
3
Location
Leicester, UK
Processor AMD 64bit - Dual-Core 4200+X2 at 2.64GHz 24/7
Motherboard ASUS A8n-SLi Deluxe
Cooling Zalman AB3CL CPU Cooler with 12Cm Fan, Plus 10 Fans at 12CM lol
Memory 2GB DDR 400MHz 3-3-3-8
Video Card(s) BFG 7900GTX OC - " My Big F'N Gun "
Storage 1 x 250GB WD Caviar RE SATA-300, 1 x 250GB Maxtor IDE, 1 x 160GB Samsung Spinpoint
Display(s) 17 " Hansol TFT LCD
Case Thermaltake Kandalf VA9000SWA - Aluminium Full Tower Case
Audio Device(s) On-board 7.1
Power Supply 650WAtt Atrix
Software Vista Business
#3
Did i mention i want it to do both cable and adsl!!


@ wile E thanks for the up man, that looks like a nice router, just wondering if it will be easy to find in greece.