• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

NVFlash (5.660.0) does not run --protecton command on RTX3080 (Strix OC) successfully?

jbattermann

New Member
Joined
Oct 27, 2020
Messages
4 (0.11/day)
Hey there,

I used v5.660.0 of the NVFlash tool to flash one of my two GPU bioses and in order to to do so I ran nvflash64 --protectoff first, flashed the bios and then tried to run nvflash64 --protecton again but unfortunately it does not work:

-------------------------------------------------------------------------------------------------------
D:\tools\NVFlash»nvflash64.exe --protecton
NVIDIA Firmware Update Utility (Version 5.660.0)
Copyright (C) 1993-2020, NVIDIA Corporation. All rights reserved.

Adapter: GeForce RTX 3080 (10DE,2206,1043,87AC) H:--:NRM S:00,B:07,D:00,F:00

EEPROM ID (EF,6015) : WBond W25Q16FW/JW 1.65-1.95V 16384Kx1S, page

Setting EEPROM software protect setting...

Setting of EEPROM protect failed.
PROGRAMMING ERROR: Error: set EEPROM protection function failed

-------------------------------------------------------------------------------------------------------


Others have reported the same / similar problem with RTX 30* cards (i.e. see https://www.overclock.net/threads/official-nvidia-rtx-3090-owners-club.1753930/page-125) and I was wondering if somebody knows a work around and or would know, where I could report this as a bug / feature request to make that command compatible with those newer cards?

Thanks!
-JB
 

jbattermann

New Member
Joined
Oct 27, 2020
Messages
4 (0.11/day)
Probably a newer version helps. I talk to @W1zzard ...

EDIT:
Try NVIDIA NVFlash 5.667.0
Thanks for the quick reply! However / unfortunately it did not fix the problem.. downloaded the .zip (which does not contain a 64bit version btw) and ran it again.. however:

D:\Tools\NVFlash»nvflash.exe --protecton
NVIDIA Firmware Update Utility (Version 5.667.0)
Copyright (C) 1993-2020, NVIDIA Corporation. All rights reserved.


Adapter: GeForce RTX 3080 (10DE,2206,1043,87AC) H:--:NRM S:00,B:07,D:00,F:00


EEPROM ID (EF,6015) : WBond W25Q16FW/JW 1.65-1.95V 16384Kx1S, page

Setting EEPROM software protect setting...


Setting of EEPROM protect failed.

ERROR: set EEPROM protection function failed
 

jbattermann

New Member
Joined
Oct 27, 2020
Messages
4 (0.11/day)
Ah ok... didn't check / look that far. But yeah.. unfortunately the --protecton flag doesn't work, yet. If he/she needs any more data or something to identify why this is (not) happening, let me know.. happy to help
 

dzkien

New Member
Joined
Oct 29, 2020
Messages
5 (0.14/day)
I have the same problem with my 3080 TUF. Where you able to update your vBIOS ? I got this error.

Results:
Index | Match | Flash | Name
<00> * GeForce RTX 3080 (10DE,2206,1043,87B0) S:00, B:26
Nothing changed!



ERROR: Update aborted
 
Joined
Oct 22, 2014
Messages
10,203 (4.57/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
Ah ok... didn't check / look that far. But yeah.. unfortunately the --protecton flag doesn't work, yet. If he/she needs any more data or something to identify why this is (not) happening, let me know.. happy to help
Pretty sure that is known problem, but the flashed Bios will work.
 

Harmoney

New Member
Joined
Aug 21, 2020
Messages
1 (0.01/day)
I have a ASUS RTX 3080 TUF 10G and I get the same error message when I try the --protecton command. Any news on this yet?
 
Joined
Aug 22, 2010
Messages
371 (0.10/day)
Location
Germany
System Name https://goo.gl/FDgehs
Recheck later with NVFlash 5.670 (Windows)

Otherwise you could make a try under Linux (5.652 or later).
 
Top