• We've upgraded our forums. Please post any issues/requests in this thread.

nVidia driver problem?

Joined
Feb 18, 2010
Messages
1,715 (0.60/day)
Likes
408
System Name Eldritch
Processor AMD Ryzen 5 1500X
Motherboard MSI B350 PC Mate
Cooling Satan's butthole after going to Taco Bell
Memory 16 GB G.Skill Flare X
Video Card(s) nVidia (Gigabyte) GT 740 2GB
Storage 80 GB IBM, 2 TB WD Green
Display(s) Dell 2007WFP
Software Debian Buster
#1
OK, I turned on the craputer today and started Mint 9 up and was greeted by a grey box with an error message saying that it couldn't start the nVidia kernel, some crap about having screens but none with a useable configuration, and other randomish crap.

I've had this problem on previous installations of Mint 9, and I've fixed them before, but this time it took a while for it to come up (as in everything was fine a couple of weeks ago), so I fixed it in my hillbilly style (blacklisted crap, reinstalled nVidia drivers). Then I updated my kernel to 2.6.32-24 (I don't know why it wasn't there before), and it magically popped up again. I could fix it (reinstall the drivers again), but I'd prefer if there was something a little more permanent.


On another note, if I drop to a terminal and run startx everything is perfect. No errors, it uses the drivers, everything runs fine.
 
Joined
Mar 31, 2007
Messages
1,895 (0.48/day)
Likes
162
Location
ontario canada
System Name home brew
Processor Intel Corei7 3770K OC @ 4.5Ghz
Motherboard ASUS P8Z77-V
Cooling Corsair H100
Memory 16GB DDR3 1600 GSKILL
Video Card(s) Powercolor Radeon 7970, MSI Radeon 7970
Storage Mushkin Chronos Deluxe 240gb. 2 TB Hdd.
Display(s) 3x24inch Dell Ultra IPS
Case CM storm trooper
Power Supply Antec Quattro OC ed. 1200w
Software Windows 7 Business x64
Benchmark Scores vantage: P43089
#2
I havent tried mint for a few years now. With that said I havent run into this issue on ubuntu 10 with my nvidia workstation at work or my laptop at home. Maybe try another os in a dualboot if u can
 
Joined
Feb 18, 2010
Messages
1,715 (0.60/day)
Likes
408
System Name Eldritch
Processor AMD Ryzen 5 1500X
Motherboard MSI B350 PC Mate
Cooling Satan's butthole after going to Taco Bell
Memory 16 GB G.Skill Flare X
Video Card(s) nVidia (Gigabyte) GT 740 2GB
Storage 80 GB IBM, 2 TB WD Green
Display(s) Dell 2007WFP
Software Debian Buster
#3
Well, I never had this problem with Lubuntu (it got wiped by Winblows) and I believe that they both used the same driver version...

IDK....
 
Joined
Mar 31, 2007
Messages
1,895 (0.48/day)
Likes
162
Location
ontario canada
System Name home brew
Processor Intel Corei7 3770K OC @ 4.5Ghz
Motherboard ASUS P8Z77-V
Cooling Corsair H100
Memory 16GB DDR3 1600 GSKILL
Video Card(s) Powercolor Radeon 7970, MSI Radeon 7970
Storage Mushkin Chronos Deluxe 240gb. 2 TB Hdd.
Display(s) 3x24inch Dell Ultra IPS
Case CM storm trooper
Power Supply Antec Quattro OC ed. 1200w
Software Windows 7 Business x64
Benchmark Scores vantage: P43089
#4
Yeah but it could be something in Mint thats causing the problem.
 
Joined
Feb 18, 2010
Messages
1,715 (0.60/day)
Likes
408
System Name Eldritch
Processor AMD Ryzen 5 1500X
Motherboard MSI B350 PC Mate
Cooling Satan's butthole after going to Taco Bell
Memory 16 GB G.Skill Flare X
Video Card(s) nVidia (Gigabyte) GT 740 2GB
Storage 80 GB IBM, 2 TB WD Green
Display(s) Dell 2007WFP
Software Debian Buster
#5
That's what I was figuring, but where exactly would I start? I blacklisted Noveau and a few buffers (?) as per the instructions on the bottom post (seemed easier to follow) of this.

My curiosity seems to lead me to "screens found, but none have a usable configuration" first and I start t think that the driver screen config gets out of sync with the X screen config, which might have been confirmed when it did it this morning and I started in low graphics mode and went to the nVidia X Server settings and it told me to run nvidia-xconfig as root, which I did, and when I rebooted everything was fine (which wouldn't happen before blacklisted junk, I tried). Maybe the configs would get out of sync, then the Noveau and stuff would... prevent it from reconfiguring things right..... and with the junk blacklisted it can reconfigure it no prob.

I honestly have no clue though.

BTW I'll be leaving on vacation tomorrow (Wednesday) and I won't be back 'til the end of next week - and I'm not bringing the computer, because then it wouldn't be a vacation :p .