• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Ok this is driving me nuts... System can't boot up

WarEagleAU

Bird of Prey
Joined
Jul 9, 2006
Messages
10,813 (1.96/day)
Location
Gurley, AL
System Name Pandemic 2020
Processor AMD Ryzen 5 "Gen 2" 2600X
Motherboard AsRock X470 Killer Promontory
Cooling CoolerMaster 240 RGB Master Cooler (Newegg Eggxpert)
Memory 32 GB Geil EVO Portenza DDR4 3200 MHz
Video Card(s) ASUS Radeon RX 580 DirectX 12 DUAL-RX580-O8G 8GB 256-Bit GDDR5 HDCP Ready CrossFireX Support Video C
Storage WD 250 M.2, Corsair P500 M.2, OCZ Trion 500, WD Black 1TB, Assorted others.
Display(s) ASUS MG24UQ Gaming Monitor - 23.6" 4K UHD (3840x2160) , IPS, Adaptive Sync, DisplayWidget
Case Fractal Define R6 C
Audio Device(s) Realtek 5.1 Onboard
Power Supply Corsair RMX 850 Platinum PSU (Newegg Eggxpert)
Mouse Razer Death Adder
Keyboard Corsair K95 Mechanical & Corsair K65 Wired, Wireless, Bluetooth)
Software Windows 10 Pro x64
:banghead::banghead::banghead::banghead::banghead::banghead::banghead::banghead:

Ok last week, I decided to remove my liquid cooling setup in my system (didn't really need it and it was becoming a pain, had a small leak that did NO damage). So I went with my Scythe Mugen 2 for cooling. Installed like the directions said, and mobo had power and what not, but would not start. So I tried resetting the CMOS, clearing the RAM, etc, with no luck. So I get on with Asus Tech Support, Sean Reck and Leah were online for 3 hours with me. So, long story short, the board was RMA'd and I got my replacement today. Reports show it was ok, so I went and installed my ram, proc, and Mugen 2. Board has power, reset/start button lights up and stays lit, the CLEAR CMOS button on the back is lit up, and the ROG light flashes like normal (slow pulse). Well, the system still will not start up. I am at wits end trying to figure out what the hell the problem is. I have shorted the 24 pin ATX connector and the drives and fans connected to the PSU start up no issues, but the board still will not power up fully. Sean was saying I had a grounding issue and that I Could use some electrical tape to help with the standoffs if that was the issue.

IS it me, or am I missing something small for my system not to boot up. I have the HSF plugged into the CPU fan connector on the board. I have the chassis fans (minus the front one which is connected via 4 pin molex) hooked up to the optional fans on the motherboard. I don;t have the GPU or Sound card in the system to see if I Can get it to start up (I've tried with everything and still nothing). So does anyone have any ideas?
 
Joined
Jul 18, 2008
Messages
2,892 (0.61/day)
Location
South Carolina
System Name KILLER
Processor Intel Core i7 4790K
Motherboard MSI Z87 G45 Gaming
Cooling Water Cooling
Memory 2x8GB Gskill 2400mhz
Video Card(s) EVGA GTX 980
Storage SSD Samsung 500GB
Display(s) 24" Asus 144hz
Case Cooler Master HAF
Audio Device(s) X-Fi Platinum
Power Supply Antec 1200 Watt Modular
Software Windows 10 64 Bit
Benchmark Scores 3DMark Vantage 51342
I would say its some kind of grounding issue also.

Does you new cooler have a backplate? If so place some cardboard or something in between it and the mobo.

Check all your cables to insure proper placement.

Make sure your HDD cables are in the proper port.
 

brandonwh64

Addicted to Bacon and StarCrunches!!!
Joined
Sep 6, 2009
Messages
19,542 (4.49/day)
Try taking the motherboard out of the case and setting it on the motherboard box and start with the CPU, GPU, and 1 stick of ram and see if that works. if it does then you are grounding out somewhere in the case
 

WarEagleAU

Bird of Prey
Joined
Jul 9, 2006
Messages
10,813 (1.96/day)
Location
Gurley, AL
System Name Pandemic 2020
Processor AMD Ryzen 5 "Gen 2" 2600X
Motherboard AsRock X470 Killer Promontory
Cooling CoolerMaster 240 RGB Master Cooler (Newegg Eggxpert)
Memory 32 GB Geil EVO Portenza DDR4 3200 MHz
Video Card(s) ASUS Radeon RX 580 DirectX 12 DUAL-RX580-O8G 8GB 256-Bit GDDR5 HDCP Ready CrossFireX Support Video C
Storage WD 250 M.2, Corsair P500 M.2, OCZ Trion 500, WD Black 1TB, Assorted others.
Display(s) ASUS MG24UQ Gaming Monitor - 23.6" 4K UHD (3840x2160) , IPS, Adaptive Sync, DisplayWidget
Case Fractal Define R6 C
Audio Device(s) Realtek 5.1 Onboard
Power Supply Corsair RMX 850 Platinum PSU (Newegg Eggxpert)
Mouse Razer Death Adder
Keyboard Corsair K95 Mechanical & Corsair K65 Wired, Wireless, Bluetooth)
Software Windows 10 Pro x64
I tried that brandon, set it up on my life game box as Sean said and it still did not work.

@Asylum, yeah it has a backpate with foam spacers and like a plastic washer backing in the center of the backplate itself.
 
Joined
Jul 18, 2008
Messages
2,892 (0.61/day)
Location
South Carolina
System Name KILLER
Processor Intel Core i7 4790K
Motherboard MSI Z87 G45 Gaming
Cooling Water Cooling
Memory 2x8GB Gskill 2400mhz
Video Card(s) EVGA GTX 980
Storage SSD Samsung 500GB
Display(s) 24" Asus 144hz
Case Cooler Master HAF
Audio Device(s) X-Fi Platinum
Power Supply Antec 1200 Watt Modular
Software Windows 10 64 Bit
Benchmark Scores 3DMark Vantage 51342
I tried that brandon, set it up on my life game box as Sean said and it still did not work.

@Asylum, yeah it has a backpate with foam spacers and like a plastic washer backing in the center of the backplate itself.

I had the same problem when i set up this Classified.

The backplate was touching one of the pins sticking up out of the board and grounding it out.
My backplate had coating too but was doing it anyway.
 

brandonwh64

Addicted to Bacon and StarCrunches!!!
Joined
Sep 6, 2009
Messages
19,542 (4.49/day)
I tried that brandon, set it up on my life game box as Sean said and it still did not work.

@Asylum, yeah it has a backpate with foam spacers and like a plastic washer backing in the center of the backplate itself.

Have you tried a diffrent PSU or video card?
 

WarEagleAU

Bird of Prey
Joined
Jul 9, 2006
Messages
10,813 (1.96/day)
Location
Gurley, AL
System Name Pandemic 2020
Processor AMD Ryzen 5 "Gen 2" 2600X
Motherboard AsRock X470 Killer Promontory
Cooling CoolerMaster 240 RGB Master Cooler (Newegg Eggxpert)
Memory 32 GB Geil EVO Portenza DDR4 3200 MHz
Video Card(s) ASUS Radeon RX 580 DirectX 12 DUAL-RX580-O8G 8GB 256-Bit GDDR5 HDCP Ready CrossFireX Support Video C
Storage WD 250 M.2, Corsair P500 M.2, OCZ Trion 500, WD Black 1TB, Assorted others.
Display(s) ASUS MG24UQ Gaming Monitor - 23.6" 4K UHD (3840x2160) , IPS, Adaptive Sync, DisplayWidget
Case Fractal Define R6 C
Audio Device(s) Realtek 5.1 Onboard
Power Supply Corsair RMX 850 Platinum PSU (Newegg Eggxpert)
Mouse Razer Death Adder
Keyboard Corsair K95 Mechanical & Corsair K65 Wired, Wireless, Bluetooth)
Software Windows 10 Pro x64
ooer, that is a good idea Asylum. What do you recommend I use. Electrical tape? I never though of that, because if that is the problem, I am gonna go punch a tree on my land ha ha! Ill give that a go in the AM or afternoon when I get back from work. Also, keep posting guys. My PSU is top notch I know that, and I haven;t put the GPU back in at all.
 

sneekypeet

Retired Super Moderator
Joined
Apr 12, 2006
Messages
28,919 (5.17/day)
System Name His
Processor Intel i9 7920X
Motherboard Asus Prime X299 Deluxe
Cooling Corsair H115i RGB Platinum
Memory G.Skill TridentZ RGB 32GB @ 3600MHz
Video Card(s) nVidia RTX 2080ti
Storage Samsung 960 Pro / Crucial MX300 750GB / Seagate 1TB Spinner
Display(s) Samsung 55" 4K 60hz
Case Cooler Master Cosmos C700P (Inverted Layout)
Audio Device(s) Realtek on board > Sony Receiver > Cerwin Vega's
Power Supply Thermaltake TPSG 1050W
Mouse Always Changing
Keyboard Always Changing
Software Windows 10 Pro 64
do you have a stock cooler to try to eliminate any possible cooler issues?
 
Joined
Jul 18, 2008
Messages
2,892 (0.61/day)
Location
South Carolina
System Name KILLER
Processor Intel Core i7 4790K
Motherboard MSI Z87 G45 Gaming
Cooling Water Cooling
Memory 2x8GB Gskill 2400mhz
Video Card(s) EVGA GTX 980
Storage SSD Samsung 500GB
Display(s) 24" Asus 144hz
Case Cooler Master HAF
Audio Device(s) X-Fi Platinum
Power Supply Antec 1200 Watt Modular
Software Windows 10 64 Bit
Benchmark Scores 3DMark Vantage 51342
ooer, that is a good idea Asylum. What do you recommend I use. Electrical tape? I never though of that, because if that is the problem, I am gonna go punch a tree on my land ha ha! Ill give that a go in the AM or afternoon when I get back from work. Also, keep posting guys. My PSU is top notch I know that, and I haven;t put the GPU back in at all.

I just cut a couple of pieces of cardboard and put behind it then bolted it up.

Card board is alot thicker than tape. Just make sure the pins on the board dont come threw it.
 

WarEagleAU

Bird of Prey
Joined
Jul 9, 2006
Messages
10,813 (1.96/day)
Location
Gurley, AL
System Name Pandemic 2020
Processor AMD Ryzen 5 "Gen 2" 2600X
Motherboard AsRock X470 Killer Promontory
Cooling CoolerMaster 240 RGB Master Cooler (Newegg Eggxpert)
Memory 32 GB Geil EVO Portenza DDR4 3200 MHz
Video Card(s) ASUS Radeon RX 580 DirectX 12 DUAL-RX580-O8G 8GB 256-Bit GDDR5 HDCP Ready CrossFireX Support Video C
Storage WD 250 M.2, Corsair P500 M.2, OCZ Trion 500, WD Black 1TB, Assorted others.
Display(s) ASUS MG24UQ Gaming Monitor - 23.6" 4K UHD (3840x2160) , IPS, Adaptive Sync, DisplayWidget
Case Fractal Define R6 C
Audio Device(s) Realtek 5.1 Onboard
Power Supply Corsair RMX 850 Platinum PSU (Newegg Eggxpert)
Mouse Razer Death Adder
Keyboard Corsair K95 Mechanical & Corsair K65 Wired, Wireless, Bluetooth)
Software Windows 10 Pro x64
@Pete, I have one that I think came with an old proc of mine, or actually, I think it may have come with this 955. Ill give it a try when I get home from work.
 
Joined
Sep 20, 2009
Messages
716 (0.17/day)
Location
C:\Kitteh
Processor i7 2600K | Phenom II 840
Motherboard ASUS P8Z68 Deluxe | ASUS M4A88T-M
Cooling Corsair H60 | Scythe Samurai ZZ
Memory 4x4GB Samsung Green 1600 @ 1866 | 2x2GB Corsair XMS3 1333
Video Card(s) Evga GTX 670 FTW | On Board AMD
Storage 2 x 64GB Samsung 830, Velociraptor 300GB,1TB Black,1.5TB Black |10TB server
Display(s) HP 2509m 25" 1080p
Case Lian Li PC-V1020A | Lian Li PC-V354A
Audio Device(s) Azuntech Bravuria 7.1 | On-Board (Disabled)
Power Supply Seasonic X-series 760 , Seasonic X-series 760
Software Windows 7 Ultimate X64 | UnRaid (CentOS)
I am also thinking that something is grounding out on your board. (CPU Cooler Backplate)
 

WarEagleAU

Bird of Prey
Joined
Jul 9, 2006
Messages
10,813 (1.96/day)
Location
Gurley, AL
System Name Pandemic 2020
Processor AMD Ryzen 5 "Gen 2" 2600X
Motherboard AsRock X470 Killer Promontory
Cooling CoolerMaster 240 RGB Master Cooler (Newegg Eggxpert)
Memory 32 GB Geil EVO Portenza DDR4 3200 MHz
Video Card(s) ASUS Radeon RX 580 DirectX 12 DUAL-RX580-O8G 8GB 256-Bit GDDR5 HDCP Ready CrossFireX Support Video C
Storage WD 250 M.2, Corsair P500 M.2, OCZ Trion 500, WD Black 1TB, Assorted others.
Display(s) ASUS MG24UQ Gaming Monitor - 23.6" 4K UHD (3840x2160) , IPS, Adaptive Sync, DisplayWidget
Case Fractal Define R6 C
Audio Device(s) Realtek 5.1 Onboard
Power Supply Corsair RMX 850 Platinum PSU (Newegg Eggxpert)
Mouse Razer Death Adder
Keyboard Corsair K95 Mechanical & Corsair K65 Wired, Wireless, Bluetooth)
Software Windows 10 Pro x64
THanks guys you are the best, I just got home, gonna eat, unwind a minute (bad day at work) get on the comp and try and figure it out and then do my school work ha ha. B.S. Degree at 31, I must be crazy :D
 

Solaris17

Dainty Moderator
Staff member
Joined
Aug 16, 2005
Messages
22,364 (3.83/day)
Location
Florida
System Name Venslar
Processor I9 7980XE
Motherboard MSI x299 Tomahawk Arctic
Cooling EK Custom
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Nvidia Titan RTX
Storage 1x 250GB 960 EVO | 1x 500gb Intel 720p | 32TB SAN
Display(s) 3x AOC Q2577PWQ (2k IPS)
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Schiit Fulla 3 on Beyerdynamic DT 990 Pros
Power Supply Seasonic 1050W Snow
Mouse M55 RGB PRO (White)
Keyboard Ducky Shine 6 Snow White
VR HMD HTC VIVE
Software Windows 10 x64 Pro
just throwing this out their. idk if the mugen is a bolt through kit. but on a xilence i reviewed i freaked out. turns out i tightened it too much and it flexed the board alot. i loosened it up and everything worked fine after that :)
 
Joined
Jul 18, 2008
Messages
2,892 (0.61/day)
Location
South Carolina
System Name KILLER
Processor Intel Core i7 4790K
Motherboard MSI Z87 G45 Gaming
Cooling Water Cooling
Memory 2x8GB Gskill 2400mhz
Video Card(s) EVGA GTX 980
Storage SSD Samsung 500GB
Display(s) 24" Asus 144hz
Case Cooler Master HAF
Audio Device(s) X-Fi Platinum
Power Supply Antec 1200 Watt Modular
Software Windows 10 64 Bit
Benchmark Scores 3DMark Vantage 51342
Anything on this yet?
 

WarEagleAU

Bird of Prey
Joined
Jul 9, 2006
Messages
10,813 (1.96/day)
Location
Gurley, AL
System Name Pandemic 2020
Processor AMD Ryzen 5 "Gen 2" 2600X
Motherboard AsRock X470 Killer Promontory
Cooling CoolerMaster 240 RGB Master Cooler (Newegg Eggxpert)
Memory 32 GB Geil EVO Portenza DDR4 3200 MHz
Video Card(s) ASUS Radeon RX 580 DirectX 12 DUAL-RX580-O8G 8GB 256-Bit GDDR5 HDCP Ready CrossFireX Support Video C
Storage WD 250 M.2, Corsair P500 M.2, OCZ Trion 500, WD Black 1TB, Assorted others.
Display(s) ASUS MG24UQ Gaming Monitor - 23.6" 4K UHD (3840x2160) , IPS, Adaptive Sync, DisplayWidget
Case Fractal Define R6 C
Audio Device(s) Realtek 5.1 Onboard
Power Supply Corsair RMX 850 Platinum PSU (Newegg Eggxpert)
Mouse Razer Death Adder
Keyboard Corsair K95 Mechanical & Corsair K65 Wired, Wireless, Bluetooth)
Software Windows 10 Pro x64
OK I wanted to try it out again to double check. What you said Asylum and what Sneeky said try with the original HSF. turns out it was doing the same thing with the original HSF. So while it was plugged in and technically on, I picked the board up slightly off my Game of LIFE cardboard box and low and behold the shit was working. I put it back down and it stopped. so you were right Asylum (and later on Solaris, yes it has a bolt through kit, may need to do cardboard like Asylum said) it seems to be because of the backplates. Now that I know, I can breathe a sigh of relief, all my school stuff is on there. THANKS GUYS YOU KICK ASS!
 

Solaris17

Dainty Moderator
Staff member
Joined
Aug 16, 2005
Messages
22,364 (3.83/day)
Location
Florida
System Name Venslar
Processor I9 7980XE
Motherboard MSI x299 Tomahawk Arctic
Cooling EK Custom
Memory 32GB Corsair DDR4 3000mhz
Video Card(s) Nvidia Titan RTX
Storage 1x 250GB 960 EVO | 1x 500gb Intel 720p | 32TB SAN
Display(s) 3x AOC Q2577PWQ (2k IPS)
Case Inwin 303 White (Thermaltake Ring 120mm Purple accent)
Audio Device(s) Schiit Fulla 3 on Beyerdynamic DT 990 Pros
Power Supply Seasonic 1050W Snow
Mouse M55 RGB PRO (White)
Keyboard Ducky Shine 6 Snow White
VR HMD HTC VIVE
Software Windows 10 x64 Pro
cool beans bro. just a pro tip. they sell extended risers so you dont short on the case :toast:
 
Joined
Jul 18, 2008
Messages
2,892 (0.61/day)
Location
South Carolina
System Name KILLER
Processor Intel Core i7 4790K
Motherboard MSI Z87 G45 Gaming
Cooling Water Cooling
Memory 2x8GB Gskill 2400mhz
Video Card(s) EVGA GTX 980
Storage SSD Samsung 500GB
Display(s) 24" Asus 144hz
Case Cooler Master HAF
Audio Device(s) X-Fi Platinum
Power Supply Antec 1200 Watt Modular
Software Windows 10 64 Bit
Benchmark Scores 3DMark Vantage 51342
OK I wanted to try it out again to double check. What you said Asylum and what Sneeky said try with the original HSF. turns out it was doing the same thing with the original HSF. So while it was plugged in and technically on, I picked the board up slightly off my Game of LIFE cardboard box and low and behold the shit was working. I put it back down and it stopped. so you were right Asylum (and later on Solaris, yes it has a bolt through kit, may need to do cardboard like Asylum said) it seems to be because of the backplates. Now that I know, I can breathe a sigh of relief, all my school stuff is on there. THANKS GUYS YOU KICK ASS!

Glad to hear you got it sorted. :toast:
 

WarEagleAU

Bird of Prey
Joined
Jul 9, 2006
Messages
10,813 (1.96/day)
Location
Gurley, AL
System Name Pandemic 2020
Processor AMD Ryzen 5 "Gen 2" 2600X
Motherboard AsRock X470 Killer Promontory
Cooling CoolerMaster 240 RGB Master Cooler (Newegg Eggxpert)
Memory 32 GB Geil EVO Portenza DDR4 3200 MHz
Video Card(s) ASUS Radeon RX 580 DirectX 12 DUAL-RX580-O8G 8GB 256-Bit GDDR5 HDCP Ready CrossFireX Support Video C
Storage WD 250 M.2, Corsair P500 M.2, OCZ Trion 500, WD Black 1TB, Assorted others.
Display(s) ASUS MG24UQ Gaming Monitor - 23.6" 4K UHD (3840x2160) , IPS, Adaptive Sync, DisplayWidget
Case Fractal Define R6 C
Audio Device(s) Realtek 5.1 Onboard
Power Supply Corsair RMX 850 Platinum PSU (Newegg Eggxpert)
Mouse Razer Death Adder
Keyboard Corsair K95 Mechanical & Corsair K65 Wired, Wireless, Bluetooth)
Software Windows 10 Pro x64
Thanks Solaris, I may check that out, though the risers never gave me a problem. Oh and I am now on my system and no more on the wifes lappy. Sweet Sweet deal guys. Thanks again!
 

r9

Joined
Jul 28, 2008
Messages
2,876 (0.60/day)
System Name PC1| PC2|Poweredge r410
Processor i7 9700k| Ryzen 1600| 2 x E5620 @2.4GHz
Memory 16GB DDR4 |16GB DDR4 | 32GB ECC DDR3
Video Card(s) GTX 1070|2 x RX570 |On-Board
Storage 512GB SSD+1TB SSD|512GB SSD+1TB|2x256GBSSD 2x2TBGB
Display(s) 50" 4k TV | 27" + 2 x 24" LCD Setup
Software Windows 10 |Windows 10| Server 2012 r2
I`v had couple of coolers that mount with backplate and all were isolated at one side meant which was meant to make contact with the motherboard. So this is strange to say at least.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
31,191 (6.06/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I tried that brandon, set it up on my life game box as Sean said and it still did not work.

@Asylum, yeah it has a back-pate with foam spacers and like a plastic washer backing in the center of the back-plate itself.

Take the machine out of the case and run the board on a box (non conductive surface) with the necessities, if it powers up, you have an issue where the board is making contact with the rest of the case. Trust me an I.O. plate, the P.C.I. card bracket, a solder joint, even the C.P.U. cooling bracket can cause grounding issues between the board and the case. One thing I may suggest as well is to re-seat your C.P.U. cooler. Just because the power supply runs up without the motherboard in the chain doesn't mean it is not bad, I've had one where I did the same thing and it would not power up with the motherboard. I swapped the power-supply and the motherboard powered up. I tried that possible bad P.S.U. on another machine that was working and it would not power up. Also if all of your school stuff is on there you should do backups to CD/DVD and a U.S.B. thumb drive, external hard drive, or network storage device.
 

WarEagleAU

Bird of Prey
Joined
Jul 9, 2006
Messages
10,813 (1.96/day)
Location
Gurley, AL
System Name Pandemic 2020
Processor AMD Ryzen 5 "Gen 2" 2600X
Motherboard AsRock X470 Killer Promontory
Cooling CoolerMaster 240 RGB Master Cooler (Newegg Eggxpert)
Memory 32 GB Geil EVO Portenza DDR4 3200 MHz
Video Card(s) ASUS Radeon RX 580 DirectX 12 DUAL-RX580-O8G 8GB 256-Bit GDDR5 HDCP Ready CrossFireX Support Video C
Storage WD 250 M.2, Corsair P500 M.2, OCZ Trion 500, WD Black 1TB, Assorted others.
Display(s) ASUS MG24UQ Gaming Monitor - 23.6" 4K UHD (3840x2160) , IPS, Adaptive Sync, DisplayWidget
Case Fractal Define R6 C
Audio Device(s) Realtek 5.1 Onboard
Power Supply Corsair RMX 850 Platinum PSU (Newegg Eggxpert)
Mouse Razer Death Adder
Keyboard Corsair K95 Mechanical & Corsair K65 Wired, Wireless, Bluetooth)
Software Windows 10 Pro x64
Already fixed aidairaman1. Turns out the backplate of the cooler (both stock and Mugen 2) were causing a small short. Fixed it.
 
Top