• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

One setting that makes antialiasing look much more like it's supposed to on nvidia Maxwell and above chips

Mussels

Freshwater Moderator
Staff member
Joined
Oct 6, 2004
Messages
53,483 (8.31/day)
Location
Oystralia
System Name Rainbow Sparkles
Processor Ryzen R7 5800X (PBO tweaked, 4.4-5.05GHz)
Motherboard Asus x570 Gaming-F
Cooling EK Quantum Velocity AM4 + EK Quantum ARGB 3090 w/ active backplate. Dual rad.
Memory 2x32GB DDR4 3600 Corsair Vengeance RGB @3800 C18-22-22-22-42 TRFC704 (1.4V, SoC 1.15V Hynix MJR)
Video Card(s) Galax RTX 3090 SG 24GB: Often underclocked to 1500Mhz 0.737v
Storage 2TB WD SN850 NVME + 1TB Sasmsung 970 Pro NVME + WD AN1500 1TB + 1TB Intel 6000P NVME USB 3.2
Display(s) Gigabyte G32QC (4k80Hz, 1440p 165Hz) + Phillips 328m6fjrmb (4K 60Hz, 1440p 144Hz)
Case Fractal Design R6
Audio Device(s) Logitech G560 |Razer Leviathan | Corsair Void pro RGB |Blue Yeti mic
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G Pro wireless + Steelseries Prisma XL
Keyboard Razer Huntsman TE (custom white and steel keycaps)
VR HMD Oculus Rift S
Software Windows 11 pro x64 (Yes, it's genuinely a good OS)
Benchmark Scores I don't quite know how i managed to get such a top tier PC, I am not rich.
Okay, samsungs manual lists the max resolution as being different. Product pages for it show that you're correct.
Yay for old devices have incorrect information.

They also list it has DVI and HDMI - have you tried both seperately, with no adaptors?


And you shouldnt make any adjustments outside of colour and brightness within the displays settings for a digital connection, or something is really wrong with the signal sent, or the monitor itself
 
Joined
May 20, 2020
Messages
493 (0.68/day)
Interesting. Well this monitor has only VGA and DVI input and I do not use any adaptors of any kind, I even changed the DVI cable from factory one to another, that has an UL mark on it, so it has to be good? :)
Anyhow I have never had much changed on this monitor:
- Brightness to 27 (factory 100 is much too bright)
- Contrast left at 75 (factory)
- Gamma left at factory mode_1
- Auto Source changed to manual because I do not want the monitor to change to active signal just because it's active
- OSD Position H-position: to 80, V-position: to 20, Transparency: ON
That's all. I mean the magic stuff - bright and other go to custom when changing brightness to other than factory and dynamic contrast is off by default, so not really much to change and it becomes usable.
 
Joined
May 20, 2020
Messages
493 (0.68/day)
Turns out that there is not one wonderous setting that would make things look right, but more like 17-25, depending on your Windows version.

For good AA+AF quality on newer GeForce cards with really all games you have to give the card a baseline (of color settings) which the driver doesn't do anymore upon installation (a real mess).

This can still all be done via nv_control_panel in a curious way:

1.) After driver installation go to "Adjust video color settings" (trust me it ain't just video, it affects 3D too),

2.) then choose "with the NVIDIA settings",

3.) then again choose the factory setting "With the video player settings",

4.) click "Apply".

This seemingly silly process makes nv_CP throw from 25 (WinXP) to 17 (Win7 and Win10) baseline color settings into Windows Registry under HKLM/System/CurrentControlSet/Video/{code of current video card/driver}.

Then you can configure AF (8x/16x) and AA (4/8xMS+4/8xTSS) via nv_CP or in-game. It shall look good. :)

You can get that code by looking under HKLM/Hardware/DeviceMap/Video usually the first one after "TSDDD" is the current graphics card's code (Video0).

This has now all been cleared up - picture on all monitors now is good again, there are still variations due to monitor properties, but no more due to graphics card being improperly set up.
I would also like to rename this topic if I can to:

"Settings that make antialiasing look like it's supposed to on nvidia Fermi, Kepler, Maxwell and above chips".​

 
Joined
Apr 30, 2020
Messages
366 (0.49/day)
System Name New One
Processor Ryzen 5 5600X
Motherboard MSI MGP Gaming WIFI
Cooling Stock
Memory Corsair Vengeance pro RGB 3200mhz 16Gbs
Video Card(s) EVGA 2080 Ti FTW 3
Storage Western digital Sata SDD 500gb
Display(s) HP X24i
Case Corsair 4000D Airflow
Power Supply Corsair 650M
Mouse Lifeworks gaming mouse lol
Keyboard lifeworks monster rgb light keyboard
Turns out that there is not one wonderous setting that would make things look right, but more like 17-25, depending on your Windows version.

For good AA+AF quality on newer GeForce cards with really all games you have to give the card a baseline (of color settings) which the driver doesn't do anymore upon installation (a real mess).

This can still all be done via nv_control_panel in a curious way:

1.) After driver installation go to "Adjust video color settings" (trust me it ain't just video, it affects 3D too),

2.) then choose "with the NVIDIA settings",

3.) then again choose the factory setting "With the video player settings",

4.) click "Apply".

This seemingly silly process makes nv_CP throw from 25 (WinXP) to 17 (Win7 and Win10) baseline color settings into Windows Registry under HKLM/System/CurrentControlSet/Video/{code of current video card/driver}.

Then you can configure AF (8x/16x) and AA (4/8xMS+4/8xTSS) via nv_CP or in-game. It shall look good. :)

You can get that code by looking under HKLM/Hardware/DeviceMap/Video usually the first one after "TSDDD" is the current graphics card's code (Video0).

This has now all been cleared up - picture on all monitors now is good again, there are still variations due to monitor properties, but no more due to graphics card being improperly set up.
I would also like to rename this topic if I can to:

"Settings that make antialiasing look like it's supposed to on nvidia Fermi, Kepler, Maxwell and above chips".​


you know I thought there might have been a real problem with this refurbished card I got cause the colors kept going darker than normal. I noticed it by the task bar being oddlyy Black and you could see it doing it, while it usually happened while idling with. Alot of times when I was reading something. Then I did this trick and stopped completely. o_O! Now my colors a brighter too.
 
Joined
May 20, 2020
Messages
493 (0.68/day)
One additional step would be to click "Restore Defaults" and "Apply" under "Manage 3D Settings" before setting any AF and AA.
That ensures all nVidia profiles are at their factory values and also adds one misterious setting (0x20xxxxxx code) under the main profile.
Funny thing is that when drivers are not set via nv control panel (but with nvprofileinspector) image quality is lower, so best to stick to factory profiles and make all changes through nv control panel.
 
Joined
May 20, 2020
Messages
493 (0.68/day)
And most of all - do not install a monitor driver (with color management profile).
Leave it at "Plug and Play monitor" (windows default); nvidia driver produces its best picture this way. Helps greatly with anti-aliasing, @mtcn77.
 
Joined
May 20, 2020
Messages
493 (0.68/day)
I have found a monitor color profile that produces more smooth images than sRGB (for nv cards), DonRGB4 (4K), on this page.

With that I have to add - if you do not install monitor driver (windows uses Plug and play monitor), you do not need to restore any defaults, or add any settings to registry, picture is smoothest that way (without any monitor color profile).
 
Last edited:
Top