• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Pagefile confusion. Windows 10.

Joined
May 18, 2009
Messages
1,166 (0.30/day)
Location
MN
System Name Personal / HTPC
Processor i5-4670k @ 4.4 / i5-4460
Motherboard ASUS z97-AR /ASRock Z87 Extreme4
Cooling Corsair H100i / stock HSF
Memory 16GB DDR3 1600 / 8GB DDR3 1600
Video Card(s) Zotac GTX 980Ti AMP! Omega / Zotac GTX 980Ti AMP! Omega
Storage 250 GB Crucial SSD MX200, 1TB & 500GB Western Digital / 2x 4TB WD Red
Display(s) 3x 24" Asus Ve248H LED (5760x1080) / 50" LCD TV
Case CoolerMaster XB Evo / CM HAF XB Evo
Power Supply 850W SeaSonic X Series / 750W SeaSonic X Series
Mouse Logitech G502
Keyboard Microsoft Natural Elite Keyboard
Software Windows 7 Home 64 / Windows 10 Home 64
I have had a few instances where if there was no page file set games would cause low memory issues; which in turn would cause the game to run sluggishly.

Last game I came into this issue was Shadow of Mordor. GTX 980Ti, 16GB RAM and I ran the game across 5760x1080. I could play the game for 10 minutes some days or hours on other days before the low memory issue struck. Sure, the game was utilizing all 6GB of VRAM, but only making use of 3-4GB of RAM.

Dinking around with settings in the game and so forth I found no solution. I eventually figured I'd check the pagefile - it was turned off. I turned it on and set it 4096MB. After that, no low memory issue with the game. I don't know why it was off for me since I never touched it before. Perhaps Windows 7 thought it was ideal to turn it off because I had just done a clean install of Windows on the new SSD I just installed.

So, in my opinion, I wouldn't recommend anyone to turning it off.
 

TheMailMan78

Big Member
Joined
Jun 3, 2007
Messages
22,599 (4.89/day)
Location
'Merica. The Great SOUTH!
System Name TheMailbox 5.0 / The Mailbox 4.5
Processor RYZEN 1700X / Intel i7 2600k @ 4.2GHz
Motherboard Fatal1ty X370 Gaming K4 / Gigabyte Z77X-UP5 TH Intel LGA 1155
Cooling MasterLiquid PRO 280 / Scythe Katana 4
Memory ADATA RGB 16GB DDR4 2666 16-16-16-39 / G.SKILL Sniper Series 16GB DDR3 1866: 9-9-9-24
Video Card(s) MSI 1080 "Duke" with 8Gb of RAM. Boost Clock 1847 MHz / ASUS 780ti
Storage 256Gb M4 SSD / 128Gb Agelity 4 SSD , 500Gb WD (7200)
Display(s) LG 29" Class 21:9 UltraWide® IPS LED Monitor 2560 x 1080 / Dell 27"
Case Cooler Master MASTERBOX 5t / Cooler Master 922 HAF
Audio Device(s) Realtek ALC1220 Audio Codec / SupremeFX X-Fi with Bose Companion 2 speakers.
Power Supply Seasonic FOCUS Plus Series SSR-750PX 750W Platinum / SeaSonic X Series X650 Gold
Mouse SteelSeries Sensei (RAW) / Logitech G5
Keyboard Razer BlackWidow / Logitech (Unknown)
Software Windows 10 Pro (64-bit)
Benchmark Scores Benching is for bitches.
Am I the only one on this forum that just installs windows, lets it update and installs the basic drivers like Nvidia and then just uses the system normally for years? WTH does everyone seem to "fix" so much that isn't broken?
 
Joined
Feb 8, 2012
Messages
2,934 (1.01/day)
Location
Zagreb, Croatia
System Name Windows 7 64-bit Core i5 3570K
Processor Intel Core i5 3570K @ 4.2 GHz, 1.26 V
Motherboard Gigabyte GA-Z77MX-D3H
Cooling Scythe Katana 4
Memory 4 x 4 GB G-Skill Sniper DDR3 @ 1600 MHz
Video Card(s) Gainward NVIDIA GeForce GTX 970 Phantom
Storage Western Digital Caviar Blue 1 TB, Seagate Baracuda 1 TB
Display(s) Dell P2414H
Case CoolerMaster Silencio 550
Audio Device(s) VIA HD Audio
Power Supply Corsair TX v2 650W
Mouse Steelseries Sensei
Keyboard CM Storm Quickfire Pro, Cherry MX Reds
Software MS Windows 7 Enterprise 64-bit SP1
Joined
Apr 21, 2010
Messages
5,731 (1.61/day)
Location
West Midlands. UK.
System Name Ryzen Reynolds
Processor Ryzen 1600 - 4.0Ghz 1.415v - SMT disabled
Motherboard mATX Asrock AB350m AM4
Cooling Raijintek Leto Pro
Memory Vulcan T-Force 16GB DDR4 3000 16.18.18 @3200Mhz 14.17.17
Video Card(s) Sapphire Nitro+ 4GB RX 580 - 1450/2000 BIOS mod 8-)
Storage Seagate B'cuda 1TB/Sandisk 128GB SSD
Display(s) Acer ED242QR 75hz Freesync
Case Corsair Carbide Series SPEC-01
Audio Device(s) Onboard
Power Supply Corsair VS 550w
Mouse Zalman ZM-M401R
Keyboard Razor Lycosa
Software Windows 10 x64
Benchmark Scores https://www.3dmark.com/spy/6220813
The page file setting is literally in the exact same place in Windows 7 and 10, accessed the same way through Control Panel -> System -> Advanced System Settings

It takes me about 5 minutes to get a fresh install of Windows 10 to the way I like it and almost running the same as Windows 7.
Yea it was me being an idiot, I thought they replaced control panel with settings which does most of what control panel does though you cannot change pagefile from settings anywhere, also sure there used to be a link to cp with win+X though it's not the only way I could find control panel was to type it into start, needless to say I've pinned it to the task bar now :laugh:
 
Joined
Jul 25, 2006
Messages
6,414 (1.30/day)
Location
Nebraska, USA
System Name Brightworks Systems BWS-6 E-IV
Processor Intel Core i5-6600 @ 3.9GHz
Motherboard Gigabyte GA-Z170-HD3 Rev 1.0
Cooling Quality case, 2 x Fractal Design 140mm fans, stock CPU HSF
Memory 16GB (2 x 8GB) DDR4 3000 Corsair Vengeance
Video Card(s) EVGA GEForce GTX 1050Ti 4Gb GDDR5
Storage Samsung 850 Pro 256GB SSD, Samsung 860 Evo 500GB SSD
Display(s) Samsung S24E650BW LED x 2
Case Fractal Design Define R4
Power Supply EVGA Supernova 550W G2 Gold
Mouse Microsoft Wireless 5000
Keyboard Microsoft Wireless Comfort 5050
Software W10 Pro 64-bit
I thought they replaced control panel with settings
They did, more or less. At least they are working their way towards getting rid of the CP completely. But it is still there. I created a shortcut to it and put it in my Quicklaunch tool bar - another well liked, but hidden feature from days past.

BTW, you can easily get to the Control Panel from within Settings by typing Control Panel in the Find a setting text box.
Am I the only one on this forum that just installs windows, lets it update and installs the basic drivers like Nvidia and then just uses the system normally for years?
No you are not. And actually, that is how most users do it because the default settings work.
 
Joined
Jan 17, 2010
Messages
11,324 (3.09/day)
Location
Oregon
System Name Delta // Alpha-HTPC
Processor Intel i7 6700K // Intel i5 4570
Motherboard GIGABYTE Z270X-Gaming K7 // Gigabyte H97M -D3H
Cooling Corsair H80i V2 // Silverstone NT-06 Pro
Memory Corsair DDR4 3000 32gb //G.SKILL Ripjaws X Series 8GB 1600
Video Card(s) EVGA RTX 2080// EVGA GTX 980 ti
Storage Samsung 950 Pro NVMe 512, 2 Tb FireCuda// Samsung 1Tb SSD
Display(s) ASUS PB278Q 27" 1440X 2560 // 55" LG 4K SK8000 Series
Case Corsair Obsidian Series 550D // Silverstone Granada GD05
Audio Device(s) Focusrite Scarlett // HDMI to Samsung HW-R650 sound bar
Power Supply Corsair TX850M // SeaSonic G Series 550w
Mouse Logitech G502
Keyboard Cooler Master CK550 RBG
Software Windows 10 Pro // Windows 10 Pro
That's the one thing I love about 10. Install it and forget it. Just works
 
Joined
Nov 4, 2005
Messages
10,479 (2.02/day)
System Name MoFo 2
Processor AMD PhenomII 1100T @ 4.2Ghz
Motherboard Asus Crosshair IV
Cooling Swiftec 655 pump, Apogee GT,, MCR360mm Rad, 1/2 loop.
Memory 8GB DDR3-2133 @ 1900 8.9.9.24 1T
Video Card(s) HD7970 1250/1750
Storage Agility 3 SSD 6TB RAID 0 on RAID Card
Display(s) 46" 1080P Toshiba LCD
Case Rosewill R6A34-BK modded (thanks to MKmods)
Audio Device(s) ATI HDMI
Power Supply 750W PC Power & Cooling modded (thanks to MKmods)
Software A lot.
Benchmark Scores Its fast. Enough.
Am I the only one on this forum that just installs windows, lets it update and installs the basic drivers like Nvidia and then just uses the system normally for years? WTH does everyone seem to "fix" so much that isn't broken?

I install windows, update, new drivers, disable a few services that I don't need, manually set pagefile to 2-3X RAM, and unless something major happens, I let windows do its thing.
 
Top