• We've upgraded our forums. Please post any issues/requests in this thread.

PC Game Stuttering, Input Lag and YOU!!!! <---

Joined
Apr 21, 2005
Messages
6,885 (1.49/day)
Likes
1,501
System Name MY PC
Processor E8400 @ 3.80Ghz > Q9650 3.60Ghz
Motherboard Maximus Formula
Cooling D5, 7/16" ID Tubing, Maze4 with Fuzion CPU WB
Memory XMS 8500C5D @ 1066MHz
Video Card(s) HD 2900 XT 858/900 to 4870 to 5870 (Keep Vreg area clean)
Storage 2
Display(s) 24"
Case P180
Audio Device(s) X-fi Plantinum
Power Supply Silencer 750
Software XP Pro SP3 to Windows 7
Benchmark Scores This varies from one driver to another.
#1
I've found that from time to time I noticed some intermittent stuttering that would rear it's ugly head during specific aspects of game play. Most notably during times were replays and cinematic animated cut scenes were played. The actual game play didn't exhibit this behavior and played fine.

Upon researching a fix for steering wheel input lag when playing PC racing games; which are not found on the console. I stumbled upon a suggestion that if you disable flip queue (pre-rendered frames) it would help improve input response. From my understand Radeons are set to a pre-rendered frame of 3. Sure enough it worked but I also noticed that replays were smoother then before and to me, looked different then before. So after some further testing in other games I begin to notice a trend. This fix works! :toast:

In order to disable this you have to download Ati Tray Tools (unless there are other programs/tweaks out there). Install ATT and go to 3D and Flip Queue Size. Change it from Undefined to 0. The screen may flicker for a moment and return to normal. With ATT minimized in the lower right corner of your screen try a game and see if stutter decreases.

One thing I have noticed is that depending on the game you may get a slight decrease in frame rates. Furthermore, as with any tweak like this, it may or may not be compatible with your PC/OS/Games/ETC. What works for me just fine may/may not work for you.

From the few games I've tried so far I have noticed no stutter at all during cut scenes, replays, etc. And the input response time is much better now.
 
Last edited:
Joined
Apr 21, 2005
Messages
6,885 (1.49/day)
Likes
1,501
System Name MY PC
Processor E8400 @ 3.80Ghz > Q9650 3.60Ghz
Motherboard Maximus Formula
Cooling D5, 7/16" ID Tubing, Maze4 with Fuzion CPU WB
Memory XMS 8500C5D @ 1066MHz
Video Card(s) HD 2900 XT 858/900 to 4870 to 5870 (Keep Vreg area clean)
Storage 2
Display(s) 24"
Case P180
Audio Device(s) X-fi Plantinum
Power Supply Silencer 750
Software XP Pro SP3 to Windows 7
Benchmark Scores This varies from one driver to another.
#2
Update!!!!<---

I have found that you can leave flip queue size (pre-rendered frames) at it's default. If the Transaction Booster is relaxed a little (IE using a higher value or it's default value for that ram) then I still notice an overall improvement during cut scenes, etc. I am not totally convienced that input lag has been reduced on the same level as setting pre-rendered frames ahead is set to 0. But there is some noticeable smoothest.

It appears that although I can lower the performance level of my ram (which can provide a slight performance benefit in some memory intensive benchmarks) it maybe attributing to some odd stuttering. I thought that it was flip queue size that was the problem. However, this may not be the case.

I used Memset to determine the performance level (aka Transaction Booster) of my ram.
 
Last edited:

Baam

New Member
Joined
Aug 14, 2008
Messages
93 (0.03/day)
Likes
18
Location
Trucker..so all over
Processor AMD FX-8120@4.5Ghz
Motherboard ASUS Sabertooth 990FX
Cooling Thermalright Venomous X Black
Memory G.SKILL Ripjaws X Series 8GB
Video Card(s) ATI 5850 crossfire
Case COOLER MASTER HAF 912
Audio Device(s) Creative X-Fi
Power Supply Antec TPQ-850
Software Windows 7 Ultimate 64 bit
#3
I tried this and with it set to 0 None of my games will even start, so i set it back to undefined. This is with Windows 7, so maybe it just don't work right with windows 7.
 
Joined
Apr 21, 2005
Messages
6,885 (1.49/day)
Likes
1,501
System Name MY PC
Processor E8400 @ 3.80Ghz > Q9650 3.60Ghz
Motherboard Maximus Formula
Cooling D5, 7/16" ID Tubing, Maze4 with Fuzion CPU WB
Memory XMS 8500C5D @ 1066MHz
Video Card(s) HD 2900 XT 858/900 to 4870 to 5870 (Keep Vreg area clean)
Storage 2
Display(s) 24"
Case P180
Audio Device(s) X-fi Plantinum
Power Supply Silencer 750
Software XP Pro SP3 to Windows 7
Benchmark Scores This varies from one driver to another.
#4
Interesting, I found this wiki about it. They call it output lag:
PC Videocard related causes of output lag that manifest themselves in 3d applications may be the following: prerender frame buffer (also known as "max frames to render ahead" or "flip queue size" setting) reducing the value of this setting to zero may eliminate any videocard related output lag though framerate, in most cases, shall decrease i.e. a system capable of 11000 marks in 3dmark06 will manage only around 9000.

I tried this and with it set to 0 None of my games will even start, so i set it back to undefined. This is with Windows 7, so maybe it just don't work right with windows 7.
Yeah, that's why I wanted to make sure I posted that this may not work on other OS, etc in the OP :toast:.

So far here's the deal:
-The offical cat drivers for win7 start with Cat 9.3. Baam may want to try this again. Although there is no guarantee this will still work
-When you reduce flip queue size to 0 there is a reduction in frame rates but input response should be improved in FPS games and motorsport games (for example)
-This may or may not work for everyone depending on OS, PC setup, etc used so caution is expected
-Relaxing the PL of your ram may smooth out game play but may/may not have any tangible effect on input lag
-There are a few topics regarding this issue when googling

Edit:
Read this thread. It IMO seem to explain why rendering frames ahead causes input lag.
 
Last edited: