• We've upgraded our forums. Please post any issues/requests in this thread.

Phone flash memory failing?

Status
Not open for further replies.
Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#1
Hi everyone,

This is regarding my ASUS ZenFone 2 ZE551ML (1.8 GHz CPU, 4 GB RAM, 16 GB ROM). A few days ago, after 1 year and 11 months of excellent service, suddenly I saw that some of the apps (Play Music, ASUS MiniMovie) were corrupted. But a simple uninstall and reinstall fixed them. Later that day, I was about to open settings when a message popped up "Unfortunately, settings has stopped". Rebooting the phone did not fix it and I was totally stuck as I was unable to clear the data also for the settings app which also requires "Settings" to function. I managed to do a factory reset after which, I could not even get to the home screen because that involves the Settings app as well.


I went on to proceed with factory reset from the recovery mode and to my shock, the recovery mode was also corrupted. Screen just froze with a USB logo. I tried to flash the recovery with xFSTK but got write error.
Then I took apart the device and cooled the flash memory (SK hynix manufactured) with some IPA.
The device booted up and was able to get to the home screen. Then I followed the ASUS standard downgrade procedure to downgrade the device from Marshmallow to Lollipop (which should force flashing of the recovery as well and everything). Phone was stable then. Then following ASUS standard upgrade procedure, I upgraded to Marshmallow and did a factory reset again. Set up everything and phone is rock stable now, performs good as new with no slow downs or anything.

My question is "What exactly happened?" It was never rooted and very well taken care of (even looks like new). Is the flash memory failing? Can the firmware get corrupted on its own?
Any answers would be appreciated. Thanks.
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
19,188 (5.03/day)
Likes
4,795
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#2
Hi everyone,

This is regarding my ASUS ZenFone 2 ZE551ML (1.8 GHz CPU, 4 GB RAM, 16 GB ROM). A few days ago, after 1 year and 11 months of excellent service, suddenly I saw that some of the apps (Play Music, ASUS MiniMovie) were corrupted. But a simple uninstall and reinstall fixed them. Later that day, I was about to open settings when a message popped up "Unfortunately, settings has stopped". Rebooting the phone did not fix it and I was totally stuck as I was unable to clear the data also for the settings app which also requires "Settings" to function. I managed to do a factory reset after which, I could not even get to the home screen because that involves the Settings app as well.


I went on to proceed with factory reset from the recovery mode and to my shock, the recovery mode was also corrupted. Screen just froze with a USB logo. I tried to flash the recovery with xFSTK but got write error.
Then I took apart the device and cooled the flash memory (SK hynix manufactured) with some IPA.
The device booted up and was able to get to the home screen. Then I followed the ASUS standard downgrade procedure to downgrade the device from Marshmallow to Lollipop (which should force flashing of the recovery as well and everything). Phone was stable then. Then following ASUS standard upgrade procedure, I upgraded to Marshmallow and did a factory reset again. Set up everything and phone is rock stable now, performs good as new with no slow downs or anything.

My question is "What exactly happened?" It was never rooted and very well taken care of (even looks like new). Is the flash memory failing? Can the firmware get corrupted on its own?
Any answers would be appreciated. Thanks.
you must of had an app on there that goofed it up.

My phone had a bootloop issue despite the battery being good, i had to buy a tool just to fix the phone.
 
Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#3
you must of had an app on there that goofed it up.

My phone had a bootloop issue despite the battery being good, i had to buy a tool just to fix the phone.
But my phone was not rooted. Can an app access internal system files if it is not given root access? To my knowledge, it should not happen. And even recovery was corrupted.
Edit: Even a factory reset could not fix it. Things got worse then with the keyboard app corrupted as well.
 
Last edited:

P4-630

The Way It's Meant to be Played
Joined
Jan 5, 2006
Messages
9,173 (2.10/day)
Likes
8,932
Location
Vinewood
System Name Sansaya / Sansaya Laptop
Processor Intel i5 6500 / Intel i3 7100U
Motherboard Asus Z170 Pro Gaming / HP 83A3 (U3E1)
Cooling Cooler Master Hyper 212 Evo + Thermal Grizzly Kryonaut + Scythe 1200rpm + 4 case fans / Fan
Memory 16GB DDR4 Corsair Vengeance LPX 3000MHz CL15 / 6GB DDR4 Samsung 2400MHz CL15
Video Card(s) MSI GTX1070 Gaming X 8GB / Intel HD620
Storage Samsung 850 Pro 512GB + Hitachi 2.5" 7200rpm 750GB / Samsung 256GB M.2 SSD
Display(s) 23.8" Dell S2417DG 165Hz G-Sync 1440p + 21.5" LG 22MP67VQ IPS 60Hz 1080p / 14" 1080p IPS Glossy
Case Be quiet! Silent Base 600 - Window / HP Pavilion
Audio Device(s) SupremeFX Onboard / Realtek onboard + B&O speaker system
Power Supply Be quiet! Straight Power 10 500 Watt CM / Powerbrick
Mouse Logitech MX Anywhere 2 Laser wireless / Logitech Nano Laser wireless
Keyboard RAPOO E9270P Black 5GHz wireless / HP backlit
Software Windows 8.1 x64 / Windows 10
Benchmark Scores Superposition 14106 (1080p medium) Fire Strike 21169 graphics score. Valley 8xAA 4218
#4
Warranty?
 
Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#5
It is not in warranty anymore. It had a 1 year warranty and I did not extend it. The phone will be exactly 2 years old near the end of December this year. It is working fine now. I just wonder what happened!
 
Joined
Oct 17, 2012
Messages
6,821 (3.63/day)
Likes
8,959
Location
Massachusetts
Processor i7 4790
Motherboard Asrock Z97 Extreme 4
Cooling Corsair H-110i GTX
Memory 16 Gb kingston Hyper X
Video Card(s) Nvidia Reference GTX 970 x2
Storage C:\Samsung 850EVO 500Gb & Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Phanteks Enthoo Pro M Acrylic
Audio Device(s) Realtech Edition X1789,Ver2.78
Power Supply EVGA 220-G2-0650-Y1
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
#6
Something very similar to this happened with my wife's phone. It started out small like what you're experiencing, until one day It was stuck in the boot menu and would not get out of it. no factory refresh or anything else would fix it ...system memory corrupted= rip
 
Joined
Mar 26, 2010
Messages
7,642 (2.71/day)
Likes
1,984
Location
Jakarta, Indonesia
System Name micropage7
Processor Intel G4400
Motherboard MSI B150M Bazooka D3
Cooling Stock ( Lapped )
Memory 16 Gb Team Xtreem DDR3
Video Card(s) Nvidia GTX460
Storage Seagate 1 TB, 5oo Gb and SSD A-Data 128 Gb
Display(s) LG 19 inch LCD Wide Screen
Case HP dx6120 MT
Audio Device(s) Stock
Power Supply Be Quiet 600 Watt
Software Windows 7 64-bit
Benchmark Scores Classified
#7
Hi everyone,

This is regarding my ASUS ZenFone 2 ZE551ML (1.8 GHz CPU, 4 GB RAM, 16 GB ROM). A few days ago, after 1 year and 11 months of excellent service, suddenly I saw that some of the apps (Play Music, ASUS MiniMovie) were corrupted. But a simple uninstall and reinstall fixed them. Later that day, I was about to open settings when a message popped up "Unfortunately, settings has stopped". Rebooting the phone did not fix it and I was totally stuck as I was unable to clear the data also for the settings app which also requires "Settings" to function. I managed to do a factory reset after which, I could not even get to the home screen because that involves the Settings app as well.


I went on to proceed with factory reset from the recovery mode and to my shock, the recovery mode was also corrupted. Screen just froze with a USB logo. I tried to flash the recovery with xFSTK but got write error.
Then I took apart the device and cooled the flash memory (SK hynix manufactured) with some IPA.
The device booted up and was able to get to the home screen. Then I followed the ASUS standard downgrade procedure to downgrade the device from Marshmallow to Lollipop (which should force flashing of the recovery as well and everything). Phone was stable then. Then following ASUS standard upgrade procedure, I upgraded to Marshmallow and did a factory reset again. Set up everything and phone is rock stable now, performs good as new with no slow downs or anything.

My question is "What exactly happened?" It was never rooted and very well taken care of (even looks like new). Is the flash memory failing? Can the firmware get corrupted on its own?
Any answers would be appreciated. Thanks.
i still think its just corrupted app, like crashing. but since its the part of system it hangs

i have xiaomi with bad emmc, i did nothing just restart it then it freezed, flashing just hanging

maybe its time to do backup than you sorry then
 
Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#8
Alright now, so it is now more than a week since this happened and I re-flashed it. The phone is still rocking. Can we assume that phone firmware can get corrupted on its own?
 
Joined
Nov 4, 2005
Messages
9,946 (2.25/day)
Likes
2,309
System Name MoFo 2
Processor AMD PhenomII 1100T @ 4.2Ghz
Motherboard Asus Crosshair IV
Cooling Swiftec 655 pump, Apogee GT,, MCR360mm Rad, 1/2 loop.
Memory 8GB DDR3-2133 @ 1900 8.9.9.24 1T
Video Card(s) HD7970 1250/1750
Storage Agility 3 SSD 6TB RAID 0 on RAID Card
Display(s) 46" 1080P Toshiba LCD
Case Rosewill R6A34-BK modded (thanks to MKmods)
Audio Device(s) ATI HDMI
Power Supply 750W PC Power & Cooling modded (thanks to MKmods)
Software A lot.
Benchmark Scores Its fast. Enough.
#9
Probably a controller issue where certain performance states it's not getting enough voltage.
 
Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#10
Probably a controller issue where certain performance states it's not getting enough voltage.
Even I thought the same. But how come after re-flashing, everything is perfect?
 

OneMoar

There is Always Moar
Joined
Apr 9, 2010
Messages
7,338 (2.62/day)
Likes
3,949
Location
Rochester area
System Name Kreij Lives On
Processor Intel Core i5 4670K @ 4.4Ghz 1.32V
Motherboard ASUS Maximus VI Gene Z87
Cooling Reeven Okeanos Single 140MM Fan +2 SP120 White's
Memory 16GB kingston hyper x @ 2133 @ 11 11 11 32
Video Card(s) EVGA GTX 1060 ACX Copper Single fan
Storage 240gb Cruical MX200SSD/WD Blue 1TB
Display(s) Samsung S24D300/HP2071D
Case Custom Full Aluminum By ST.o.CH <3
Audio Device(s) onboard
Power Supply HX 750i
Mouse Roccat KONE
Keyboard Rocatt ISKU with ISKUFX keycaps
Software Windows 10 +startisback
#11
NAND degradation happens
this is exactly the failure mode you get when the NAND starts throwing bad bits data corruption,crashes reboots
ect
a factory data reset just wipes /data and /datadata not /system(the rom) which is usually mounted RO but if there is a NAND issue it can be corrupted

hence the need todo a complete low_ship re-flash with odin or in this case asus flash tool xor fast boot a low_ship or 'raw' re-flash runs what is effectively a a chkdsk on the NAND marking any bad cells as unusable

that device has a unlockable bootloader if you want to get into playing with that as a smaller rom image or custom kernel may be of help with aging nand a custom kernel will go miles toward improving performace and battery life on intel based androidroid devices

I should mention this being a intel powered device not to expect much,intels x86-android platform is garbage(they run hot they have poor reliability poor kernel support)

https://forum.xda-developers.com/zenfone2/help/thead-bricked-phone-updating-to-mm-tips-t3452785
 
Last edited:
Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#12
NAND degradation happens
this is exactly the failure mode you get when the NAND starts throwing bad bits data corruption,crashes reboots
ect
a factory data reset just wipes /data and /datadata not /system(the rom) which is usually mounted RO but if there is a NAND issue it can be corrupted

hence the need todo a complete low_ship re-flash with odin or in this case asus flash tool xor fast boot a low_ship or 'raw' re-flash runs what is effectively a a chkdsk on the NAND marking any bad cells as unusable

that device has a unlockable bootloader if you want to get into playing with that as a smaller rom image or custom kernel may be of help with aging nand a custom kernel will go miles toward improving performace and battery life on intel based androidroid devices

I should mention this being a intel powered device not to expect much,intels x86-android platform is garbage(they run hot they have poor reliability poor kernel support)

https://forum.xda-developers.com/zenfone2/help/thead-bricked-phone-updating-to-mm-tips-t3452785
Thanks for the input. Thing is since this works perfectly fine now, what should be the next course of action? I don't have any plans to buy a new phone in the next 3-4 months unless it totally fails. Will it last that long? Next year on March, I will probably get a new phone but it would be great if the existing ZenFone 2 serves me well up to that time.
Also, what you said about Intel powered devices holds true. Though personally, I still like my device. I mean it can still do anything I want without breaking a sweat. Battery is still reliable even after almost 2 years and the phone does not heat up much as well except during fast charging (18 W) which is also normal. 1080p IPS display, 4 GB of RAM, dedicated memory card slot (I have a 64 GB EVO Plus UHS3 card) and even the camera is great as well if one knows to use it properly. True that it has it quirks but even after everything, it serves me well. And the most remarkable thing about the phone is the audio quality (headphones). Even GSMArena and Tom's Hardware have praised it for having top notch audio quality rivaling some of the flagships of that time.
The day this problem happened, I was almost about to buy the Moto Z2 Play which was a steal deal at 25000 INR but then I gave this a shot and now here it is.
 
Joined
Oct 9, 2010
Messages
1,281 (0.49/day)
Likes
466
Location
Kolkata, India
System Name Kaby | HP ab221TX laptop
Processor Intel Core i5 7600K @stock | Intel Core i5 5200U
Motherboard Asus Maximus VIII Ranger | HP
Cooling Cooler Master Seidon 120V hydro cooler | Laptop standard copper cooler
Memory 4*8 GB Kingston HyperX Fury @2900 MHz 15-15-15-35 2T | 8GB DDR3 1600MHz
Video Card(s) Sapphire Radeon R9 270X VaporX: Core: 1150 MHz, memory 1485 MHz | Intel HD Graphics + NVIDIA GT940M
Storage HyperX 3K 240 GB+Fury 240 GB SSDs, WD10EARS, ST500DM002, ST2000DM006 | Toshiba MQ01ABD100
Display(s) Dell S2240M 22" Full HD IPS widescreen| 15.6" full HD IPS LED LCD (LG Display)
Case Corsair Carbide 100R | HP ab221TX chassis
Audio Device(s) Realtek ALC1150 (Supreme FX) | Realtek ALC 290 with Bang & Olufsen (B&O Play)
Power Supply Corsair CS750M | 65W power brick
Mouse Logitech G300S | Synaptics SMBus touchpad
Keyboard Cooler Master Storm Devastator | Island style backlit keyboard
Software Windows 10 Pro | Windows 10 Home x64
#13
Update here: The phone died on 26th November at around 8:10 p.m. The battery got exhausted. I charged it and when I tried to boot it up, the revolving dots kept on revolving. Tried factory reset but no go. Tried flashing with ASUS flash tool. Flash failed and phone is totally dead. It just vibrates two times and goes on a loop. Bootloader and fastboot can be flashed as well, phone shows USB symbol but never boots into fastboot mode. May it rest in peace.

On the good side, I got a new Moto Z2 Play. Overall, a great device for the price. I miss the capacitive buttons here but otherwise, everything else is good.
 
Status
Not open for further replies.