1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Powercolor hd3650 agp device id change?

Discussion in 'AMD / ATI' started by west503, Apr 22, 2010.

  1. west503 New Member

    Joined:
    Apr 22, 2010
    Messages:
    2 (0.00/day)
    Thanks Received:
    0
    I'm encountering some problem using RBE to change the device id from 9598 to 9596. Most manufacturers use 9596 to designate the AGP version of this card while my card (Powercolor) uses the PCIe id of 9598. I need the 9596 id to use certain driver files in a Mac install. My method to this point has been to use a backup stock bios taken from my card and using RBE to do a hash dump and changing 98 to 96 in both id locations, save the bios and flash back to my card. Everything goes fine until the reboot with no display. I can blind flash the card back to original and it works. I'm just not certain if I'm doing everything I need to change this id and make it work. Any ideas?
     
  2. Yukikaze

    Yukikaze

    Joined:
    Sep 24, 2008
    Messages:
    2,456 (0.74/day)
    Thanks Received:
    599
    Location:
    Hillsboro, Oregon, USA
    The BIOS is probably protected by a checksum value somewhere in the image. When you change the ID, the checksum no longer matches and the device does not initialize properly.
     
  3. west503 New Member

    Joined:
    Apr 22, 2010
    Messages:
    2 (0.00/day)
    Thanks Received:
    0
    Makes sense...
    As an aside, I've also tried to flash with other manufacturers bios with the same result. The problem with this may be that I'm being hampered by a 64 bit card while the 3650 bios's I've been able to find have been 128 bit.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)