• We've upgraded our forums. Please post any issues/requests in this thread.

Powercolor Radeon HD 4870X2 Crashing w/ Catalyst AI Enabled!! :(

chespace

New Member
Joined
Oct 12, 2008
Messages
2 (0.00/day)
Likes
0
#1
I've been pulling my hair out with this problem where I can't run any games (have tried Crysis, Trackmania Nations, HL2) with Catalyst A.I. enabled (BSoD saying the ATI driver is in an infinite loop), which basically means I can't use the 2nd GPU on the card. It works in windowed mode but that's because it's not using the 2nd core.

Obviously, I can turn off CAT AI and games will run fine but performance takes a huge hit as you can imagine. Also, running 3DMark Vantage gets me a blackscreen and a reset.

Here are my specs:

Antec 1200 Case
Intel Core 2 Quad 9550 2.83GHz
8GB DDR2 G.Skill RAM 800MHz
Asus P5Q Pro mobo
PowerColor 4870X2
2 Seagate 360GB SATA HDDs
Corsair TX750W PSU
Windows Vista 64-bit SP1
Catalyst 8.10 final

Any idea what could be conflicting with the Cat. A.I.? When I try to run games with the AI enabled, I get a BSoD (driver is in infinite loop it says) and/or a blackscreen then reboot.

Things I've tried:

Fresh install of Vista and all updates/SP1
Updated all mobo drivers
Fresh install of Catalyst 8.10 final
Swapping out various DIMMs
Torture test my CPU/RAM for stability

I'm about to go nuts trying to figure this out.

Thanks for your time and help!
 

stanhemi

New Member
Joined
Sep 12, 2008
Messages
801 (0.24/day)
Likes
347
Location
Montreal,-Canada.
System Name CRUNSHING MINI FARM
Processor Q9550 C1(lapped)@4105mhz 1,38vcore/Q6600 G0 @3010mhz 1,24vcore
Motherboard P5Q-E 8.5 x 483 fsb/P5QPL-AM 9x334fsb
Cooling watercooled storm,mcw60,2x240mm,micro res rev2,laing ddc3.2/Xig s1283(lapped)
Memory CORSAIR DOMINATOR 2X2G 1066MHZ@965-mhz 5-4-5-15/kingston kvr800mhz 2x1g
Video Card(s) SAPPHIRRE 4870 1G @850/1020/ati x1950 pro
Storage RAID0 2X RAPTOR 74gb/wd 250g
Display(s) 22'' LCD 1680x1050/lg 17" 1280x1024
Case Antec 900 white inside/crappy white case
Audio Device(s) onboard/onboard
Power Supply ocz 700 watt mod xstream pro/enermax noiseblocker 485 watt
Software Windows 7 x64/vista 32
Benchmark Scores 3dmark06 18950
#2
Hi,i know that some crossfire whit 4850 and 4870 can't handled cat a.i maybe you got the same problem whit 4870 x2
 

chespace

New Member
Joined
Oct 12, 2008
Messages
2 (0.00/day)
Likes
0
#3
Hi,i know that some crossfire whit 4850 and 4870 can't handled cat a.i maybe you got the same problem whit 4870 x2
Yeah but this problem doesn't seem that wide spread, and I heard that the 4870X2 isn't really crossfire?
 

Binge

Overclocking Surrealism
Joined
Sep 15, 2008
Messages
6,979 (2.07/day)
Likes
1,734
Location
PA, USA
System Name Molly
Processor i5 3570K
Motherboard Z77 ASRock
Cooling CooliT Eco
Memory 2x4GB Mushkin Redline Ridgebacks
Video Card(s) Gigabyte GTX 680
Case Coolermaster CM690 II Advanced
Power Supply Corsair HX-1000
#4
I don't know what hippo guy is talking about honestly. I've had both crossfire and the X2 and the X2 has it's own set of HUGE issues-- Check out my thread on graphical corruption and power cycling. I'm having a nightmare.
 

stanhemi

New Member
Joined
Sep 12, 2008
Messages
801 (0.24/day)
Likes
347
Location
Montreal,-Canada.
System Name CRUNSHING MINI FARM
Processor Q9550 C1(lapped)@4105mhz 1,38vcore/Q6600 G0 @3010mhz 1,24vcore
Motherboard P5Q-E 8.5 x 483 fsb/P5QPL-AM 9x334fsb
Cooling watercooled storm,mcw60,2x240mm,micro res rev2,laing ddc3.2/Xig s1283(lapped)
Memory CORSAIR DOMINATOR 2X2G 1066MHZ@965-mhz 5-4-5-15/kingston kvr800mhz 2x1g
Video Card(s) SAPPHIRRE 4870 1G @850/1020/ati x1950 pro
Storage RAID0 2X RAPTOR 74gb/wd 250g
Display(s) 22'' LCD 1680x1050/lg 17" 1280x1024
Case Antec 900 white inside/crappy white case
Audio Device(s) onboard/onboard
Power Supply ocz 700 watt mod xstream pro/enermax noiseblocker 485 watt
Software Windows 7 x64/vista 32
Benchmark Scores 3dmark06 18950
#5
do some google search and you see what im talking about
 

Binge

Overclocking Surrealism
Joined
Sep 15, 2008
Messages
6,979 (2.07/day)
Likes
1,734
Location
PA, USA
System Name Molly
Processor i5 3570K
Motherboard Z77 ASRock
Cooling CooliT Eco
Memory 2x4GB Mushkin Redline Ridgebacks
Video Card(s) Gigabyte GTX 680
Case Coolermaster CM690 II Advanced
Power Supply Corsair HX-1000
#6
I honestly can't relate though as my 2 4870s never had problems with Cat AI >.>
 

stanhemi

New Member
Joined
Sep 12, 2008
Messages
801 (0.24/day)
Likes
347
Location
Montreal,-Canada.
System Name CRUNSHING MINI FARM
Processor Q9550 C1(lapped)@4105mhz 1,38vcore/Q6600 G0 @3010mhz 1,24vcore
Motherboard P5Q-E 8.5 x 483 fsb/P5QPL-AM 9x334fsb
Cooling watercooled storm,mcw60,2x240mm,micro res rev2,laing ddc3.2/Xig s1283(lapped)
Memory CORSAIR DOMINATOR 2X2G 1066MHZ@965-mhz 5-4-5-15/kingston kvr800mhz 2x1g
Video Card(s) SAPPHIRRE 4870 1G @850/1020/ati x1950 pro
Storage RAID0 2X RAPTOR 74gb/wd 250g
Display(s) 22'' LCD 1680x1050/lg 17" 1280x1024
Case Antec 900 white inside/crappy white case
Audio Device(s) onboard/onboard
Power Supply ocz 700 watt mod xstream pro/enermax noiseblocker 485 watt
Software Windows 7 x64/vista 32
Benchmark Scores 3dmark06 18950
#7
I now it not all of them but some 4850 and 4870 in crossfire mode have this issue whit Cat AI.

@Binge how many fps you have whit your system in AOC. (my friend want to built a rigs for AOC)

thank
 
Last edited:

Blacklash

New Member
Joined
Feb 22, 2007
Messages
186 (0.05/day)
Likes
36
System Name The Thrashing Dragon
Processor AMD Phenom II X6 1055T @ 4.0GHz (1.45v)
Motherboard ASUS Crosshair IV (AMD 890FX)
Cooling Xigmatek HDT-S1284EE
Memory GeIL Black Dragon DDR3 1600 (4x2Gb)
Video Card(s) Powercolor Radeon HD 5870 1Gb (x2)
Storage WD VelociRaptor 150Gb HD (x2)
Display(s) Acer GD235HZbid
Case SilverStone TJ10-B
Power Supply SILVERSTONE OP1000-E
Software Vista HP x64 SP2
#8
Yeah but this problem doesn't seem that wide spread, and I heard that the 4870X2 isn't really crossfire?
You had it right in your first post. You're getting a huge FPS hit because disabling CAT AI also disables on board Crossfire on the X2 leaving you with single GPU performance. The X2 does indeed use Crossfire tech.

I have no idea what is causing your problem. A stab in the dark would be some mobos don't support the X2 unless they're on the latest BIOS. I know the DFI X48 board had a lot of issues with the X2 and you aren't using said board. So if you aren't on the latest BIOS for your mobo, get it.

That PSU of yours should be enough for the X2 unless it's faulty. If you're really desperate you could also try reseating the card in your mobo.

Other places to ask around; Rage, DH, and the official AMD forums-

http://www.rage3d.com/board/

http://www.driverheaven.net/forum.php

http://forums.amd.com/game/
 
Last edited:

Binge

Overclocking Surrealism
Joined
Sep 15, 2008
Messages
6,979 (2.07/day)
Likes
1,734
Location
PA, USA
System Name Molly
Processor i5 3570K
Motherboard Z77 ASRock
Cooling CooliT Eco
Memory 2x4GB Mushkin Redline Ridgebacks
Video Card(s) Gigabyte GTX 680
Case Coolermaster CM690 II Advanced
Power Supply Corsair HX-1000
#9
I now it not all of them but some 4850 and 4870 in crossfire mode have this issue whit Cat AI.

@Binge how many fps you have whit your system in AOC. (my friend want to built a rigs for AOC)

thank
I have to believe after struggling with my x2 that CAI errors and corruption are due to a less than perfect driver install.

@hippo- AoC will recognize a 4870x2 and the frames are well over 70 on the low end. This does not apply to crossfire. AoC supports SLI but not crossfire. AoC is also very dead. PvP patch was weak and the end game is still horrid. Most servers max 100 people a day and it is not a good game w/low populations :(. Damn Funcom
 

Blacklash

New Member
Joined
Feb 22, 2007
Messages
186 (0.05/day)
Likes
36
System Name The Thrashing Dragon
Processor AMD Phenom II X6 1055T @ 4.0GHz (1.45v)
Motherboard ASUS Crosshair IV (AMD 890FX)
Cooling Xigmatek HDT-S1284EE
Memory GeIL Black Dragon DDR3 1600 (4x2Gb)
Video Card(s) Powercolor Radeon HD 5870 1Gb (x2)
Storage WD VelociRaptor 150Gb HD (x2)
Display(s) Acer GD235HZbid
Case SilverStone TJ10-B
Power Supply SILVERSTONE OP1000-E
Software Vista HP x64 SP2
#10

Binge

Overclocking Surrealism
Joined
Sep 15, 2008
Messages
6,979 (2.07/day)
Likes
1,734
Location
PA, USA
System Name Molly
Processor i5 3570K
Motherboard Z77 ASRock
Cooling CooliT Eco
Memory 2x4GB Mushkin Redline Ridgebacks
Video Card(s) Gigabyte GTX 680
Case Coolermaster CM690 II Advanced
Power Supply Corsair HX-1000
#11
That must be new because on the forums the devs even verified that the program would not support crossfire until they finally included DX10. >..>

I have a character Ra, lvl 80 Herald of Xotli, full T2 raid gear on Bluesteel :-/ It's sooo dead.
 

stanhemi

New Member
Joined
Sep 12, 2008
Messages
801 (0.24/day)
Likes
347
Location
Montreal,-Canada.
System Name CRUNSHING MINI FARM
Processor Q9550 C1(lapped)@4105mhz 1,38vcore/Q6600 G0 @3010mhz 1,24vcore
Motherboard P5Q-E 8.5 x 483 fsb/P5QPL-AM 9x334fsb
Cooling watercooled storm,mcw60,2x240mm,micro res rev2,laing ddc3.2/Xig s1283(lapped)
Memory CORSAIR DOMINATOR 2X2G 1066MHZ@965-mhz 5-4-5-15/kingston kvr800mhz 2x1g
Video Card(s) SAPPHIRRE 4870 1G @850/1020/ati x1950 pro
Storage RAID0 2X RAPTOR 74gb/wd 250g
Display(s) 22'' LCD 1680x1050/lg 17" 1280x1024
Case Antec 900 white inside/crappy white case
Audio Device(s) onboard/onboard
Power Supply ocz 700 watt mod xstream pro/enermax noiseblocker 485 watt
Software Windows 7 x64/vista 32
Benchmark Scores 3dmark06 18950
#12
thank Binge for the info.