• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Problems with ati radeon hd5770

secodrvr

New Member
Joined
Nov 24, 2020
Messages
1 (0.02/day)
Hi all. I'm having a problem with an ati radeon hd5770. With just the card inserted into the motherboard, the fan spins but there is no display. With the 6 pin power connector inserted, the fan does not spin and still no video. I can reinsert my old gpu and it works fine. The motherboard is a gigabyte 880-ud2h, has 16 gigs ddr3 1333 ram. I also bought a new psu with the correct 6+2 pin connector rated at 600 watts. Any help would be appreciated
 
Joined
Nov 25, 2020
Messages
13 (0.24/day)
System Name ASUS ROG STRIX G15
Processor i7-10750H @ 5 GHZ
Motherboard ASUS
Cooling 2 Fans and 7 Heat pipes
Memory 16GB 3200 MHZ Dual channel
Video Card(s) RTX 2060 Mobile
Storage 512 GB Intel 660p SDD
Display(s) 15" 144 HZ 1080p
Power Supply 230 watt charger
Mouse Standard With RGB
Keyboard Standard With RGB
Software Hwinfo
Benchmark Scores Too much for you to handle
how did you get the ati radeon hd5770?
If second hand-> did it work for the previous owner?
try using the integrated graphics -> boot windows -> switch the video input
 
Joined
Oct 30, 2008
Messages
1,790 (0.40/day)
Processor 5930K
Motherboard MSI X99 SLI
Cooling WATER
Memory 16GB DDR4 2132
Video Card(s) EVGAY 2070 SUPER
Storage SEVERAL SSD"S
Display(s) Catleap/Yamakasi 2560X1440
Case D Frame MINI drilled out
Audio Device(s) onboard
Power Supply Corsair TX750
Mouse DEATH ADDER
Keyboard Razer Black Widow Tournament
Software W10HB
Benchmark Scores PhIlLyChEeSeStEaK
How did you install drivers? Do a clean install?
 
Joined
Jul 16, 2014
Messages
4,331 (1.82/day)
Location
SE Michigan
System Name Dumbass
Processor AMD-9370BE @4.6
Motherboard ASUS SABERTOOTH 990FX R2.0 +SB950
Cooling CM Nepton 280L
Memory G.Skill Sniper 16gb DDR3 2400
Video Card(s) GreenTeam 1080 Gaming X 8GB
Storage C:\SSD (240GB), D:\Seagate (2TB), E:\Western Digital (1TB)
Display(s) 1x Nixeus NX_EDG27, 2x Dell S2440L (16:9)
Case Phanteks Enthoo Primo w/8 140mm SP Fans
Audio Device(s) onboard (realtek?) SPKRS:Logitech Z623 200w 2.1
Power Supply Corsair HX1000i
Mouse Logitech G700s
Keyboard Logitech G910 Orion Spark
Software windows 10
Benchmark Scores https://i.imgur.com/aoz3vWY.jpg?2
Hi all. I'm having a problem with an ati radeon hd5770. With just the card inserted into the motherboard, the fan spins but there is no display. With the 6 pin power connector inserted, the fan does not spin and still no video. I can reinsert my old gpu and it works fine. The motherboard is a gigabyte 880-ud2h, has 16 gigs ddr3 1333 ram. I also bought a new psu with the correct 6+2 pin connector rated at 600 watts. Any help would be appreciated
Whats the old GPU? What was the old PSU?

Buying a 2nd hand card from a questionable source, like Ebay, means you need to ask questions, like was this card used for mining or did this card work before selling.

Also, you can buy cables separately with whatever pin count you need.
 

Frick

Fishfaced Nincompoop
Joined
Feb 27, 2006
Messages
16,742 (3.08/day)
Location
Piteå
System Name Black MC in Tokyo
Processor Ryzen 5 2600x
Motherboard Asrock B450M-HDV
Cooling AMD Wraith Spire I think
Memory 2 x 8GB G-skill Aegis 3000 or somesuch
Video Card(s) Gigabyte RTX 2060 Gaming OC Pro
Storage Kingston A400 240GB | WD Blue 1TB x 2 | Toshiba P300 2TB
Display(s) BenQ GL2450HT
Case Antec dumpster find
Audio Device(s) Line6 UX1 + some headphones
Power Supply Fractal Design Effekt 400W
Mouse Logitech G602
Keyboard Dell Sk3205
Software Windows 10 Pro
Benchmark Scores I once had +100 dorfs in DF, so yeah pretty great
It's dead. Return it if you can.
 
Top