1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

PSU won't turn off

Discussion in 'General Hardware' started by fang_laluna, Jul 12, 2010.

  1. fang_laluna New Member

    Joined:
    Sep 5, 2009
    Messages:
    108 (0.04/day)
    Thanks Received:
    4
    Hi,

    I bought enermax 1250w couple of weeks ago.
    It's making a buzzing noise now even when it's off. It happens as soon as I plug the power cable into the PSU.

    Now the power light on the mobo won't turn off even if I unplug all power cables.
     
  2. computertechy

    computertechy

    Joined:
    Apr 3, 2006
    Messages:
    833 (0.21/day)
    Thanks Received:
    188
    Location:
    UK, Brighton
    give Enermax a email mate, your motherboard needs to discharge before the power light goes out and varies how long it can take.

    the PSU stays on after your computer has shut down for active cooling and turns off when a certain temperature is reached

    if you didn't know some of that already :p the buzzing shouldn't happen though, i have the same PSU as you
     
    fang_laluna says thanks.
    10 Year Member at TPU
  3. fang_laluna New Member

    Joined:
    Sep 5, 2009
    Messages:
    108 (0.04/day)
    Thanks Received:
    4
    Will do
    Thanks mate.

    So the PSU shouldn't make that buzzing noise. The noise is somewhat similar to cricket noise :wtf: dud PSU?
     
  4. jonnyGURU

    jonnyGURU

    Joined:
    Apr 24, 2007
    Messages:
    97 (0.03/day)
    Thanks Received:
    39
    The power light on the motherboard should stay on. That's telling you it's getting +5VSB; something a motherboard gets as long as the PSU is plugged into the wall.

    And some Enermax's are known to buzz. Do you have the PSU plugged into a UPS? This will be one of the things Enermax will ask you and if you say you have anything other than an online UPS, they'll blame the UPS. Plug the PSU directly into the wall. Does it still buzz?
     
    fang_laluna says thanks.
  5. fang_laluna New Member

    Joined:
    Sep 5, 2009
    Messages:
    108 (0.04/day)
    Thanks Received:
    4
    Umm that's the thing. PSU is unplugged, ATX 24 pin is also unplugged but motherboard power light is still on :confused:

    Nope, I plug the PSU directly into wall socket.
     
  6. computertechy

    computertechy

    Joined:
    Apr 3, 2006
    Messages:
    833 (0.21/day)
    Thanks Received:
    188
    Location:
    UK, Brighton
    is the 8pin still plugged in?

    unplug everything.
     
    fang_laluna says thanks.
    10 Year Member at TPU
  7. fang_laluna New Member

    Joined:
    Sep 5, 2009
    Messages:
    108 (0.04/day)
    Thanks Received:
    4
    Yes it's still plugged it, it might explains the power led :rolleyes: Will give it a try in the morning.

    Thanks guys
     
  8. purecain

    purecain

    Joined:
    May 12, 2006
    Messages:
    750 (0.19/day)
    Thanks Received:
    218
    i know this is daft advice, but to be absolutely certain... reconnect all of the modular cables making sure your using the correct cable for the connector next to the cpu...
     
    10 Year Member at TPU

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)