• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

R9 290 Artifacts in certain games

Joined
Feb 18, 2006
Messages
5,145 (1.02/day)
Location
AZ
System Name Thought I'd be done with this by now
Processor i7 4790K 4.4GHZ turbo currently at 4.6GHZ at 1.16v
Motherboard MSI Z97-G55 SLI
Cooling Scythe Mugen 2 rev B (SCMG-2100), stock on gpu's.
Memory 8GB G.SKILL Ripjaws Z Series DDR3 2400MHZ 10-12-12-31
Video Card(s) EVGA GTX 760 Superclocked replaced HIS R9 290 that was artifacting
Storage 1TB MX300 M.2 OS + Games, 4x ST31000524NS in Raid 10 Storage and Backup, external 2tb backup,
Display(s) BenQ GW2255 surprisingly good screen for the price.
Case Raidmax Scorpio 668
Audio Device(s) onboard HD
Power Supply EVGA 750 GQ
Software Windows 10
Benchmark Scores no one cares anymore lols
Recently loaded up the skyrim enhanced edition and noticed certain objects artifact. They are typically yellow/whiteish or some form of it in random polygons on certain surfaces. Notable water and grass are not affected but things like semi-reflective rocks, buildings, etc are. Most matte surfaces are fine.

For kicks I loaded up my modded skyrim and there are some present, but not as many. Tomb Raider is the same except that it also affects certain shadows.

The odd thing is most other games work fine. Shadow of Mordor, Darksiders 1 and 2, Half Life 2, Two Worlds 1 and 2, Sleeping Dogs, etc

I've updated drivers, checked for temps (not an issue), upped the power limit (gpu is currently at stock) to see if that helped to no avail.

Not sure what's wrong but it is annoying. If the card was having a memory issue I'd expect it to be abut more universal.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,301 (6.23/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
have you replaced any thermal compound or TIM on the chip/ram?
 
Joined
Feb 18, 2006
Messages
5,145 (1.02/day)
Location
AZ
System Name Thought I'd be done with this by now
Processor i7 4790K 4.4GHZ turbo currently at 4.6GHZ at 1.16v
Motherboard MSI Z97-G55 SLI
Cooling Scythe Mugen 2 rev B (SCMG-2100), stock on gpu's.
Memory 8GB G.SKILL Ripjaws Z Series DDR3 2400MHZ 10-12-12-31
Video Card(s) EVGA GTX 760 Superclocked replaced HIS R9 290 that was artifacting
Storage 1TB MX300 M.2 OS + Games, 4x ST31000524NS in Raid 10 Storage and Backup, external 2tb backup,
Display(s) BenQ GW2255 surprisingly good screen for the price.
Case Raidmax Scorpio 668
Audio Device(s) onboard HD
Power Supply EVGA 750 GQ
Software Windows 10
Benchmark Scores no one cares anymore lols
have you replaced any thermal compound or TIM on the chip/ram?
no, I think I'll give that a try. I also haven't tried the other bios out (via the switch on the card) to see if it works better.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,301 (6.23/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
no, I think I'll give that a try. I also haven't tried the other bios out (via the switch on the card) to see if it works better.
give it a shot, pray that it works out.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,301 (6.23/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Sep 20, 2010
Messages
282 (0.08/day)
Processor AMD Phenom II X4 945
Motherboard Gigabyte GA-880GM-UD2H
Memory 6gb DDR3-1333
Video Card(s) Sapphire Radeon HD6870
Storage Seagate 1tb
Display(s) Acer AL2216W
Case Generic
Audio Device(s) onboard
Power Supply Ultra LS-550
I would say that you are experiencing a bug similar to the rainbow texture one that AMD users are experiencing with Fallout 4, which is based on the Skyrim game engine. The devs over at the Bethesda forums currently have no plan to fix that bug and have come out and said as much.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,301 (6.23/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I would say that you are experiencing a bug similar to the rainbow texture one that AMD users are experiencing with Fallout 4, which is based on the Skyrim game engine. The devs over at the Bethesda forums currently have no plan to fix that bug and have come out and said as much.
thus they will start being boycotted
 
Joined
Feb 18, 2006
Messages
5,145 (1.02/day)
Location
AZ
System Name Thought I'd be done with this by now
Processor i7 4790K 4.4GHZ turbo currently at 4.6GHZ at 1.16v
Motherboard MSI Z97-G55 SLI
Cooling Scythe Mugen 2 rev B (SCMG-2100), stock on gpu's.
Memory 8GB G.SKILL Ripjaws Z Series DDR3 2400MHZ 10-12-12-31
Video Card(s) EVGA GTX 760 Superclocked replaced HIS R9 290 that was artifacting
Storage 1TB MX300 M.2 OS + Games, 4x ST31000524NS in Raid 10 Storage and Backup, external 2tb backup,
Display(s) BenQ GW2255 surprisingly good screen for the price.
Case Raidmax Scorpio 668
Audio Device(s) onboard HD
Power Supply EVGA 750 GQ
Software Windows 10
Benchmark Scores no one cares anymore lols
no luck with skyrim enhanced but driver cleaner, 2nd bios on card and new thermal paste have made it vanish everywhere else. Thus I haven't played the skyrim enhanced and instead fired up original with mods including the forgotten city which I had not played before. Have to say I found that far more entertaining than playing through the original game for the umpteenth time with a few more pretties.
 
Top