1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Radeon HD 4890 bios and Dell 2408 problem.

Discussion in 'AMD / ATI' started by nabla666, May 12, 2009.

  1. nabla666 New Member

    May 12, 2009
    1 (0.00/day)
    Thanks Received:
    I am having a blinking problem with my Sapphire Radeon HD 4890 and my dell 2480wfp monitor.
    We can discuss this problem in this thread but before that I have some remarks concerning your bios database :
    First the most important : does this bios ( http://www.techpowerup.com/vgabios/43130/XFX.RadeonHD4890.1024.090304.html ) has the good size ?
    It's only 64k, don't all the bios for 4890 are 128ko ?
    Secondly, when I tried to upload my own bios, I have the message :
    "The bios is already part of our collection. 45251.rom"
    But this bios is not downloadable for the moment, which is annoying.
    And thirdly, I tried to flash my Sapphire card with your (only?) 4890 bios available
    ( http://www.techpowerup.com/vgabios/44976/ATI.HD4890.1024.090319.html ) and I crashed my PC as soon as I clicked on the program button. (With Winflash 2017 under vista 64 )
    (I took the precaution to backup my own bios but I've got hard time finally restoring my card with atiflash under dos...)

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)