• We've upgraded our forums. Please post any issues/requests in this thread.

Radeon HD5770 crossfire - yellow/green tint in 3d apps

Joined
Jul 13, 2010
Messages
43 (0.02/day)
Likes
10
Location
Slovakia
System Name Pap1er
Processor AMD FX 8370 @ 4550 MHz
Motherboard GIGABYTE 990X-Gaming SLI
Cooling Corsair H50
Memory Kingston HyperX DDR3 1866MHz
Video Card(s) Sapphire Nitro RX 570 4GB
Storage OCZ-VECTOR150 @ 120GB / Radeon R7 @ 240GB / WD20EURS @ 2TB
Display(s) LG 29UC88 Curved UltraWide Monitor
Case Corsair 230T Graphite Series - Orange
Audio Device(s) OnBoard
Power Supply Corsair CX750M
Mouse Creative Sound BlasterX Siege M04 Gaming mouse
Software Windows 10 Pro x64
#1
Helo pals,
I am currently trying to solve problem with my radeon crossfire setup. 2 days ago I downloaded latest catalyst 13.12 for my radeon HD5770 crossfire and suddenly problem occurred.
Everything went fine until I started some game (world of warcraft, but it is not importat)
Upon starting the game in fullscreen mode (windowed mode is not affected because crossfire works only in fullscreen mode) game colors turned in yellow ~ greenish tint.
Sometimes color flips back to standard color palette but most of time screen is yellowish ~ greenish... simply ugly.

So I completely uninstalled whole AMD software in safe mode and also removed all remainings from previous driver installations using Display Driver Uninstaller.
Again I installed catalyst 13.12 with same result. Later I have repeated whole uninstall/reinstall proces (about 5 times) with different catalyst versions (13.10 / 13.9 / 13.4 and so on) but the result was always the same.

As I mentioned above this problem shows up only in full screen mode while crossfire is turned on. Otherwise when crossfire is disabled in CCC or aplication is running in windowed mode there is no problem so far.

I have searched many forum topics all over the internet, where people were suggesting different solutions starting with change refresh rate of monitor trough checking / changing HDMI cable up to reinstalling whole system (by the way reinstalling the system is the latest thing I would do), but nobody was able to clearly say what is causing this problem. It seems to me like latest catalyst has messed something in system registry and it is the main reason why problem persist even with older versions of driver.

My system spec:
Amd Phenom II 965 BE @ 3816MHz
Kingston HyperX 8GB ram ddr II 800MHz
2x seagate baracuda 500GB raid 0
1x western digital 2TB AVGP
Sapphire radeon HD5770 crossfire
Windows 8 Pro x64


I would really apreciate any suggestion,
thank you
Paul
 

brandonwh64

Addicted to Bacon and StarCrunches!!!
Joined
Sep 6, 2009
Messages
19,516 (6.46/day)
Likes
6,937
Location
Chatsworth, GA
System Name The StarCrunch Defender! | X58 Cruncher!
Processor I7 6700K @ STOCK | Intel I7-920
Motherboard Gigabyte Z170X-UD5 | Alienware MS-7543 X58
Cooling Corsair A70 Push/Pull | Corsair H50
Memory Crucial Ballistix DDR4 2400 MHz | Pereema 3x2GB DDR3
Video Card(s) Gigabyte Gaming G1 GTX 1070 | Gigabyte 7970 3GB
Storage 2x Samsung Pro 256GB M.2 SSD's in Raid 0 | 4TB Western Digital SATA drive
Display(s) ViewSonic VG2227wm 1080P | OLD viewsonics
Case NZXT Tempest 410 Elite | NZXT Source 210
Audio Device(s) Onboard
Power Supply Corsair 750TX | Enermax Liberty 500W
Mouse MX518 | MX502
Keyboard TESORO Mechanical | ANZO Mechanical
Software Windows 10 Pro on both
#2
Joined
Jul 13, 2010
Messages
43 (0.02/day)
Likes
10
Location
Slovakia
System Name Pap1er
Processor AMD FX 8370 @ 4550 MHz
Motherboard GIGABYTE 990X-Gaming SLI
Cooling Corsair H50
Memory Kingston HyperX DDR3 1866MHz
Video Card(s) Sapphire Nitro RX 570 4GB
Storage OCZ-VECTOR150 @ 120GB / Radeon R7 @ 240GB / WD20EURS @ 2TB
Display(s) LG 29UC88 Curved UltraWide Monitor
Case Corsair 230T Graphite Series - Orange
Audio Device(s) OnBoard
Power Supply Corsair CX750M
Mouse Creative Sound BlasterX Siege M04 Gaming mouse
Software Windows 10 Pro x64
#3
I am using 13.10 without an issue with 5770 Xfire but if you do not play BF4 then I would recommend installing 11.11c performance driver cause it was the best I could find for 5xxx series cards.

http://www.techpowerup.com/156030/amd-posts-catalyst-11-11c-performance-driver.html
Thank you, I'll try it as soon as i get home

Anyway I was using 13.10 without any problems too until I installed 13.12... 13.12 totally messed my system so also 13.10 does not work properly :/
 

brandonwh64

Addicted to Bacon and StarCrunches!!!
Joined
Sep 6, 2009
Messages
19,516 (6.46/day)
Likes
6,937
Location
Chatsworth, GA
System Name The StarCrunch Defender! | X58 Cruncher!
Processor I7 6700K @ STOCK | Intel I7-920
Motherboard Gigabyte Z170X-UD5 | Alienware MS-7543 X58
Cooling Corsair A70 Push/Pull | Corsair H50
Memory Crucial Ballistix DDR4 2400 MHz | Pereema 3x2GB DDR3
Video Card(s) Gigabyte Gaming G1 GTX 1070 | Gigabyte 7970 3GB
Storage 2x Samsung Pro 256GB M.2 SSD's in Raid 0 | 4TB Western Digital SATA drive
Display(s) ViewSonic VG2227wm 1080P | OLD viewsonics
Case NZXT Tempest 410 Elite | NZXT Source 210
Audio Device(s) Onboard
Power Supply Corsair 750TX | Enermax Liberty 500W
Mouse MX518 | MX502
Keyboard TESORO Mechanical | ANZO Mechanical
Software Windows 10 Pro on both
#4
Joined
Jul 13, 2010
Messages
43 (0.02/day)
Likes
10
Location
Slovakia
System Name Pap1er
Processor AMD FX 8370 @ 4550 MHz
Motherboard GIGABYTE 990X-Gaming SLI
Cooling Corsair H50
Memory Kingston HyperX DDR3 1866MHz
Video Card(s) Sapphire Nitro RX 570 4GB
Storage OCZ-VECTOR150 @ 120GB / Radeon R7 @ 240GB / WD20EURS @ 2TB
Display(s) LG 29UC88 Curved UltraWide Monitor
Case Corsair 230T Graphite Series - Orange
Audio Device(s) OnBoard
Power Supply Corsair CX750M
Mouse Creative Sound BlasterX Siege M04 Gaming mouse
Software Windows 10 Pro x64
#5
Well catalyst 11.11 is without doubt best performance driver for radeon HD5000 but anyway it did not solve my problem. Hm, I have to check each card independently.
 
Joined
Jul 13, 2010
Messages
43 (0.02/day)
Likes
10
Location
Slovakia
System Name Pap1er
Processor AMD FX 8370 @ 4550 MHz
Motherboard GIGABYTE 990X-Gaming SLI
Cooling Corsair H50
Memory Kingston HyperX DDR3 1866MHz
Video Card(s) Sapphire Nitro RX 570 4GB
Storage OCZ-VECTOR150 @ 120GB / Radeon R7 @ 240GB / WD20EURS @ 2TB
Display(s) LG 29UC88 Curved UltraWide Monitor
Case Corsair 230T Graphite Series - Orange
Audio Device(s) OnBoard
Power Supply Corsair CX750M
Mouse Creative Sound BlasterX Siege M04 Gaming mouse
Software Windows 10 Pro x64
#6
Problem SOLVED,
my assumption was right. catalyst 13.12 had written some mess into system registy which caused color flickering in full screen mode.
I physically exchanged 1. card with 2. card in motherboard slots, system then installed both cards as new devices and broblem has gone. I presume that upon installing both cards as a new devices system has made new registry record which effectively overcome the problem.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
19,224 (5.03/day)
Likes
4,811
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#7
Factory reset your monitor, check your video cables remove and reinstall them and revert radeon color profiles to default