• We've upgraded our forums. Please post any issues/requests in this thread.

Razer Carcharias mic has a high pitch sound?

V1nom

New Member
Joined
Mar 21, 2013
Messages
3 (0.00/day)
Likes
0
#1
Hello I just got my Razer Carcharias headset today. Plugged it up and went online to talk to my friends and they said they hear like a high pitch type sound in the background, and my old headset never did this. I tried turning off the mic boost and lowering the mic volume but still ha that high pitch sound. Has this happened to someone before or knows what I'm talking about? Please help me
 

erocker

Senior Moderator
Staff member
Joined
Jul 19, 2006
Messages
42,376 (10.17/day)
Likes
18,020
Processor Intel i7 8700k
Motherboard Gigabyte z370 AORUS Gaming 7
Cooling Water
Memory 16gb G.Skill 4000 MHz DDR4
Video Card(s) Evga GTX 1080
Storage 3 x Samsung Evo 850 500GB, 1 x 250GB, 2 x 2TB HDD
Display(s) Nixeus EDG27
Case Thermaltake X5
Power Supply Corsair HX1000i
Mouse Zowie EC1-B
Software Windows 10
#2
Check your connections (dust, etc.) but most likely it is a bad connection in the headset somewhere. Get it replaced.
 
Joined
Aug 2, 2009
Messages
4,014 (1.31/day)
Likes
1,832
System Name Abacus
Processor i5 2500K
Motherboard ASRock p67 Extreme4 Gen3
Cooling Swiftech MCP35X, EK HF Copper, 2.120 rad, 3.120 rad
Memory 2x4GB G.Skill Sniper 1600
Video Card(s) 2 Zotac GTX 770 4GB w/ FC EK Blocks
Storage WD 640BG x2/WD 250GB/Samsung 2TB
Display(s) QNIX 27" PLS
Case Corsair 700D
Audio Device(s) X-Fi XtremeGamer
Power Supply EVGA G2 750W
Mouse Logitech G500
Keyboard Corsair K70 RGB MX Brown
Software Windows 10
#3
It could be noise from electronic interference, although you would think it would also be present in your headphones. Try plugging into your motherboard jacks instead of your front I/O panel and see if it is any better.
 

V1nom

New Member
Joined
Mar 21, 2013
Messages
3 (0.00/day)
Likes
0
#4
When I plug them into the back into my motherboard, like the mic doesn't work at all.
 
Joined
May 13, 2010
Messages
4,422 (1.60/day)
Likes
1,603
System Name RemixedBeast
Processor Intel i5 3570K @ 3.4Ghz
Motherboard ASRock Z77 Pro3
Cooling Coolermaster Hyper 212 Evo
Memory 16GB Corsair XMS3
Video Card(s) EVGA Nvidia GTX 650 Ti SSC 1GB
Storage 1.5TB Seagate/128GB Samsung 840
Display(s) Samsung SyncMaster P2350 23in @ 1920x1080 + LG Flatron 19in Widescreen 1440x900
Case Antec Three Hundred Two
Audio Device(s) Beyerdynamic DT770 Pro 80 // Fiio E7 Amp/DAC
Power Supply 620w Antec High Current Gamer HCG-620M
Mouse Logitech G700s/G502
Keyboard Logitech K740
Software Windows Server 2012 x64 Standard
Benchmark Scores Network: APs: Cisco Meraki MR32, Ubiquiti Unifi AP-AC-LR and Lite, Ligowave NFT-3AC
#5
Try it on another system.
 

V1nom

New Member
Joined
Mar 21, 2013
Messages
3 (0.00/day)
Likes
0
#6
Yea tired in 3 other systems still have thing. And I noticed it has a static type sound in the audio, like the headset itself. I'll have no music or game on and hear this static type sound and did it on all 4 computers as well.
 
Joined
May 13, 2010
Messages
4,422 (1.60/day)
Likes
1,603
System Name RemixedBeast
Processor Intel i5 3570K @ 3.4Ghz
Motherboard ASRock Z77 Pro3
Cooling Coolermaster Hyper 212 Evo
Memory 16GB Corsair XMS3
Video Card(s) EVGA Nvidia GTX 650 Ti SSC 1GB
Storage 1.5TB Seagate/128GB Samsung 840
Display(s) Samsung SyncMaster P2350 23in @ 1920x1080 + LG Flatron 19in Widescreen 1440x900
Case Antec Three Hundred Two
Audio Device(s) Beyerdynamic DT770 Pro 80 // Fiio E7 Amp/DAC
Power Supply 620w Antec High Current Gamer HCG-620M
Mouse Logitech G700s/G502
Keyboard Logitech K740
Software Windows Server 2012 x64 Standard
Benchmark Scores Network: APs: Cisco Meraki MR32, Ubiquiti Unifi AP-AC-LR and Lite, Ligowave NFT-3AC
#7
You may need to return it then. :(