• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Re Encoding to enable DXVA support

Joined
Oct 2, 2005
Messages
2,913 (0.65/day)
Likes
659
Location
Baltimore MD
Processor FX-8320@ 4.2Ghz
Motherboard Gigabyte 970A-UD3
Cooling Xigmatek S1283
Memory 2x4Gb Corsair 1600 9-9-9-24
Video Card(s) Sapphire RX-480 Nitro
Storage OCZ Vertex 3 120G, 1TB WD Black
Display(s) Dell S2330MX
Case Corsair Carbide Air 540
Audio Device(s) X-Fi Fatal1ty / 5.1 Logitech Z-5500
Power Supply Silverstone DA750
Software Win10 pro 64bit
#1
Does anyone know of a program or way to re encode videos to support DXVA.
I would like to be able to re encode with DXVA support while keeping resolution and subtitles, I do not care if the subs lose styling or animation as long as there synced and readable.
I've tried a few things and searched alot but haven't found a sure fire way to do this.

99% of the videos are anime in .mkv h.264 that do not support DXVA ,which presents a problem for my E-350 zactae based ZBox.
This is not a DXVA configuration issue with my rig the videos are simply encoded with setting not supported by DXVA for quality reasons such as hi10p etc.

Any help would be appreciated, thanks in advance.
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,203 (9.52/day)
Likes
13,691
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon
Cooling Fractal Celsius S24 (Silent fans, meh pump)
Memory 16GB 2133 generic @ 2800
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5. So much room, so quiet...
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 / sennheiser HD595/518 + Corsair Void RGB
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G403 + KKmoon desk-sized mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#2
you just need to encode them to the H264 standards. use handbrake, and try its profiles til one works. (you may need to stuff around to get subtitles working right, i know i had to)


edit: are you using xyfilter on the zacate box? it really boosts performance on stylised subs, and may simply negate your issue. i use it as a plugin for MPC-HC. (i think its a default feature in the latest CCCP)
 
Joined
Oct 2, 2005
Messages
2,913 (0.65/day)
Likes
659
Location
Baltimore MD
Processor FX-8320@ 4.2Ghz
Motherboard Gigabyte 970A-UD3
Cooling Xigmatek S1283
Memory 2x4Gb Corsair 1600 9-9-9-24
Video Card(s) Sapphire RX-480 Nitro
Storage OCZ Vertex 3 120G, 1TB WD Black
Display(s) Dell S2330MX
Case Corsair Carbide Air 540
Audio Device(s) X-Fi Fatal1ty / 5.1 Logitech Z-5500
Power Supply Silverstone DA750
Software Win10 pro 64bit
#3
edit: are you using xyfilter on the zacate box? it really boosts performance on stylized subs, and may simply negate your issue. i use it as a plugin for MPC-HC. (i think its a default feature in the latest CCCP)
Yea I tried the new cccp last night it includes xyfilter for that reason.
i noticed the subs during OP/ED causing lag prior, any tweaks i should make i just re tested with known working DXVA vids and its definitely the encode and not the system.
edit: i know about enabling dxva2 copyback in LAV filters.
Edit 2: xyfilter on cccp made a huge difference on the styled subs.
 
Last edited:

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,203 (9.52/day)
Likes
13,691
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon
Cooling Fractal Celsius S24 (Silent fans, meh pump)
Memory 16GB 2133 generic @ 2800
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5. So much room, so quiet...
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 / sennheiser HD595/518 + Corsair Void RGB
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G403 + KKmoon desk-sized mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#4
test it out properly with XY then, you may not even need to recode the files.
 
Joined
Oct 6, 2007
Messages
5,154 (1.37/day)
Likes
1,219
Location
Nelson B.C. Canada
System Name Blacknet
Processor E5-1650 Xeon @ 4.7Ghz
Motherboard Asus P9X79 Pro
Cooling Noctua NH-D14/7case fans
Memory 32gb Gskill 1866 Cas9
Video Card(s) Asus Strix GTX970 OC
Storage 2x Toshiba 3TB, Seagate 2TB, 2x EVO 850 250GB
Display(s) 27" Asus VS278Q 1ms
Case Antec 1200
Audio Device(s) Soundblaster Z + AKG Q701 Studio Monitors
Power Supply XFX XTR 750 Gold
Mouse Corsair Vengeance M95
Keyboard Cheap Azio
Software Kubuntu 17.10, Win7 x64 SP1 Ultimate
Benchmark Scores Average....
#5
Xilisoft Video Converter?
 
Joined
Oct 2, 2005
Messages
2,913 (0.65/day)
Likes
659
Location
Baltimore MD
Processor FX-8320@ 4.2Ghz
Motherboard Gigabyte 970A-UD3
Cooling Xigmatek S1283
Memory 2x4Gb Corsair 1600 9-9-9-24
Video Card(s) Sapphire RX-480 Nitro
Storage OCZ Vertex 3 120G, 1TB WD Black
Display(s) Dell S2330MX
Case Corsair Carbide Air 540
Audio Device(s) X-Fi Fatal1ty / 5.1 Logitech Z-5500
Power Supply Silverstone DA750
Software Win10 pro 64bit
#6
Its been quite a while since i messed with handbrake, whatever they did it works fine now.
Add source select HQ set to .mkv set subs and add to queue output looks the same only with DXVA it couldn't be easier thanks Mussels.