• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Reading a Damaged vBIOS, Step One XFX HD685x-zcfc

Joined
Sep 6, 2019
Messages
8 (0.04/day)
Location
Cambridge, MA
System Name AM2/AM3 board, Vista 32-bit OS, base memory on 128-bit bus
Processor Athlon II, 2X 245 at 2900MHz
Motherboard M4A875-m
Cooling std, air
Memory 2.0GB DDR2 800MHz
Video Card(s) ASUS EN8400GS - silent
Storage SATA III drive 500+ GB
Case low center of gravity, Thermalke, V-100
Audio Device(s) HD Audio, run on Kinter SS amp
Power Supply 600W
Mouse PS2
The AMD system board strongly objects to insertion of my XFX card to PCIe_16x.

XFX HD685x-zcfc


Card connected 15 December, however. {Manipulate the system of install new hardware.}
I performed tests through the AMD flash works and with the CPU-Z.2.28.0 for resultant operations.

An electronic signature was generated with output, and vbios replacement as well.

-
dev_recognze.jpg


-
dev_recognzed.jpg


==================================================================
Pre-install, and post-install bios ROMs were made with the GPU-Z.2.28.0.

Card information, and later, the tool to write-in another version were done with the 'amdvbiosflash'.
Post flash reading indicate continued problems of FAN works, and now it also appears to have memory access control eliminated as well as disabled GPU clock.
The temporary fan does not spin, whereas before, control existed to increase, level, and decrease rpm with the OEM fan (a degree of friction present).

-
gpuz_15dec_successFLASH.jpg
gpuZ_15dec_imgTOOL.jpg

-

A screen production from XFX HD685x-zcfc-v.2.0 (1024MB, DDR5) has yet to form.

The card serial number is MXY078819. White QC stickers at GPU clamp screws were fully intact. The fan was stiff.
I traded for it with a set of computer speakers. The vendor has not supplied useful info of any prior use.

-
flashe.jpg

-

A. Less memory addresses, can v-card clock a task at 775MHz? Are chips destroyed?

B. Is the OEM fan a sufficient and necessary condition for it to cool?

-
Windows information

System Name: AMD_SYS3
[Display]
Item Value
Name ATI Radeon HD 4200
PNP Device ID PCI\VEN_1002&DEV_9710&SUBSYS_83A21043&REV_00\4&8C88DC&0&2808
Adapter Type ATI display adapter (0x9710), ATI Technologies Inc. compatible
Adapter Description ATI Radeon HD 4200
Adapter RAM 256.00 MB (268,435,456 bytes)
Installed Drivers aticfx32.dll,aticfx32.dll,atiumdag.dll,atidxx32.dll,atiumdva.cap
Driver Version 8.14.01.6210
INF File oem3.inf (ati2mtag_RS880 section)
Color Planes Not Available
Color Table Entries Not Available
Resolution Not Available
Bits/Pixel Not Available
Memory Address 0xC0000000-0xCFFFFFFF
I/O Port 0x0000C000-0x0000CFFF
Memory Address 0xFE9F0000-0xFE9FFFFF
Memory Address 0xFE800000-0xFE9FFFFF
IRQ Channel IRQ 10
Driver c:\windows\system32\drivers\atikmpag.sys (8.14.1.6210, 238.00 KB (243,712 bytes), 4/20/2011 1:22 AM)

Name AMD Radeon HD 6800 Series
PNP Device ID PCI\VEN_1002&DEV_6739&SUBSYS_31171682&REV_00\4&35F9BA94&0&0010
Adapter Type Not Available, ATI Technologies Inc. compatible
Adapter Description AMD Radeon HD 6800 Series
Adapter RAM Not Available
Installed Drivers aticfx32.dll,aticfx32.dll,aticfx32.dll,atiumdag.dll,atidxx32.dll,atiumdva.cap
Driver Version 8.14.01.6210
INF File oem3.inf (ati2mtag_NI section)
Color Planes Not Available
Color Table Entries Not Available
Resolution Not Available
Bits/Pixel Not Available
Driver c:\windows\system32\drivers\atikmpag.sys (8.14.1.6210, 238.00 KB (243,712 bytes), 4/20/2011 1:22 AM)

========================================================
XFX_mfg_tags.jpg

-

A. Less memory addresses, can v-card clock a task at 775MHz? Are chips destroyed?

B. Is the OEM fan a sufficient and necessary condition for it to cool?

Thank you for your interest.
 

Attachments

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,356 (6.52/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Pull the heatsink and get a pic of the ram on the card
 
Joined
Sep 6, 2019
Messages
8 (0.04/day)
Location
Cambridge, MA
System Name AM2/AM3 board, Vista 32-bit OS, base memory on 128-bit bus
Processor Athlon II, 2X 245 at 2900MHz
Motherboard M4A875-m
Cooling std, air
Memory 2.0GB DDR2 800MHz
Video Card(s) ASUS EN8400GS - silent
Storage SATA III drive 500+ GB
Case low center of gravity, Thermalke, V-100
Audio Device(s) HD Audio, run on Kinter SS amp
Power Supply 600W
Mouse PS2

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,356 (6.52/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
The wrong bios is on the card that's the reason why it is not working correctly I will find you the proper bios for that card

For reference https://www.amazon.com/XFX-TECHNOLOGIES-HD-685X-ZCFC/dp/B016YJVJYQ


Download this tool, open it in windows and find the bios file you downloaded and flash.


Here are Verified bios files for your specific card (HD-685X-ZCFC) with Elpida ram


Download this bios first and try it,
Bios Build date 2011 09 20 no UEFI support (Latest Bios)

Bios Build date 2011 08 15 no UEFI support

Bios Build date 2011 07 21 no UEFI Support

These are Unverified bios files

Bios Build date 2011 09 20 no UEFI support (Latest)

Bios Build date 2011 07 21 no UEFI support
 
Last edited:
Joined
Sep 6, 2019
Messages
8 (0.04/day)
Location
Cambridge, MA
System Name AM2/AM3 board, Vista 32-bit OS, base memory on 128-bit bus
Processor Athlon II, 2X 245 at 2900MHz
Motherboard M4A875-m
Cooling std, air
Memory 2.0GB DDR2 800MHz
Video Card(s) ASUS EN8400GS - silent
Storage SATA III drive 500+ GB
Case low center of gravity, Thermalke, V-100
Audio Device(s) HD Audio, run on Kinter SS amp
Power Supply 600W
Mouse PS2
Does TechPowerUp work with the saved (stored) BIOS material?
Thank you for your interest.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,356 (6.52/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Does TechPowerUp work with the saved (stored) BIOS material?
Thank you for your interest.
No need to, rest assured the bios already on your card which is incorrect is in the vga bios collection. I however gave you several files that are specific to your card. So download 1 file and flash it to your card.

Now if you need a bios modified you need radeon bios editor.
 
Joined
Sep 6, 2019
Messages
8 (0.04/day)
Location
Cambridge, MA
System Name AM2/AM3 board, Vista 32-bit OS, base memory on 128-bit bus
Processor Athlon II, 2X 245 at 2900MHz
Motherboard M4A875-m
Cooling std, air
Memory 2.0GB DDR2 800MHz
Video Card(s) ASUS EN8400GS - silent
Storage SATA III drive 500+ GB
Case low center of gravity, Thermalke, V-100
Audio Device(s) HD Audio, run on Kinter SS amp
Power Supply 600W
Mouse PS2
2019 season's greetings!

seems the vBIOS pictures above represent what I had installed.
perhaps, the 110721 which was installed just to put something recognizable inside was the better performance.
I do not recall if that BIN format was the one.

The one current status, which all of the reports are based, is that 110920.
The five option choice have unverified files.
If the 20110920 file I had selected for latest of choices was the unverified, how does one determine that?

New file installation has been updated to < 013.012.000.025.000000 > vBIOS. (temp fan does not spin)
-
revert_VbiosXFX685xzcf.jpg

-
this is the latest. Please note upon installing card that works, GPU-Z reported that same thing on 0.00 ram and for the clock speed as 0, but later made the asusGT8400GS restoration through normal dev Install.

XFX685xzcf housing (fan cover) has this tag/sticker as well: "80-687x.00SB-NTK" / "N1138S-1" label w/o UPC bar.
Don't know what that is.
Best regards,
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,356 (6.52/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
2019 season's greetings!

seems the vBIOS pictures above represent what I had installed.
perhaps, the 110721 which was installed just to put something recognizable inside was the better performance.
I do not recall if that BIN format was the one.

The one current status, which all of the reports are based, is that 110920.
The five option choice have unverified files.
If the 20110920 file I had selected for latest of choices was the unverified, how does one determine that?

New file installation has been updated to < 013.012.000.025.000000 > vBIOS. (temp fan does not spin)
-
View attachment 140616
-
this is the latest. Please note upon installing card that works, GPU-Z reported that same thing on 0.00 ram and for the clock speed as 0, but later made the asusGT8400GS restoration through normal dev Install.

XFX685xzcf housing (fan cover) has this tag/sticker as well: "80-687x.00SB-NTK" / "N1138S-1" label w/o UPC bar.
Don't know what that is.
Best regards,
The top 1s are verified, its possible the fan is dead
 
Joined
Sep 6, 2019
Messages
8 (0.04/day)
Location
Cambridge, MA
System Name AM2/AM3 board, Vista 32-bit OS, base memory on 128-bit bus
Processor Athlon II, 2X 245 at 2900MHz
Motherboard M4A875-m
Cooling std, air
Memory 2.0GB DDR2 800MHz
Video Card(s) ASUS EN8400GS - silent
Storage SATA III drive 500+ GB
Case low center of gravity, Thermalke, V-100
Audio Device(s) HD Audio, run on Kinter SS amp
Power Supply 600W
Mouse PS2
Radeon HD 685x-zcf version 2
27 February 2020
Additional Data

Video card status, answering the Post of 18 Dec 2019

Examples use the very same system, suggestion from site: <https://pcpartpicker.com/product/DNCwrH> where amd board likes the HD6850.​
January 2020, trial on Windows system.
TPU tools, CPU-Z v. 2.29 and amdvbflash Utility.

Procedure
Status check, what's here, "amdvbflash -ai" ?
Unlock rom. Replace VBIOS content in video card with bin file version.
Completion
Windows10 reports of "atikmdag.sys" upon UPDATE of driver files.​
"SYSTEM_SERVICE_EXCEPTION" on APP gpu-z, and​
beyond the vga files, stops installation "SYSTEM_THREAD_EXCEPTION_NOT_HANDLED" notice that device file fails.​

xfx865xzcf_infoB_id_17jan.jpg


xfx865xzcf_infoC_id_17jan.jpg

xfx865xzcf_infoD_id_17jan.jpg


System rejects device,
Start Win10pro install driver
xfx865xzcf_18jan.jpg

.
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,356 (6.52/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Sep 6, 2019
Messages
8 (0.04/day)
Location
Cambridge, MA
System Name AM2/AM3 board, Vista 32-bit OS, base memory on 128-bit bus
Processor Athlon II, 2X 245 at 2900MHz
Motherboard M4A875-m
Cooling std, air
Memory 2.0GB DDR2 800MHz
Video Card(s) ASUS EN8400GS - silent
Storage SATA III drive 500+ GB
Case low center of gravity, Thermalke, V-100
Audio Device(s) HD Audio, run on Kinter SS amp
Power Supply 600W
Mouse PS2
Absolutely.
Question: the comment on the fan being non-functioning, Are you saying the FAN Circuits are burnt/disrupted?
There is a temporary fan in place, reasoning that drag and increased friction may affect the circuitry, or bias it in ways the board circuits disagree with a fan rated hundreds of milli-amps lower. (I may have the 3-pin new fan incorrectly connected. That fan is not fried.)
 
Last edited:
Top