• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Realtek DCH Modded Audio Driver for Windows 10/11 - Only for HDAUDIO

NightHunter

New Member
Joined
Oct 13, 2023
Messages
2 (0.01/day)
anyone had issues with 5.1 sound?
i am using 3 aux out for 5.1 on a asus tuf motherboard x570 but only stereo works whenever i set Speakers/headphones configuration to 5.1 no sound will come out
 
Joined
Dec 10, 2014
Messages
1,325 (0.39/day)
Location
Nowy Warsaw
System Name SYBARIS
Processor AMD Ryzen 5 3600
Motherboard MSI Arsenal Gaming B450 Tomahawk
Cooling Cryorig H7 Quad Lumi
Memory Team T-Force Delta RGB 2x8GB 3200CL16
Video Card(s) Colorful GeForce RTX 2060 6GV2
Storage Crucial MX500 500GB | WD Black WD1003FZEX 1TB | Seagate ST1000LM024 1TB | WD My Passport Slim 1TB
Display(s) AOC 24G2 24" 144hz IPS
Case Montech Air ARGB
Audio Device(s) Massdrop + Sennheiser PC37X | QKZ x HBB
Power Supply Corsair CX650-F
Mouse Razer Viper Mini | Cooler Master MM711 | Logitech G102 | Logitech G402
Keyboard Drop + The Lord of the Rings Dwarvish
Software Windows 10 Education 22H2 x64
I only want DTS Headphone:X and Dolby Atmos for Gaming. Do I need to install AAF Optimus Bus Driver and Realtek ASIO Controller? Like are these two dependencies or sth?
 
Joined
Mar 1, 2017
Messages
1,151 (0.45/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DarkFlash DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF DCH Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Software Windows 11 Pro x64 23H2
Joined
Sep 28, 2012
Messages
962 (0.23/day)
System Name Poor Man's PC
Processor AMD Ryzen 5 7500F
Motherboard MSI B650M Mortar WiFi
Cooling ID Cooling SE 206 XT
Memory 32GB GSkill Flare X5 DDR5 6000Mhz
Video Card(s) Sapphire Pulse RX 6800 XT
Storage XPG Gammix S70 Blade 2TB + 8 TB WD Ultrastar DC HC320
Display(s) Mi Gaming Curved 3440x1440 144Hz
Case Cougar MG120-G
Audio Device(s) MPow Air Wireless + Mi Soundbar
Power Supply Enermax Revolution DF 650W Gold
Mouse Logitech MX Anywhere 3
Keyboard Logitech Pro X + Kailh box heavy pale blue switch + Durock stabilizers
VR HMD Meta Quest 2
Benchmark Scores Who need bench when everything already fast?
@AAF Optimus It seems your driver doesn't work on Realtek ALC4080 which is USB based chip embedded in my motherboard. I've tried simple PID and VID hardware mod but Windows 11 refuses to acknowledge.
Oh and thank you for supporting me with with your fantastic driver for all these year :toast:
 

NightHunter

New Member
Joined
Oct 13, 2023
Messages
2 (0.01/day)
anyone had issues with 5.1 sound?
i am using 3 aux out for 5.1 on a asus tuf motherboard x570 but only stereo works whenever i set Speakers/headphones configuration to 5.1 no sound will come out
weird it was signal enhancements that was doing it.
if i disable it i get sound but i dont think sound blaster works
1697347068474.png
 
Joined
Dec 8, 2020
Messages
2,686 (2.28/day)
I know someone who tried both, in some cases it depends, but DTS most probably. If we are talking HDMI, DTS:X has lower latency and better quality.

@frknaknc, it may also depend on the receiver and setup, how much latency you get with HDMI. 500ms = 1/2 a second.
 

Attachments

  • Interesting.png
    Interesting.png
    431.7 KB · Views: 109
  • DTS-X Home Theatre.png
    DTS-X Home Theatre.png
    11.8 KB · Views: 105
Last edited:

wilburman

New Member
Joined
Mar 24, 2021
Messages
17 (0.02/day)
CLARIFICATION: Due to some accusations against me for allegedly including types of viruses or including fraudulent codes for data collection, cryptocurrency mining and other purposes, from now on, when the installation of the packages is finished, a copy of the original script in text file format on Desktop. In this file, the user will have full knowledge of the procedures that I have included in the installer.

What a guy, extra mile! Jus wow! Wish more developers out there would be this great! Thanks Alan XD @AAF Optimus
 

lenovolegion5

New Member
Joined
Oct 16, 2023
Messages
1 (0.01/day)
This driver is unstable on my system. Lenovo Legion 5 2021. Windows 11 Insider Preview Build 23565. The driver installs and is functional for about 30 minutes after which the audio is silent. I have to open control panel > sounds, and go to my speaker and toggle enable/disable audio enhancements for the sound to work again. I'm not sure what is the cause of the issue but I have already uninstalled and reinstalled it (PROPERLY) multiple times. How do I file a bug report?
 

silentbogo

Moderator
Staff member
Joined
Nov 20, 2013
Messages
5,467 (1.46/day)
Location
Kyiv, Ukraine
System Name WS#1337
Processor Ryzen 7 3800X
Motherboard ASUS X570-PLUS TUF Gaming
Cooling Xigmatek Scylla 240mm AIO
Memory 4x8GB Samsung DDR4 ECC UDIMM
Video Card(s) Inno3D RTX 3070 Ti iChill
Storage ADATA Legend 2TB + ADATA SX8200 Pro 1TB
Display(s) Samsung U24E590D (4K/UHD)
Case ghetto CM Cosmos RC-1000
Audio Device(s) ALC1220
Power Supply SeaSonic SSR-550FX (80+ GOLD)
Mouse Logitech G603
Keyboard Modecom Volcano Blade (Kailh choc LP)
VR HMD Google dreamview headset(aka fancy cardboard)
Software Windows 11, Ubuntu 20.04 LTS
This driver is unstable on my system. Lenovo Legion 5 2021. Windows 11 Insider Preview Build 23565. The driver installs and is functional for about 30 minutes after which the audio is silent. I have to open control panel > sounds, and go to my speaker and toggle enable/disable audio enhancements for the sound to work again. I'm not sure what is the cause of the issue but I have already uninstalled and reinstalled it (PROPERLY) multiple times. How do I file a bug report?
I don't think it's an issue with this particular driver, it's more of a Win11 issue in general. Had two Lenovo laptops in my workshop(10th gen Ideapad and 10th gen Legion 5), both had similar symptoms with stock driver. Headphones would only work if I did the same thing with "audio enhancements". After unplugging - all sound was gone. Rolled back to win10 and all issues disappeared.
 

Ahhzz

Moderator
Staff member
Joined
Feb 27, 2008
Messages
8,675 (1.48/day)
System Name OrangeHaze / Silence
Processor i7-13700KF / i5-10400 /
Motherboard ROG STRIX Z690-E / MSI Z490 A-Pro Motherboard
Cooling Corsair H75 / TT ToughAir 510
Memory 64Gb GSkill Trident Z5 / 32GB Team Dark Za 3600
Video Card(s) Palit GeForce RTX 2070 / Sapphire R9 290 Vapor-X 4Gb
Storage Hynix Plat P41 2Tb\Samsung MZVL21 1Tb / Samsung 980 Pro 1Tb
Display(s) 22" Dell Wide/24" Asus
Case Lian Li PC-101 ATX custom mod / Antec Lanboy Air Black & Blue
Audio Device(s) SB Audigy 7.1
Power Supply Corsair Enthusiast TX750
Mouse Logitech G502 Lightspeed Wireless / Logitech G502 Proteus Spectrum
Keyboard K68 RGB — CHERRY® MX Red
Software Win10 Pro \ RIP:Win 7 Ult 64 bit
This driver is unstable on my system. Lenovo Legion 5 2021. Windows 11 Insider Preview Build 23565. The driver installs and is functional for about 30 minutes after which the audio is silent. I have to open control panel > sounds, and go to my speaker and toggle enable/disable audio enhancements for the sound to work again. I'm not sure what is the cause of the issue but I have already uninstalled and reinstalled it (PROPERLY) multiple times. How do I file a bug report?
As a Windows 11 Insider Preview user, I would definitely contact M$ via their Feedback channel (https://www.microsoft.com/en-us/windowsinsider/feedback) for bugs. Thanks!
 

frknaknc

New Member
Joined
Oct 13, 2023
Messages
8 (0.06/day)
I know someone who tried both, in some cases it depends, but DTS most probably. If we are talking HDMI, DTS:X has lower latency and better quality.

@frknaknc, it may also depend on the receiver and setup, how much latency you get with HDMI. 500ms = 1/2 a second.
I have tested, DTS X Ultra is better than Dolby Atmos in music, DTS is now your favorite
 

Karim HI

New Member
Joined
May 21, 2023
Messages
9 (0.03/day)
guys please help I installed everything correctly but I don't have dts headphone x in spatial sounds
 

redefined sugar

New Member
Joined
Oct 17, 2023
Messages
1 (0.01/day)
@Optimus
Coming from 9468, 9575 brings back DTSi/DDL sound to my Realtek ALC1220 @ MEG X570 Unify with newes driver package.
I'm very happy to spare myself the texting now.

By the way. When deselecting the unwanted stuff in the install menu every time, it's hard to tell the difference between the two shades of blue in the little blue boxes. Could you please spice up the user interface a bit?
 
Joined
Dec 15, 2018
Messages
28 (0.01/day)
I've noticed a weird thing, if i have Equalizer APO installed and turn on, it seems that it makes conflicts somehow with the mod.
To be clearer, for example, Nahimic wasn't giving me surround sound with headphones, but when i turned off EQ APO the surround was back (even though without a subwoofer channel have no idea why)
 

czesio666

New Member
Joined
Dec 16, 2022
Messages
11 (0.03/day)
Is there any way to have "speakers fill" on ALC1200? I have B550 AORUS ELITE V2 (ALC1200), win10 and tried official Gigabyte drivers, patched drivers and AFF. Still doesn't work. On 5.1 speakers (3x jack connection) 2.0 streams are played on front speakers only.

When I was using Gigabyte X48-DQ6 with chipset ALC889A I used original driver 2.70 from gigabyte (DTS was supported in default, no need to patch). Then turning DTS on allows playing 2.0 streams on all speakers. Now, on new motherboard, turning DTS on in speakers settings does nothing. Still, front speakers are playing. Of course, 5.1 streams are playing correctly. Is there any way to fix it?
 

Ruki

New Member
Joined
Jan 28, 2022
Messages
4 (0.01/day)
The Nahimic app inside the Microsoft Store has been updated to version 1.9.22.
 

admgloval

New Member
Joined
Sep 13, 2023
Messages
5 (0.03/day)
Is there any way to have "speakers fill" on ALC1200? I have B550 AORUS ELITE V2 (ALC1200), win10 and tried official Gigabyte drivers, patched drivers and AFF. Still doesn't work. On 5.1 speakers (3x jack connection) 2.0 streams are played on front speakers only.

When I was using Gigabyte X48-DQ6 with chipset ALC889A I used original driver 2.70 from gigabyte (DTS was supported in default, no need to patch). Then turning DTS on allows playing 2.0 streams on all speakers. Now, on new motherboard, turning DTS on in speakers settings does nothing. Still, front speakers are playing. Of course, 5.1 streams are playing correctly. Is there any way to fix it?
It took me awhile to figure this out but if you want all of the effect type options to appear in the Realtek console (EQ, Bass Mgmt, Room Correction, Speaker Fill etc.), you need to uncheck everything except for Realtek patched driver (DDL/DTS). I thought you also needed the AAF Optimus bus driver but someone asked above and Alan replied that it is optional (not sure what it does honestly). You could also install the ASIO driver if you ever plan on using your onboard sound card as an audio interface with a DAW for guitar or vocals but idk anyone who actually does that. I have a separate USB interface for recording.
 

czesio666

New Member
Joined
Dec 16, 2022
Messages
11 (0.03/day)
It took me awhile to figure this out but if you want all of the effect type options to appear in the Realtek console (EQ, Bass Mgmt, Room Correction, Speaker Fill etc.), you need to uncheck everything except for Realtek patched driver (DDL/DTS). I thought you also needed the AAF Optimus bus driver but someone asked above and Alan replied that it is optional (not sure what it does honestly). You could also install the ASIO driver if you ever plan on using your onboard sound card as an audio interface with a DAW for guitar or vocals but idk anyone who actually does that. I have a separate USB interface for recording.
Performed clean install once again. Unchecked everything except for Realtek patched driver (DDL/DTS). Still there is no speaker fill option. DTS on does change nothing, still 2.0 streams are played on front speakers only.

Edit:
I've figure it out. Finally installed "some"drivers that have speakers fill. Now I will check if it dependent on drivers or on specific driver uninstall procedure. I will give more information soon.
 

Attachments

  • rac.jpg
    rac.jpg
    231.8 KB · Views: 93
Last edited:

admgloval

New Member
Joined
Sep 13, 2023
Messages
5 (0.03/day)
Performed clean install once again. Unchecked everything except for Realtek patched driver (DDL/DTS). Still there is no speaker fill option. DTS on does change nothing, still 2.0 streams are played on front speakers only.

Edit:
I've figure it out. Finally installed "some"drivers that have speakers fill. Now I will check if it dependent on drivers or on specific driver uninstall procedure. I will give more information soon.
Weird, guess things are different for various mobos/chipsets. It did work for me, I have an Asus Tuf Gaming X570 Pro board with ALCS1200A Realtek chip. Another option would be to install either Nahimic or Sonic Sound Studio and use those for their EQ and effects but I am not sure if they have a speaker fill type option in them. I have never had to use the speaker fill option myself, when I setup the 5.1 speakers in the Realtek console and enable the Bass Mgmt option, I hear sound out of all my speakers including the sub in everything I do in Windows. Using the Asus supplied drivers, I would only hear 5.1 in sources that were specifically encoded for it like games or movies viewed in VLC. One thing I noticed in your screenshot is you left the 'Full Range Speakers' checkboxes checked for your front and surround speakers. I uncheck those as I don't want bass coming from those speakers, just from my sub. I actually have an Onkyo receiver I use along with component Klipsch 2 way speakers from an old Klipsch PC 5.1 speaker set I had plus a powered Sony 10" subwoofer. The amplifier in the Klipsch sub died years ago so I replaced it with the Onkyo receiver and run analog outs to the analog ins on the receiver. I guess you could say it's a clunky setup but it works for me and the receiver was an old one I had sitting around so worked out well. It's hard to even find a receiver anymore that has separate analog inputs for surround.
 

czesio666

New Member
Joined
Dec 16, 2022
Messages
11 (0.03/day)
Ok. I've tried method and drivers from that site:
ASUS Realtek drivers

And then speaker fill option appeared. Thus, I think it was a problem that official gigabyte drivers were still existing in the system. Now each time I install new drivers I follow this procedure:


CLEANUP

1. Uninstall Realtek (HD) Audio Driver, Realtek Audio Control/Console, Sonic Studio III, Sonic Radar III installed
2. Uninstall Realtek device from Device manager (if exist), check Delete driver software for this device
3. Launch Driver Store Explorer > Check the boxes of all versions of drivers which .inf starts with (if you find them) :
a-volute | avolute | dts | hdx | realtek
Check the box "Force Deletion" then click on the "Delete Driver(s)" button
4.Delete C:\Program Files (x86)\Realtek\Audio

Then new drivers can be installed. I've tried AAF and those from ASUS page. Both have speakers fill option.

But now after installing AAF Realtek DDL/DTS Patched, I have no DTS Connect !!!!
I have no idea what is going on.

Summarizing:
- AAF (DTS patched) and ASUS drivers with replaced patched dll give speaker fill without DTS
- original drivers from Gigabyte with replaced patched dll gives DTS but no speaker fill

WIth speaker fill it works as I want. 5.1 stream is played correctly on corresponding speaker, 2.0 is filled to all speakers. Tested on music/video files and in browser (HTML test). But it doesn't work in youtube. Tried with different browsers. What the hell ????

Maybe you have receiver that have speaker fill built-in. I have rather old 5.1 speakers from Logitech connected with 3 jacks with matrix function that should do something like speaker fill. But it cannot distinguish how many channels source audio has. Thus, 2.0 are played on all speakers (that is correct) but 5.1 is also mixed so, one single channel is played on all speakers. That is why I need Realtek hardware speakers fill because it will not be used on 5.1 streams.
 
Last edited:

admgloval

New Member
Joined
Sep 13, 2023
Messages
5 (0.03/day)
Ok. I've tried method and drivers from that site:
ASUS Realtek drivers

And then speaker fill option appeared. Thus, I think it was a problem that official gigabyte drivers were still existing in the system. Now each time I install new drivers I follow this procedure:


CLEANUP

1. Uninstall Realtek (HD) Audio Driver, Realtek Audio Control/Console, Sonic Studio III, Sonic Radar III installed
2. Uninstall Realtek device from Device manager (if exist), check Delete driver software for this device
3. Launch Driver Store Explorer > Check the boxes of all versions of drivers which .inf starts with (if you find them) :
a-volute | avolute | dts | hdx | realtek
Check the box "Force Deletion" then click on the "Delete Driver(s)" button
4.Delete C:\Program Files (x86)\Realtek\Audio

Then new drivers can be installed. I've tried AAF and those from ASUS page. Both have speakers fill option.

But now after installing AAF Realtek DDL/DTS Patched, I have no DTS Connect !!!!
I have no idea what is going on.

Summarizing:
- AAF (DTS patched) and ASUS drivers with replaced patched dll give speaker fill without DTS
- original drivers from Gigabyte with replaced patched dll gives DTS but no speaker fill

WIth speaker fill it works as I want. 5.1 stream is played correctly on corresponding speaker, 2.0 is filled to all speakers. Tested on music/video files and in browser (HTML test). But it doesn't work in youtube. Tried with different browsers. What the hell ????

Maybe you have receiver that have speaker fill built-in. I have rather old 5.1 speakers from Logitech connected with 3 jacks with matrix function that should do something like speaker fill. But it cannot distinguish how many channels source audio has. Thus, 2.0 are played on all speakers (that is correct) but 5.1 is also mixed so, one single channel is played on all speakers. That is why I need Realtek hardware speakers fill because it will not be used on 5.1 streams.
I looked at my PC again today at lunch and you are right, Speaker Fill is missing. I know I remember seeing it there at some point but I never used it since the times I tried it before, it seemed to give all audio a 'phased' kind of sound to it. With the AAF Optimus drivers, as long as I setup my speakers as 5.1, disable the Full Range Speakers options and enable Bass Mgmt, I get audio out of all my speakers automatically for all types of audio. But with the Asus drivers, I only got 2 channel for things like MP3's, Youtube, etc, basically almost all normal windows audio. Also, I do not enable DTS as I don't really see the point it it. I don't hear any improvement in audio quality by enabling it (I thought it was mostly for headphones anyway but maybe I am wrong about that).
 
Joined
Dec 8, 2020
Messages
2,686 (2.28/day)
@czesio666, find a driver you want to use, ideally install it with a clean run, so ALL other drivers-extensions-software components related to the Realtek device are fully removed.
Once you have removed all Realtek sound drivers from the computer (sometimes there can be quite a few), you can go ahead and install the driver of choice.

If you don't care about Realtek SFX or other APO's on SFX, you can replace it with Equalizer APO (see here, skip step 1B).

If I remember correctly there is-was an issue with the patched version, not setting up 6 channels for SFX-MFX, where 'disable enhancements', fixes it because it disables SFX-MFX.
Some people are ok with that, and are happy running raw to EFX to get 6 channels, but you lose SFX-MFX processing, and any quality improvements-features.

Upmixing is done on SFX, so unless SFX is setup properly as 6 channels it probably wont do anything at all.

----

Stereo upmixers are coded to detect 2 channel streams, which is 100% correct, however web browsers and some apps-games will stream the number of channels it detects.
So even if you get 6 channels throughout the Windows audio engine (SFX-MFX-EFX), the above will only populate [x] channels with audio.

In short, web browsers connect to my SPDIF as a 6 channel stream, I play stereo audio, so only left-right is populated with audio, upmixer detects 6 channels.

YouTube (Edge).png

As you can see no upmixing occurred, there are 6 channels.
 

Attachments

  • DTS DCH Speakers.png
    DTS DCH Speakers.png
    500.8 KB · Views: 134
Joined
Jan 18, 2016
Messages
121 (0.04/day)
Location
Brasil
System Name Windows 10: Pro Insider x64
Processor i5-3570
Motherboard MSI P67s-C43 B3
Cooling Stock
Memory 16GB DDR3 1333mHz
Video Card(s) GTX 680
Storage 2x Seagate 1TB 6Gbs 1x SSD 128GB
Display(s) LG 23" FLATRON E2355
Case THERMALTAKE CHASER MK-I
Audio Device(s) Receiver Onkyo Tx-NR 757
Power Supply C3 TECH 750W
Mouse THERMALTAKE PHERON
Keyboard A4TECH LED MULTIMEDIA
Chrome had an update a long time ago that disabled channel filling.
and because of this we need to use cmd line in the shortcut
try one of these:
--try-supported-channel-layouts
--force-wave-audio
--disable-audio-output-resampler


will look like this:
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --try-supported-channel-layouts
 
Joined
Feb 15, 2019
Messages
64 (0.03/day)
Ok. I've tried method and drivers from that site:
ASUS Realtek drivers

And then speaker fill option appeared. Thus, I think it was a problem that official gigabyte drivers were still existing in the system. Now each time I install new drivers I follow this procedure:


CLEANUP

1. Uninstall Realtek (HD) Audio Driver, Realtek Audio Control/Console, Sonic Studio III, Sonic Radar III installed
2. Uninstall Realtek device from Device manager (if exist), check Delete driver software for this device
3. Launch Driver Store Explorer > Check the boxes of all versions of drivers which .inf starts with (if you find them) :
a-volute | avolute | dts | hdx | realtek
Check the box "Force Deletion" then click on the "Delete Driver(s)" button
4.Delete C:\Program Files (x86)\Realtek\Audio

Then new drivers can be installed. I've tried AAF and those from ASUS page. Both have speakers fill option.

But now after installing AAF Realtek DDL/DTS Patched, I have no DTS Connect !!!!
I have no idea what is going on.

Summarizing:
- AAF (DTS patched) and ASUS drivers with replaced patched dll give speaker fill without DTS
- original drivers from Gigabyte with replaced patched dll gives DTS but no speaker fill

WIth speaker fill it works as I want. 5.1 stream is played correctly on corresponding speaker, 2.0 is filled to all speakers. Tested on music/video files and in browser (HTML test). But it doesn't work in youtube. Tried with different browsers. What the hell ????

Maybe you have receiver that have speaker fill built-in. I have rather old 5.1 speakers from Logitech connected with 3 jacks with matrix function that should do something like speaker fill. But it cannot distinguish how many channels source audio has. Thus, 2.0 are played on all speakers (that is correct) but 5.1 is also mixed so, one single channel is played on all speakers. That is why I need Realtek hardware speakers fill because it will not be used on 5.1 streams.
Try cleaning your drivers again, installing AAF driver with whatever features you pick, after install is finished add {62dc1a93-ae24-464c-a43e-452f824c4250} key to your composite stream SFX registry on the endpoint you want up mixed. This is the microsoft apo key.
 
Top