• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Realtek DCH Modded Audio Driver for Windows 10

ravipe

New Member
Joined
Apr 29, 2021
Messages
1 (0.07/day)
Ola Alan! Firstly thank you for your hard work and support you provide the community.

My desktop (motherboard Gigabyte Aorus B550i Pro Ax, Realtek ALC1220-VB, version installed is R2.82) is connected to a receiver (Denon X1600H) which is connected to my LG E9 tv. I have tried installing your AAF DCH Optimus Sound 6.0.9147.1 (Signed) (didn't change any option during installation, except of course enabling developer mode on windows settings) but still can't get the my videos to output proper surround sound. Sound is still only coming from my front speakers. If you could please provide some help that would be fantastic. Muito obrigado!
 
Joined
Jul 18, 2020
Messages
69 (0.23/day)
@Alan Finotty .Alan hello. I decided to deal with Dts ultra and understand what's going on. Other amps are working. I removed your driver and installed it from Ferather. He had other errors-it was Dts ultra that was important to me. (I'll describe the problems later) The motherboard I have Asus Rampage III alc 889) Removed its driver and put it in a clean one again. DtS unboard was not installed during installation. I tried to install it manually from the files that appear in the temp folder when installing your driver. I gave this error. I installed the same version from the Ferather files - it was installed. But the Ultra problem remains, although the other amps all work.
 

Attachments

  • ошибка.jpg
    ошибка.jpg
    63.5 KB · Views: 81
Joined
Dec 8, 2020
Messages
723 (4.61/day)
You are doing something wrong, or you have past extensions or drivers on your system.
 

Maksim999

New Member
Joined
Apr 29, 2021
Messages
2 (0.13/day)
Hello everyone, thank you for the work done and the entire sound software package. I have a few questions, if knowledgeable people would not be difficult to answer. I have a built-in Realtek ALC236 sound card. It makes quite a lot of noise when loading the processor, moving the mouse cursor. This can be heard if you connect your laptop to an amp or in headphones. On one of the resources, I found drivers for the realtek sound card and dolby advanced audio software. Oh, a miracle! The noise disappeared and the sound became much more filtered. And how I liked the volume equalization option and the equalizer! But there was one problem because of which I had to abandon them - a loud click in the acoustics after a pause between sounds! This was not only annoying, but also unsafe for acoustics. Not so long ago, I decided to try the drivers from Alan from this topic. I chose to install the Dolby access codec, along with additional software and an application from realtek, but nothing worked. Could you tell us which software is better for stereo audio output? I really liked the Dolby volume smoothing feature and the equalizer as well. Maybe there are some analogues? Maybe DTS, what can you say about it?I also wonder, maybe there is a minimum set, where there will only be a driver for manual installation and software for management? Without unnecessary and additional programs that will be installed without demand. Thank you in advance for the information.
 
Joined
Feb 18, 2018
Messages
65 (0.06/day)
DOWNLOAD MY DRIVERS FROM HERE:
DCH-UAD VERSION (RECOMMENDED)

STANDARD VERSION

DCH DRIVER VERSION UPDATED TO 6.0.9147.1
HDA PANEL INCLUDED IN DCH DRIVER


  • REALTEK DEFAULT EFFECTS
  • CREATIVE SOUND BLASTER X-Fi MB5
  • REALTEK DEFAULT EFFECTS
  • CREATIVE SOUND BLASTER X-Fi MB5
  • ASIO EXTRA
  • REALTEK DEFAULT EFFECTS
  • REALTEK DEFAULT EFFECTS WITH DDL/DTS
  • CREATIVE SOUND BLASTER CONNECT 2 (LEGACY)
    • 360°
    • 720°
  • NAHIMIC 3
  • SONIC STUDIO 3 (ASUS ROG)
  • SONIC RADAR 3 SUPPORTED
  • DOLBY ATMOS
  • DOLBY DIGITAL (OVERRIDE)
  • DTS INTERACTIVE (OVERRIDE)
  • REALTEK ASIO
  • REALTEK DEFAULT EFFECTS WITH DOLBY DIGITAL LIVE & DTS INTERACTIVE
  • REALTEK DEFAULT EFFECTS WITH DOLBY DIGITAL
  • CREATIVE SOUND BLASTER CONNECT (UWP)
    • 360°
    • 720°
    • CINEMA 5
  • NAHIMIC 3 (APO v3)
  • SONIC STUDIO 3 (ASUS ROG) (APO v3)
  • SONIC STUDIO 3 (ASUS ROG) (APO v4)
  • SONIC RADAR 3 SUPPORTED
  • DOLBY ATMOS SPEAKER SYSTEM
  • DOLBY ATMOS FOR GAMING
  • DTS:X ULTRA
  • DTS SOUND UNBOUND
IMAGES (WINDOWS 10)
CREATIVE PANEL (LEGACY)
View attachment 145072
REALTEK AUDIO CONSOLE (UWP)
View attachment 159335
View attachment 159540

CREATIVE PANEL (UWP)
View attachment 158671
NAHIMIC 3
View attachment 133729

SONIC STUDIO 3 (ASUS ROG)
View attachment 156931

View attachment 156932

View attachment 156933


SCOUT RADAR 3 (NOT INCLUDED, BUT SUPPORT ENABLED)
View attachment 156935

View attachment 156936

DOLBY ATMOS
View attachment 143507

ATTENTION: If the Sound Blaster, if installed, is unable to detect your audio device correctly, the executable that will allow you to restore this operation is attached.

DOWNLOAD KGA CONFIG EXECUTABLE

ENJOY !!!
asus 887 DTS:X Ultra not available :(
 

Attachments

  • 2021-05-01_170438.png
    2021-05-01_170438.png
    51.9 KB · Views: 53
Joined
Dec 8, 2020
Messages
723 (4.61/day)
@Maksim999, this has been bothering me for a while, turns out its a problem with the Realtek drivers: RTKVHD64.sys or RTAIODAT.dat.
I tried everything, including removing all APO's and using just basic Realtek codes, even depop options using the tool.

As you said, it can only be reduced by protective enhancers, in my case DTS:X APO4 (SRS).

----

I managed to get it down to stop-start pop, which is more of a too fast pop (spamming windows alert sound).
If I make the alerts come at a normal pace, I get no pop-noise at all, so its a speed thing.

 
Last edited:

pyuras

New Member
Joined
Jan 18, 2021
Messages
20 (0.17/day)
@Alan Finotty @Ferather I've encountered a problem with "The Medium" game pass edition and driver version 6.0.9129.1. The game loses sound until I go to the audio settings screen. If I die and reload, the sound goes out again until I go back to that audio screen. I don't need to change any settings in the audio screen, just opening it gets the sound back. It didn't happen in previous versions of the driver, IIRC. I'll install older versions again to test if this is, indeed, the case. I'll report back.
 
Joined
Dec 8, 2020
Messages
723 (4.61/day)
Unfortunately I don't know which version of AAF to suggest for that particular issue. Are you using SPDIF?
 
Joined
Feb 18, 2018
Messages
65 (0.06/day)
asus b150m et series 887 DTS:X Ultra not available :(
 

Attachments

  • 2021-05-02_020226.png
    2021-05-02_020226.png
    201.1 KB · Views: 76
  • 2021-05-02_020247.png
    2021-05-02_020247.png
    1.4 MB · Views: 74
  • 2021-05-02_021241.png
    2021-05-02_021241.png
    85 KB · Views: 84
  • 2021-05-02_023129.png
    2021-05-02_023129.png
    776.4 KB · Views: 69
  • 2021-05-02_023218.png
    2021-05-02_023218.png
    782.3 KB · Views: 67
  • 2021-05-02_023230.png
    2021-05-02_023230.png
    773.4 KB · Views: 59
  • 2021-05-02_023235.png
    2021-05-02_023235.png
    796.1 KB · Views: 51
  • 2021-05-02_023242.png
    2021-05-02_023242.png
    775 KB · Views: 56
Joined
Dec 8, 2020
Messages
723 (4.61/day)
@dododo, Are the DTS APO3 and APO4 services running? I also notice quite a few options missing (not on), in the Realtek tool, such as DTS.
Also make sure you fully do pnputil when removing drivers, some of Alans extensions can remain and become a problem.

1619906855520.png
2.png

Open command prompt as admin and type: pnputil -e
 
Joined
Feb 18, 2018
Messages
65 (0.06/day)
@dododo, Are the DTS APO3 and APO4 services running? I also notice quite a few options missing (not on), in the Realtek tool, such as DTS.
Also make sure you fully do pnputil when removing drivers, some of Alans extensions can remain and become a problem.

View attachment 198808
View attachment 198809

Open command prompt as admin and type: pnputil -e
Drive deleted
The APO3 and APO4 drivers of Ferather and Alan Finotty mod did not start :(
 

JacobDrivers

New Member
Joined
Apr 29, 2021
Messages
4 (0.27/day)
Thank you for this amazing driver! I have posted to just about everything I asked questions on previously. I fixed my problems with the drivers! After hours of installing/uninstalling the program/s, trying to find the right settings, I got it (If I knew more about audio, it wouldn't have taken me this long)... I am using https://github.com/AlanFinotty/AAFDCHDriverMod/releases - I don't know much about sound/audio drivers and the like, but I am using 5.1 ANALOG, so, that means I guess I do not need the DTS parts of the suite/tools. That and enabling the developer mode for the new API/Window store apps seemed to work just fine! Posting this in case anyone has the same issues.

The only issues I have now are - What is the best Sound Blaster program to choose to install? What are the best settings for a user who games/listens to music (Spotify) and watches videos? A lot of questions! Thank you all for helping, and making this!
 
Joined
Dec 8, 2020
Messages
723 (4.61/day)
If you need help with Ultra, DM me. I'd prefer it was my driver, as I almost never get complaints about it not working.
If the service is not running, there is either an install error (past drivers) or conflict with another APO.


I did warn Alan about these issues well before he added Ultra.
 

Maksim999

New Member
Joined
Apr 29, 2021
Messages
2 (0.13/day)
@Maksim999, this has been bothering me for a while, turns out its a problem with the Realtek drivers: RTKVHD64.sys or RTAIODAT.dat.
I tried everything, including removing all APO's and using just basic Realtek codes, even depop options using the tool.

As you said, it can only be reduced by protective enhancers, in my case DTS:X APO4 (SRS).

----

I managed to get it down to stop-start pop, which is more of a too fast pop (spamming windows alert sound).
If I make the alerts come at a normal pace, I get no pop-noise at all, so its a speed thing.

I have an analog output via JACK 3.5. That is, the problem with noise and clicks is solved via DTSx? Do you happen to know where you can download this driver and the control program for it without extra software and additional programs?
 

torang

New Member
Joined
Jan 18, 2021
Messages
6 (0.05/day)
hi

I have some problems
1. realtek audio console does not work
2. dts is not activated
3. I have lag ... CPU is consumed about 35%......(windows audio device graph isolation)

my hardware : cpu = i5 4570 ram = 8g main = asrock z87 extreme 4
7.1 CH HD Audio with Content Protection (Realtek ALC1150 Audio Codec), Supports DTS Connect
windows 10 x64 20H2 19042.928

Does anyone have a solution?
 

Attachments

  • real1.png
    real1.png
    8.2 KB · Views: 31
  • real2.png
    real2.png
    672.1 KB · Views: 33
  • real3.png
    real3.png
    32.6 KB · Views: 31
  • real4.png
    real4.png
    15 KB · Views: 35
  • real5.png
    real5.png
    6.2 KB · Views: 32
Joined
Jul 18, 2020
Messages
69 (0.23/day)
hi

I have some problems
1. realtek audio console does not work
2. dts is not activated
3. I have lag ... CPU is consumed about 35%......(windows audio device graph isolation)

my hardware : cpu = i5 4570 ram = 8g main = asrock z87 extreme 4
7.1 CH HD Audio with Content Protection (Realtek ALC1150 Audio Codec), Supports DTS Connect
windows 10 x64 20H2 19042.928

Does anyone have a solution?
I don't know about the console - I have hda. My console is buggy. Everything works. Dts only works in a multichannel - and you don't need another one.
 

Attachments

  • izo.jpg
    izo.jpg
    16.1 KB · Views: 46
  • dts.jpg
    dts.jpg
    152.3 KB · Views: 47
  • work.jpg
    work.jpg
    276.4 KB · Views: 47

torang

New Member
Joined
Jan 18, 2021
Messages
6 (0.05/day)
I don't know about the console - I have hda. My console is buggy. Everything works. Dts only works in a multichannel - and you don't need another one.
Could not be solved with this method
The main problem is the overuse of the cpu
This happens when playing a video or music
Announce if you have an effective solution
 

dhrto

New Member
Joined
Jan 21, 2021
Messages
21 (0.19/day)
@torang I have the same problems as you, with the exception of number 3 (no high cpu load). I can no langer select non-encoded formats with S/PDIF as well it now seems (no 2-channel 16/24 bit 48000/96000 Hz), keep getting this format is not supported popup. I think I'll revert to v6.0.9091.1 with patched APO for now, as it seems there are too many bugs in the newer versions, since I have no need for DTS:X or other enhancers (just need the on-the-fly DTS-encode of 5.1 to my receiver).

Maybe too much was added to the base driver, resulting in conflicting modules, I don't know.
 
Joined
Dec 8, 2020
Messages
723 (4.61/day)
Maybe too much was added to the base driver, resulting in conflicting modules, I don't know.
Exactly this, when DTS:X was requested, I warned Alan about it, and the fact he already had issues to resolve. In its current state, its a bad representation of DTS:X.
I have communicated various information to Alan, based on experience with coding DTS:X (alone), however there is a language barrier.

Alan is still learning how to implement DTS:X into his current system, to be fair it took me a few months to work it all out.

----

The first few releases of my driver with DTS:X, indeed had performance issues, mostly because I didn't understand what to do with it (very complicated compared to other APO's).
Alan is most likely at this stage now, plus all the additional issues already present, or perhaps becoming present now another APO has been added.

----

If you currently have major CPU issues, uninstall Sound Unbound, and try without it (use APO3, Headphones:X v1 instead), SU is not overly optimized for all PC's.
Technically speaking, your ALC and OEM will have already setup the necessary hardware and-or software changes for DTS:X, if it came with it.
 

杨伟锋

New Member
Joined
May 5, 2021
Messages
3 (0.33/day)
I've already installed the driver, but when I open those software, it's only in the process of loading, and I can't get in. Except for Dolby, how do I need to set it? Or if there is a tutorial connection, you can send it to me, and I'll check the corresponding settings directly. Thank you
010000.png
 
Top