• We've upgraded our forums. Please post any issues/requests in this thread.

Recovering goofed hard drive

Joined
Feb 18, 2010
Messages
1,715 (0.60/day)
Likes
408
System Name Eldritch
Processor AMD Ryzen 5 1500X
Motherboard MSI B350 PC Mate
Cooling Satan's butthole after going to Taco Bell
Memory 16 GB G.Skill Flare X
Video Card(s) nVidia (Gigabyte) GT 740 2GB
Storage 80 GB IBM, 2 TB WD Green
Display(s) Dell 2007WFP
Software Debian Buster
#1
I'm undecided whether this belongs here or in the hardware section, so whatever...

Treebeard said:
There is no curse in Elvish, Entish, or the tongues of men for this treachery.
Long story short I had to use a busted SATA cable due to A) very important, time-critical reasons, and B) I didn't have another, and I had to hard shutdown because it got disconnected (due to busted cable), this morning I got a new cable and now fuck's shitted up.

EDIT: The drive is a 1TB Seagate Barracuda 7200rpm ST31000523AS.

At boot I'm lucky if BIOS will see it, and I can't boot from it, and if I try to do anything (fsck, etc.) usually spits out
Code:
Attempt to read block from filesystem resulted in short read while trying to open /dev/sda3
Could this be a zero-length partition?
However, mke2fs can (apprently) see things:
Code:
mint@mint ~/Desktop $ sudo mke2fs /dev/sda
mke2fs 1.42 (29-Nov-2011)
/dev/sda is entire device, not just one partition!
Proceed anyway? (y,n) y
Warning: could not erase sector 2: Attempt to write block to filesystem resulted in short write
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
61054976 inodes, 244190646 blocks
12209532 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=4294967296
7453 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
	4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968, 
	102400000, 214990848
I've tried to use various things using a backup superblock, but that usually fails with
Code:
dumpe2fs: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda
Couldn't find valid filesystem superblock.
Also of note is that the kernel log is downright littered with
Code:
Apr 16 21:26:31 mint kernel: [   51.669184] end_request: I/O error, dev sda, sector 1953524992
Apr 16 21:26:31 mint kernel: [   51.669188] Buffer I/O error on device sda, logical block 244190624
Apr 16 21:26:31 mint kernel: [   51.669807] sd 2:0:0:0: [sda] Unhandled error code
Apr 16 21:26:31 mint kernel: [   51.669811] sd 2:0:0:0: [sda]  Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
Apr 16 21:26:31 mint kernel: [   51.669816] sd 2:0:0:0: [sda] CDB: Read(10): 28 00 74 70 6d a0 00 00 08 00
But apparently it's able to do enough to tell what partitions it has:
Code:
mint@mint ~/Desktop $ sudo ls -l /dev/sda*
brw-rw---- 1 root disk 8, 0 Apr 16 22:16 /dev/sda
brw-rw---- 1 root disk 8, 1 Apr 16 21:33 /dev/sda1
brw-rw---- 1 root disk 8, 2 Apr 16 21:27 /dev/sda2
brw-rw---- 1 root disk 8, 3 Apr 16 21:54 /dev/sda3
brw-rw---- 1 root disk 8, 4 Apr 16 21:27 /dev/sda4
And I'm looking for help.
 
Last edited:

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
10,401 (4.84/day)
Likes
5,481
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.2Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Zalman CPNS9900MAX 130mm
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-1T 1.65v
Video Card(s) MSI AMD Radeon R9 390 GAMING 8GB @ PCI-E 3.0
Storage 2x120Gb SATA3 Corsair Force GT Raid-0, 4x1Tb RAID-5, 1x500GB
Display(s) 1x LG 27UD69P (4k), 2x Dell S2340M (1080p)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898 8-Channel High Definition Audio
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100
Software Ubuntu 17.10
Benchmark Scores Benchmarks aren't everything.
#2
Are you certain the drive itself is good?

Code:
sudo apt-get install smartmontools
sudo smartctl -a /dev/sda
 
Joined
Feb 18, 2010
Messages
1,715 (0.60/day)
Likes
408
System Name Eldritch
Processor AMD Ryzen 5 1500X
Motherboard MSI B350 PC Mate
Cooling Satan's butthole after going to Taco Bell
Memory 16 GB G.Skill Flare X
Video Card(s) nVidia (Gigabyte) GT 740 2GB
Storage 80 GB IBM, 2 TB WD Green
Display(s) Dell 2007WFP
Software Debian Buster
#3
If I'm really (really, really) fucking fast I can get fsck.ext4 -b 32768 -B 4096 /dev/sda3 to tell me that all the groups are messed up and it gets to about 20% fixing inodes before it starts throwing short read/writes at me. Also, if I run gparted first thing when partedmagic boots it'll tell me all the partitions, but once I refresh the devices it'll disappear, and if I run anything after it it'll start throwing short read/writes again.

I'll try smartmontools in a little bit.

EDIT:
Code:
sudo smartctl -a -T verypermissive /dev/sda
smartctl 5.41 2011-06-09 r3365 [x86_64-linux-3.2.0-23-generic] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

Vendor:               /2:0:0:0
Product:              
User Capacity:        600,332,565,813,390,450 bytes [600 PB]
Logical block size:   774843950 bytes
>> Terminate command early due to bad response to IEC mode page

Error Counter logging not supported
Device does not support Self Test logging
 
Last edited:
Joined
Feb 18, 2010
Messages
1,715 (0.60/day)
Likes
408
System Name Eldritch
Processor AMD Ryzen 5 1500X
Motherboard MSI B350 PC Mate
Cooling Satan's butthole after going to Taco Bell
Memory 16 GB G.Skill Flare X
Video Card(s) nVidia (Gigabyte) GT 740 2GB
Storage 80 GB IBM, 2 TB WD Green
Display(s) Dell 2007WFP
Software Debian Buster
#4
Right now it's really looking like a mechanical failure of some kind, and I figure that I'm going to need a clean room and a new drive to make any progress... so fuck.
 
Joined
Oct 18, 2007
Messages
1,190 (0.32/day)
Likes
579
System Name Firebird
Processor Intel i7 2600K @5.0'ish 24/7 stock core Voltage {5.2 w/102 bCLK}
Motherboard Intel Extreme DZ68BC SkullTrail Z68 Cougerpoint, Excellent MCH !
Cooling Scythe NINJA PLUS Rev.B[skt478] Modded to 1155 Scythe SH12 fan
Memory Samsung 32nm 16Gb 4x4 (@19xxmhz} low profile[ better than 2133 banwidth]
Video Card(s) @Norton F@H Kreij GigaByte 7950 ARCTIC Accelero Xtreme III / XFX HD5870-XXX Edition
Storage Toshiba 3Tbx2,Hitachi 320,1TBx2,'Cuda 400 7200.10, WD1TBUSB,moved to SATA
Display(s) Acer K272HUL 1440 27" WQHD, Samsung 226W, Vizio M60C3 4K 60",Vizio XVT3D554SV
Case CoolerMaster HAF 932
Audio Device(s) Intel 10ch[9+1] HD Audio X540> Pioneer VSX39TX[copper chasis,Rosewood sides 5x6LCD remote
Power Supply Seasonic X750 @ 24/7
Mouse Logictech G300s
Keyboard Saitek Cyborg v7
Software Windows 7 ROG E3 X64 by Neuropass/tweakscene
Benchmark Scores 4642@665/1600 220/GAT F1 4544 220/667strap 2.5/3/2/6 Bliss 650/1500 6490 Q6700 Bliss 690/1500
#5
If you relly need something off that drive fridge it rice, and start getting what you can
I've actually froze a drive 4-5 times and was able to get the stuff off, BUT I got a new drive/install to have a pc ready to transfer to.
Getdatback has saved my ass toooo many times
Good luck