• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Retro laptop crash on PhysX-enabled games (geforce 260m)

Jan 28, 2020
7 (0.01/day)
Guys, i'm collecting and using retro laptops. Recently i bought ASUS ROG G60VX with geforce 260m. 3dmark06 runs fine, hour in battlefield 3 also went fluently. But when i tried several physx-enabled games i started catching driver crash or bugs.

I've tried alice madness returns, fluidmark and cryostasis. When i see fluid on screen it ends up ether in driver crash or fluid disappears.

Take a look:

Water just disappeared
Driver crash

I've tried different drivers and physx versions, all from 2010, 2011, 2013 or 2016. No luck. I even tried clean windows install, with only videodriver and directx, no luck.

The most bothering thing here is that i've got similar laptop, a year younger, alienware m11x from 2010 powered by geforce 335m, and there i didn't see any graphical issues in physx titles i mentioned.

Can gpu be partly dead? The part which is used for physx? Can i test it somehow?
Dec 12, 2020
1,295 (1.54/day)
In Nvidia control panel you could try setting PhysX to CPU to determine for certain if it's the GPU.
Jan 28, 2020
7 (0.01/day)
In Nvidia control panel you could try setting PhysX to CPU to determine for certain if it's the GPU.
Good point, i should've mention it. I did a test earlier, gpu is definetly in business. First of all, when i'm using cpu i'm not experiencing any crashes or bugs and also i'm getting lower fps and high cpu load.

(318) 17 March 2023 - YouTube

Left is CPU right GPU.
Sep 21, 2020
1,105 (1.20/day)
Processor 5800X3D -30 CO
Motherboard MSI B550 Tomahawk
Cooling DeepCool Assassin III
Memory 32GB G.SKILL Ripjaws V @ 3800 CL14-14-14
Video Card(s) ASRock MBA 7900XTX
Storage 1TB WD SN850X + 1TB ADATA SX8200 Pro
Display(s) Dell S2721QS 4K60
Case Cooler Master CM690 II Advanced USB 3.0
Audio Device(s) Audiotrak Prodigy Cube Black (JRC MUSES 8820D) + CAL (recabled)
Power Supply Seasonic Focus GX-650
Mouse Logitech Cordless Desktop Wave
Keyboard Logitech Cordless Desktop Wave
Software Windows 10 Pro
Have you tried installing the latest PhysX 9.21? For games released in 2007 and earlier you may also need the legacy PhysX 9.13.

Space Lynx

Oct 17, 2014
12,549 (4.06/day)
Processor Ryzen 5600 at 4.6 all core @ 1.200v ($130)
Motherboard MSI B550 Pro VC ($109)
Cooling Thermalright Frost Commander 140 ($40) + MX-6
Memory 4x8gb DDR4 3200 cas16 ($85)
Video Card(s) MSI Trio Z 6800 XT ($540)
Storage Kingston KC3000 1TB ($90)
Display(s) NZXT 27" Canvas 2560x1440 IPS 165hz ($150)
Case Corsair 110q ($60)
Audio Device(s) Schiit Modi 3 DAC - Logitech 400w THX 2.1 ($185)
Power Supply Corsair RM 850w Gold ($110)
there are older games that need the older Physx software like QuietBob said. I had this happen with Dragon Age Origins I think, can't remember.
Jan 28, 2020
7 (0.01/day)
Legacy PhysX driver required on modern computes, when using modern hardware and up-to-date drivers. On my machine I’m using old driver, like I mentioned I tried 2010,11,13 and 16 (latest possible) years, including their own physx drivers. I used ddu to make everything clean.

On m11x, which works perfectly, I have videodriver from 2010 and PhysX package from 2011.

in my desperate attempt to sort this issue I also tried this legacy driver, but no luck.

Today I installed Windows Vista 32х, and still PhysX crashes video driver. So looks like it’s driver/os/bittness irrelevant issue.
Last edited: