• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

RX 480 crashes with original bios, stable with bios from 580

FantasticAvocado

New Member
Joined
Apr 12, 2021
Messages
6 (0.20/day)
Prehistory:
  • I have AMD Radeon RX 480 i struggle with, with default (or another one) bios card is crashing a lot, often gets artifacts, but with underclocked RX 580 bios (clocked by me, file attached), in Windows it's stable as it can be - no crashes, no overheating, no artifacts - perfect video card, but i want RX 480 bios because of display ports (doesn't work with 580).
How i flash:
  1. Load to Ubuntu on intel iGPU
  2. Start Heaven benchmark on AMD GPU with help of DRI_PRIME=1 flag
  3. Now when GPU gets load i can see it's bios
  4. Using AMD VBFlash 4.69 i unlock rom with -unlockrom 0 command
  5. And flash my bios with -f -p 0 biosname.rom
System:
  • Windows 10
  • z390 i Aorus PRO WiFi motherboard
  • Intel i7-9700 (not K) CPU
  • Lexar DDR4 32GB RAM
  • 1000w Corsair PSU

Different card ids:
  • S/N 181626 203453
    P/N 102D0090100 028322
    GV-RX480D5-8GD-B REV.1.0
    SN163101002982

What can be wrong with that card?
 

Attachments

  • 212856L.rom.zip
    110.7 KB · Views: 20
Last edited:
Joined
Aug 15, 2016
Messages
286 (0.17/day)
Processor Intel i7 4770k @ 4.5 GHz 1.294V
Motherboard ASUS Sabertooth Z87
Cooling Corsair H100i
Memory Patriot Viper 3 RedD 16 GB @ 1866 MHz
Video Card(s) XFX RX 480 GTR 8GB
Storage 1x SSD Samsung EVO 250 GB 1x HDD Seagate Barracuda 3 TB 1x HDD Seagate Barracuda 4 TB
Display(s) AOC Q27G2U QHD, Dell S2415H FHD
Case Cooler Master HAF XM
Audio Device(s) Magnat LZR 980, Razer BlackShark V2, Altec Lansing 251
Power Supply Corsair AX860
Mouse Razer DeathAdder V2
Keyboard Razer Huntsman Tournament Edition
Software Windows 10 Pro x64
Post GPU-z screenshot, you're probably using a BIOS with different memory config.
 
Joined
Feb 6, 2021
Messages
329 (3.43/day)
Location
Germany
Processor Intel Core i9 10900KF 5.1 Ghz /4.8 GHz Cache
Motherboard ASUS Z490 PRIME-A
Cooling Noctua NH-D15 Chromax. Black
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB)
Video Card(s) RTX 3090 Gaming X Trio, 6900XT Merc and Nitro + & almost all Ampere, Turing, Pascal, Maxwell Cards
Storage Corsair MP600 1TB, Samsung 970 Evo Plus 500GB, 2x Samsung 870 QVO 4TB
Display(s) Samsung Odyssey G7 32"
Case Fractal Design Meshify S2 White TG / Noctua NF-A14 iPPC-3000RPM Fans
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a SoundblasterX G6
Power Supply bequiet! Dark Power Pro 12 1200w Titanium
Mouse Glorious PC Gaming Race Model O, G903 Hero, G502 Hero SE, Deathadder V2, EC2-A
Keyboard ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
degraded memory or wrong timings would be the first thing that comes in mind.
 

FantasticAvocado

New Member
Joined
Apr 12, 2021
Messages
6 (0.20/day)
Brand is Gigabyte, link to official page.
Screenshots of working 580 bios below.
I am open to experiments with different 480 bios versions, so any advice is welcome.
 

Attachments

  • Screenshot 2021-04-19 212456.png
    Screenshot 2021-04-19 212456.png
    686 KB · Views: 19
  • Screenshot 2021-04-19 212518.png
    Screenshot 2021-04-19 212518.png
    90.1 KB · Views: 21
Last edited:
Joined
Mar 21, 2021
Messages
84 (1.62/day)
can you share the image of your card.
does it have XFX led in the middle or side?

Brand is Gigabyte, link to official page.
Screenshots of working 580 bios below.
I am open to experiments with different 480 bios versions, so any advice is welcome.
VGA Bios Collection: Gigabyte RX 480 8 GB | TechPowerUp

you need to force flash it. it will work fine if that 580 bios is working.

using command prompt cmd

amdvbflashwin -p -f 0 biosname
 
Top