• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

RX 480 No signal after windows starting logo

Joined
Sep 18, 2017
Messages
23 (0.03/day)
So I bought used HIS RX 480 8GB a week ago. The card was nice, working okay on the first day. After a few days Im having difficulties entering the windows. After windows starting logo my display went no signal. But sometimes just restarting the machine will make it work. Gaming, compute were fine no sign of artifact or any faulty. When I turned off my PC and try to start it again the next day the problem occurred again.

What I have tried so far: (but still not work
Boot with minimum hardware (ram+ssd) was fine - Plug the card, problem persist
I look for YT, told to disable intel display on hardware manager - I did - Plug the card, problem persist
I look for google some ppl had that problem saying its display driver problem, so I uninstall the driver 19.9.2 - Plug the card, problem persist
Clear CMOS - problem persist
Plug it in other PCI slot - problem persist
I haven't try using DVI/DP since my monitor only support HDMI
When no signal, pressing power button wont do anything, pressing restart button will turn off the PC, it will turn on again after a few sec. If I did this 3 times the 4th time PC wont turn on, I have switch off the PSU then PC can be turned on again.

My spec
i5 3570k
Asrock Z77 Extreme 3
Kingston HyperX 2X4
Samsung 850 evo 250gb
WD Blue 1TB
Superflower 500w
Windows 10 1903

When/if I made it into windows I wont getting no signal display randomly, It will just fine I can game and stuff as long as I want. It appears that problem only occurred during windows starting logo.
I still believe the card is fine though, since it still post the display even until windows starting. Current situation, I use onboard intel HD. I asked the seller the card was fine, I did saw bunch of tests on the ads when he sell the card.
So do you guys think the card is faulty? Any other solution?
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,343 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Get a gpu-z screenshot, also bios screenshots, be thorough with the screenshots
 
Joined
Sep 18, 2017
Messages
23 (0.03/day)
Get a gpu-z screenshot, also bios screenshots, be thorough with the screenshots
I cant plug the card right now, so no GPU-Z
what do you mean with be thorough with the screenshots? do I have to take screenshot every tab in bios settings? its all default anyway
 
Last edited:
Joined
Jul 20, 2018
Messages
236 (0.46/day)
Enter bios and check wich is your primary graphic options integrated or pciexpress. And you can check your card is seating properly, power cables too.
 

muslumturkmen

New Member
Joined
Nov 12, 2019
Messages
12 (0.43/day)
I cant plug the card right now, so no GPU-Z, even with installed card and set onboard display, hdmi trough the motherboard wont give me display.
what do you mean with be thorough with the screenshots? do I have to take screenshot every tab in bios settings? its all default anyway
Disable PCI slots in bios and boot with VGA. GPU-Z shows ur card.

Disable PCI slots in bios and boot with VGA. GPU-Z shows ur card.
 
Joined
Sep 18, 2017
Messages
23 (0.03/day)
Enter bios and check wich is your primary graphic options integrated or pciexpress. And you can check your card is seating properly, power cables too.
I did that too. PCIE selected I got no siplay after windows starting logo. Power cable was okay, led indicator was light up.
 
Joined
Jul 20, 2018
Messages
236 (0.46/day)
Remove every graphics driver, both amd - intel, let the basic microsoft driver in use.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,343 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Mar 26, 2010
Messages
8,404 (2.37/day)
Location
Jakarta, Indonesia
System Name micropage7
Processor Intel Xeon X3470
Motherboard Gigabyte Technology Co. Ltd. P55A-UD3R (Socket 1156)
Cooling Enermax ETS-T40F
Memory Samsung 8.00GB Dual-Channel DDR3
Video Card(s) NVIDIA Quadro FX 1800
Storage V-GEN03AS18EU120GB, Seagate 2 x 1TB and Seagate 4TB
Display(s) Samsung 21 inch LCD Wide Screen
Case Icute Super 18
Audio Device(s) Auzentech X-Fi Forte
Power Supply Silverstone 600 Watt
Mouse Logitech G502
Keyboard Sades Excalibur + Taihao keycaps
Software Win 7 64-bit
Benchmark Scores Classified
Joined
Sep 6, 2019
Messages
882 (9.28/day)
System Name just ordinary potato system, but dont understimate potato..
Processor ryzen raven ridge 2200g
Motherboard msi b350 pc mate
Cooling x2 cheap china handmade
Memory klevv dual channel 3000mhz, random ddr2 stick
Video Card(s) vega 8, rx 580
Storage wd green ssd 240gb, 3tb seagate expnasion, random laptop hdd x4, 1tb 3.5
Display(s) acer vgo 22inch fullhd 75hz
Case cheap segotep/dazumba mid atx, alcatroz mini atx
Audio Device(s) genius retro wood style, harman kardon stick iii
Power Supply be quite system power9, powerlogic standar, voltron 300fx
Mouse rexus, genius ps/2, powerlogic ps/2 ball tracking
Keyboard rexus, random china product x3
Software talking abt best software, autodesk/unity3d/notepad yes notepad!!
Benchmark Scores theres nothing to brag abt potato, but it can run decent 30fps fullhd with good setting:)
unplug display port and replug it, sometimes i also get problem like thisz not sure it is related to hardware or software but i did suspect on drivers, oh nevermind, thats definitly bcouse of bad bios hehe
 
Last edited:

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,343 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Can we get all white sticker pictures from card back or side of card heatsink?
 
Joined
Sep 18, 2017
Messages
23 (0.03/day)
unplug display port and replug it, sometimes i also get problem like thisz not sure it is related to hardware or software but i did suspect on drivers, oh nevermind, thats definitly bcouse of bad bios hehe
Already tried that still no signal.

Ok, its worthy to follow the path what eidairman1 suggest, but meanwhile can you try an amd driver for your card? Latest maybe?
Im sticking with microsoft driver right now, if I install amd driver I might get no signal again.

Can we get all white sticker pictures from card back or side of card heatsink?
Is this ok?
DSC_0023.JPG
DSC_0024.JPG
DSC_0025.JPG
DSC_0026.JPG
DSC_0027.JPG
DSC_0028.JPG
DSC_0030.JPG
DSC_0033.JPG
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,343 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
When is the last time you updated the motherboard bios?
 
Joined
Jul 20, 2018
Messages
236 (0.46/day)
Im sticking with microsoft driver right now, if I install amd driver I might get no signal again.
Ok, if it works for you, but sometimes it is very basic driver, not working with 3d application like benchmarks, games, etc. (Like generic/basic display driver which should work almost everything and normal graphics driver by their developer (amd, nvidia, etc) released by ms.)
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,343 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
There is one last bios in 2018 I would suggest getting it
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,343 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
The beta one? It says CPU update microcode, does it have anything to do with last year Meltdown & Spectre patch that reduce the performance?
Considering the last bios to show is from 2013 and the beta is latest it will cover more for compatibility.
 
Joined
Sep 18, 2017
Messages
23 (0.03/day)
Ok, if it works for you, but sometimes it is very basic driver, not working with 3d application like benchmarks, games, etc. (Like generic/basic display driver which should work almost everything and normal graphics driver by their developer (amd, nvidia, etc) released by ms.)
Yeah I installed amd driver now. I got the problem again, but I found some trick by putting the PC to sleep instead of turning it off. It works that way.

Considering the last bios to show is from 2013 and the beta is latest it will cover more for compatibility.
OK I'll do that later.
 
Joined
Aug 7, 2017
Messages
21 (0.02/day)
Processor Ryzen 7 3700x
Motherboard MSI MPG X570 Gaming Pro Carbon
Cooling Corsair H100iv2
Memory Trident Z Royal Silver 2x8GB
Video Card(s) MSI Radeon RX 5700 XT MECH
Storage Corsair Force MP600 500GB, WD Caviar Blue 4TB
Display(s) LG 27UD68
Power Supply Seasonic Focus Plus Gold 650w
I have a feeling its the card all along. BIOS flash is the last resort when youre in dead end.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,343 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I have a feeling its the card all along. BIOS flash is the last resort when youre in dead end.
All we can do is wait for him to mobo flash.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
28,343 (6.24/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Looks like it is :(


I flashed with the beta, still no good. What should I do now? :(

Lets get pics of ram chips and a close up of 1, remove the hsf and verify it.
 
Top