• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Rx 570 4gb device ID of a rx 580 8gb-Mining bios help :(

rptidemule

New Member
Joined
Nov 19, 2019
Messages
3 (0.00/day)
Problem
I somehow have a sapphire rx 570 4gb pulse edition with a device Id of a sapphire rx 580 8gb pulse edition. It’s in a mining bios atm and when I try to flash it back to the original, I get “subsystem Id mismatch”
Any thoughts on how to get it back? How did the previous owner even flash it to another card? Im trying to use it for some gaming so should i just try flashing it to the original bios of a rx 580 8 gb pulse? Ive only tried using atiflash. I have flashed multiple cards before with atiflash so i dont think thats the issue.

Physical condition
Seller said he only used it for mining for a few months and it sat in the closet for a while. Came with the box, card has minimal dust, no rust at all on copper pipes or io shield, no bulging capacitors. The sticker on the card says its a sapphire rx 570 4gb dual fan pulse model. And the warranty voided stickers on top of the backplate/cooler screws are untouched so i dont think the previous owner slapped on a different cooler.

Pictures
attached are the pictures of 1) model # on cooler 2) gpu-z 3) current vbios from atiflash

Any help is appreciated!
 

Attachments

  • IMG_8391.jpg
    IMG_8391.jpg
    1.4 MB · Views: 36
  • IMG_8390 (1).jpg
    IMG_8390 (1).jpg
    60 KB · Views: 34
  • IMG_8450.jpg
    IMG_8450.jpg
    4.5 MB · Views: 41
Joined
Oct 22, 2014
Messages
12,443 (5.03/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
I think you're confused as the device I.D. is also for your card.

There is nothing in the pictures you posted to indicate it has been flashed to RX580 or has 8GB.
 

rptidemule

New Member
Joined
Nov 19, 2019
Messages
3 (0.00/day)
Wait now im confused, isnt this the device ID for the 580 8gb? welp i guess its not a 580 8gb but im still not sure whats causing the subsystem id mismatch. Because the verified version of the 570 4gb pulse shows a different subsystem id
 

madhack27

New Member
Joined
Jul 21, 2021
Messages
1 (0.09/day)
Hello

I have same issue with my Pulse RX570. I`m tired of using [Amd/Ati Pixel Clock Patcher] each time I receive updates from AMD. I decided to find Original Bios but the problem as you mentioned was
[Subsystem ID Mismatch]

I found that my RX570 Subsystem ID belongs to RX580 )))
Currently I flashed to RX580 Bios
Temperature in idle is bit high but not a problem for me
I`m bit afraid of GPU Clock is too high now...
I will test in Crysis 1

P.s
Driver Version was successfully Updated to Latest 21.6.1

Hello

I contacted to Sapphire but they didn`t give me Proper vBIOS yet
I rewrote Pule RX570 Bios using this link

Revrite AMD Bios without Promting Mismatch
 

Attachments

  • RX570.gif
    RX570.gif
    26.7 KB · Views: 4
Top