• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

rx 580 low fps

joshuajesse

New Member
Joined
Jul 5, 2020
Messages
25 (0.66/day)
i used to have a gtx 960 and i recently got a rx 580 and when i used it i had around the same if not worse fps with the card but when i look at benchmarks people on games such as fortnite would get 200+ and i barely get 100 i have deleted old drivers and reinstalled some unplugged my gpu and put it back in overclocked it and nothing has workded please help
 

r9

Joined
Jul 28, 2008
Messages
2,651 (0.60/day)
System Name PC1| PC2|Poweredge r410
Processor i5 6600k| Ryzen 1600| 2 x E5620 @2.4GHz
Memory 16GB DDR4 |16GB DDR4 | 32GB ECC DDR3
Video Card(s) GTX 1070|2 x RX570 |On-Board
Storage 512GB SSD+1TB SSD|512GB SSD+1TB|2x256GBSSD 2x2TBGB
Display(s) 27" Dell + 2 x 24" LCD Setup
Software Windows 10 |Windows 10| Server 2012 r2
Depends of the CPU, resolution and game detail you have it set.
 

Attachments

Joined
Jan 31, 2012
Messages
1,890 (0.61/day)
Location
Bulgaria
System Name Sandfiller
Processor I5-7600K
Motherboard Asus PRIME Z270-P
Cooling Noctua NH-L9i
Memory 2 x 8GB Cruicial 2400 mhz DDR4 CL17
Video Card(s) RX 580 4GB NITRO+
Storage Cruicial M.2 275GB drive
Display(s) 2560x1080 LG 29"
Case TT URBAN R31
Audio Device(s) Creative Sound Blaster Z
Power Supply Fractal Design IntegraM 650W
Mouse Logitech G602
Keyboard Dell Somethin wireless
Software Windows 10 x 64 bits
Depends. There is RX580 4GB and RX580 8 GB. Recommended CPU from Intel side is i5-7400/7600, that shouldn't bottleneck the card. Recommended PSU - 500W. Also game specific settings: do you have Vsync ON, AMD pannel settings, etc etc. Too little info to serach where the problem is.

EDIT: OP posted while I was typing. i3-9100F should be fine for this card. How much RAM, what speed? You have your games on a HDD or SDD? Was the GPU new or second hand? Have you flashed with alternative BIOS or something? I'd suggest reset everything to stock, check the AMD pannel, make sure you turn off everything you don't want and reset the power settings of the card.
 
Last edited:

joshuajesse

New Member
Joined
Jul 5, 2020
Messages
25 (0.66/day)
Depends. There is RX580 4GB and RX580 8 GB. Recommended CPU from Intel side is i5-7400/7600, that shouldn't bottleneck the card. Recommended PSU - 500W. Also game specific settings: do you have Vsync ON, AMD pannel settings, etc etc. Too little info to serach where the problem is.
i have a rx580 8gb 8gb ram 500w psu intel i3 9100f

Depends of the CPU, resolution and game detail you have it set.
i have intel i3 9100f all low settings 1920x1080
 
Joined
Feb 14, 2012
Messages
1,104 (0.36/day)
Location
Romania
System Name "No name"
Processor Ryzen 2700X
Motherboard MSI Tomahawk MAX
Cooling Noctua U12P
Memory 16GB 3200Mhz
Video Card(s) MSI GTX 1070 Ti
Storage Adata 512GB SSD, WD30PURX
Display(s) AOC CQ32G1
Case Segotep Halo 5
Audio Device(s) ALC Codec + Maudio AV32 and Fiio E10k + Audiotehnica TAD 400
Power Supply Seasonic G650 650W
Mouse Logitech G203
Keyboard Asus Strix MX Brown
Software Windows 10 Pro x64
What about Vsync or a frame cap ? That i3 is fine for the RX 580, no bottleneck there.
Try installing MSI Afterburner + RTSS and the setup the overlay so that you can monitor CPU and GPU usage during your games. If the GPU is at >95% there is no bottleneck.
 

joshuajesse

New Member
Joined
Jul 5, 2020
Messages
25 (0.66/day)
What about Vsync or a frame cap ? That i3 is fine for the RX 580, no bottleneck there.
Try installing MSI Afterburner + RTSS and the setup the overlay so that you can monitor CPU and GPU usage during your games. If the GPU is at >95% there is no bottleneck.
my gpu is at 30-40%
 
Joined
Feb 14, 2012
Messages
1,104 (0.36/day)
Location
Romania
System Name "No name"
Processor Ryzen 2700X
Motherboard MSI Tomahawk MAX
Cooling Noctua U12P
Memory 16GB 3200Mhz
Video Card(s) MSI GTX 1070 Ti
Storage Adata 512GB SSD, WD30PURX
Display(s) AOC CQ32G1
Case Segotep Halo 5
Audio Device(s) ALC Codec + Maudio AV32 and Fiio E10k + Audiotehnica TAD 400
Power Supply Seasonic G650 650W
Mouse Logitech G203
Keyboard Asus Strix MX Brown
Software Windows 10 Pro x64
Then you have a problem. Did you try the card on a different PC ? Try uninstalling the drivers using the AMD Uninstall Utility or DDU. Reinstall the latest WHQL.
 

joshuajesse

New Member
Joined
Jul 5, 2020
Messages
25 (0.66/day)
i uninstalled all earlier and reinstalled amd but ill reinstall this whql thing
Then you have a problem. Did you try the card on a different PC ? Try uninstalling the drivers using the AMD Uninstall Utility or DDU. Reinstall the latest WHQL.
i deleted my old drivers and amd ones then reinstalled amd ones should i try just installing WHQL or delete them first then reinstall WHQL?
 
Joined
Sep 28, 2005
Messages
1,363 (0.25/day)
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Raijentek Zelos low profile cpu cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) GTX 1070
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR - Coil Whine Issue
Software Windows 10 64bit Pro
Quick question, what does GPUZ show in terms of core and men? As well, is PCIe 3.0 @ 16x also show up? Recently I had a 570 4gb come to me with poor performance and after playing around with it (doing same as suggestions) I decided to look at its core and clock settings. Found out that it was seriously off from the standard of the Aurous series of the same card. So I obtained the ATI flash and the bios from here, flashed it, and now it is working as intended for my customer.

Can you post the GPUZ screen here please?

Also, can you list all your parts for your PC as well?

As well, when removing drivers, do it in safe mode. Run DDU (display driver uninstaller). Then reboot back into main desktop and install latest drivers. I know you said you uninstalled drivers, but I don't believe you mentioned how you did. And same DDU method should be done for both AMD and NVIDIA drivers
 

joshuajesse

New Member
Joined
Jul 5, 2020
Messages
25 (0.66/day)
intel i3 9100f
rx 580 8gb
8gb ram
500w 80siver rated psu

Quick question, what does GPUZ show in terms of core and men? As well, is PCIe 3.0 @ 16x also show up? Recently I had a 570 4gb come to me with poor performance and after playing around with it (doing same as suggestions) I decided to look at its core and clock settings. Found out that it was seriously off from the standard of the Aurous series of the same card. So I obtained the ATI flash and the bios from here, flashed it, and now it is working as intended for my customer.

Can you post the GPUZ screen here please?

Also, can you list all your parts for your PC as well?

As well, when removing drivers, do it in safe mode. Run DDU (display driver uninstaller). Then reboot back into main desktop and install latest drivers. I know you said you uninstalled drivers, but I don't believe you mentioned how you did. And same DDU method should be done for both AMD and NVIDIA drivers
i3 9100f
rx 580 8gb
8gb ram
500w powersupply silver rated
 

Attachments

Joined
Feb 14, 2012
Messages
1,104 (0.36/day)
Location
Romania
System Name "No name"
Processor Ryzen 2700X
Motherboard MSI Tomahawk MAX
Cooling Noctua U12P
Memory 16GB 3200Mhz
Video Card(s) MSI GTX 1070 Ti
Storage Adata 512GB SSD, WD30PURX
Display(s) AOC CQ32G1
Case Segotep Halo 5
Audio Device(s) ALC Codec + Maudio AV32 and Fiio E10k + Audiotehnica TAD 400
Power Supply Seasonic G650 650W
Mouse Logitech G203
Keyboard Asus Strix MX Brown
Software Windows 10 Pro x64
Do you have vsync on or some other frame cap active ?
 
Joined
Jan 25, 2006
Messages
1,015 (0.19/day)
Processor Ryzen 1600AF @4.2Ghz 1.35v
Motherboard MSI B450M PRO-A-MAX
Cooling Deepcool Gammaxx L120t
Memory 16GB Team Group Dark Pro Sammy-B-die 3400mhz 14.15.14.30-1.4v
Video Card(s) XFX RX 5600 XT THICC II PRO
Storage 240GB Brave eagle SSD/ 2TB Seagate Barracuda
Display(s) Dell SE2719HR
Power Supply EVGA 600W 80+
Software Windows 10 Pro
It's a modded bios, you need to flash the original
 
Joined
Sep 28, 2005
Messages
1,363 (0.25/day)
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Raijentek Zelos low profile cpu cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) GTX 1070
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR - Coil Whine Issue
Software Windows 10 64bit Pro
take a picture of the white sticker on the back and we will look for the right bios
 
Joined
Sep 28, 2005
Messages
1,363 (0.25/day)
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Raijentek Zelos low profile cpu cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) GTX 1070
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR - Coil Whine Issue
Software Windows 10 64bit Pro
Joined
Sep 28, 2005
Messages
1,363 (0.25/day)
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Raijentek Zelos low profile cpu cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) GTX 1070
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR - Coil Whine Issue
Software Windows 10 64bit Pro
I really cant see it. Can you get a bigger photo of it please? If have to, post it on imgr and post it here.
 
Joined
Sep 28, 2005
Messages
1,363 (0.25/day)
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Raijentek Zelos low profile cpu cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) GTX 1070
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR - Coil Whine Issue
Software Windows 10 64bit Pro
i cant tell but this?
 
Joined
Sep 28, 2005
Messages
1,363 (0.25/day)
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Raijentek Zelos low profile cpu cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) GTX 1070
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR - Coil Whine Issue
Software Windows 10 64bit Pro

Sorry, dealing with two things at same time. This is link I found.
 
Joined
Sep 28, 2005
Messages
1,363 (0.25/day)
Location
Calgary Alberta, Canada
System Name PussySlayer
Processor Intel Core i7 4770
Motherboard Asrock Z87E-ITX
Cooling Raijentek Zelos low profile cpu cooler
Memory 2x8GB Gskill RipjawsX 1600
Video Card(s) GTX 1070
Storage 1x500gb Crucial SSD
Display(s) BenQ 24" 1080P
Case Couger QBX
Audio Device(s) Onboard
Power Supply 650W EVGA BR - Coil Whine Issue
Software Windows 10 64bit Pro
first, does this look like your card?
 
Top