• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

RX 590 World of Warships Issue

Joined
Sep 27, 2018
Messages
66 (0.20/day)
System Name A COLD ONE
Processor i7 6700k @ 4.5ghz soon to be R7 3800X
Motherboard Asrock Z170 extreme 6 soon to be MSI X570 Pro Carbon Wifi
Cooling Full custom WC loop/ EK blocks & pumps / 300mm res / Hard lined / linked to external 560 x 80 rad.
Memory 16gb of 2400mhz ddr4 soon to be 32gb of 3600mhz ddr4
Video Card(s) MSI GTX 1080 EKWB Seahawk. soon to be RTX2070 super/RTX2080/Radeon XT series..........PRICE
Storage 1 x Samsung 500gb 970 Evo NVME/ 2 x 500gb Samsung SSD
Display(s) Dell Ultrasharp Curved 3440x1440
Case Heavily Modified Silverstone Fortress FT02
Audio Device(s) Asus Sound card
Power Supply Corsair HX1000i
Mouse Corsair M95
Keyboard Corsair K95
Software Windows 10 64bit home
My sons PC has had an issue with the above game and only this game since i built it.

SPECS..
B450 MSI mobo
R5 2600 CPU with water block
2x8gb 3200mhz DDR4
WD 1TB NVME M.2 drive
Asrock RX590 with latest drivers. with water block
2560x1440 Dell Ultrasharp monitor
Custom WC loop

ISSUE..
Basically when playing the game it will sit at around 75fps and then roughly every 60sec it will drop to like 33fps and then jump straight back to 75fps making playing the game a bit stuttery.
Ive used NZXT CAM software to monitor his CPU/GPU temps and clocks during play, and the temps are all fine well below 60c. VRM temps sit around 50c on Mobo. However during these fps drops ive noticed the GPU clocks are dropping down to 300mhz as though the GPU is going into idle mode as its not detecting any load maybe? Again its only in this game that it happens and not the 57 :) other steam games he has which all play faultlessly.

Has anybody any ideas what this could be or had similar issues maybe?
 
Joined
Mar 15, 2013
Messages
2,863 (1.22/day)
Location
GMT +2
System Name Red Radiance l under construction
Processor 2600x
Motherboard x470 taichi
Cooling stock wrath
Memory TridentZ rgb 3200mhz (2x8 kit)
Video Card(s) Sapphire Vega 64 nitro+
Storage 970 evo nvme
Display(s) c27gh70
Case tt core x5 tge
Audio Device(s) sennheiser's pc323d usb soundcard
Power Supply corsair AX860i
Mouse roccat leader
Keyboard roccat ryos mk fx
Software windows 10
game has build in fps and ping metter (top left corner of the screen). when fps drops down what happens with ping. if it jumps up then it is networking issue. it isnt like it is for first time for wargaming.
 
Joined
Sep 27, 2018
Messages
66 (0.20/day)
System Name A COLD ONE
Processor i7 6700k @ 4.5ghz soon to be R7 3800X
Motherboard Asrock Z170 extreme 6 soon to be MSI X570 Pro Carbon Wifi
Cooling Full custom WC loop/ EK blocks & pumps / 300mm res / Hard lined / linked to external 560 x 80 rad.
Memory 16gb of 2400mhz ddr4 soon to be 32gb of 3600mhz ddr4
Video Card(s) MSI GTX 1080 EKWB Seahawk. soon to be RTX2070 super/RTX2080/Radeon XT series..........PRICE
Storage 1 x Samsung 500gb 970 Evo NVME/ 2 x 500gb Samsung SSD
Display(s) Dell Ultrasharp Curved 3440x1440
Case Heavily Modified Silverstone Fortress FT02
Audio Device(s) Asus Sound card
Power Supply Corsair HX1000i
Mouse Corsair M95
Keyboard Corsair K95
Software Windows 10 64bit home
Hes playing on the EU server, hes over Ethernet on a 330mbs fibre connection, ill have a look later too see what the ping is doing.
 
Joined
Mar 15, 2013
Messages
2,863 (1.22/day)
Location
GMT +2
System Name Red Radiance l under construction
Processor 2600x
Motherboard x470 taichi
Cooling stock wrath
Memory TridentZ rgb 3200mhz (2x8 kit)
Video Card(s) Sapphire Vega 64 nitro+
Storage 970 evo nvme
Display(s) c27gh70
Case tt core x5 tge
Audio Device(s) sennheiser's pc323d usb soundcard
Power Supply corsair AX860i
Mouse roccat leader
Keyboard roccat ryos mk fx
Software windows 10
your connection doesnt realy matter much. it's server side issue. it happend before with world of tanks. now it is ok and one may think that wargameing should've learned but...

edit:
you may try game support forums for instructions for prot forwarding for the game (services and port numbers) to set up for your home router but improvemnt wont be very noticable.
you can try also trace route command (again instructions and server ips should be in game support forums) but i doubt with fiber you will be out of the ok range
 
Last edited:

dmdougherty

New Member
Joined
Jul 16, 2019
Messages
1 (0.03/day)
Hi

Have a look here

Also you can change the FPS from the default 75 in the res gui file in the world of warships directory I have mine set at 300

Hope this helps
 
Top